Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
vmware-player 3.1.0.261024 fails with unitialized function?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
kazamatzuri
n00b
n00b


Joined: 12 Oct 2007
Posts: 8

PostPosted: Tue Jul 13, 2010 10:05 pm    Post subject: vmware-player 3.1.0.261024 fails with unitialized function? Reply with quote

Hi there,

I'm running on ~amd64 and pulled in the vmware overlay.
with vmware-player 3.1.0.261024 i'm getting the following error:

SSL wrapper: invoked uninitialized function aesni_set_encrypt_key!

the strange this is, on another machine of mine (same settings, but amd instead of intel cpu) everything works fine..

Has anybody seen this yet, and possibly knows a solution?

Thanks a lot
_________________
www.fabianhaupt.de
Back to top
View user's profile Send private message
Edweirdo
Guru
Guru


Joined: 28 Jan 2003
Posts: 353
Location: Boston, Mass, USA

PostPosted: Sun Aug 01, 2010 2:50 pm    Post subject: Reply with quote

I was trying to use the overlay to get VMware-Workstation 7.1 working but it wasn't installing correctly. My solution was to remove vmware-mouldes and then install the official VMware-Workstation package normally. The only problem is that the modules won't compile with gentoo-sources-2.6.34. I downgraded to gentoo-sources-2.6.33-r2 and the VMware install went fine. I even tried VMware Player stand alone and that worked.

Alternatively, the latest VirtualBox works perfectly fine using emerge and the latest 2.6.34. It's free and you can even convert VMware VMs to it. That is just another alternative.
_________________
Life is too short and too important to { take seriously | use Windows }.
Back to top
View user's profile Send private message
kazamatzuri
n00b
n00b


Joined: 12 Oct 2007
Posts: 8

PostPosted: Wed Aug 18, 2010 6:11 am    Post subject: Reply with quote

Virtualbox is what I usually go for, but unfortunately it's in a commercial context I'm using vmware right now, so the vbox-license doesn't cover it.

a possible workaround is to force vmware to use the shipped libcrypto und libssl ...
_________________
www.fabianhaupt.de
Back to top
View user's profile Send private message
umaksuman
n00b
n00b


Joined: 30 Aug 2010
Posts: 1

PostPosted: Mon Aug 30, 2010 7:06 pm    Post subject: Re: vmware-player 3.1.0.261024 fails with unitialized functi Reply with quote

Hi,

[quote="kazamatzuri"]Hi there,

I'm running on ~amd64 and pulled in the vmware overlay.
with vmware-player 3.1.0.261024 i'm getting the following error:

SSL wrapper: invoked uninitialized function aesni_set_encrypt_key!

the strange this is, on another machine of mine (same settings, but amd instead of intel cpu) everything works fine..

Has anybody seen this yet, and possibly knows a solution?

[/quote]

this happened to me on a Westmere (core-i7 32nm xeon); vmware (workstation 7.1.1, i gues the same applies for the viewer? - but have not checked this) tries to use the aes-ni intel extension
but this is not yet supported by openssh 0.9.8. (my latest unstable is 1.0.0a which also does not seem to have it patched). After ebuild ing with including the patch openssl-0.9.8-branch-aesni-x64.diff
from http://rt.openssl.org/Ticket/Display.html?id=2067 things started to work again.
(Kernel 2.6.35-r5 , gentoo-sources, kernel-option and module aesni_intel loaded.

Hope it helps.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum