Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] Drucken aus KDE-Anwendungen nicht möglich
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Moldmaker
n00b
n00b


Joined: 13 Jul 2010
Posts: 33

PostPosted: Sun Jul 18, 2010 10:02 am    Post subject: [gelöst] Drucken aus KDE-Anwendungen nicht möglich Reply with quote

Hallo zusammen, ich habe folgendes Problem:

Nachdem es mir kürzlich gelungen ist, KDE zu installieren, habe ich nun festgestellt, daß ich aus KDE-Anwendungen nicht drucken kann.
Das Drucksystem ist installiert, konfiguriert und funktioniert perfekt. Das soll heißen, daß die Druckerverwaltung über das CUPS-Frontend tadellos funktioniert und ich beipsielsweise aus Firefox ganz normal drucken kann. In KDE habe ich noch das Druckerapplet in den Systemeinstellungen nachinstalliert, und ich kann auch hier die Drucker sehen und verwalten und auch eine Testseite ausdrucken. Aber wenn ich beispielsweise aus KWrite oder Kate einen Ausdruck abschicke, erscheint er nicht in der Druckerwarteschlage und es passiert auch nichts.
Kennt jemand dieses Problem und vielleicht sogar die Lösung?
Muß ich vielleicht ein bestimmtes USE-flag setzen, damit KDE-Anwendungen drucken können?
(Anmerkung: Es handelt sich um einen Brother HL-2040, den ich über einen Printserver anspreche. Es scheint kein Treiberproblem o.ä. zu sein, denn das Drucken aus Nicht-KDE-Anwendungen funktioniert tadellos.)
_________________
Mm.


Last edited by Moldmaker on Tue Jul 20, 2010 5:46 pm; edited 1 time in total
Back to top
View user's profile Send private message
lxg
Veteran
Veteran


Joined: 12 Nov 2005
Posts: 1019
Location: Aachen, Germany

PostPosted: Sun Jul 18, 2010 9:41 pm    Post subject: Reply with quote

Durchaus möglich, dass da etwas ohne CUPS-Support gebaut wurde. Was ist die Ausgabe von:

Code:
USE="cups" emerge -pvuND world

_________________
lxg.de – codebits and tech talk
Back to top
View user's profile Send private message
Moldmaker
n00b
n00b


Joined: 13 Jul 2010
Posts: 33

PostPosted: Mon Jul 19, 2010 2:21 pm    Post subject: Reply with quote

Danke für Deine Antwort. Hier ist die Ausgabe auf den Befehl:

    # USE="cups" emerge -pvuND world
    These are the packages that would be merged, in order:
    Calculating dependencies... done!
    Total: 0 packages, Size of downloads: 0 kB

Und dann habe ich noch in /etc/make.conf das Useflag cups eingetragen und den folgenden Befehl abgesetzt:

    # emerge --update --deep world
    Calculating dependencies... done!
    >>> Auto-cleaning packages...
    >>> No outdated packages were found on your system.

Das Useflag cups ist also leider nicht das Problem.
_________________
Mm.
Back to top
View user's profile Send private message
Moldmaker
n00b
n00b


Joined: 13 Jul 2010
Posts: 33

PostPosted: Mon Jul 19, 2010 4:13 pm    Post subject: Reply with quote

Ich habe noch ein bißchen recehrchiert und folgendes gefunden:
http://lists-archives.org/kde-devel/15264-printer-system-of-kde4-i-can-t-print.html
Hier wird ein ähnliches Problem beschrieben - ohne daß es zu einer Lösung gekommen ist.
Ich spreche meinen Drucker über einen Printserver an, der die feste Adresse 192.168.1.50 hat. Aus allen anderen Linux-Systemen ist es kein Problem, über die Geräte-URI socket://192.168.50.1 Druckaufträge abzusetzen. Nur KDE4 scheint ein Problem damit zu haben und fügt die Aufträge nicht mal der Warteschlange hinzu. Ich kann aber PDF erzeugen und mit Okular öffnen. Wenn ich nun aus Okular einen Ausdruck auf den Drucker abschicke, dann wird er tatsächlich der Druckerwarteschlange hinzugefügt, aber letztlich doch nicht gedruckt. Ich muß den Druckauftrag manuell abbrechen. So ein kleines PDF sollte nach einigen Sekunden ausgedruckt sein.
Ich habe dann in CUPS einfach mal andere Adressen ausprobiert, also ipp://192.168.1.50 und so weiter, abeer dann kann ich auch aus Firefox nicht mehr drucken.
Aber:
Wenn ich den Drucker lokal anschließe (also über das USB-Kabel), dann kann ich ganz normal drucken! Bin gerade erst auf die Idee gekommen, das mal zu testen... Also scheint KDE4 Schwierigkeiten mit meinem Printserver zu haben. Ich muß das noch weiter untersuchen. Hat sonst jemand einen Drucker an einem Printserver laufen und KDE4 kann darauf drucken? Wie ist der Drucker in CUPS dann konfiguriert? Vielleicht kann ja jemand kurz was dazu schreiben.
_________________
Mm.
Back to top
View user's profile Send private message
lxg
Veteran
Veteran


Joined: 12 Nov 2005
Posts: 1019
Location: Aachen, Germany

PostPosted: Mon Jul 19, 2010 5:08 pm    Post subject: Reply with quote

Ok, sorry … zum Thema Printserver und KDE kann ich nix sagen. Wenn CUPS übers Netzwerk drucken kann und der Drucker via USB auch in KDE funktioniert, dann scheint das wirklich was sehr spezielles zu sein.

Ich sehe in Portage zwei Anwendungen, die anscheinend in KDE eine Druckerverwaltung realisieren: kde-base/printer-applet und kde-base/system-config-printer-kde. Hast Du Dir die mal angeschaut?
_________________
lxg.de – codebits and tech talk
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Mon Jul 19, 2010 5:15 pm    Post subject: Reply with quote

Welche Qt-Version?
AFAIK gab es da mal einen bösen Bug, mit dem ein korrekt laufendes CUPS auf nem Print-Server nicht erkannt werden konnte. Wurde AFAIR mit Qt-4.6.3 gefixt. Also notfalls ein Upgrade.

Hmm, wo ich so nachdenk, ging es in dem Bug darum den Drucker erstmal zu erkennen -das scheint bei dir ja zu gehen :(

Ansonsten warte drauf dass dir die Trommel kaputt geht und hol dir dann den 2150N, der kann schon selber Netzwerk :D
Back to top
View user's profile Send private message
Moldmaker
n00b
n00b


Joined: 13 Jul 2010
Posts: 33

PostPosted: Mon Jul 19, 2010 5:21 pm    Post subject: Reply with quote

@lxg
Ja, die beiden Pakete dienen dazu, überhaupt erst das Druckerkonfigurationsapplet (was für ein Wort) in den KDE-Systemeinstellungen erscheinen zu lassen. Leider werden die beim emergen von KDE nicht automatisch berücksichtigt (wäre vielleicht eine gute Idee). Jedenfalls dachte ich zuerst auch, daß das Fehlen dieser Pakete für das Problem verantwortlich ist, aber nach ihrer Installation weiß ich, daß dem nicht so ist.
Mein letzter Versuch war folgender: Ich habe auf meinem Eee-PC ein Ubuntu mit Gnome, das denselben Drucker via CUPS über lpd://192.168.1.50/lp anspricht. Das funktioniert zwar auch unter Gentoo, aber wieder nur für nicht-KDE-Programme. Das war also leider erfolglos.
Hier scheint wirklich ein spezielles Problem vorzuliegen. Vielleicht hat es was mit den KDE-Netzwerkeinstellungen zu tun. Ich werde wohl mal weiterforschen müssen.
Danke für die Antwort, vielleicht fällt Dir ja noch was ein.
_________________
Mm.
Back to top
View user's profile Send private message
Moldmaker
n00b
n00b


Joined: 13 Jul 2010
Posts: 33

PostPosted: Mon Jul 19, 2010 5:34 pm    Post subject: Reply with quote

@franzf
Das ist ja ein interessanter Hinweis. Nun, ich habe hier Gentoo auf dem neuesten Stand, und dazu gehört Qt 4.6.2-r1 und bei einigen Paketen 4.6.2, wenn ich das System befrage. Ich sehe aber, daß einges an Qt-Paketen nicht installiert ist, das scheinen mir aber optionale Sachen zu sein. Ich kriege von emerge jedenfalls kein 4.6.3 angezeigt, auch nicht maskiert.
Der Drucker wird tatsächlich erkannt, aber Firefox ist m.W. kein Qt-Programm. Also könnte Dein Hinweis doch zielführend sein. Vielleicht sollte ich ein Weilchen warten, bis Qt 4.6.3 auch für Gentoo zur Verfügung steht.
Der Drucker ist im übrigen richtig gut und ich will nicht, daß er kaputtgeht, vor allem, weil er tadellos funktioniert...! Eigentlich.
_________________
Mm.
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4459

PostPosted: Mon Jul 19, 2010 5:50 pm    Post subject: Reply with quote

ebuilds für gt-4.6.3 existieren in portage schon seit 8. Juni 2010.
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
Moldmaker
n00b
n00b


Joined: 13 Jul 2010
Posts: 33

PostPosted: Mon Jul 19, 2010 6:19 pm    Post subject: Reply with quote

Hallo firefly,

mit Gentoo kenne ich mich momentan noch nicht so richtig gut aus. Wenn ich eingebe
Code:
emerge -s qt
dann kriege ich eine Liste von Paketen angezeigt, von denen einige maskiert sind, aber keine Version 4.6.3. In Unterverzeichnissen von /usr/portage/x11-libs sehe ich allerdings etliche ebuilds mit dieser Versionsnummer. So ganz habe ich portage noch nicht durchschaut.
Deshalb hier jetzt meine Anfängerfrage: Wie hieve ich denn meine Qt-Installation elegant auf den neueren Versionsstand?
_________________
Mm.
Back to top
View user's profile Send private message
lxg
Veteran
Veteran


Joined: 12 Nov 2005
Posts: 1019
Location: Aachen, Germany

PostPosted: Mon Jul 19, 2010 6:28 pm    Post subject: Reply with quote

Moldmaker wrote:
Deshalb hier jetzt meine Anfängerfrage: Wie hieve ich denn meine Qt-Installation elegant auf den neueren Versionsstand?


Ganz normal, mit:

Code:
emerge --sync && emerge -pvuND world


(Das pv in pvuND zeigt an, was alles aktualisiert werden soll; das tatsächliche Ausführen geht dann mit emerge -uND world.)
_________________
lxg.de – codebits and tech talk
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Mon Jul 19, 2010 7:26 pm    Post subject: Reply with quote

lxg wrote:
Ganz normal, mit:

Code:
emerge --sync && emerge -pvuND world

Prinzipiell ja, aber ich denke seine Frage bezog sich auf das Installieren von maskierter Software. Das geht über package.keywords
http://www.gentoo.org/doc/de/handbook/handbook-x86.xml?part=3&chap=3#doc_chap2
package.mask ist dann etwas zu heftig für unbedarfte User (ist hier eh nicht notwendig, nur so als Warnung).

Und um alle Pakete die verfügbar sind (incl. maskierten) anzuzeigen nimmst du am einfachsten app-portage/eix. Es gab auch irgend ein Tool in portage-utils/gentoolkit/..., mit dem man sich eine schöne Tabelle aller Plattformen/Versionen hat ausgeben lassen können, nur weiß ich nicht mehr welches und wie ;)
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Tue Jul 20, 2010 5:59 am    Post subject: Reply with quote

lxg wrote:
Moldmaker wrote:
Deshalb hier jetzt meine Anfängerfrage: Wie hieve ich denn meine Qt-Installation elegant auf den neueren Versionsstand?


Ganz normal, mit:

Code:
emerge --sync && emerge -pvuND world


(Das pv in pvuND zeigt an, was alles aktualisiert werden soll; das tatsächliche Ausführen geht dann mit emerge -uND world.)


Und zum Installieren von maskierten Paketen nimmst du "autounmask".

Damit tippst du du dann nur:
autounmask x11-libs/qt-svg-4.6.3

und er nimmt auch gleich alle Abhängigkeiten mit.

Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
Moldmaker
n00b
n00b


Joined: 13 Jul 2010
Posts: 33

PostPosted: Tue Jul 20, 2010 1:01 pm    Post subject: Reply with quote

Hallo an alle,

vielen Dank für die gute Unterstützung.
Ich habe mich in einigen Punkten wohl mißverständlich ausgedrückt.
1) Qt 4.6.3 ist nicht maskiert. Die Pakete befinden sich bei mir zwar in /usrPortage/x11-libs/... , wurden aber nicht installiert, sondern es wurde Version 4.6.2 installiert. Das verstehe ich nicht. daher kam meine Frage wie ich denn Qt auf den neuen Stand bringen kann.
2) Eine weitere Frage, die ich hatte, habt Ihr mir jetzt schon beantwortet, denn ich bin selbst schon auf autounmask gestoßen und habe es auch schon verwendet, aber nur für Einzelpakete. Daß beim Demaskieren einzelner Pakete die Abhängigkeiten gleich mit demaskiert werden, wußte ich noch nicht, ist aber logisch (und angenehm). Danke für die Information!
3) Zurück zu meinem Problem und dem Rat von lxg. Wenn ich also eingebe
Code:
emerge --sync && emerge -pvuND world

erhalte ich folgende Ausgabe:

Quote:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild U ] media-libs/jpeg-8b [8a] 943 kB
[ebuild NS ] sys-kernel/gentoo-sources-2.6.34-r1 [2.6.32-r7] USE="-build -deblob -symlink" 66,072 kB
[ebuild R ] x11-base/xorg-drivers-1.7 INPUT_DEVICES="evdev keyboard mouse virtualbox -acecad -aiptek -fpit% -joystick -penmount -synaptics -tslib -vmmouse -void -wacom" VIDEO_CARDS="nv nvidia -apm -ark -ast -chips -cirrus -dummy -epson -fbdev -fglrx -geode -glint -i128 -i740 (-impact) -intel -mach64 -mga -neomagic (-newport) -nouveau% -r128 -radeon -radeonhd -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -vesa -via -virtualbox -vmware (-voodoo) -xgi" 0 kB
[ebuild U ] x11-proto/xproto-7.0.17 [7.0.16] 169 kB
[ebuild NS ] sys-libs/db-4.8.30 [4.7.25_p4] USE="-doc -examples -java -nocxx -tcl -test" 22,351 kB
[ebuild U ] media-fonts/font-util-1.1.1-r1 [1.1.1] USE="(-debug%)" 0 kB
[ebuild U ] x11-libs/pixman-0.18.2 [0.17.2] USE="(-altivec) -mmx -sse2 -static-libs% (-debug%)" 412 kB
[ebuild U ] media-libs/audiofile-0.2.7 [0.2.6-r4] 491 kB
[ebuild U ] x11-libs/libdrm-2.4.20-r1 [2.4.18_pre20100211-r1] USE="-debug" 392 kB
[ebuild U ] sys-apps/vbetool-1.1 [1.0] 179 kB
[ebuild U ] x11-apps/sessreg-1.0.6 [1.0.5] USE="(-debug%)" 111 kB
[ebuild R ] dev-db/virtuoso-server-6.1.1 USE="ldap readline -kerberos (-static-libs%)" 0 kB
[ebuild U ] sys-apps/coreutils-8.5 [8.4] USE="acl nls unicode -caps -gmp (-selinux) -static -vanilla -xattr" 10,494 kB
[ebuild U ] sys-apps/util-linux-2.17.2 [2.16.2] USE="crypt nls perl unicode -loop-aes -old-linux (-selinux) -slang (-uclibc)" 3,727 kB
[ebuild U ] dev-lang/yasm-1.0.1 [0.8.0] USE="nls" 1,381 kB
[ebuild U ] net-dns/libidn-1.19 [1.15] USE="nls -doc -emacs -java -mono -static-libs%" 3,133 kB
[ebuild U ] app-text/enchant-1.6.0 [1.5.0] USE="hunspell -aspell -zemberek" 593 kB
[ebuild R ] sys-fs/udev-149 USE="devfs-compat extras* (-selinux) -test" 535 kB
[ebuild U ] x11-libs/libxcb-1.6 [1.5] USE="-doc (-selinux) -static-libs% (-debug%)" 310 kB
[ebuild U ] sci-libs/gsl-1.14 [1.13-r1] USE="-cblas" 3,055 kB
[ebuild U ] x11-libs/libX11-1.3.4 [1.3.3] USE="ipv6 xcb -doc -static-libs% -test (-debug%)" 2,077 kB
[ebuild U ] x11-apps/xlsatoms-1.1.0 [1.0.2] USE="(-debug%)" 102 kB
[ebuild U ] x11-libs/libXext-1.1.2 [1.1.1] USE="-static-libs% (-debug%)" 312 kB
[ebuild U ] x11-libs/libXrender-0.9.6 [0.9.5] USE="-static-libs% (-debug%)" 253 kB
[ebuild U ] x11-libs/libXfixes-4.0.5 [4.0.4] USE="-static-libs% (-debug%)" 250 kB
[ebuild U ] x11-libs/libvdpau-0.4 [0.2] USE="-doc" 442 kB
[ebuild U ] x11-apps/xlsclients-1.1.0 [1.0.2] USE="(-debug%)" 106 kB
[ebuild U ] x11-libs/libXfont-1.4.2 [1.4.1] USE="ipv6 -static-libs% (-debug%)" 424 kB
[ebuild U ] x11-libs/libXdamage-1.1.3 [1.1.2] USE="-static-libs% (-debug%)" 244 kB
[ebuild U ] x11-libs/libXcomposite-0.4.2 [0.4.1] USE="-doc -static-libs% (-debug%)" 254 kB
[ebuild U ] media-fonts/encodings-1.0.3-r1 [1.0.3] USE="(-debug%)" 0 kB
[ebuild U ] media-fonts/font-alias-1.0.2 [1.0.1] USE="(-debug%)" 92 kB
[ebuild U ] media-libs/mesa-7.8.2 [7.7.1] USE="nptl xcb -debug (-gallium) -motif -pic (-selinux)" VIDEO_CARDS="-intel -mach64 -mga -none -nouveau -r128 -radeon -radeonhd -savage -sis -svga -tdfx -via (-sunffb%)" 5,019 kB
[ebuild U ] x11-misc/xkeyboard-config-1.9 [1.7] 636 kB
[ebuild U ] x11-apps/xinput-1.5.2 [1.5.1] USE="(-debug%)" 127 kB
[ebuild U ] x11-misc/xdg-utils-1.0.2_p20100618 [1.0.2-r3] USE="-doc" 298 kB
[ebuild U ] sys-apps/shadow-4.1.4.2-r4 [4.1.4.2-r3] USE="cracklib nls pam -audit (-selinux) -skey" 0 kB
[ebuild U ] media-fonts/font-misc-misc-1.1.0 [1.0.0] USE="X nls" 1,885 kB
[ebuild U ] media-fonts/font-xfree86-type1-1.0.2 [1.0.1] USE="X" 115 kB
[ebuild U ] media-fonts/font-adobe-utopia-100dpi-1.0.2 [1.0.1] USE="X nls" 342 kB
[ebuild U ] media-fonts/font-ibm-type1-1.0.1 [1.0.0] USE="X (-nls%*)" 367 kB
[ebuild U ] media-fonts/font-adobe-75dpi-1.0.1 [1.0.0] USE="X nls" 886 kB
[ebuild U ] media-fonts/font-bh-type1-1.0.1 [1.0.0] USE="X" 620 kB
[ebuild U ] media-fonts/font-micro-misc-1.0.1 [1.0.0] USE="X nls" 87 kB
[ebuild U ] media-fonts/font-bh-ttf-1.0.1 [1.0.0] USE="X" 443 kB
[ebuild U ] media-fonts/font-adobe-utopia-75dpi-1.0.2 [1.0.1] USE="X nls" 266 kB
[ebuild U ] media-fonts/font-misc-ethiopic-1.0.1-r1 [1.0.0-r1] USE="X" 231 kB
[ebuild U ] media-fonts/font-sony-misc-1.0.1 [1.0.0] USE="X nls" 97 kB
[ebuild U ] media-fonts/font-screen-cyrillic-1.0.2 [1.0.1] USE="X nls" 92 kB
[ebuild U ] media-fonts/font-jis-misc-1.0.1 [1.0.0] USE="X nls" 611 kB
[ebuild U ] media-fonts/font-bh-100dpi-1.0.1 [1.0.0] USE="X nls" 708 kB
[ebuild U ] media-fonts/font-cursor-misc-1.0.1 [1.0.0] USE="X nls" 91 kB
[ebuild U ] media-fonts/font-misc-cyrillic-1.0.1 [1.0.0] USE="X nls" 114 kB
[ebuild U ] media-fonts/font-arabic-misc-1.0.1 [1.0.0] USE="X nls" 101 kB
[ebuild U ] media-fonts/font-bitstream-100dpi-1.0.1 [1.0.0] USE="X nls" 188 kB
[ebuild U ] media-fonts/font-misc-meltho-1.0.1 [1.0.0] USE="X" 1,512 kB
[ebuild U ] media-fonts/font-adobe-100dpi-1.0.1 [1.0.0] USE="X nls" 1,094 kB
[ebuild U ] media-fonts/font-bh-75dpi-1.0.1 [1.0.0] USE="X nls" 544 kB
[ebuild U ] media-fonts/font-cronyx-cyrillic-1.0.1 [1.0.0] USE="X nls" 252 kB
[ebuild U ] media-fonts/font-daewoo-misc-1.0.1 [1.0.0] USE="X nls" 718 kB
[ebuild U ] media-fonts/font-mutt-misc-1.0.1 [1.0.0] USE="X nls" 251 kB
[ebuild U ] media-fonts/font-bitstream-speedo-1.0.1 [1.0.0] USE="X" 383 kB
[ebuild U ] media-fonts/font-sun-misc-1.0.1 [1.0.0] USE="X nls" 105 kB
[ebuild U ] media-fonts/font-bitstream-75dpi-1.0.1 [1.0.0] USE="X nls" 162 kB
[ebuild U ] media-fonts/font-adobe-utopia-type1-1.0.2 [1.0.1] USE="X" 256 kB
[ebuild U ] media-fonts/font-bh-lucidatypewriter-100dpi-1.0.1 [1.0.0] USE="X nls" 238 kB
[ebuild U ] media-fonts/font-winitzki-cyrillic-1.0.1 [1.0.0] USE="X nls" 89 kB
[ebuild U ] media-fonts/font-dec-misc-1.0.1 [1.0.0] USE="X nls" 89 kB
[ebuild U ] media-fonts/font-schumacher-misc-1.1.0 [1.0.0] USE="X nls" 134 kB
[ebuild U ] media-fonts/font-isas-misc-1.0.1 [1.0.0] USE="X nls" 824 kB
[ebuild U ] media-fonts/font-bitstream-type1-1.0.1 [1.0.0] USE="X" 399 kB
[ebuild U ] media-fonts/font-bh-lucidatypewriter-75dpi-1.0.1 [1.0.0] USE="X nls" 208 kB
[ebuild U ] net-wireless/bluez-4.66-r1 [4.63] USE="alsa consolekit cups usb -caps -debug -gstreamer -old-daemons -pcmcia -test-programs" 968 kB
[ebuild U ] app-text/libspectre-0.2.5 [0.2.2] USE="-debug -doc -test" 334 kB
[ebuild U ] dev-cpp/eigen-2.0.13 [2.0.5] USE="-debug -doc -examples" 359 kB
[ebuild U ] kde-base/kopete-4.4.5-r1 [4.4.5] USE="addbookmarks autoreplace contactnotes handbook highlight history jabber nowlistening pipes privacy ssl statistics texteffect translator urlpicpreview (-aqua) -debug -gadu -groupwise -jingle (-kdeenablefinal) (-kdeprefix) -latex -meanwhile -msn -oscar -otr -qq -skype -sms -testbed -v4l2 -webpresence -winpopup -yahoo -zeroconf" 0 kB
[ebuild U ] x11-drivers/xf86-input-virtualbox-3.1.8-r1 [3.0.12] USE="hal -debug" 54,973 kB
[ebuild U ] x11-drivers/xf86-input-evdev-2.4.0 [2.3.2] USE="-debug" 300 kB
[ebuild U ] x11-drivers/nvidia-drivers-195.36.24 [190.42-r3] USE="acpi gtk -custom-cflags (-multilib)" 24,048 kB
[ebuild U ] media-video/nvidia-settings-195.36.24 [190.42] 1,372 kB

Total: 80 packages (75 upgrades, 2 in new slots, 3 reinstalls), Size of downloads: 221,803 kB


Soweit scheint mir das in Ordnung, ich habe den Vorgang jetzt allerdings nicht angestoßen, denn da sind die Qt-Sachen ja gar nicht dabei. Meine Idee ist ja, auf den Rat von franzf hin Qt von 4.6.2 auf 4.6.3 zu bringen, aber ich weiß nicht wie. Muß man diese ebuilds eventuell spezifizieren?
_________________
Mm.
Back to top
View user's profile Send private message
astaecker
Guru
Guru


Joined: 28 Apr 2003
Posts: 403
Location: Hamburg / Germany

PostPosted: Tue Jul 20, 2010 1:42 pm    Post subject: Reply with quote

Qt 4.6.3 ist maskiert mittels Keyword. Das Sperren von Paketen durch Keywords (~Irgendwas) wird auch als Maskierung bezeichnet. Die Maskierung mittels package.mask usw. ist nur eine deutlichere Art der Maskierung.
Daher musst du Qt 4.6.3 erstmal demaskieren, damit du es installieren kannst. Dies geht sehr einfach mit autounmask.
Back to top
View user's profile Send private message
Moldmaker
n00b
n00b


Joined: 13 Jul 2010
Posts: 33

PostPosted: Tue Jul 20, 2010 2:49 pm    Post subject: Reply with quote

Hallo arlsair,

Danke für den Hinweis, also hab ich das mit den Maskierungen doch nicht richtig kapiert. Also dann, ich habe eingegeben
Code:
autounmask x11-libs/qt-core-4.6.3

und erhalte folgende Antwort:
Quote:
# autounmask x11-libs/qt-core-4.6.3

autounmask version 0.27 (using PortageXS-0.02.09 and portage-2.1.8.3)

* Using repository: /usr/portage

* Using package.keywords file: /etc/portage/package.keywords/autounmask-qt-core
* Using package.unmask file: /etc/portage/package.unmask
* Using package.use file: /etc/portage/package.use

* Unmasking x11-libs/qt-core-4.6.3 and its dependencies.. this might take a while..

[ebuild R ] sys-libs/zlib-1.2.3-r1
[ebuild R ] dev-libs/expat-2.0.1-r3
[ebuild R ] virtual/libintl-0
[ebuild R ] sys-devel/gnuconfig-20100122
[ebuild R ] virtual/libiconv-0
[ebuild R ] app-misc/pax-utils-0.1.19
[ebuild R ] app-arch/bzip2-1.0.5-r1
[ebuild R ] dev-libs/gmp-4.3.2
[ebuild R ] sys-devel/gcc-config-1.4.1
[ebuild R ] app-misc/mime-types-8
[ebuild R ] sys-devel/automake-wrapper-4
[ebuild R ] sys-libs/timezone-data-2010i
[ebuild R ] sys-devel/autoconf-wrapper-8
[ebuild R ] dev-libs/libffi-3.0.9
[ebuild R ] dev-util/pkgconfig-0.23
[ebuild R ] media-libs/jpeg-8a
[ebuild R ] app-arch/xz-utils-4.999.9_beta
[ebuild R ] app-text/libpaper-1.1.23
[ebuild R ] media-fonts/gnu-gs-fonts-std-8.11
[ebuild R ] dev-util/gperf-3.0.4
[ebuild R ] sys-apps/tcp-wrappers-7.6-r8
[ebuild R ] net-print/foomatic-db-ppds-3.0.20060720
[ebuild R ] app-portage/portage-utils-0.3.1
[ebuild R ] dev-db/mysql-init-scripts-1.2
[ebuild R ] sys-devel/m4-1.4.12
[ebuild R ] sys-kernel/linux-headers-2.6.30-r1
[ebuild R ] sys-apps/sandbox-1.6-r2
[ebuild R ] virtual/libffi-0
[ebuild R ] dev-libs/mpfr-2.4.2_p3
[ebuild R ] media-libs/libpng-1.4.3
[ebuild R ] media-libs/tiff-3.9.4
[ebuild R ] app-arch/unzip-6.0-r1
[ebuild R ] sys-apps/debianutils-3.1.3
[ebuild R ] virtual/acl-0
[ebuild R ] app-admin/python-updater-0.8
[ebuild R ] sys-devel/binutils-config-1.9-r4
[ebuild R ] sys-process/procps-3.2.8
[ebuild R ] virtual/mysql-5.0
[ebuild R ] virtual/perl-ExtUtils-CBuilder-0.27.03
[ebuild R ] app-text/docbook-xsl-stylesheets-1.75.2
[ebuild R ] app-text/build-docbook-catalog-1.4
[ebuild R ] virtual/perl-IO-Compress-2.021
[ebuild R ] x11-misc/xdg-utils-1.0.2-r3
[ebuild R ] app-admin/eselect-fontconfig-1.0
[ebuild R ] app-admin/gamin-0.1.10
[ebuild R ] net-print/foomatic-filters-ppds-20070501
[ebuild R ] sys-auth/pambase-20100310
[ebuild R ] virtual/perl-Storable-2.20
[ebuild R ] virtual/perl-File-Spec-3.30
[ebuild R ] virtual/perl-Module-Build-0.36.07
[ebuild R ] virtual/perl-Test-Harness-3.17
[ebuild R ] virtual/perl-Archive-Tar-1.54
[ebuild R ] virtual/perl-Package-Constants-0.02
[ebuild R ] virtual/perl-Compress-Raw-Bzip2-2.021
[ebuild R ] virtual/perl-Compress-Raw-Zlib-2.021
[ebuild R ] virtual/perl-Scalar-List-Utils-1.21
[ebuild R ] virtual/perl-IO-Zlib-1.09
[ebuild R ] virtual/perl-ExtUtils-ParseXS-2.22.05
[ebuild R ] virtual/perl-Sys-Syslog-0.27
[ebuild R ] sys-devel/autoconf-2.65
[ebuild R ] sys-devel/libtool-2.2.6b
[ebuild R ] sys-devel/automake-1.11.1
[ebuild R ] x11-misc/util-macros-1.10.0
[ebuild R ] app-text/sgml-common-0.6.3-r5
[ebuild R ] sys-devel/binutils-2.20.1-r1
[ebuild R ] sys-libs/db-4.7.25_p4
[ebuild R ] x11-proto/xproto-7.0.16
[ebuild R ] x11-proto/xextproto-7.1.1
[ebuild R ] x11-libs/xtrans-1.2.5
[ebuild R ] x11-proto/inputproto-2.0
[ebuild R ] x11-proto/kbproto-1.0.4
[ebuild R ] x11-proto/xineramaproto-1.2
[ebuild R ] x11-proto/renderproto-0.11
[ebuild R ] x11-libs/pixman-0.17.2
[ebuild R ] dev-libs/libpthread-stubs-0.1
[ebuild R ] x11-proto/damageproto-1.2.0
[ebuild R ] x11-proto/fontcacheproto-0.1.3
[ebuild R ] x11-proto/xf86miscproto-0.9.3
[ebuild R ] x11-proto/randrproto-1.3.1
[ebuild R ] x11-proto/fontsproto-2.1.0
[ebuild R ] x11-proto/xf86bigfontproto-1.2.0
[ebuild R ] x11-proto/compositeproto-0.4.1
[ebuild R ] sys-libs/gdbm-1.8.3-r4
[ebuild R ] x11-libs/libXau-1.0.5
[ebuild R ] x11-libs/libICE-1.0.6
[ebuild R ] x11-libs/libXdmcp-1.0.3
[ebuild R ] x11-proto/fixesproto-4.1.1
[ebuild R ] x11-libs/libfontenc-1.0.5
[ebuild R ] sys-devel/libperl-5.8.8-r2
[ebuild R ] dev-lang/perl-5.8.8-r8
[ebuild R ] dev-perl/XML-Parser-2.36-r1
[ebuild R ] dev-perl/Net-Daemon-0.43
[ebuild R ] perl-core/Storable-2.20
[ebuild R ] perl-core/File-Spec-3.30
[ebuild R ] dev-perl/YAML-Tiny-1.41
[ebuild R ] perl-core/Test-Harness-3.17
[ebuild R ] perl-core/Archive-Tar-1.54
[ebuild R ] perl-core/Package-Constants-0.02
[ebuild R ] perl-core/IO-Compress-2.021
[ebuild R ] perl-core/Compress-Raw-Bzip2-2.021
[ebuild R ] perl-core/Compress-Raw-Zlib-2.021
[ebuild R ] perl-core/Scalar-List-Utils-1.21
[ebuild R ] perl-core/IO-Zlib-1.09
[ebuild R ] perl-core/ExtUtils-ParseXS-2.22.05
[ebuild R ] perl-core/ExtUtils-CBuilder-0.27.03
[ebuild R ] perl-core/Sys-Syslog-0.27
[ebuild R ] dev-util/intltool-0.41.1
[ebuild R ] dev-perl/PlRPC-0.2020-r1
[ebuild R ] perl-core/Module-Build-0.36.07
[ebuild R ] dev-perl/DBI-1.609
[ebuild R ] dev-perl/DBD-mysql-4.01.3
[ebuild R ] sys-devel/gettext-0.17-r1
[ebuild R ] sys-apps/sed-4.2
[ebuild R ] sys-apps/findutils-4.4.2
[ebuild R ] sys-devel/flex-2.5.35
[ebuild R ] sys-apps/attr-2.4.43
[ebuild R ] dev-libs/popt-1.16
[ebuild R ] sys-devel/bison-2.4.1
[ebuild R ] sys-apps/diffutils-2.8.7-r2
[ebuild R ] dev-libs/glib-2.22.5
[ebuild R ] dev-libs/libgpg-error-1.7
[ebuild R ] dev-perl/Locale-gettext-1.05-r1
[ebuild R ] sys-apps/acl-2.2.49
[ebuild R ] net-misc/rsync-3.0.6
[ebuild R ] sys-apps/help2man-1.37.1
[ebuild R ] dev-libs/libgcrypt-1.4.5
[ebuild R ] dev-libs/atk-1.28.0
[ebuild R ] dev-util/desktop-file-utils-0.16
[ebuild R ] dev-libs/openssl-0.9.8o
[ebuild U ] x11-libs/qt-core-4.6.3 [4.6.2-r1]
[ebuild U ] x11-libs/qt-script-4.6.3 [4.6.2]
[ebuild R ] sys-libs/ncurses-5.7-r3
[ebuild R ] sys-apps/texinfo-4.13
[ebuild R ] sys-apps/coreutils-8.4
[ebuild R ] sys-apps/util-linux-2.16.2
[ebuild R ] app-shells/bash-4.0_p37
[ebuild R ] net-nds/openldap-2.4.19-r1
[ebuild R ] sys-libs/gpm-1.20.5
[ebuild R ] sys-libs/readline-6.1
[ebuild R ] app-admin/perl-cleaner-1.05
[ebuild R ] sys-devel/automake-1.9.6-r3
[ebuild R ] app-misc/ca-certificates-20090709
[ebuild R ] x11-libs/libSM-1.1.1
[ebuild R ] net-misc/curl-7.20.0-r2
[ebuild R ] sys-apps/ed-1.0
[ebuild R ] dev-db/sqlite-3.6.23.1
[ebuild U ] x11-libs/qt-sql-4.6.3-r2 [4.6.2] USE="-freetds%"
[ebuild R ] app-admin/eselect-1.2.10
[ebuild R ] dev-libs/libxml2-2.7.7
[ebuild R ] x11-misc/shared-mime-info-0.71
[ebuild R ] dev-libs/xmlrpc-c-1.18.02
[ebuild R ] app-text/docbook-xml-dtd-4.3-r1
[ebuild R ] app-admin/eselect-python-20100321
[ebuild R ] dev-lang/python-2.6.5-r2
[ebuild R ] dev-lang/python-3.1.2-r3
[ebuild R ] sys-apps/file-5.03
[ebuild R ] x11-proto/xcb-proto-1.6
[ebuild R ] dev-libs/libgamin-0.1.10-r2
[ebuild R ] sys-libs/cracklib-2.8.15
[ebuild R ] sys-apps/portage-2.1.8.3
[ebuild R ] dev-libs/libxslt-1.1.26
[ebuild R ] dev-lang/swig-1.3.36
[ebuild R ] app-admin/gam-server-0.1.10
[ebuild R ] x11-libs/libxcb-1.5
[ebuild R ] media-libs/lcms-1.19
[ebuild R ] dev-util/gtk-doc-am-1.13
[ebuild R ] x11-libs/libX11-1.3.3
[ebuild R ] media-libs/libmng-1.0.10
[ebuild R ] x11-libs/xcb-util-0.3.6
[ebuild R ] x11-libs/libXext-1.1.1
[ebuild R ] media-libs/freetype-2.3.12
[ebuild R ] x11-libs/libXt-1.0.8
[ebuild R ] x11-libs/libXrender-0.9.5
[ebuild R ] x11-libs/libXfixes-4.0.4
[ebuild R ] x11-apps/xprop-1.1.0
[ebuild R ] media-libs/fontconfig-2.8.0
[ebuild R ] sys-apps/dbus-1.2.24
[ebuild R ] x11-libs/libXi-1.3
[ebuild R ] x11-libs/libXmu-1.0.5
[ebuild R ] x11-libs/libXcursor-1.1.10
[ebuild R ] x11-libs/libXinerama-1.1
[ebuild R ] x11-libs/libXfont-1.4.1
[ebuild R ] x11-libs/libXrandr-1.3.0
[ebuild R ] x11-libs/libXdamage-1.1.2
[ebuild R ] x11-libs/libXxf86misc-1.0.2
[ebuild R ] x11-libs/libXfontcache-1.0.5
[ebuild R ] x11-libs/libXcomposite-0.4.1
[ebuild R ] dev-libs/dbus-glib-0.86
[ebuild R ] x11-libs/libXft-2.1.14
[ebuild U ] x11-libs/qt-dbus-4.6.3 [4.6.2]
[ebuild R ] x11-apps/xset-1.1.0
[ebuild U ] x11-libs/qt-gui-4.6.3 [4.6.2] USE="-trace%"
[ebuild U ] x11-libs/qt-qt3support-4.6.3 [4.6.2]
[ebuild R ] x11-libs/cairo-1.8.8-r1
[ebuild R ] dev-util/cmake-2.6.4-r3
[ebuild R ] x11-libs/pango-1.26.2
[ebuild R ] sys-libs/glibc-2.11.2
[ebuild R ] sys-devel/gcc-4.4.3-r2
[ebuild R ] sys-libs/pam-1.1.0
[ebuild R ] sys-auth/consolekit-0.4.1
[ebuild R ] dev-db/mysql-5.0.90-r2
[ebuild R ] net-print/cups-1.3.11-r2
[ebuild R ] x11-libs/gtk+-2.18.9
[ebuild R ] app-text/ghostscript-gpl-8.71-r1
[ebuild R ] app-text/poppler-0.12.4-r3
[ebuild R ] net-print/foomatic-filters-3.0.20080507
[blocks B ] <x11-libs/qt-sql-4.6.3 ("<x11-libs/qt-sql-4.6.3" is blocking x11-libs/qt-gui-4.6.3, x11-libs/qt-script-4.6.3, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-core-4.6.3, x11-libs/qt-dbus-4.6.3)
[blocks B ] <x11-libs/qt-xmlpatterns-4.6.3 ("<x11-libs/qt-xmlpatterns-4.6.3" is blocking x11-libs/qt-gui-4.6.3, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-sql-4.6.3-r2, x11-libs/qt-core-4.6.3, x11-libs/qt-dbus-4.6.3, x11-libs/qt-script-4.6.3)
[blocks B ] <x11-libs/qt-qt3support-4.6.3 ("<x11-libs/qt-qt3support-4.6.3" is blocking x11-libs/qt-gui-4.6.3, x11-libs/qt-script-4.6.3, x11-libs/qt-dbus-4.6.3, x11-libs/qt-core-4.6.3, x11-libs/qt-sql-4.6.3-r2)
[blocks B ] <x11-libs/qt-script-4.6.3 ("<x11-libs/qt-script-4.6.3" is blocking x11-libs/qt-gui-4.6.3, x11-libs/qt-sql-4.6.3-r2, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-core-4.6.3, x11-libs/qt-dbus-4.6.3)
[blocks B ] <x11-libs/qt-gui-4.6.3 ("<x11-libs/qt-gui-4.6.3" is blocking x11-libs/qt-dbus-4.6.3, x11-libs/qt-script-4.6.3, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-core-4.6.3, x11-libs/qt-sql-4.6.3-r2)
[blocks B ] <x11-libs/qt-opengl-4.6.3 ("<x11-libs/qt-opengl-4.6.3" is blocking x11-libs/qt-gui-4.6.3, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-sql-4.6.3-r2, x11-libs/qt-core-4.6.3, x11-libs/qt-dbus-4.6.3, x11-libs/qt-script-4.6.3)
[blocks B ] >x11-libs/qt-gui-4.6.2-r9999 (">x11-libs/qt-gui-4.6.2-r9999" is blocking x11-libs/qt-sql-4.6.2, x11-libs/qt-webkit-4.6.2-r1, x11-libs/qt-xmlpatterns-4.6.2, x11-libs/qt-core-4.6.2-r1, x11-libs/qt-svg-4.6.2, x11-libs/qt-test-4.6.2, x11-libs/qt-opengl-4.6.2, x11-libs/qt-qt3support-4.6.2, x11-libs/qt-script-4.6.2, x11-libs/qt-dbus-4.6.2)
[blocks B ] <x11-libs/qt-core-4.6.3 ("<x11-libs/qt-core-4.6.3" is blocking x11-libs/qt-gui-4.6.3, x11-libs/qt-script-4.6.3, x11-libs/qt-dbus-4.6.3, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-sql-4.6.3-r2)
[blocks B ] >x11-libs/qt-sql-4.6.2-r9999 (">x11-libs/qt-sql-4.6.2-r9999" is blocking x11-libs/qt-webkit-4.6.2-r1, x11-libs/qt-gui-4.6.2, x11-libs/qt-xmlpatterns-4.6.2, x11-libs/qt-core-4.6.2-r1, x11-libs/qt-svg-4.6.2, x11-libs/qt-test-4.6.2, x11-libs/qt-opengl-4.6.2, x11-libs/qt-qt3support-4.6.2, x11-libs/qt-script-4.6.2, x11-libs/qt-dbus-4.6.2)
[blocks B ] >x11-libs/qt-script-4.6.2-r9999 (">x11-libs/qt-script-4.6.2-r9999" is blocking x11-libs/qt-sql-4.6.2, x11-libs/qt-gui-4.6.2, x11-libs/qt-xmlpatterns-4.6.2, x11-libs/qt-core-4.6.2-r1, x11-libs/qt-svg-4.6.2, x11-libs/qt-test-4.6.2, x11-libs/qt-opengl-4.6.2, x11-libs/qt-webkit-4.6.2-r1, x11-libs/qt-qt3support-4.6.2, x11-libs/qt-dbus-4.6.2)
[blocks B ] >x11-libs/qt-qt3support-4.6.2-r9999 (">x11-libs/qt-qt3support-4.6.2-r9999" is blocking x11-libs/qt-sql-4.6.2, x11-libs/qt-gui-4.6.2, x11-libs/qt-xmlpatterns-4.6.2, x11-libs/qt-core-4.6.2-r1, x11-libs/qt-svg-4.6.2, x11-libs/qt-test-4.6.2, x11-libs/qt-opengl-4.6.2, x11-libs/qt-webkit-4.6.2-r1, x11-libs/qt-script-4.6.2, x11-libs/qt-dbus-4.6.2)
[blocks B ] <x11-libs/qt-svg-4.6.3 ("<x11-libs/qt-svg-4.6.3" is blocking x11-libs/qt-gui-4.6.3, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-sql-4.6.3-r2, x11-libs/qt-core-4.6.3, x11-libs/qt-dbus-4.6.3, x11-libs/qt-script-4.6.3)
[blocks B ] >x11-libs/qt-dbus-4.6.2-r9999 (">x11-libs/qt-dbus-4.6.2-r9999" is blocking x11-libs/qt-sql-4.6.2, x11-libs/qt-gui-4.6.2, x11-libs/qt-xmlpatterns-4.6.2, x11-libs/qt-core-4.6.2-r1, x11-libs/qt-svg-4.6.2, x11-libs/qt-test-4.6.2, x11-libs/qt-opengl-4.6.2, x11-libs/qt-webkit-4.6.2-r1, x11-libs/qt-qt3support-4.6.2, x11-libs/qt-script-4.6.2)
[blocks B ] >x11-libs/qt-core-4.6.2-r9999 (">x11-libs/qt-core-4.6.2-r9999" is blocking x11-libs/qt-sql-4.6.2, x11-libs/qt-gui-4.6.2, x11-libs/qt-xmlpatterns-4.6.2, x11-libs/qt-svg-4.6.2, x11-libs/qt-test-4.6.2, x11-libs/qt-opengl-4.6.2, x11-libs/qt-webkit-4.6.2-r1, x11-libs/qt-qt3support-4.6.2, x11-libs/qt-script-4.6.2, x11-libs/qt-dbus-4.6.2)
[blocks B ] <x11-libs/qt-webkit-4.6.3 ("<x11-libs/qt-webkit-4.6.3" is blocking x11-libs/qt-gui-4.6.3, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-sql-4.6.3-r2, x11-libs/qt-core-4.6.3, x11-libs/qt-dbus-4.6.3, x11-libs/qt-script-4.6.3)
[blocks B ] <x11-libs/qt-test-4.6.3 ("<x11-libs/qt-test-4.6.3" is blocking x11-libs/qt-gui-4.6.3, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-sql-4.6.3-r2, x11-libs/qt-core-4.6.3, x11-libs/qt-dbus-4.6.3, x11-libs/qt-script-4.6.3)
[blocks B ] <x11-libs/qt-dbus-4.6.3 ("<x11-libs/qt-dbus-4.6.3" is blocking x11-libs/qt-gui-4.6.3, x11-libs/qt-script-4.6.3, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-core-4.6.3, x11-libs/qt-sql-4.6.3-r2)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

('installed', '/', 'x11-libs/qt-opengl-4.6.2', 'nomerge') pulled in by
>=x11-libs/qt-opengl-4.6.0:4 required by ('installed', '/', 'kde-base/kalgebra-4.4.5', 'nomerge')
>=x11-libs/qt-opengl-4.6.2:4 required by ('installed', '/', 'dev-python/PyQt4-4.7.3', 'nomerge')
>=x11-libs/qt-opengl-4.6.0:4[-aqua] required by ('installed', '/', 'media-sound/phonon-4.4.1-r1', 'nomerge')
(and 12 more)

('installed', '/', 'x11-libs/qt-sql-4.6.2', 'nomerge') pulled in by
>=x11-libs/qt-sql-4.6.2:4 required by ('installed', '/', 'dev-python/PyQt4-4.7.3', 'nomerge')
>=x11-libs/qt-sql-4.6.0:4[qt3support] required by ('installed', '/', 'kde-base/libplasmagenericshell-4.4.5', 'nomerge')
>=x11-libs/qt-sql-4.6.0:4[qt3support] required by ('installed', '/', 'kde-base/kbattleship-4.4.5', 'nomerge')
(and 205 more)

('installed', '/', 'x11-libs/qt-gui-4.6.2', 'nomerge') pulled in by
>=x11-libs/qt-gui-4.6.0:4[accessibility,dbus] required by ('installed', '/', 'kde-base/kmines-4.4.5', 'nomerge')
>=x11-libs/qt-gui-4.6.0:4[accessibility,dbus] required by ('installed', '/', 'kde-base/qguiplatformplugin_kde-4.4.5', 'nomerge')
>=x11-libs/qt-gui-4.6.0:4[accessibility,dbus] required by ('installed', '/', 'kde-base/kjumpingcube-4.4.5', 'nomerge')
(and 218 more)

('ebuild', '/', 'x11-libs/qt-gui-4.6.3', 'merge') pulled in by
>=x11-libs/qt-gui-4.6.0:4[accessibility,dbus] required by ('installed', '/', 'kde-base/kmines-4.4.5', 'nomerge')
>=x11-libs/qt-gui-4.6.0:4[accessibility,dbus] required by ('installed', '/', 'kde-base/qguiplatformplugin_kde-4.4.5', 'nomerge')
>=x11-libs/qt-gui-4.6.0:4[accessibility,dbus] required by ('installed', '/', 'kde-base/kjumpingcube-4.4.5', 'nomerge')
(and 215 more)

('ebuild', '/', 'x11-libs/qt-core-4.6.3', 'merge') pulled in by
>=x11-libs/qt-core-4.6.0:4[qt3support,ssl] required by ('installed', '/', 'kde-base/kglobalaccel-4.4.5', 'nomerge')
>=x11-libs/qt-core-4.6.0:4[qt3support,ssl] required by ('installed', '/', 'kde-base/kdiamond-4.4.5', 'nomerge')
>=x11-libs/qt-core-4.6.0:4[qt3support,ssl] required by ('installed', '/', 'kde-base/katomic-4.4.5', 'nomerge')
(and 214 more)

('ebuild', '/', 'x11-libs/qt-script-4.6.3', 'merge') pulled in by
>=x11-libs/qt-script-4.6.0:4 required by ('installed', '/', 'kde-base/kscreensaver-4.4.5', 'nomerge')
>=x11-libs/qt-script-4.6.0:4 required by ('installed', '/', 'kde-base/kbounce-4.4.5', 'nomerge')
>=x11-libs/qt-script-4.6.0:4 required by ('installed', '/', 'kde-base/libkexiv2-4.4.5', 'nomerge')
(and 204 more)

('installed', '/', 'x11-libs/qt-core-4.6.2-r1', 'nomerge') pulled in by
>=x11-libs/qt-core-4.6.0:4[qt3support,ssl] required by ('installed', '/', 'kde-base/kglobalaccel-4.4.5', 'nomerge')
>=x11-libs/qt-core-4.6.0:4[qt3support,ssl] required by ('installed', '/', 'kde-base/kdiamond-4.4.5', 'nomerge')
>=x11-libs/qt-core-4.6.0:4[qt3support,ssl] required by ('installed', '/', 'kde-base/katomic-4.4.5', 'nomerge')
(and 217 more)

('ebuild', '/', 'x11-libs/qt-qt3support-4.6.3', 'merge') pulled in by
>=x11-libs/qt-qt3support-4.6.0:4[accessibility,kde] required by ('installed', '/', 'kde-base/kalgebra-4.4.5', 'nomerge')
>=x11-libs/qt-qt3support-4.6.0:4[accessibility,kde] required by ('installed', '/', 'kde-base/kdegraphics-strigi-analyzer-4.4.5', 'nomerge')
>=x11-libs/qt-qt3support-4.6.0:4[accessibility,kde] required by ('installed', '/', 'kde-base/nsplugins-4.4.5', 'nomerge')
(and 203 more)

('ebuild', '/', 'x11-libs/qt-sql-4.6.3-r2', 'merge') pulled in by
>=x11-libs/qt-sql-4.6.2:4 required by ('installed', '/', 'dev-python/PyQt4-4.7.3', 'nomerge')
>=x11-libs/qt-sql-4.6.0:4[qt3support] required by ('installed', '/', 'kde-base/libplasmagenericshell-4.4.5', 'nomerge')
>=x11-libs/qt-sql-4.6.0:4[qt3support] required by ('installed', '/', 'kde-base/kbattleship-4.4.5', 'nomerge')
(and 205 more)

('installed', '/', 'x11-libs/qt-dbus-4.6.2', 'nomerge') pulled in by
>=x11-libs/qt-dbus-4.5.0:4 required by ('installed', '/', 'dev-libs/soprano-2.4.3', 'nomerge')
x11-libs/qt-dbus:4 required by ('installed', '/', 'app-misc/strigi-0.7.2', 'nomerge')
>=x11-libs/qt-dbus-4.6.0:4[-aqua] required by ('installed', '/', 'media-sound/phonon-4.4.1-r1', 'nomerge')
(and 3 more)

('installed', '/', 'x11-libs/qt-webkit-4.6.2-r1', 'nomerge') pulled in by
>=x11-libs/qt-webkit-4.6.0:4[kde] required by ('installed', '/', 'kde-base/kdeplasma-addons-4.4.5', 'nomerge')
>=x11-libs/qt-webkit-4.6.2:4 required by ('installed', '/', 'dev-python/PyQt4-4.7.3', 'nomerge')
>=x11-libs/qt-webkit-4.6.0:4[kde] required by ('installed', '/', 'kde-base/kdelibs-4.4.5', 'nomerge')

('installed', '/', 'x11-libs/qt-script-4.6.2', 'nomerge') pulled in by
>=x11-libs/qt-script-4.6.0:4 required by ('installed', '/', 'kde-base/kscreensaver-4.4.5', 'nomerge')
>=x11-libs/qt-script-4.6.0:4 required by ('installed', '/', 'kde-base/libkexiv2-4.4.5', 'nomerge')
>=x11-libs/qt-script-4.5.1:4 required by ('installed', '/', 'x11-themes/qtcurve-qt4-0.69.2', 'nomerge')
(and 204 more)

('installed', '/', 'x11-libs/qt-svg-4.6.2', 'nomerge') pulled in by
>=x11-libs/qt-svg-4.6.0:4 required by ('installed', '/', 'kde-base/mplayerthumbs-4.4.5', 'nomerge')
>=x11-libs/qt-svg-4.5.1:4 required by ('installed', '/', 'kde-misc/kcm_gtk-1.1', 'nomerge')
>=x11-libs/qt-svg-4.6.0:4 required by ('installed', '/', 'kde-base/kuser-4.4.5', 'nomerge')
(and 203 more)

('ebuild', '/', 'x11-libs/qt-dbus-4.6.3', 'merge') pulled in by
x11-libs/qt-dbus:4 required by ('installed', '/', 'app-misc/strigi-0.7.2', 'nomerge')
>=x11-libs/qt-dbus-4.6.2:4 required by ('installed', '/', 'dev-python/PyQt4-4.7.3', 'nomerge')
>=x11-libs/qt-dbus-4.5.0:4 required by ('installed', '/', 'dev-libs/soprano-2.4.3', 'nomerge')
(and 2 more)

('installed', '/', 'x11-libs/qt-qt3support-4.6.2', 'nomerge') pulled in by
>=x11-libs/qt-qt3support-4.6.0:4[accessibility,kde] required by ('installed', '/', 'kde-base/nsplugins-4.4.5', 'nomerge')
>=x11-libs/qt-qt3support-4.6.0:4[accessibility,kde] required by ('installed', '/', 'kde-base/kiten-4.4.5', 'nomerge')
>=x11-libs/qt-qt3support-4.6.0:4[accessibility,kde] required by ('installed', '/', 'kde-base/kanagram-4.4.5', 'nomerge')
(and 203 more)

('installed', '/', 'x11-libs/qt-test-4.6.2', 'nomerge') pulled in by
>=x11-libs/qt-test-4.6.0:4 required by ('installed', '/', 'kde-base/kdebase-kioslaves-4.4.5', 'nomerge')
>=x11-libs/qt-test-4.6.0:4 required by ('installed', '/', 'kde-base/ktouch-4.4.5', 'nomerge')
>=x11-libs/qt-test-4.6.0:4 required by ('installed', '/', 'kde-base/kubrick-4.4.5', 'nomerge')
(and 205 more)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

* done!


Sieht so aus, als ob nicht alle installierten Pakete mit der Qt-Version 4.6.3 zusammenarbeiten werden. Deshalb ist es wahrscheinlich auch maskiert.
Nun muß ich wohl warten, bis die neuere Version standardmäßig angeboten wird und kann velleicht dann aus KDE-Anwendungen heraus über meinen Printserver drucken (denn das ist ja mein Problem).
Oder kann ich die o.g. Warnungen über blockierte ebuilds ignorieren? Eher nicht, denke ich mir.
_________________
Mm.
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3688
Location: Hamburg

PostPosted: Tue Jul 20, 2010 4:09 pm    Post subject: Re: Drucken aus KDE-Anwendungen nicht möglich Reply with quote

Moldmaker wrote:
, habe ich nun festgestellt, daß ich aus KDE-Anwendungen nicht drucken kann.
Versuch es mal mit cups-1.4.4 : https://forums.gentoo.org/viewtopic-t-834229-highlight-.html
Back to top
View user's profile Send private message
Moldmaker
n00b
n00b


Joined: 13 Jul 2010
Posts: 33

PostPosted: Tue Jul 20, 2010 5:44 pm    Post subject: Reply with quote

Hallo toralf,

Volltreffer! Jetzt funktioniert das Drucken aus KDE-Anwendungen auch über den Printserver!
Danke an alle, die Geduld mit mir hatten. Habe was gelernt hier im Forum.

:D

PS. Es gibt eine Nebenwirkung. Ich kann jetzt in den Systemeinstellungen von KDE die Einstellungen der Drucker nicht mehr ansehen oder ändern; die installierten Drucker sind nur noch zu sehen, Anklicken ist zwecklos. Das stört mich aber nicht, denn das Browser-Frontend von CUPS ist mit ohnehin lieber zur Druckerkonfiguration. Und das funktioniert normal. Zudem erscheint nach dem Absetzen des Druckbefehles nicht mehr dieses zappelige Fensterchen, das den erfolgten Ausdruck meldet; das scheint nur bei lokal angeschlossenen Druckern zu erscheinen. Das ist mir sogar ganz recht.
_________________
Mm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum