Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Gnome automount
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
HoloDoc
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2006
Posts: 76

PostPosted: Sun Jul 18, 2010 7:13 pm    Post subject: [Solved] Gnome automount Reply with quote

Hallo zusammen!

Da ich persönlich finde, dass KDE 4 sehr langsam geworden ist, bin ich jetzt zur aktuellen stabilen Version von Gnome umgestiegen.

Bisher gefällt mir Gnome ganz gut, jedoch vermisse ich 1 Programm:

Wenn ich in KDE 4 einen USB-Stick angeschlossen habe, kam ein Popup von einem Taskbaricon hoch und ich konnte die Festplatte einbinden. Über das gleiche Menü des Taskbaricons konnte ich den Stick auch ohne Probleme ausbinden.

Gibt es so ein schönes Tool auch für Gnome?

Grüße und Danke im Vorraus!

HoloDoc


Last edited by HoloDoc on Wed Jul 21, 2010 4:43 pm; edited 1 time in total
Back to top
View user's profile Send private message
bas89
Apprentice
Apprentice


Joined: 02 Mar 2010
Posts: 243
Location: Germany ;)

PostPosted: Mon Jul 19, 2010 8:52 am    Post subject: Reply with quote

Wenn ich mich recht erinnere, kann man das doch auch sehr bequem auf dem Desktop machen. Oder ist das Problem eher, dass du das auch bei geöffneten Fenstern machen willst?
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Mon Jul 19, 2010 2:35 pm    Post subject: Reply with quote

Geht doch eigentlich ganz von alleine. Du steckst den Stick ein und auf dem Desktop erscheint ein Icon. Dafür muss hal aktiv sein und dein User in der Gruppe plugdev.
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2224
Location: Germany

PostPosted: Mon Jul 19, 2010 2:52 pm    Post subject: Reply with quote

Schau mal ob auf deinem Desktop ein Festplatten-Symbol aufgetaucht ist, wenn nicht sind vielleicht die Einstellung Deaktiviert?

Guck mal unter: System-> Einstellungen-> Wechseldatenträger- und Medieneinstellungen
Back to top
View user's profile Send private message
HoloDoc
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2006
Posts: 76

PostPosted: Mon Jul 19, 2010 4:13 pm    Post subject: Reply with quote

Hallo ihr beiden,

erstmal vielen Dank!

Also die Platten erscheinen nicht auf dem Desktop, jedoch im Menü unter Orte bzw im Datei-Browser unter Rechner. Wenn ich nun aber den USB Stick mounten möchte, erscheint folgende Fehlermeldung:

4,0 GB Dateisystem konnte nicht eingehängt werden
Not Authorized

Ich habe eine Anleitung des Problems gefunden, aber auch diese hat mir nicht weitergeholfen:
http://ubuntuforums.org/showthread.php?t=1435044

Grüße

HoloDoc
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Mon Jul 19, 2010 4:18 pm    Post subject: Reply with quote

Was hast du für Einträge in der fstab? Es funktioniert nicht, wenn das Device da eingetragen ist. Hast du inotify im Kernel aktiviert?

Ok, das mit dem Icon ist eine Sache der Einstellung. Aber dein System merkt schon mal, dass du etwas einsteckst.
Back to top
View user's profile Send private message
HoloDoc
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2006
Posts: 76

PostPosted: Mon Jul 19, 2010 4:27 pm    Post subject: Reply with quote

in der fstab ist nix drin

inotify: ich denke schon, habs mal per"/" in menuconfig gesucht:
Symbol: INOTIFY [=y] │
│ Prompt: Inotify file change notification support │
│ Defined at fs/notify/inotify/Kconfig:1 │
│ Location: │
│ -> File systems │
│ Selected by: AUDIT_TREE [=n] && AUDITSYSCALL [=n] │
│ │
│ │
│ Symbol: INOTIFY_USER [=y] │
│ Prompt: Inotify support for userspace │
│ Defined at fs/notify/inotify/Kconfig:16 │
│ Location: │
│ -> File systems │
│ Selects: FSNOTIFY [=y]
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Mon Jul 19, 2010 4:48 pm    Post subject: Reply with quote

Sehr seltsam. Wenn es unter KDE ging, dann ist ja auch sicher gestellt, dass in Bezug auf FS und USB im Kernel alles richtig ist. Da scheint irgend wo etwas an den Zugriffsrechten zu klemmen.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Mon Jul 19, 2010 5:07 pm    Post subject: Reply with quote

Mit inotify sollte das doch nix zu tun haben, oder? Das ist dazu da, um sich Änderungen am Dateisystem mitteilen zu lassen, ohne teuer ewig rumzupollen.
Ich nehm an, das war keine komplette Neuinstallation, für kde brauchte es da schon hal und dbus, das wird wohl unter Gnome auch Anwendung finden.
Gnome hat ja jetzt irgendwie einiges auf PolicyKit umgestellt, evtl. brauchts dazu eine Regel, kenn mich aber da nicht so wirklich aus...
Ansonsten kann es sein, dass du dich in eine eigene Gruppe eintragen musst.
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Mon Jul 19, 2010 5:25 pm    Post subject: Reply with quote

Ich zitiere einfach mal das elog von Gnome, deshalb die Frage zu inotify:
Code:
* The main file alteration monitoring functionality is
 * provided by >=glib-2.16. Note that on a modern Linux system
 * you do not need the USE=fam flag on it if you have inotify
 * support in your linux kernel ( >=2.6.13 ) enabled.
 * USE=fam on glib is however useful for other situations,
 * such as Gentoo/FreeBSD systems. A global USE=fam can also
 * be useful for other packages that do not use the new file
 * monitoring API yet that the new glib provides.

Ok, es geht dabei um Änderungen am Filesystem und nicht um neue Devices.

Ansonsten zu Policykit usw: Hast du dein System von KDE auf Gnome umgestellt oder neu installiert? Welches Profil verwendest du? Es gibt inzwischen eins für KDE und eins für Gnome.
Back to top
View user's profile Send private message
HoloDoc
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2006
Posts: 76

PostPosted: Mon Jul 19, 2010 5:45 pm    Post subject: Reply with quote

Ich hab bisher KDE4 genutzt. Ich hab nun einfach emerge gnome gemacht und "gdm" eingestellt, sonst nichts weiter
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Mon Jul 19, 2010 5:51 pm    Post subject: Reply with quote

Dann mach mal ein eselect profile list und danach ein eselect profile set auf das Gnome Profil. Und wenn du das gemacht hast ein emerge -uDN world.
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2224
Location: Germany

PostPosted: Mon Jul 19, 2010 7:59 pm    Post subject: Reply with quote

Das wird wohl helfen.

Aber achte auch darauf das du sys-auth/policykit installierst und das policykit Useflag in deine make.conf schreibst. Anschließend das emerge -uDN world und alles ist gut. Bei mir ist das Problem auch aufgetreten. Mir ist das zuerst aber nicht aufgefallen, da ich so selten Wechseldatenträger benutze.

Konnte es aber in den letzten zwei Stunden beheben.
Back to top
View user's profile Send private message
HoloDoc
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2006
Posts: 76

PostPosted: Wed Jul 21, 2010 4:42 pm    Post subject: Reply with quote

Vielen Dank es funktioniert.

Ich muss zwar jetzt immer mein root passwort angeben, aber damit kann ich leben.
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2224
Location: Germany

PostPosted: Thu Jul 22, 2010 2:40 am    Post subject: Reply with quote

HoloDoc wrote:
Vielen Dank es funktioniert.

Ich muss zwar jetzt immer mein root passwort angeben, aber damit kann ich leben.


Oh, das sollte so aber nicht sein..? Vielleicht ist das jetzt so weil du die "Ubuntu-Lösung" Ausprobiert hast.

Ich wollte meine Konfiguration nicht verändern daher hab ich diesen Versuch nicht unternommen, sondern nur das policy Useflag gesetzt und diverse Pakete neu gebaut. Aber nun habe ich die Nebenwirkung das ich nach dem Einbinden den Stick nicht mehr im Nautilus-Fenster "aushängen" kann. Dann sagt mir eine Fehlermeldung sinngemäß: Das Programm es wurde wohl per Konsole eingehängt und nicht mit Nautilus.

Ein umount via Terminal geht ohne Probleme.
Back to top
View user's profile Send private message
JoHo42
l33t
l33t


Joined: 14 Feb 2004
Posts: 944
Location: Germany

PostPosted: Thu Jul 22, 2010 7:47 am    Post subject: Reply with quote

Hi Leute,

bei mir funktioniert der Automount unter gnome.
Allerdings wenn ich eine mit crypsetup verschlüsselte Festplatte anschliesse,
frag der mich nicht nach einem Password.
Ich weiss das das unter gnome geht, allerdings was muss ich dazu installieren / einstellen?

Ich habe den Menüpunkt:
System-> Einstellungen-> Wechseldatenträger- und Medieneinstellungen

nicht.

Welches Packet beinhaltet das?
Ich habe gnome-light installiert.

Gruss Jörg
Back to top
View user's profile Send private message
HoloDoc
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2006
Posts: 76

PostPosted: Thu Jul 22, 2010 12:31 pm    Post subject: Reply with quote

@JoHo42: also bei emerge gnome ist das dabei. Kann dir leider nicht sagen ob das noch in nem anderen paket enthalten ist

@ChrisJumper: ICh kann mir gut vorstellen, dass es disbezüglich in der Konfigurationsdatei usr/share/polkit-1/actions/org.freedesktop.disks.policy
einen Eintrag gibt:

Probier doch mal eine der folgenden Werte zu ändern:

Code:
<action id="org.freedesktop.devicekit.disks.drive-detach">


oder

Code:
<action id="org.freedesktop.devicekit.disks.drive-eject"



Bei mir stehen beide auf dem Wert: <allow_active>yes</allow_active>


Grüße

Holodoc
Back to top
View user's profile Send private message
Jorgo
n00b
n00b


Joined: 18 Jun 2004
Posts: 62
Location: Bochum, Germany

PostPosted: Sun Aug 01, 2010 4:57 pm    Post subject: Reply with quote

Da ich hier auch mit dem Problem zu kämpfen habe:

Solltest Du schon auf udisks geupdated haben, schau dir mal folgende Datei an:
/usr/share/polkit-1/actions/org.freedesktop.udisks.policy

Code:
<action id="org.freedesktop.udisks.filesystem-mount">
    <description>Mount a device</description>
    <description xml:lang="da">Montér en enhed</description>
    <message>Authentication is required to mount the device</message>
    <message xml:lang="da">Autorisering er påkrævet for at montere et fil system</message>
    <defaults>
      <allow_any>yes</allow_any>
      <allow_inactive>yes</allow_inactive>
      <allow_active>yes</allow_active>
    </defaults>
  </action>

  <action id="org.freedesktop.udisks.filesystem-mount-system-internal">
    <description>Mount a system-internal device</description>
    <description xml:lang="da">Montér en intern enhed</description>
    <message>Authentication is required to mount the device</message>
    <message xml:lang="da">Autorisering er påkrævet for at montere et fil system</message>
    <defaults>
      <allow_any>yes</allow_any>
      <allow_inactive>yes</allow_inactive>
      <allow_active>yes</allow_active>
    </defaults>
  </action>


Die ersten beiden Blöcke habe ich editiert, und "NO" durch "Yes" ersetzt. (bzw. auch "Auth ..."
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum