Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Ungereimtheiten beim Systemupdate
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Jefferson
n00b
n00b


Joined: 10 Nov 2005
Posts: 66

PostPosted: Sun Jul 25, 2010 8:49 am    Post subject: [solved] Ungereimtheiten beim Systemupdate Reply with quote

Hallöle,

beim Systemupdate meines Rechners habe ich gesehen, dass er mir eine ganze Menge neuer Pakete installieren will, die ich bisher noch nie gebraucht habe (Rechner läuft schon seit über 2 Jahren).
Auf dem Rechner ist auch gar kein X-Server am laufen.

Kann mir jemand einen Tip geben, wo ich anfangen muss zu suchen um rauszufinden, warum portage die ganzen nachfolgenden (x11)-Pakete installieren will?

Code:

[ebuild  N    ] sys-power/acpid-2.0.4-r2  73 kB
[ebuild  N    ] virtual/jpeg-0  0 kB
[ebuild  N    ] x11-base/xorg-drivers-1.7  INPUT_DEVICES="evdev keyboard mouse -acecad -aiptek -fpit -joystick -penmount -synaptics -tslib -virtualbox -vmmouse -void -wacom" VIDEO_CARDS="fbdev nvidia vesa -apm -ark -ast -chips -cirrus -dummy -epson -fglrx (-geode) -glint -i128 (-i740) (-impact) -intel -mach64 -mga -neomagic (-newport) -nouveau -nv -r128 -radeon -radeonhd -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -via -virtualbox -vmware (-voodoo) (-xgi)" 0 kB                                                                                                                                                                                                                                 
[ebuild  N    ] app-admin/eselect-opengl-1.1.1-r2  58 kB
[ebuild  N    ] dev-python/setuptools-0.6.13  297 kB
[ebuild  N    ] x11-misc/util-macros-1.10.0  64 kB
[ebuild  N    ] x11-proto/xproto-7.0.17  169 kB
[ebuild  N    ] dev-libs/libxslt-1.1.26  USE="crypt python -debug" 3,322 kB
[ebuild  N    ] x11-libs/pixman-0.18.2  USE="mmx sse2 (-altivec) -static-libs" 412 kB
[ebuild  N    ] x11-proto/xextproto-7.1.1  70 kB
[ebuild  N    ] x11-proto/inputproto-2.0  137 kB
[ebuild  N    ] x11-proto/kbproto-1.0.4  103 kB
[ebuild  N    ] x11-libs/xtrans-1.2.5  USE="-debug" 139 kB
[ebuild  N    ] x11-proto/randrproto-1.3.1  108 kB
[ebuild  N    ] x11-proto/fontsproto-2.1.0  56 kB
[ebuild  N    ] x11-libs/libXau-1.0.5  USE="-static-libs" 245 kB
[ebuild  N    ] x11-proto/renderproto-0.11  65 kB
[ebuild  N    ] x11-proto/xf86vidmodeproto-2.3  83 kB
[ebuild  N    ] x11-libs/libXdmcp-1.0.3  USE="-static-libs" 251 kB
[ebuild  N    ] dev-libs/libpthread-stubs-0.1  USE="-debug" 190 kB
[ebuild  N    ] x11-proto/damageproto-1.2.0  52 kB
[ebuild  N    ] x11-proto/videoproto-2.3.0  54 kB
[ebuild  N    ] x11-proto/dri2proto-2.3  94 kB
[ebuild  N    ] x11-proto/xf86driproto-2.1.0  49 kB
[ebuild  N    ] x11-proto/resourceproto-1.1.0  48 kB
[ebuild  N    ] x11-proto/glproto-1.4.11  106 kB
[ebuild  N    ] x11-proto/xf86bigfontproto-1.2.0  49 kB
[ebuild  N    ] x11-proto/xcb-proto-1.6  91 kB
[ebuild  N    ] x11-proto/trapproto-3.4.3  48 kB
[ebuild  N    ] x11-proto/compositeproto-0.4.1  88 kB
[ebuild  N    ] x11-proto/bigreqsproto-1.1.0  48 kB
[ebuild  N    ] x11-proto/xf86dgaproto-2.1  84 kB
[ebuild  N    ] x11-proto/xineramaproto-1.2  82 kB
[ebuild  N    ] x11-proto/scrnsaverproto-1.2.0  49 kB
[ebuild  N    ] x11-libs/libpciaccess-0.11.0  USE="zlib -debug -minimal" 289 kB
[ebuild  N    ] x11-apps/rgb-1.0.3  USE="-debug" 102 kB
[ebuild  N    ] x11-proto/xf86rushproto-1.1.2  37 kB
[ebuild  N    ] x11-misc/xbitmaps-1.1.0  100 kB
[ebuild  N    ] x11-proto/recordproto-1.14  83 kB
[ebuild  N    ] x11-proto/xcmiscproto-1.2.0  48 kB
[ebuild  N    ] x11-libs/libfontenc-1.0.5  USE="-debug" 245 kB
[ebuild  N    ] x11-misc/makedepend-1.0.2  USE="-debug" 114 kB
[ebuild  N    ] x11-libs/libICE-1.0.6  USE="-debug -ipv6" 273 kB
[ebuild  N    ] x11-libs/libdrm-2.4.20-r1  USE="-debug" 392 kB
[ebuild  N    ] x11-proto/fixesproto-4.1.1  90 kB
[ebuild  N    ] x11-libs/libxcb-1.6  USE="-doc (-selinux) -static-libs" 310 kB
[ebuild  N    ] x11-libs/libXfont-1.4.2  USE="-ipv6 -static-libs" 424 kB
[ebuild  N    ] x11-libs/libX11-1.3.4  USE="xcb -doc -ipv6 -static-libs -test" 2,077 kB
[ebuild  N    ] x11-libs/libSM-1.1.1  USE="uuid -debug -ipv6" 257 kB
[ebuild  N    ] x11-libs/libXext-1.1.2  USE="-static-libs" 312 kB
[ebuild  N    ] x11-libs/libxkbfile-1.0.6  USE="-debug" 279 kB
[ebuild  N    ] x11-libs/libXt-1.0.8  USE="-static-libs" 524 kB
[ebuild  N    ] x11-libs/libvdpau-0.4  USE="-doc" 442 kB
[ebuild  N    ] x11-apps/iceauth-1.0.3  USE="-debug" 104 kB
[ebuild  N    ] x11-libs/libXfixes-4.0.5  USE="-static-libs" 250 kB
[ebuild  N    ] x11-libs/libXmu-1.0.5  USE="-debug -ipv6" 316 kB
[ebuild  N    ] x11-apps/xkbcomp-1.1.1  USE="-debug" 215 kB
[ebuild  N    ] x11-libs/libxkbui-1.0.2  USE="-debug" 217 kB
[ebuild  N    ] x11-libs/libXres-1.0.4  USE="-debug" 244 kB
[ebuild  N    ] x11-libs/libXi-1.3  USE="-debug" 343 kB
[ebuild  N    ] x11-libs/libXdamage-1.1.3  USE="-static-libs" 244 kB
[ebuild  N    ] x11-libs/libXxf86vm-1.1.0  USE="-debug" 243 kB
[ebuild  N    ] x11-apps/xauth-1.0.4  USE="-debug -ipv6" 117 kB
[ebuild  N    ] media-libs/mesa-7.8.2  USE="xcb -debug (-gallium) -motif -nptl -pic (-selinux)" VIDEO_CARDS="-intel -mach64 -mga -none -nouveau -r128 -radeon -radeonhd -savage -sis -svga -tdfx -via" 5,019 kB
[ebuild  N    ] x11-misc/xkeyboard-config-1.9  636 kB
[ebuild  N    ] x11-apps/xrdb-1.0.6  USE="-debug" 106 kB
[ebuild  N    ] x11-apps/xinit-1.2.0-r3  USE="minimal pam -debug" 134 kB
[ebuild  N    ] x11-base/xorg-server-1.7.6  USE="hal xorg -debug -dmx -ipv6 -kdrive -minimal -nptl -sdl -tslib" 4,813 kB
[ebuild  N    ] x11-drivers/xf86-video-fbdev-0.4.2  257 kB
[ebuild  N    ] x11-drivers/xf86-input-evdev-2.4.0  USE="-debug" 300 kB
[ebuild  N    ] x11-drivers/xf86-input-keyboard-1.4.0  USE="-debug" 281 kB
[ebuild  N    ] x11-drivers/xf86-input-mouse-1.5.0  USE="-debug" 301 kB
[ebuild  N    ] x11-drivers/xf86-video-vesa-2.3.0  USE="-debug" 259 kB
[ebuild  N    ] app-emulation/emul-linux-x86-opengl-20100611  14,208 kB
[ebuild  N    ] app-emulation/emul-linux-x86-xlibs-20100611  USE="opengl" 7,946 kB
[ebuild  N    ] x11-drivers/nvidia-drivers-195.36.24  USE="acpi (multilib) -custom-cflags -gtk" 41,093 kB


Last edited by Jefferson on Sun Jul 25, 2010 10:14 am; edited 1 time in total
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2040
Location: My own world! I and Gentoo!

PostPosted: Sun Jul 25, 2010 9:26 am    Post subject: Reply with quote

Lass dir mal die Ausgabe von emerge -ptuDN ausgeben.

Ist dir vielleicht das X,gtk oder qt Use-Flag zwischengerutscht?
_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Sun Jul 25, 2010 9:42 am    Post subject: Reply with quote

Quote:
[ebuild N ] x11-drivers/nvidia-drivers ...
Hehe, bei einem System ohne X würde ich als erstes nachschauen wer mir da denn die nvidia-drivers installieren möchte :wink:
Ansonsten maskiere doch einfach mal den xorg-server , dann sollte bei einem "emerge -avuDNt world" ersichtlich sein wer was warum benötigt.
BTW
Was wird den für ein Profil verwendet?
Back to top
View user's profile Send private message
Jefferson
n00b
n00b


Joined: 10 Nov 2005
Posts: 66

PostPosted: Sun Jul 25, 2010 10:14 am    Post subject: Reply with quote

Quote:

Hehe, bei einem System ohne X würde ich als erstes nachschauen wer mir da denn die nvidia-drivers installieren möchte


Das war's! Imagemagick wollte den nvidia Treiber installieren und der nvidia Treiber die ganzen x11-Packete.

Nach Anpassung der make.conf war wieder alles wie sonst auch.

Danke für eure Hilfe.
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Sun Jul 25, 2010 4:27 pm    Post subject: Reply with quote

jetzt nicht so ganz direkt zum Problem, aber zum thema:
Wieso kann man nvidia-drivers nicht ohne X-server installieren? Nur mal angenommen, man möchte sich irgendeinen "rechenknecht" bauen, der OpenCL/CUDA verwendet, dann brauch ich doch die nvidia-treiber dafür, aber wieso braucht man dan X?
Back to top
View user's profile Send private message
Qubit
Tux's lil' helper
Tux's lil' helper


Joined: 23 Sep 2002
Posts: 136
Location: /dev/urandom

PostPosted: Sun Jul 25, 2010 4:48 pm    Post subject: Reply with quote

Da die Abhängigkeiten des Treibers selbst dies voraussetzen:

http://us.download.nvidia.com/XFree86/Linux-x86_64/256.35/README/minimumrequirements.html

Gruß Daniel
_________________
©Qubit
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Sun Jul 25, 2010 4:58 pm    Post subject: Reply with quote

ah, ok. dann ist es die schuld von nvidia, nicht von gentoo. Meine Welt ist wieder in Ordnung.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum