Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ssh] configuration sur debian...[résolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Mon Jul 26, 2010 8:37 am    Post subject: [ssh] configuration sur debian...[résolu] Reply with quote

Bonjour,

Sur mon LAN j'ai un NAS (MyBookWorld edition).
Sur ce NAS (hacké) il est possible de se connecter avec ssh.
Depuis ma gentoo je parviens à me connecter sur le port 22.
J'ai voulu faire de même sur le port 443 et pour se faire j'ai modifié le fichier de config du NAS /etc/sshd_config pour ajouter la ligne Port 443
Code:
[BENJAMIN@MyBookWorld etc]$ cat sshd_config
#       $OpenBSD: sshd_config,v 1.69 2004/05/23 23:59:53 dtucker Exp $

# This is the sshd server system-wide configuration file.  See
# sshd_config(5) for more information.

# This sshd was compiled with PATH=/usr/bin:/bin:/usr/sbin:/sbin

# The strategy used for options in the default sshd_config shipped with
# OpenSSH is to specify options with their default value where
# possible, but leave them commented.  Uncommented options change a
# default value.

Port 22
Port 443
#Protocol 2,1
#ListenAddress 0.0.0.0
#ListenAddress ::

# HostKey for protocol version 1
#HostKey /etc/ssh_host_key
# HostKeys for protocol version 2
#HostKey /etc/ssh_host_rsa_key
#HostKey /etc/ssh_host_dsa_key

# Lifetime and size of ephemeral version 1 server key
#KeyRegenerationInterval 1h
#ServerKeyBits 768

# Logging
#obsoletes QuietMode and FascistLogging
#SyslogFacility AUTH
#LogLevel INFO

# Authentication:

#LoginGraceTime 2m
#PermitRootLogin yes
#StrictModes yes
#MaxAuthTries 6

#RSAAuthentication yes
#PubkeyAuthentication yes
#AuthorizedKeysFile     .ssh/authorized_keys

# For this to work you will also need host keys in /etc/ssh_known_hosts
#RhostsRSAAuthentication no
# similar for protocol version 2
#HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# RhostsRSAAuthentication and HostbasedAuthentication
#IgnoreUserKnownHosts no
# Don't read the user's ~/.rhosts and ~/.shosts files
#IgnoreRhosts yes

# To disable tunneled clear text passwords, change to no here!
#PasswordAuthentication yes
#PermitEmptyPasswords no

# Change to no to disable s/key passwords
#ChallengeResponseAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes
#KerberosGetAFSToken no

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication mechanism.
# Depending on your PAM configuration, this may bypass the setting of
# PasswordAuthentication, PermitEmptyPasswords, and
# "PermitRootLogin without-password". If you just want the PAM account and
# session checks to run without PAM authentication, then enable this but set
# ChallengeResponseAuthentication=no
#UsePAM no

#AllowTcpForwarding yes
#GatewayPorts no
#X11Forwarding no
#X11DisplayOffset 10
#X11UseLocalhost yes
#PrintMotd yes
#PrintLastLog yes
#TCPKeepAlive yes
#UseLogin no
#UsePrivilegeSeparation yes
#PermitUserEnvironment no
#Compression yes
#ClientAliveInterval 0
#ClientAliveCountMax 3
#UseDNS yes
#PidFile /var/run/sshd.pid
#MaxStartups 10

# no default banner path
#Banner /some/path

ClientAliveInterval 15
ClientAliveCountMax 4

# override default of no subsystems
Subsystem       sftp    /usr/sbin/sftp-server

oui je sais normalement ce devrait être dans le répertoire /etc/ssh mais là c'est pas fait comme ça le répertoire /etc/ssh n'existe pas !
J'ai tenté une connexion sur le port 443 depuis ma gentoo sans succès de même avec putty depuis un pc XP :
Code:
ben@ataualpa /etc/ssh $ ssh -p 22 BENJAMIN@192.168.1.21
BENJAMIN@192.168.1.21's password:
[BENJAMIN@MyBookWorld ~]$ logout
Connection to 192.168.1.21 closed.
ben@ataualpa /etc/ssh $ ssh -p 443 BENJAMIN@192.168.1.21
ssh: connect to host 192.168.1.21 port 443: Connection refused


Je me suis dis que je devais déjà avoir un service qui écoute le port 443 car je ne pense pas que le problème vienne de la configuration.
On peut se demander si c'est le bon fichier de configuration qui est lu pour ça j'ai fait ceci connecté sur le NAS :
Code:
[root@MyBookWorld /]# /usr/sbin/sshd -f /etc/sshd_config -d
debug1: sshd version OpenSSH_3.9p1
debug1: private host key: #0 type 0 RSA1
debug1: read PEM private key done: type RSA
debug1: private host key: #1 type 1 RSA
debug1: read PEM private key done: type DSA
debug1: private host key: #2 type 2 DSA
debug1: rexec_argv[0]='/usr/sbin/sshd'
debug1: rexec_argv[1]='-f'
debug1: rexec_argv[2]='/etc/sshd_config'
debug1: rexec_argv[3]='-d'
socket: Address family not supported by protocol
debug1: Bind to port 443 on 0.0.0.0.
socket: Address family not supported by protocol
debug1: Bind to port 22 on 0.0.0.0.
Bind to port 22 on 0.0.0.0 failed: Address already in use.
Cannot bind any address.

J'ai du mal a en déduire quelque chose. J'ai ensuite joué un peu avec netstat (il n'y a pas beaucoup de commandes sur le NAS (busybox oblige))
Code:
[root@MyBookWorld BENJAMIN]# netstat -a
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State
tcp        0      0 *:26180                 *:*                     LISTEN
tcp        0      0 *:rsync                 *:*                     LISTEN
tcp        0      0 *:netbios-ssn           *:*                     LISTEN
tcp        0      0 *:www                   *:*                     LISTEN
tcp        0      0 *:ssh                   *:*                     LISTEN
tcp        0      0 MyBookWorld:ssh         192.168.1.10:45095      ESTABLISHED
udp        0      0 *:3073                  *:*
udp        0      0 MyBookWorld:netbios-ns  *:*
udp        0      0 *:netbios-ns            *:*
udp        0      0 MyBookWorld:netbios-dgm *:*
udp        0      0 *:netbios-dgm           *:*
udp        0      0 *:5353                  *:*
udp        0      0 localhost:ntp           *:*
udp        0      0 MyBookWorld:ntp         *:*
udp        0      0 *:ntp                   *:*
Active UNIX domain sockets (servers and established)
Proto RefCnt Flags       Type       State         I-Node Path
unix  2      [ ACC ]     STREAM     LISTENING     668    /tmp/php.socket-0
unix  2      [ ACC ]     STREAM     LISTENING     672    /tmp/php.socket-1
unix  2      [ ACC ]     STREAM     LISTENING     676    /tmp/php.socket-2
unix  2      [ ACC ]     STREAM     LISTENING     680    /tmp/php.socket-3
unix  3      [ ]         STREAM     CONNECTED     826
unix  3      [ ]         STREAM     CONNECTED     825
unix  3      [ ]         STREAM     CONNECTED     587
unix  3      [ ]         STREAM     CONNECTED     586

[root@MyBookWorld BENJAMIN]# grep 443 /etc/services
https           443/tcp                         # MCom
https           443/udp                         # MCom
====================================================================================
[root@MyBookWorld BENJAMIN]# grep ssh /etc/services
ssh             22/tcp                          # SSH Remote Login Protocol
ssh             22/udp                          # SSH Remote Login Protocol
[root@MyBookWorld BENJAMIN]# grep sshd /etc/services
[root@MyBookWorld BENJAMIN]#
====================================================================================
[root@MyBookWorld BENJAMIN]# cat /etc/inetd.conf
netbios-ssn stream tcp nowait root /usr/local/samba/sbin/smbd smbd -s/etc/smb.conf -l/var/log -d0
#swat stream tcp nowait root /usr/local/samba/sbin/swat swat -a -d 1 -l /var/log
#tftp    dgram   udp     wait    root    /usr/sbin/in.tftpd in.tftpd -c -s /tftpboot
ssh stream tcp nowait root /usr/sbin/sshd sshd -i
telnet  stream  tcp     nowait  root    /usr/sbin/telnetd       telnetd
rsync   stream  tcp     nowait  root    /opt/bin/rsync rsyncd --daemon

mais j'ai pas retrouvé dans les sorties quelque chose d'intéressant (faut dire que je ne sais pas bien les lire non plus).
Peut-être qu'au final c'est un conflit avec rsync qui utilise ssh je crois... bref tout ça pour dire que j'en sais rien.
Petite info supplémentaire j'utilise ipkg sur ce NAS et voici la liste de ce qu'il y a d'installé :
Code:
[root@MyBookWorld BENJAMIN]# ipkg status
Package: bzip2
Version: 1.0.5-1
Status: install ok installed
Architecture: arm

Package: cyrus-sasl-libs
Version: 2.1.22-2
Status: install ok installed
Architecture: arm

Package: gdbm
Version: 1.8.3-2
Status: install ok installed
Architecture: arm

Package: gettext
Version: 0.14.5-2
Status: install ok installed
Architecture: arm

Package: libcurl
Version: 7.19.6-1
Depends: openssl, zlib
Status: install user installed
Architecture: arm

Package: libdb
Version: 4.2.52-3
Status: install ok installed
Architecture: arm

Package: libevent
Version: 1.4.11-1
Status: install ok installed
Architecture: arm

Package: libiconv
Version: 1.13-1
Status: install user installed
Architecture: arm

Package: libstdc++
Version: 6.0.3-6
Status: install ok installed
Architecture: arm

Package: libxml2
Version: 2.7.5-1
Depends: zlib
Status: install ok installed
Architecture: arm

Package: libxslt
Version: 1.1.26-1
Depends: libxml2
Status: install ok installed
Architecture: arm

Package: nano
Version: 2.1.10-1
Depends: ncurses
Status: install user installed
Architecture: arm

Package: ncurses
Version: 5.7-1
Status: install ok installed
Architecture: arm

Package: openldap-libs
Version: 2.3.43-1
Depends: openssl, libdb, gdbm, cyrus-sasl-libs
Status: install ok installed
Architecture: arm

Package: openssl
Version: 0.9.7m-5
Status: install ok installed
Architecture: arm

Package: pcre
Version: 7.9-1
Depends: libstdc++
Status: install ok installed
Architecture: arm

Package: php
Version: 5.2.11-1
Depends: bzip2, openssl, zlib, libxml2, libxslt, gdbm, libdb, pcre, cyrus-sasl-libs, openldap-libs
Status: install user installed
Architecture: arm

Package: php-fcgi
Version: 5.2.11-3
Depends: php (5.2.11), pcre
Status: install user installed
Architecture: arm

Package: php-pear
Version: 5.2.11-1
Depends: php
Status: install user installed
Architecture: arm
Installed-Time: 1255037223

Package: rsync
Version: 3.0.6-1
Depends: libiconv
Status: install user installed
Architecture: arm

Package: transmission
Version: 1.75-1
Depends: openssl, libcurl, libevent, gettext
Status: install user installed
Architecture: arm

Package: zlib
Version: 1.2.3-3
Status: install ok installed
Architecture: arm

Successfully terminated.

Mais bon, même avec ça je ne sais pas d'où peut venir le problème.


Last edited by BENJI on Wed Sep 15, 2010 9:13 am; edited 1 time in total
Back to top
View user's profile Send private message
man in the hill
Veteran
Veteran


Joined: 15 Dec 2005
Posts: 1552
Location: Madinina

PostPosted: Mon Jul 26, 2010 11:12 am    Post subject: Reply with quote

Salut,

Il faut que tu commente la ligne avec port 22 sinon ssh écoutera tjrs le 22 .

Il est possible que le port 443 soit déjà utilisé sur le NAS car c'est le port du https .

Code:
netstat -ltn
Connexions Internet actives (seulement serveurs)
Proto Recv-Q Send-Q Adresse locale          Adresse distante        Etat       
tcp        0      0 127.0.0.1:3306          0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:139             0.0.0.0:*               LISTEN     
tcp        0      0 127.0.0.1:5037          0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN     
tcp        0      0 127.0.0.1:631           0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:443             0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:445             0.0.0.0:*               LISTEN

_________________
Get Up and Go !
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Mon Jul 26, 2010 1:10 pm    Post subject: Reply with quote

Sur ma gentoo puis sur le Mybook :
Code:
ben@ataualpa ~ $ netstat -ltn
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State
tcp        0      0 0.0.0.0:49152           0.0.0.0:*               LISTEN
tcp        0      0 127.0.0.1:3306          0.0.0.0:*               LISTEN
tcp        0      0 0.0.0.0:139             0.0.0.0:*               LISTEN
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN
tcp        0      0 0.0.0.0:443             0.0.0.0:*               LISTEN
tcp        0      0 0.0.0.0:445             0.0.0.0:*               LISTEN
ben@ataualpa ~ $ ssh BENJAMIN@192.168.1.21 -p 22
BENJAMIN@192.168.1.21's password:
[BENJAMIN@MyBookWorld ~]$ netstat -ltn
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State
tcp        0      0 0.0.0.0:26180           0.0.0.0:*               LISTEN
tcp        0      0 0.0.0.0:873             0.0.0.0:*               LISTEN
tcp        0      0 0.0.0.0:139             0.0.0.0:*               LISTEN
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN
tcp        0      0 0.0.0.0:23              0.0.0.0:*               LISTEN

Est-ce que je me trompe si je dis que le port 443 n'est pas déjà écouté ?

Voici le sshd_config sur ma gentoo :
Code:
ben@ataualpa ~ $ sudo cat /etc/ssh/sshd_config
Password:
#       $OpenBSD: sshd_config,v 1.80 2008/07/02 02:24:18 djm Exp $

# This is the sshd server system-wide configuration file.  See
# sshd_config(5) for more information.

# This sshd was compiled with PATH=/usr/bin:/bin:/usr/sbin:/sbin

# The strategy used for options in the default sshd_config shipped with
# OpenSSH is to specify options with their default value where
# possible, but leave them commented.  Uncommented options change a
# default value.

Port 22
Port 443
#AddressFamily any
#ListenAddress 0.0.0.0
#ListenAddress
[...]::

Les deux ports sont précisés et ça marche sur ma gentoo je ne voyais donc pas bien l'intérêt de commenter Port 22 sur le NAS mais bon ça coûtait pas grand chose d'essayer
J'ai donc fait la modification,
Code:
[BENJAMIN@MyBookWorld ~]$ grep Port /etc/sshd_config
Port 443
#GatewayPorts no

relancé le service mais ça ne fonctionne toujours pas !
Code:
ben@ataualpa ~ $ ssh BENJAMIN@192.168.1.21 -p 443
ssh: connect to host 192.168.1.21 port 443: Connection refused

Le port 443 doit être utilisé mais par qui ? comment le savoir ? si je réponds à ça je résous mon problème !
Une autre idée ? :roll:
Est-ce qu'on peut déduire qqch de ça ?
Code:
[root@MyBookWorld BENJAMIN]# iperf -c localhost -p 443
connect failed: Connection refused
write1 failed: Broken pipe
write2 failed: Broken pipe
------------------------------------------------------------
Client connecting to localhost, TCP port 443
TCP window size: 16.0 KByte (default)
------------------------------------------------------------
[  5] local 0.0.0.0 port 4753 connected with 127.0.0.1 port 443
[  5]  0.0- 0.0 sec  0.00 Bytes  0.00 bits/sec
Back to top
View user's profile Send private message
Picani
Apprentice
Apprentice


Joined: 05 Jul 2009
Posts: 180

PostPosted: Mon Jul 26, 2010 4:40 pm    Post subject: Reply with quote

Tu peux essayer avec net-analyzer/nmap. Tu fais un petit
Code:
# nmap -sSU le nom ou l'IP du NAS
et sa va te sortir tous les ports ouverts ou avec un pare-feux derrière du NAS, en TCP et en UDP (si tu veux pas UDP, enlève le U). Il doit y avoir un moyen de regarder que le port 443, mais je ne sais pas le faire, faudrait que je lise le manuel ...
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Tue Jul 27, 2010 4:38 am    Post subject: Reply with quote

Dans le doute... tu as bien redémarré le service?

(Perso j'aurais aussi dit que 2 Ports d'écoute c'était bizare...)

Maintenant, j'ai une question existentielle... Pourquoi écouter du SSH sur un 443? Pour passer une firewall (un NAS c'est sur LAN en général)? J'ai beau chercher, je ne vois pas trop ^^


edit:

man 5 sshd_config wrote:

Code:

     Port    Specifies the port number that sshd(8) listens on.  The default
             is 22.  Multiple options of this type are permitted.  See also
             ListenAddress.



Au temps pour moi...


edit 2:
Je ne vois pas openssh dans ta liste de paquets installés, tu es sur qu'il s'agit bien de l'implémentation de openssh, donc ça a du être installé à la main et/ou par défaut. Ce n'est pas un truc style dropbear ou autre?
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7935
Location: ~Brussels - Belgique

PostPosted: Tue Jul 27, 2010 7:53 am    Post subject: Reply with quote

L'avantage d'écouter sur le port 443 est de pouvoir passer à travers un pare-feu qui n'ouvre que les ports HTTP/HTTPS, sans vérifier les flux.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Tue Jul 27, 2010 9:12 am    Post subject: Reply with quote

Poussin wrote:
Dans le doute... tu as bien redémarré le service?

(Perso j'aurais aussi dit que 2 Ports d'écoute c'était bizare...)

Maintenant, j'ai une question existentielle... Pourquoi écouter du SSH sur un 443? Pour passer une firewall (un NAS c'est sur LAN en général)? J'ai beau chercher, je ne vois pas trop ^^


edit:

man 5 sshd_config wrote:

Code:

     Port    Specifies the port number that sshd(8) listens on.  The default
             is 22.  Multiple options of this type are permitted.  See also
             ListenAddress.



Au temps pour moi...


edit 2:
Je ne vois pas openssh dans ta liste de paquets installés, tu es sur qu'il s'agit bien de l'implémentation de openssh, donc ça a du être installé à la main et/ou par défaut. Ce n'est pas un truc style dropbear ou autre?

XavierMiller a donné la réponse.
Sinon plus que le service j'ai bien redémarré le NAS.
Je n'ai pas installé openssh car il l'était déjà d'origine (c'est très difficile de savoir où d'ailleurs, d'en connaitre la version et de savoir comment et par qui il est lancé). J'ai installé optware et je gère l'installe des paquets suivants avec ipkg (openssh n'en fait pa partie) :
Code:
[BENJAMIN@MyBookWorld ~]$ ipkg list_installed
bzip2 - 1.0.5-1 - Very high-quality data compression program
cyrus-sasl-libs - 2.1.22-2 - Provides client or server side authentication (see RFC 2222).
gdbm - 1.8.3-2 - GNU dbm is a set of database routines that use extensible hashing. It works similar to the standard UNIX dbm routines.
gettext - 0.14.5-2 - Set of tools for producing multi-lingual messages
libcurl - 7.19.6-1 - Curl is a command line tool for transferring files with URL syntax, supporting FTP, FTPS, HTTP, HTTPS, GOPHER, TELNET, DICT, FI
libdb - 4.2.52-3 - Berkeley DB Libraries
libevent - 1.4.11-1 - libevent to implement an event loop
libiconv - 1.13-1 - Converts between character encodings.
libstdc++ - 6.0.3-6 - Standard C++ library, needed for dynamically linked C++ programs
libxml2 - 2.7.5-1 - Libxml2 is the XML C parser and toolkit developed for the Gnome project.
libxslt - 1.1.26-1 - An XML Stylesheet processor based on libxml2
nano - 2.1.10-1 - A pico like editor
ncurses - 5.7-1 - NCurses libraries
openldap-libs - 2.3.43-1 - Open Lightweight Directory Access Protocol
openssl - 0.9.7m-5 - Openssl provides the ssl implementation in libraries libcrypto and libssl, and is needed by many other applications and librari
pcre - 7.9-1 - Perl-compatible regular expression library
php - 5.2.11-1 - The php scripting language
php-fcgi - 5.2.11-3 - The php scripting language, built as an fcgi module
php-pear - 5.2.11-1 - PHP Extension and Application Repository
rsync - 3.0.6-1 - fast remote file copy program (like rcp)
transmission - 1.75-1 - Lightweight BitTorrent client and daemon, with web interface bundled.
zlib - 1.2.3-3 - zlib is a library implementing the 'deflate' compression system.
Successfully terminated.


Picani wrote:
Tu peux essayer avec net-analyzer/nmap. Tu fais un petit
Code:
# nmap -sSU le nom ou l'IP du NAS
et sa va te sortir tous les ports ouverts ou avec un pare-feux derrière du NAS, en TCP et en UDP (si tu veux pas UDP, enlève le U). Il doit y avoir un moyen de regarder que le port 443, mais je ne sais pas le faire, faudrait que je lise le manuel ...

Voici le résultat avec nmap :
Code:
ataualpa ben # nmap -sV 192.168.1.21

Starting Nmap 5.21 ( http://nmap.org ) at 2010-07-27 12:03 CEST
Nmap scan report for MyBookWorld (192.168.1.21)
Host is up (0.0017s latency).
Not shown: 995 closed ports
PORT    STATE SERVICE     VERSION
22/tcp  open  ssh         OpenSSH 3.9p1 (protocol 1.99)
23/tcp  open  telnet      Linksys WRT54G telnetd (Tomato firmware)
80/tcp  open  http        lighttpd 1.4.3
139/tcp open  netbios-ssn Samba smbd 3.X (workgroup: WORKGROUP)
873/tcp open  rsync       (protocol version 30)
MAC Address: 00:90:A9:23:26:2B (Western Digital)
Service Info: Device: WAP

Service detection performed. Please report any incorrect results at http://nmap.org/submit/ .
Nmap done: 1 IP address (1 host up) scanned in 11.95 seconds

Code:
ataualpa ben # nmap -sVU 192.168.1.21 -p 443

Starting Nmap 5.21 ( http://nmap.org ) at 2010-07-27 12:35 CEST
Nmap scan report for MyBookWorld (192.168.1.21)
Host is up (0.00038s latency).
PORT    STATE  SERVICE VERSION
443/udp closed https
MAC Address: 00:90:A9:23:26:2B (Western Digital)

Service detection performed. Please report any incorrect results at http://nmap.org/submit/ .
Nmap done: 1 IP address (1 host up) scanned in 0.37 seconds


Le port 443 n'est donc pas écouté !
Il est closed ?
Alors c'est quoi le problème ?
La version d'OpenSSH ?
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Tue Jul 27, 2010 10:13 am    Post subject: Reply with quote

En lançant sshd à la main avec tout le debug qui va bien, ça sort quoi?
Code:

/usr/sbin/sshd -Dde -p 22 -p 443



Pour la raison, si le 443 est le seul port ouvert via le firewall, pourquoi ne pas utiliser uniquement ce port (et non le 22?)
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Tue Jul 27, 2010 11:16 am    Post subject: Reply with quote

Code:
[root@MyBookWorld network]# /usr/sbin/sshd -Dde -p 22 -p 443
debug1: sshd version OpenSSH_3.9p1
debug1: private host key: #0 type 0 RSA1
debug1: read PEM private key done: type RSA
debug1: private host key: #1 type 1 RSA
debug1: read PEM private key done: type DSA
debug1: private host key: #2 type 2 DSA
debug1: rexec_argv[0]='/usr/sbin/sshd'
debug1: rexec_argv[1]='-Dde'
debug1: rexec_argv[2]='-p'
debug1: rexec_argv[3]='22'
debug1: rexec_argv[4]='-p'
debug1: rexec_argv[5]='443'
socket: Address family not supported by protocol
debug1: Bind to port 443 on 0.0.0.0.
Server listening on 0.0.0.0 port 443.
socket: Address family not supported by protocol
debug1: Bind to port 22 on 0.0.0.0.
Bind to port 22 on 0.0.0.0 failed: Address already in use.
Generating 768 bit RSA key.
RSA key generation complete.
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Tue Jul 27, 2010 11:38 am    Post subject: Reply with quote

ouais de fait, le 22 est déjà occupé normal ^^ Mais une fois la commande lancée, tu as accès au 443?
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Tue Jul 27, 2010 11:44 am    Post subject: Reply with quote

oui ça marche !
Code:
ben@ataualpa ~ $ ssh BENJAMIN@192.168.1.21 -p 443
BENJAMIN@192.168.1.21's password:
Environment:
  USER=BENJAMIN
  LOGNAME=BENJAMIN
  HOME=/home/BENJAMIN
  PATH=/usr/bin:/bin:/usr/sbin:/sbin
  MAIL=/var/mail/BENJAMIN
  SHELL=/bin/sh
  SSH_CLIENT=192.168.1.10 44190 443
  SSH_CONNECTION=192.168.1.10 44190 192.168.1.21 443
  SSH_TTY=/dev/pts/1
  TERM=xterm
[BENJAMIN@MyBookWorld ~]$

et la suite du log ici :
Code:
debug1: permanently_set_uid: 1002/1002
debug1: Entering interactive session for SSH2.
debug1: server_init_dispatch_20
debug1: server_input_channel_open: ctype session rchan 0 win 1048576 max 16384
debug1: input_session_request
debug1: channel 0: new [server-session]
debug1: session_new: init
debug1: session_new: session 0
debug1: session_open: channel 0
debug1: session_open: session 0: link with channel 0
debug1: server_input_channel_open: confirm session
debug1: server_input_channel_req: channel 0 request pty-req reply 1
debug1: session_by_channel: session 0 channel 0
debug1: session_input_channel_req: session 0 req pty-req
debug1: Allocating pty.
debug1: session_new: init
debug1: session_new: session 0
debug1: session_pty_req: session 0 alloc /dev/pts/1
debug1: server_input_channel_req: channel 0 request shell reply 1
debug1: session_by_channel: session 0 channel 0
debug1: session_input_channel_req: session 0 req shell
debug1: Setting controlling tty using TIOCSCTTY.
debug1: Got 100/11 for keepalive
debug1: Got 100/12 for keepalive
debug1: Got 100/13 for keepalive
debug1: Got 100/14 for keepalive
debug1: Received SIGCHLD.
debug1: session_by_pid: pid 780
debug1: session_exit_message: session 0 channel 0 pid 780
debug1: session_exit_message: release channel 0
debug1: session_close: session 0 pid 780
Received disconnect from 192.168.1.10: 11: disconnected by user
debug1: do_cleanup
debug1: session_by_tty: session 0 tty /dev/pts/1
debug1: session_pty_cleanup: session 0 release /dev/pts/1
syslogin_perform_logout: logout() returned an error
debug1: do_cleanup

Code:
ataualpa ben # nmap -sV 192.168.1.21

Starting Nmap 5.21 ( http://nmap.org ) at 2010-07-27 15:20 CEST
Nmap scan report for MyBookWorld (192.168.1.21)
Host is up (0.0016s latency).
Not shown: 994 closed ports
PORT    STATE SERVICE     VERSION
22/tcp  open  ssh         OpenSSH 3.9p1 (protocol 1.99)
23/tcp  open  telnet      Linksys WRT54G telnetd (Tomato firmware)
80/tcp  open  http        lighttpd 1.4.3
139/tcp open  netbios-ssn Samba smbd 3.X (workgroup: WORKGROUP)
443/tcp open  ssh         OpenSSH 3.9p1 (protocol 1.99)
873/tcp open  rsync       (protocol version 30)
MAC Address: 00:90:A9:23:26:2B (Western Digital)
Service Info: Device: WAP

Service detection performed. Please report any incorrect results at http://nmap.org/submit/ .
Nmap done: 1 IP address (1 host up) scanned in 11.82 seconds
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Tue Jul 27, 2010 12:22 pm    Post subject: Reply with quote

la question à 1000 boules.... pourquoi ça ne marche pas via le fichier de config...

Je dois avoir un mybook qui traine, je vais tester cet aprem

edit: Oula, c'est une vieille version de SSH sur le machin!!!
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Wed Jul 28, 2010 7:06 am    Post subject: Reply with quote

Salut,
Ta question a du sens car je me posais la même et je me suis dis normalement la conf de ssh c'est sous /etc/ssh c'est donc que ce fichier de conf n'était pas lu !
Alors sous /etc/inet.conf j'ai ajouter à ma ligne ssh les mêmes options que la commande à la main (sauf les options de debug) comme ceci :
Code:
[root@MyBookWorld BENJAMIN]# cat /etc/inetd.conf
netbios-ssn stream tcp nowait root /usr/local/samba/sbin/smbd smbd -s/etc/smb.conf -l/var/log -d0
#swat stream tcp nowait root /usr/local/samba/sbin/swat swat -a -d 1 -l /var/log
#tftp    dgram   udp     wait    root    /usr/sbin/in.tftpd in.tftpd -c -s /tftpboot
ssh stream tcp nowait root /usr/sbin/sshd sshd -i -p 22 -p 443
telnet  stream  tcp     nowait  root    /usr/sbin/telnetd       telnetd
rsync   stream  tcp     nowait  root    /opt/bin/rsync rsyncd --daemon

J'ai relancé le service et bien sûr ça ne marchait pas mieux :twisted:
Je me suis donc dis que ce que j'avais fait n'a aucun effet et j'ai commencé à douter que ce fichier de conf soit lu.
J'ai donc commenter la ligne
Quote:
#ssh stream tcp nowait root /usr/sbin/sshd sshd -i -p 22 -p 443
.
J'ai relancé le service et bien entendu j'ai eu ce que je méritais... plus de connexion par ssh !
Heureusement que deux jours avant j'avais pensé à activer un service telnet...
Cette ligne était donc bien lu.
Mais c'est quoi inet au fait ?
Quelques heures de recherche plus tard j'ai enfin trouvé la solution. Pour qu'une connexion ssh sur le port 443 fonctionne il faut justement le configurer dans sshd_config mais également dans inet.conf de la façon suivante :
Code:

ssh stream tcp nowait root /usr/sbin/sshd sshd -i
https stream tcp nowait root /usr/sbin/sshd sshd -i

et là au miracle... ça marche !
prochaine étape démarrer ma gentoo depuis le NAS !
1- comment on fait un wake on lan sur gentoo ?
2- quel paquet adapter à mon NAS (ARM) je vais bien pouvoir installé ou compiler pour faire booter ma gentoo ?
Sont les deux prochaines questions auxquelles je vais devoir répondre. Si vous avez des pistes n'hésitez pas !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum