Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
"resume" innerhalb einer initramfs hängt für einige Sekunden
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
ConiKost
Developer
Developer


Joined: 11 Jan 2005
Posts: 1362

PostPosted: Sun Aug 01, 2010 9:46 pm    Post subject: "resume" innerhalb einer initramfs hängt für einig Reply with quote

Hallo,
ich habe zum Ersten Mal mein Gentoo komplett mit luks verschlüsselt.
Da ich kein genkernel einsetzen wollte, habe ich mir ne eigene initramfs gebaut.

Als Vorlage hatte ich hier was nettes gefunden: http://lunaryorn.de/articles/initramfs_gentoo.html
Daraus hab ich mir etwas in abgewandelter Form gebaut.

Mein Problem ist nun, dass das ganze hängt. Sobald er den Befehl "resume" ausführt, hängt er für etwa 30-40 Sekunden. Dannach geht es ganz normal weiter. Unabhängig davon, ob ich nun suspend-to-disk ausgeführt habe oder nicht. Und das ist doch recht nervig.. würde aber gern das verkürzen.

Funktionieren tut das Suspend-to-Disk jedoch problemlos.

Im Prinzip gibt er folgendes aus und hängt:
Code:
resume: libgrypt version: 1.4.6


Hat jemand eine Idee, was hier los ist?

Mein angepasstes Script innerhalb der initramfs:
Code:

#!/bin/busybox ash

# Umgebungsvariablen (Allgemein)
export HOTPLUG="/proc/sys/kernel/hotplug"
export INIT="/sbin/init"
export NEW_ROOT="/mnt/root"
export PATH="/bin:/sbin:/usr/lib/suspend"
export PRINTK="/proc/sys/kernel/printk"

# Umgebungsvariablen (Geraete)
export CONSOLE="/dev/console"
export NULL="/dev/null"
export TTY="/dev/tty1"

# Umgebungsvariablen (Konsole)
export CONSOLEFONT="ter-v16b"
export KEYMAP="de-latin1-nodeadkeys"

# Umgebungsvariablen (System)
export PROC="/proc"
export SYS="/sys"

# Umgebungsvariablen (Verschluesselung)
export CRYPT_ROOT="/mnt/root"
export CRYPT_SWAP="/mnt/swap"
export MAPPER_ROOT="/dev/mapper/root"
export MAPPER_SWAP="/dev/mapper/swap"
export ROOT="/dev/sda5"
export SWAP="/dev/sda6"

# Systemverzeichnise bereitstellen
mount -t proc proc $PROC
mount -t sysfs sys $SYS

# Kurze Pause
sleep 1

# Kernelausgabe deaktivieren
echo 0 > $PRINTK

# Busybox 'mdev' aktivieren
mdev -s
echo mdev > $HOTPLUG

# UTF-8 aktivieren
kbd_mode -u -C $TTY
printf "\033%%G" >> $CONSOLE

# Tastaturlayout laden
loadkmap < /usr/share/keymaps/i386/qwertz/$KEYMAP.map.bin

# Fonts setzen
setfont /usr/share/consolefonts/${CONSOLEFONT}.psf.gz -C $TTY
printf "\033(K" >> $CONSOLE

# Banner ausgeben
echo
echo "Willkommen..."
echo

# Cryptdevice mounten
cryptsetup luksOpen $ROOT root > $NULL
cryptsetup luksOpen $SWAP swap > $NULL

# Falls der Suspendmodus aktiv ist, diesen wiederherstellen
resume

# Das eigentliche / System mounten
mount -o ro ${MAPPER_ROOT} $CRYPT_ROOT

# Alles zuruecksetzen
echo "hotplug reset"
echo > $HOTPLUG
# umount $DEV
umount $PROC
umount $SYS

# Wechsel zum "echten" /
exec switch_root $CRYPT_ROOT $INIT
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum