Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gallium and radeon again
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
pactoo
Guru
Guru


Joined: 18 Jul 2004
Posts: 553

PostPosted: Thu Jul 29, 2010 9:08 pm    Post subject: gallium and radeon again Reply with quote

OK. I successfully rebuild mesa with gallium support. I rebuild xorg-server 1.8.2 with udev and without hal support. I rebuild the ati-driver 6.13.1, libdrm and emerged eselect-mesa.

I do have a X1050 based Ati card, however, however, after remerging mesa with gallium I've lost all 3D support. xdriinfo claimes: "no direct rendering available", KDE cannot activate any effects and eselect-mesa set r300 gallium complains: "Unable to update /usr/lib/dri/r300_dri.so - not a symlink". eselect-mesa show only lists classic anyway, no trace of gallium, but cannot set this either with the same error

Not sure, what went wrong. Kernel is vanilla 2.6.33.5, with dri, fb radeon all set. I've found quite a few docs, but most do not seem to reflect the current status.
Back to top
View user's profile Send private message
cyrillic
Watchman
Watchman


Joined: 19 Feb 2003
Posts: 7313
Location: Groton, Massachusetts USA

PostPosted: Thu Jul 29, 2010 11:40 pm    Post subject: Reply with quote

The latest drivers may work better with radeon + KMS rather than radeonfb in your kernel.

This is what I have been using with my ATI cards, and it seems to work well.
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 923
Location: halmstad

PostPosted: Fri Jul 30, 2010 10:05 am    Post subject: Reply with quote

cyrillic

gallium dont like kwin (3d) and compiz .unmask/keyword mesa-9999 and gallium comes by default

x ~ # emerge -av mesa

* IMPORTANT: 2 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild U ] media-libs/mesa-9999 [7.8.2] USE="classic%* gallium* nptl xcb -debug -llvm% -motif -pic (-selinux)" VIDEO_CARDS="radeon -i810% -i915% -i965% -intel -mach64 -mga -none -nouveau -r100% -r128 -r200% -r300% -r600% -radeonhd -savage -sis -tdfx -via -vmware% (-svga%)" 0 kB [0=>1]

Total: 1 package (1 upgrade), Size of downloads: 0 kB
Portage tree and overlays:
[0] /usr/portage
[1] /var/lib/layman/x11

Would you like to merge these packages? [Yes/No] n


you can use sw (Software renderer) gallium but not r300 and r600
Back to top
View user's profile Send private message
pactoo
Guru
Guru


Joined: 18 Jul 2004
Posts: 553

PostPosted: Wed Aug 04, 2010 5:06 pm    Post subject: Reply with quote

The problem lies elsewhere, KMS and 3D currently do not work at all, regardless of gallium or not. Opened another thread for this
Back to top
View user's profile Send private message
Kingoftherings
Guru
Guru


Joined: 04 May 2008
Posts: 328

PostPosted: Wed Aug 04, 2010 7:14 pm    Post subject: Reply with quote

hedmo wrote:
cyrillic

gallium dont like kwin (3d) and compiz .unmask/keyword mesa-9999 and gallium comes by default

x ~ # emerge -av mesa

* IMPORTANT: 2 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild U ] media-libs/mesa-9999 [7.8.2] USE="classic%* gallium* nptl xcb -debug -llvm% -motif -pic (-selinux)" VIDEO_CARDS="radeon -i810% -i915% -i965% -intel -mach64 -mga -none -nouveau -r100% -r128 -r200% -r300% -r600% -radeonhd -savage -sis -tdfx -via -vmware% (-svga%)" 0 kB [0=>1]

Total: 1 package (1 upgrade), Size of downloads: 0 kB
Portage tree and overlays:
[0] /usr/portage
[1] /var/lib/layman/x11

Would you like to merge these packages? [Yes/No] n


you can use sw (Software renderer) gallium but not r300 and r600


You should add r300 to your VIDEO_CARDS along with radeon. That may be the problem.
Back to top
View user's profile Send private message
robnotts
Guru
Guru


Joined: 15 Mar 2004
Posts: 405
Location: Nottingham, UK

PostPosted: Fri Aug 06, 2010 12:34 am    Post subject: Reply with quote

I had to add both r300 and r600 to get this working, even though I only have an r300 card.
_________________
---

Gentoo Phenom][ X4 955 on AMD790 + Geforce 220GT 8GB/1.75TB (Desktop)
+ MythTV (3xFreeview,1xFreesat HD) on 1080p
Gentoo Turion64 X2 Geforce 6150 2GB/120GB (Laptop)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum