Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kernel-rebuild (genkernel)
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
neph
n00b
n00b


Joined: 31 Jul 2010
Posts: 19

PostPosted: Sat Jul 31, 2010 9:42 pm    Post subject: kernel-rebuild (genkernel) Reply with quote

Hallo allerseits..

Ich hab hier ein großes problem..

Kiste fährt mit raid darauf lvm.. Bisher konnte ich das ganze einfach so hochfahren:

Code:
title=Gentoo Linux (2.6.32-gentoo-r7)
kernel (hd0,0)/boot/kernel-genkernel-x86-2.6.32-gentoo-r7 root=/dev/ram0 rootdelay=10 init=linuxrc real_root=/dev/mapper/vg0-root dolvm domdadm dodmraid console=tty1 vga=791 quite


heute musste ich auf baselayout-2 umstellen weil mir der udev nach einem emerge -va world dann sagte dass er nicht mit baselayout-1 spielen mag.. Hab ich also auf baselayout-2 um- und festgestellt das udev keine devnodes anlegt.. nach ein wenig lesen bin ich dann darauf gekommen das CONFIG_SYS_DEPRECATED gesetzt ist und in den gefunden threads darauf verwiesen wurde dass udev deswegen keine lust hat.. hab ich das also raus genommen und mit

Code:
genkernel --save-config --install --integrated-initramfs --splash="natural_gentoo" --makeopts=-j3 all


den kernel neu gebacken...

Nu spuckt der beim boot:

Code:
VFS: Cannot open root device ram0 or unknown-block(1,0)
Please append a correct "root=" boot option; here are the available partitions:


Hat jmd. eine idee?
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2042
Location: My own world! I and Gentoo!

PostPosted: Sat Jul 31, 2010 10:00 pm    Post subject: Reply with quote

Hmmmm hast du evtl den Support für ram-devices rausgenommen? Das wäre das einzigste(!) was mir auf die schnelle einfällt.
Code:
Symbol: BLK_DEV_RAM [=y]
Prompt: RAM block device support
  Defined at drivers/block/Kconfig:340
  Depends on: BLK_DEV [=y]
  Location:
    -> Device Drivers
      -> Block devices (BLK_DEV [=y])

_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic
Back to top
View user's profile Send private message
neph
n00b
n00b


Joined: 31 Jul 2010
Posts: 19

PostPosted: Sat Jul 31, 2010 10:42 pm    Post subject: Reply with quote

ne, habsch nich, aber ich hab gerade die lösung gefunden... :roll:

Die Ramdisk war zu klein, is default 8M.. Hab jetzt 64M und bootet wieder...


Danke fürs lesen...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum