Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Mauszeigergeschwindigkeit zu hoch
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
BlackEye
l33t
l33t


Joined: 04 Dec 2002
Posts: 756
Location: Germany

PostPosted: Tue Aug 03, 2010 12:19 pm    Post subject: Mauszeigergeschwindigkeit zu hoch Reply with quote

Ich bekomme meine Mauszeigergeschwindigkeit unter KDE einfach nicht weiter gedrosselt.
Ich habe die Einstellungen schon auf dem untersten Niveau und sie ist immer noch zu schnell für ein gemütliches Arbeiten.
Ich habe seit heute eine Logitech MX620 Laser Maus. Ich nehme an, es liegt an der sehr hohen DPI-Zahl solcher Mäuse.

Code:
# lshal | grep -i mouse
  info.product = 'IBM Enhanced (101/102-key, PS/2 mouse support)'  (string)
  pnp.description = 'IBM Enhanced (101/102-key, PS/2 mouse support)'  (string)
  info.product = 'MX620 Laser Cordless Mouse'  (string)
  input.x11_driver = 'mouse'  (string)
  usb_device.product = 'MX620 Laser Cordless Mouse'  (string)
  info.capabilities = {'input', 'input.mouse'} (string list)


Nach diversen googeleien bin ich schon auf die folgende fdi-Datei für HAL gestossen:
Code:
<?xml version="1.0" encoding="ISO-8859-1"?>
<deviceinfo version="0.2">
  <device>
    <match key="info.product" contains="MX620 Laser Cordless Mouse">
      <merge key="input.x11_driver" type="string">mouse</merge>
      <merge key="input.x11_options.Sensitivity" type="string">0.2</merge>
      <merge key="input.x11_options.Device" type="string">/dev/input/mice</merge>
      <merge key="input.x11_options.Resolution" type="string">1600</merge>
      <merge key="input.x11_options.SampleRate" type="string">400</merge>
    </match>
  </device>
</deviceinfo>


Leider bewirkt diese Datei rein gar nichts. Hat da noch jemand einen Tipp für mich?
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2251
Location: Germany

PostPosted: Fri Aug 06, 2010 6:03 pm    Post subject: Reply with quote

Also selbst mit einer hohen Auflösung sollte es langsamer gehen. Ich kenne mich in de KDE-Einstellungen leider nicht so gut aus. Aber bestimmt kann man auch eine Art "Beschleunigung" aktivieren. Und vielleicht ist diese Einstellung bei dir gesetzt? Ich meine jetzt nicht die Empfindlichkeit, sondern das der Zeiger immer schneller wird (Beschleunigt) wenn man die Maus ohne pause in eine Richtung schiebt.

Ich schau nachher mal bei meinem Kde vorbei.

Edit: Natürlich kann man das nicht einstellen und die Empfindlichkeit bezieht sich nur auf die Beschleunigung :/

Quote:
Leider bewirkt diese Datei rein gar nichts.


Schau mal ob und wie deine Maus im Xorg.?.log erkannt und eingerichtet wird.

Edit: Es sollte aber möglich sein, die Resolution einfach kleiner zu stellen also z.B. auf 800 statt 1600. Vorausgesetzt das Xorg diese fdi-Datei schluckt.
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1169
Location: Buchholz/GER

PostPosted: Fri Aug 06, 2010 7:05 pm    Post subject: Reply with quote

Funktioniert Systemsettings -> Systemverwaltung/Tastatur&Maus -> Maus -> Reiterkarte Erweitert -> Zeigerbeschleunigung?

Der Wert steht bei mir auf 2.2, vielleicht versuchst Du mal, daran zu drehen?
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3258
Location: de

PostPosted: Sun Aug 08, 2010 9:50 am    Post subject: Reply with quote

Installier xorg-1.8 und schmeiß das HAL-Zeug aus dem xorg raus, funktioniert da sowieso nicht mehr.

Und bei der Mouse-Section gab's/gibt's eine Option, um die Auflösung einzustellen:
Code:
    Identifier  "Mouse"
    Driver      "mouse"
    Option      "CorePointer"
#    Option     "Dev Phys"      "isa0060/serio1/input0"
#    Option     "Protocol"      "evdev"
    Option      "Buttons"       "5"
    Option      "Protocol"      "IMPS/2"
    Option      "Device"        "/dev/psaux"
    Option      "ZAxisMapping"  "4 5"
    Option      "Resolution"    "800"
EndSection

Das ist aus einer alten xorg-Config von mir. Probier mal, ob die Zeile "Resolution" noch funtioniert.
Back to top
View user's profile Send private message
BlackEye
l33t
l33t


Joined: 04 Dec 2002
Posts: 756
Location: Germany

PostPosted: Tue Aug 10, 2010 7:57 am    Post subject: Reply with quote

ChrisJumper wrote:

Schau mal ob und wie deine Maus im Xorg.?.log erkannt und eingerichtet wird.

Edit: Es sollte aber möglich sein, die Resolution einfach kleiner zu stellen also z.B. auf 800 statt 1600. Vorausgesetzt das Xorg diese fdi-Datei schluckt.


Code:
(II) config/hal: Adding input device AT Translated Set 2 keyboard
(II) LoadModule: "evdev"
(II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
(II) Module evdev: vendor="X.Org Foundation"
        compiled for 1.7.6, module version = 2.4.0
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 7.0
(**) AT Translated Set 2 keyboard: always reports core events
(**) AT Translated Set 2 keyboard: Device: "/dev/input/event2"
(II) AT Translated Set 2 keyboard: Found keys
(II) AT Translated Set 2 keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "de"
(**) Option "xkb_variant" "nodeadkeys"
(II) config/hal: Adding input device Logitech USB Receiver
(**) Logitech USB Receiver: always reports core events
(**) Logitech USB Receiver: Device: "/dev/input/event4"
(II) Logitech USB Receiver: Found 1 mouse buttons
(II) Logitech USB Receiver: Found scroll wheel(s)
(II) Logitech USB Receiver: Found relative axes
(II) Logitech USB Receiver: Found absolute axes
(II) Logitech USB Receiver: Found keys
(II) Logitech USB Receiver: Configuring as mouse
(II) Logitech USB Receiver: Configuring as keyboard
(**) Logitech USB Receiver: YAxisMapping: buttons 4 and 5
(**) Logitech USB Receiver: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "de"
(**) Option "xkb_variant" "nodeadkeys"
(EE) Logitech USB Receiver: failed to initialize for relative axes.
(**) Logitech USB Receiver: (accel) keeping acceleration scheme 1
(**) Logitech USB Receiver: (accel) acceleration profile 0
(II) Logitech USB Receiver: initialized for absolute axes.
(II) config/hal: Adding input device Logitech USB Receiver
(**) Logitech USB Receiver: always reports core events
(**) Logitech USB Receiver: Device: "/dev/input/event3"
(II) Logitech USB Receiver: Found 20 mouse buttons
(II) Logitech USB Receiver: Found scroll wheel(s)
(II) Logitech USB Receiver: Found relative axes
(II) Logitech USB Receiver: Found x and y relative axes
(II) Logitech USB Receiver: Configuring as mouse
(**) Logitech USB Receiver: YAxisMapping: buttons 4 and 5
(**) Logitech USB Receiver: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: MOUSE)
(**) Logitech USB Receiver: (accel) keeping acceleration scheme 1
(**) Logitech USB Receiver: (accel) acceleration profile 0
(II) Logitech USB Receiver: initialized for relative axes.

Keine Ahnung ob das jetzt hilfreich ist :)
Ich weiss auch nicht wie er eine Logitech-Tastatur findet. Zumal er ja als erstes die "echte" Tastatur gefunden hat. Ich habe hier eine Kabellose USB-Maus die mit einem USB-Empfänger arbeitet. Evtl ist das etwas was er hier fehlinterpretiert...

Steve` wrote:
Funktioniert Systemsettings -> Systemverwaltung/Tastatur&Maus -> Maus -> Reiterkarte Erweitert -> Zeigerbeschleunigung?

Der Wert steht bei mir auf 2.2, vielleicht versuchst Du mal, daran zu drehen?

Steht bei mir auf 0.1 und der Zeiger rennt wie hölle...

musv wrote:
Installier xorg-1.8 und schmeiß das HAL-Zeug aus dem xorg raus, funktioniert da sowieso nicht mehr.

Xorg-1.8 ist aber noch nicht stable. Na mal sehen.. Arbeitet 1.8 dann wieder mit der xorg.conf oder wie? Ich blick das alles nicht mehr. "Früher" war die xorg.conf wichtig. Jetzt (gar nicht so lange her als das kam) war HAL das große Thema mit den "tollen" fdi-Dateien. Und jetzt ist wieder april april - alles wird anders und ohne HAL. Kann man nicht endlich mal ein Ding vernünftig durchziehen? Oder setzt Xorg-1.9 dann wieder auf HAL auf? :)
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3258
Location: de

PostPosted: Wed Aug 11, 2010 12:37 pm    Post subject: Reply with quote

BlackEye wrote:
Xorg-1.8 ist aber noch nicht stable. Na mal sehen.. Arbeitet 1.8 dann wieder mit der xorg.conf oder wie? Ich blick das alles nicht mehr. "Früher" war die xorg.conf wichtig. Jetzt (gar nicht so lange her als das kam) war HAL das große Thema mit den "tollen" fdi-Dateien. Und jetzt ist wieder april april - alles wird anders und ohne HAL. Kann man nicht endlich mal ein Ding vernünftig durchziehen? Oder setzt Xorg-1.9 dann wieder auf HAL auf? :)

Ok, kann ich nicht sagen. Ich hab's schon ein paar Monate im Einsatz. Keine Ahnung, ob das jetzt schon stable ist. Bei mir läufts.

Aufgrund u.a. der tollen fdi-Dateien ist den Xorg-Leuten HAL zu blöd geworden. Der neue Hype heißt udev. Im Klartext hast du jetzt ein Verzeichnis /etc/X11/xorg.conf.d und da stehen dann Dateien drin, die im Großen und Ganzen den früheren Sections der xorg.conf entsprechen. Die wurden etwas erweitert um die Identifizierung von Eingabegeräten. Hauptsächlich sollte dabei der evdev-Treiber zum Einsatz kommen. Die xorg.conf wurde auch in den letzten xorg-Versionen mit HAL noch beachtet. Wenn sie nicht vorhanden ist, sollte es aber auch funktionieren.

HAL ist übrigens als deprecated eingestuft. K3B (bzw. die dazugehörigen Kioslaves) aus KDE4 ist bei mir das einzige Programm, was HAL zwingend erfordern würde. Deswegen nehm ich noch K3B aus KDE3.
Back to top
View user's profile Send private message
MarcenX
n00b
n00b


Joined: 30 Mar 2005
Posts: 46

PostPosted: Thu Aug 12, 2010 8:12 pm    Post subject: Reply with quote

Hallo,

versuch mal mit
Code:
   <merge key="input.x11_options.AdaptiveDeceleration" type="string">1</merge>

in deiner HAL-config. Wenn es noch zu schnell ist mal mit weniger (zB 0.5) versuchen.

Mehr zu der Einstellung http://www.x.org/wiki/Development/Documentation/PointerAcceleration
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum