Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED][Cups-1.4.4] USB-Drucker wird nicht erkannt
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Wed Aug 11, 2010 4:18 pm    Post subject: [SOLVED][Cups-1.4.4] USB-Drucker wird nicht erkannt Reply with quote

Hallo,

ich habe seit einem Jahr einen OKI B410d, der als Laserjet1100 unter Cups-1.3.x angesprochen wurde.
Nun, nach dem Update auf KDE 4.5 und Cups 1.4.4 wird der Drucker nicht gefunden.
Nur ein SCSI-Drucker (Unknown) wird gefunden.
Der Drucker ist allerdings ein ganz normaler USB-Drucker.

Eine funktionierende PPD Datei habe ich, aber da der Drucker nicht gefunden wird, hilft sie mir nichts.
Der existierende Drucker (wohl übernommen aus Cups-1.3) geht auch nicht. Der wartet immer, bis der Drucker bereit ist.

Habt ihr eine Idee?

Danke
Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke


Last edited by Finswimmer on Wed Aug 11, 2010 8:18 pm; edited 1 time in total
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2251
Location: Germany

PostPosted: Wed Aug 11, 2010 5:08 pm    Post subject: Reply with quote

Hi Finswimmer,

seit Cups 1.4.x bringt es ein eigenes USB-Printer-Modul mit, dieses verträgt sich nicht mit dem usblp aus dem Kernel.

Um USB-Drucker unter Cups ab Version 1.4.x zu verwenden musst du den Kernel mit

Code:
# CONFIG_USB_PRINTER is not set


Compilieren oder aber wenn du es als Modul gebaut und geladen hast, dieses dann nun entfernen
Code:
 # modprobe -r usblp

und in die Blacklist eintragen. Damit es beim nächsten Bootvorgang nicht geladen wird:
Code:
 # echo "blacklist usblp" >> /etc/modprobe.d/blacklist.conf


Evtl. Cups neustarten.

Ich bin mir jetzt nicht 100% sicher ob das bei allen USB-Drucker-Hersteller-Treibern der Fall ist, denke aber schon.

Grüße

Chris


Last edited by ChrisJumper on Wed Aug 11, 2010 5:09 pm; edited 1 time in total
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1186

PostPosted: Wed Aug 11, 2010 5:09 pm    Post subject: Reply with quote

schau mal das: https://forums.gentoo.org/viewtopic-t-836214-highlight-.html

EDIT: zu langsam...
Back to top
View user's profile Send private message
fuchur
Guru
Guru


Joined: 12 Aug 2003
Posts: 578

PostPosted: Wed Aug 11, 2010 5:10 pm    Post subject: Reply with quote

Hi

Seit cups 1.4 benutzt cups raw devives und nicht mehr das usblp kernel module.

Musste bei mir in /etc/modprobe.d/blacklist.conf folgendes eintragen:
Code:

# hplip and cups 1.4+ use raw USB devices, so it requires usblp not be loaded
blacklist usblp

bzw. in kernel .config deaktivieren.
Weiss jetzt nicht mehr ob noch mehr nötig war am besten mal google fragen
nach cups 1.4 und raw devices, da ich cups schon seit länger benutze.

MfG
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3715
Location: Hamburg

PostPosted: Wed Aug 11, 2010 7:39 pm    Post subject: Reply with quote

Hhm, also mit meinem Uralt-Tintenstrahler (Lexmark z617) gibt's auch mit dem neuen cups keine Probleme mit usblp (kernel 2.6.35.1).
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Wed Aug 11, 2010 8:18 pm    Post subject: Reply with quote

Danke, das wars.
Ich hatte zwar im Kernel schon nach usblp gesucht, aber da bekommt man das nicht angezeigt :/
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
lxg
Veteran
Veteran


Joined: 12 Nov 2005
Posts: 1019
Location: Aachen, Germany

PostPosted: Wed Aug 11, 2010 8:49 pm    Post subject: Reply with quote

Ist schon irgendwie ironisch, man muss cups mit USE="-usb" bauen, um USB-Drucker nutzen zu können. 8O War zumindest bei mir so und hat mich einen ganzen Abend gekostet, den Fehler bzw. die Lösung zu finden.
_________________
lxg.de – codebits and tech talk
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2251
Location: Germany

PostPosted: Thu Aug 12, 2010 12:09 am    Post subject: Reply with quote

lxg wrote:
man muss cups mit USE="-usb" bauen, um USB-Drucker nutzen zu können


Dann hast du aber im Kernel noch das USB-Printer-Modul aktiviert oder? Damit ist halt dann gemeint das Cups sein eigenes usb-Modul dann nicht mehr verwendet/besitzt. Aber danke für den Hinweis, das wusste ich noch nicht.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum