Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mysqlmanager zeigt nicht alle datenbanken an
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Craven66
n00b
n00b


Joined: 03 Aug 2010
Posts: 41

PostPosted: Fri Aug 06, 2010 8:46 am    Post subject: mysqlmanager zeigt nicht alle datenbanken an Reply with quote

Hallo ich benutze für mysql den mysqlmanger zum starten des Dienstes etc.

Leider zeigt mir der mysql nach dem connect nicht alle Datenbanken an.

Code:

mysql> show databases;

information_schema
mysql
test


Im my.cnf zeigt der datadir auf /data/mysql.

Verzeichnisstruktur unter data/mysql:

mysql.bin datien

.MYD Dateien
.MYI Dateien
.FRM Dateien

Verzeichnis Intranet:

weitere .MYD, .MYI und .FRM Files


>>>>>>Die mysql Datenbank mit allen Verzeichnissen .MYD, MYI und .FRM stammt aus einer Sicherung mit Kopiervorgang.

Wäre nett wenn ihr mir bei der Lösung helfen könntet.
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Fri Aug 06, 2010 9:24 am    Post subject: Reply with quote

Hat Dein User Zugriff auf die Datenbank?
Sind die Dateirechte in Ordnung?
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
Craven66
n00b
n00b


Joined: 03 Aug 2010
Posts: 41

PostPosted: Fri Aug 06, 2010 9:47 am    Post subject: Reply with quote

Hallo Fins,

ja ich Rechte sind in Ordnung. Ich habe beim testen aber festgestellt das er auf den falschen Pfad zugreift.

Er arbeitet mit den Datenbanken unter /var/lib/ obwohl ich ihm mit [mysqld1] in der my.cnf extra als datadir /data/mysql angegeben habe.

Ich poste hier gleich mal den aktuellen Auszug meiner my.cnf.

Ist dir bekannt wie ich den mysqlmanager zwingen kann mit /data/mysql zu arbeiten?

Vielen Dank.
Back to top
View user's profile Send private message
Craven66
n00b
n00b


Joined: 03 Aug 2010
Posts: 41

PostPosted: Fri Aug 06, 2010 9:53 am    Post subject: Reply with quote

# use [safe_mysqld] with mysql-3
[mysqld_safe]
err-log = /var/log/mysql/mysql.err

# add a section [mysqld-4.1] or [mysqld-5.0] for specific configurations
[mysqld1]
character-set-server = utf8
default-character-set = utf8
user = mysql
port = 3311
socket = /var/run/mysqld/mysqld.sock
pid-file = /var/run/mysqld/mysqld.pid
log-error = /var/log/mysql/mysqld.err
basedir = /var/lib
datadir = /data/mysql
skip-locking
key_buffer = 16M
max_allowed_packet = 1M
table_cache = 64
sort_buffer_size = 512K
net_buffer_length = 8K
read_buffer_size = 256K
read_rnd_buffer_size = 512K
myisam_sort_buffer_size = 8M
language = /usr/share/mysql/english
use-manager
# security:
# using "localhost" in connects uses sockets by default
# skip-networking
bind-address = 127.0.0.1

log-bin=mysql-bin
server-id = 1

# point the following paths to different dedicated disks
tmpdir = /tmp/
#log-update = /path-to-dedicated-directory/hostname

# you need the debug USE flag enabled to use the following directives,
# if needed, uncomment them, start the server and issue
# #tail -f /tmp/mysqld.sql /tmp/mysqld.trace
# this will show you *exactly* what's happening in your server ;)

#log = /tmp/mysqld.sql
#gdb
#debug = d:t:i:o,/tmp/mysqld.trace
#one-thread

# uncomment the following directives if you are using BDB tables
#bdb_cache_size = 4M
#bdb_max_lock = 10000

# the following is the InnoDB configuration
# if you wish to disable innodb instead
# uncomment just the next line
#skip-innodb
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2042
Location: My own world! I and Gentoo!

PostPosted: Fri Aug 06, 2010 9:58 am    Post subject: Reply with quote

Hmmm evtl musst du die Zeile
Code:
[mysqld1]

zu
Code:
[mysqld-5.1]

abändern, natürlich je nachdem welche mysql Version du installiert hast.
_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic
Back to top
View user's profile Send private message
Craven66
n00b
n00b


Joined: 03 Aug 2010
Posts: 41

PostPosted: Fri Aug 06, 2010 10:46 am    Post subject: Reply with quote

Hallo Max,

ich habe die Änderung ausprobiert. Doch leider hat es nichts gebracht. Wie ich vermutet hatte dient die Angabe wohl nur als Instanzname für mysqlmanager.

Hast du sonst noch einen Einfall Max woran das Problem liegen könnte?
Back to top
View user's profile Send private message
69719
l33t
l33t


Joined: 20 Sep 2004
Posts: 865

PostPosted: Fri Aug 06, 2010 12:55 pm    Post subject: Reply with quote

Folgende config sollte für dich funktionieren, deine ist irgendwie verkorkst...
Code:

# /etc/mysql/my.cnf: The global mysql configuration file.
# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/files/my.cnf-4.1,v 1.4 2008/11/14 02:16:25 robbat2 Exp $

# The following options will be passed to all MySQL clients
[client]
#password                                       = your_password
port                                            = 3306
socket                                          = /var/run/mysqld/mysqld.sock

[mysql]
character-sets-dir=/usr/share/mysql/charsets
default-character-set=utf8

[mysqladmin]
character-sets-dir=/usr/share/mysql/charsets
default-character-set=utf8

[mysqlcheck]
character-sets-dir=/usr/share/mysql/charsets
default-character-set=utf8

[mysqldump]
character-sets-dir=/usr/share/mysql/charsets
default-character-set=utf8

[mysqlimport]
character-sets-dir=/usr/share/mysql/charsets
default-character-set=utf8

[mysqlshow]
character-sets-dir=/usr/share/mysql/charsets
default-character-set=utf8

[myisamchk]
character-sets-dir=/usr/share/mysql/charsets

[myisampack]
character-sets-dir=/usr/share/mysql/charsets

# use [safe_mysqld] with mysql-3
[mysqld_safe]
err-log                                         = /var/log/mysql/mysql.err

# add a section [mysqld-4.1] or [mysqld-5.0] for specific configurations
[mysqld]
character-set-server            = utf8
default-character-set           = utf8
user                                            = mysql
port                                            = 3306
socket                                          = /var/run/mysqld/mysqld.sock
pid-file                                        = /var/run/mysqld/mysqld.pid
log-error                                       = /var/log/mysql/mysqld.err
basedir                                         = /usr
datadir                                         = /data/mysql
skip-locking
key_buffer                                      = 16M
max_allowed_packet                      = 1M
table_cache                             = 64
sort_buffer_size                        = 512K
net_buffer_length                       = 8K
read_buffer_size                        = 256K
read_rnd_buffer_size            = 512K
myisam_sort_buffer_size         = 8M
language                                        = /usr/share/mysql/english

# security:
# using "localhost" in connects uses sockets by default
# skip-networking
bind-address                            = 172.20.20.30

log-bin
server-id                                       = 1

# point the following paths to different dedicated disks
tmpdir                                          = /tmp/
#log-update                             = /path-to-dedicated-directory/hostname

# you need the debug USE flag enabled to use the following directives,
# if needed, uncomment them, start the server and issue
# #tail -f /tmp/mysqld.sql /tmp/mysqld.trace
# this will show you *exactly* what's happening in your server ;)

#log                                            = /tmp/mysqld.sql
#gdb
#debug                                          = d:t:i:o,/tmp/mysqld.trace
#one-thread

# uncomment the following directives if you are using BDB tables
#bdb_cache_size                         = 4M
#bdb_max_lock                           = 10000

# the following is the InnoDB configuration
# if you wish to disable innodb instead
# uncomment just the next line
#skip-innodb
#
# the rest of the innodb config follows:
# don't eat too much memory, we're trying to be safe on 64Mb boxes
# you might want to bump this up a bit on boxes with more RAM
innodb_buffer_pool_size = 16M
# this is the default, increase it if you have lots of tables
innodb_additional_mem_pool_size = 2M
#
# i'd like to use /var/lib/mysql/innodb, but that is seen as a database :-(
# and upstream wants things to be under /var/lib/mysql/, so that's the route
# we have to take for the moment
#innodb_data_home_dir           = /var/lib/mysql/
#innodb_log_arch_dir            = /var/lib/mysql/
#innodb_log_group_home_dir      = /var/lib/mysql/
# you may wish to change this size to be more suitable for your system
# the max is there to avoid run-away growth on your machine
innodb_data_file_path = ibdata1:10M:autoextend:max:128M
# we keep this at around 25% of of innodb_buffer_pool_size
# sensible values range from 1MB to (1/innodb_log_files_in_group*innodb_buffer_pool_size)
innodb_log_file_size = 5M
# this is the default, increase it if you have very large transactions going on
innodb_log_buffer_size = 8M
# this is the default and won't hurt you
# you shouldn't need to tweak it
set-variable = innodb_log_files_in_group=2
# see the innodb config docs, the other options are not always safe
innodb_flush_log_at_trx_commit = 1
innodb_lock_wait_timeout = 50
innodb_file_per_table

[mysqldump]
quick
max_allowed_packet                      = 16M

[mysql]
# uncomment the next directive if you are not familiar with SQL
#safe-updates

[isamchk]
key_buffer                                      = 20M
sort_buffer_size                        = 20M
read_buffer                             = 2M
write_buffer                            = 2M

[myisamchk]
key_buffer                                      = 20M
sort_buffer_size                        = 20M
read_buffer                             = 2M
write_buffer                            = 2M

[mysqlhotcopy]
interactive-timeout
Back to top
View user's profile Send private message
Craven66
n00b
n00b


Joined: 03 Aug 2010
Posts: 41

PostPosted: Sun Aug 08, 2010 7:48 pm    Post subject: Reply with quote

Hallo escor,

Ich habe deine my.cnf Einstellungen mal benutzt. Ohne mysqlmanager habe ich wieder das Problem das der Service stecken bleibt und nicht richtig anläuft mit dem init.d script. Zusätzlich meckert er mir das basedir Verzeichnis an. (Er kann unter /usr kein mysql finden)

Wenn ich dann die Konfiguration abändere und die Passagen für mysqlmanager einfüge. (z.B use-manager etc)
Dann funktioniert der mysqlmanager wieder und startet auch die Session und den Dienst. Somit kann ich mich wieder auf die Datenbank verbinden. Nur leider nimmt er immer noch den falschen Pfad unter /var/lib/.

Das ist das einzigste was mich noch von einem läuffähigen MySQL Dienst mit Datenbankverbindung abhält. Kennt keiner von Ihnen einen Weg wie ich das Problem mit dem falschen Pfad lösen kann?
Für jede Hilfe von euch wäre ich dankbar.

Vielen Dank. :)
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2225
Location: Germany

PostPosted: Tue Aug 10, 2010 9:07 pm    Post subject: Reply with quote

Hi Craven,

was genau ist das für ein Manager? Ich wollte den mysqlmanager bei mir installieren um mir die Konfigurations-Möglichkeiten mal an zuschauen. Aber ich hab den jetzt bei mir weder in der (standard) Installation finden können noch im Portage tree (kann aber sein das ich den übersehen hab).

Google sagt mir das es wohl einen Befehl mysqlmanager gab, aber der ist in mysql 5.0 veraltet und soll in der nächsten Version abgeschafft werden. In wie fern das dein Problem betrifft, weiß ich leider nicht.

Grüße
Back to top
View user's profile Send private message
69719
l33t
l33t


Joined: 20 Sep 2004
Posts: 865

PostPosted: Wed Aug 11, 2010 5:32 am    Post subject: Reply with quote

Kann es eventuell sein, dass du versucht hattest mysql selber zu compilieren?
Was sagt denn
Code:

equery files mysql

?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum