Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Suspend ab >=2.6.30-gentoo-r8 mit Audigy 2 ZS PCMCA Soundk.
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Fri Aug 06, 2010 7:22 pm    Post subject: Suspend ab >=2.6.30-gentoo-r8 mit Audigy 2 ZS PCMCA Sound Reply with quote

Hallo alle zusammen

Ich hab hier ein Problem mit dem wieder-aufwachen aus dem SuspendToDisk oder auch SuspendToRam mit den pm-utils
also zb
Code:
# pm-suspend


Das kuriose ist dass das ganze bis <=sys-kernel/gentoo-sources-2.6.30-r6 lange Zeit einwandfrei funktionierte, und es mit 2.6.30-gentoo-r6 auch immer noch tut.
Doch dann kam gentoo-sources-2.6.30-r8 (stable) und ab dieser Version bis einschließlich 2.6.34-gentoo-r1 bleibt der Monitor nach dem wieder aufwachen einfach schwarz...
Das System scheint bis auf die Grafik soweit wieder aufzuwachen, zumindest kann das System noch sauber via SysRq keys runter gefahren werden.

Ich hab recht umfangreich versucht dem Problem auf die schliche zu kommen, bisher jedoch vergeblich...
Es ist so das es mit dem 2.6.30-gentoo-r6 einwandfrei funktioniert, jedoch ein 2.6.30-gentoo-r8 mit exakt der selben .config , mit "make oldconfig" eingebracht, jedoch nicht mehr... :?
Ein diff der beiden bringt keine nennenswerten Differenzen zutage
Code:
$ diff  linux-2.6.30-gentoo-r6/.config linux-2.6.30-gentoo-r8/.config
3,4c3,4
< # Linux kernel version: 2.6.30-gentoo-r6
< # Sat Oct 17 02:51:30 2009
---
> # Linux kernel version: 2.6.30-gentoo-r8
> # Thu Jan 28 18:05:11 2010


Ich hab auch schon die genpatches-2.6.30-9.base.tar.bz2 und genpatches-2.6.30-9.extras.tar.bz2 entpackt und durchgesehen, doch soweit ich sehen konnte betrafen die Änderungen meist nur andere Architekturen, es brachte also auch nichts aufschlussreiches zutage.
Auch in den pm-powersave.log und pm-suspend.log Dateien konnte ich nichts hilfreiches finden.

Nun bin ich mit meinem Latein so langsam am Ende und hoffe das hier jemand eine Idee oder gar eine Lösung dazu hat...
Das Notebook ist ein älteres Medion MD 95500 RIM 2000 Modell mit Intel ICH6 Chipsatz und nVidia NV43 [GeForce Go 6600] Grafik, als Treiber werden nvidia-drivers genutzt.
emerge --info
Das System (~x86) ist ansonsten in einem aktuellen gesunden Zustand
Sollten noch weitere Infos benötigt werden reiche ich sie gern nach.

Wer also eine Idee, oder gar eine Lösung parat hat, nur raus damit... :wink:
Danke

/edit:
Titel angepasst, da nun die PCMCIA Soundkarte bzw ein ACPI_interrupt Problem als Übeltäter entlarvt wurde.


Last edited by Josef.95 on Sat Aug 07, 2010 3:24 pm; edited 2 times in total
Back to top
View user's profile Send private message
michael_w
Guru
Guru


Joined: 22 Feb 2006
Posts: 424
Location: 09xxx

PostPosted: Fri Aug 06, 2010 7:48 pm    Post subject: Reply with quote

Hi,

grundsätzlich hab ich da keine Ahnung, obwohl ich auch SaveToDisk und SaveToRAM nutze.
2 Ideen:
1. mal nen externen Monitor anschließen und schauen ob da ein Bild erscheint
2. mal mit dem neuen kernel booten und danach mit dem funktionierenden alten kernel und ins syslog schauen ob da was steht.
_________________
Linux ryzen 4.19.52-gentoo #2 SMP Mon Jun 24 18:31:32 CEST 2019 x86_64 AMD Ryzen 7 1800X Eight-Core Processor AuthenticAMD GNU/Linux
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Sat Aug 07, 2010 3:15 pm    Post subject: Reply with quote

Nach vielen Stunden mühevoller Suche bin ich nun ein gutes Stück weiter.

Nein, ein externer Monitor brachte auch nichts --> No Signal
Doch der Rat die Syslog genauer zu durchsuchen und mit den verschiedenen Kernel zu vergleichen brachte dann letztendlich ein
kernel: ACPI: EC: missing confirmations, switch off interrupt mode.

Das "Problemkind" ist wohl eine im PCMCIA Slot steckende Audigy 2 ZS Soundkarte, nehme ich die raus dann funkt Suspend auch mit >=2.6.30-gentoo-r8 einwandfrei.
Was wie und warum es nun ein Problem mit der bisher gut funktionierenden Soundkarte gibt muss ich nun erst noch herausfinden.

Danke soweit erst mal
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum