Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Boot Problem mit EFI-Bios auf HP Compaq 615
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
twelfthnight
n00b
n00b


Joined: 26 Aug 2010
Posts: 6
Location: Germany / Nuernberg

PostPosted: Thu Aug 26, 2010 7:04 pm    Post subject: Boot Problem mit EFI-Bios auf HP Compaq 615 Reply with quote

Hallo Forum,
habe leider beim Partitionieren gemäß dem Quick-Install-Guide die EFI-Partition (HP_TOOLS) zerstört.
Es war mir seitdem nicht mehr möglich von der Festplatte zu booten.
Hat jemand schon Erfahrung mit HP Notebooks mit EFI Bios? Ist es möglich damit Linux von der Festplatte zu booten?

Ggf. kann man die Partition mit einer Recovery-CD wiederherstellen.
Allerdings wäre das auch nutzlos, wenn der HP Boot Loader kein Linux läd.

Folgende Probleme sehe ich:
1. EFI ignoriert den MBR komplett, läd nur *.efi Dateien von der EFI-Partition.
2. HP EFI läd im Bootprozess nur solche *.efi Dateien, die mit einer *.sig Datei versehen sind (Signierungsdatei von HP)
D.h. selbst, wenn ich elilo / Grub2 für EFI zum Laufen bringe, würde es beim Booten ignoriert werden :(

Bitte um Hilfe. Danke.

vg,
chris
Back to top
View user's profile Send private message
Treborius
Guru
Guru


Joined: 18 Oct 2005
Posts: 582
Location: Berlin

PostPosted: Fri Aug 27, 2010 11:08 am    Post subject: Reply with quote

hab nur

http://elilo.sourceforge.net/cgi-bin/blosxom

gefunden
_________________
Systems running gentoo :
Desktop, Laptop, ZOTAC AD-10 media-center, odroid-xu4 server / wLan-router
Back to top
View user's profile Send private message
twelfthnight
n00b
n00b


Joined: 26 Aug 2010
Posts: 6
Location: Germany / Nuernberg

PostPosted: Fri Aug 27, 2010 11:19 am    Post subject: Reply with quote

Hallo Treborius,
danke für die Antwort :)

leider hab ich elilo schon probiert. Ich kann ihn zwar im EFI-Filebrowser ansprechen, und er wird auch geladen...

Aber beim direkten boot von der Festplatte wird er ignoriert :(

Die Doku von HP sagt auch, dass nur signierte *.efi Dateien geladen werden:

http://docs.google.com/viewer?a=v&q=cache:IYBVMbCEKCEJ:h20000.www2.hp.com/bc/docs/support/SupportManual/c01564727/c01564727.pdf%3Fjumpid%3Dreg_R1002_USEN+HP+Business+Notebook+HP_TOOLS+Partition+Guidelines&hl=de&gl=de&pid=bl&srcid=ADGEESjOouLlNXujfAV5oLWl3rl9750XPrgKJk5H9OHy9c6C5dZUlKqssBfYGBMF-ZxqjmuxHsg-Je1ikBCC-sOp_q1MljBf9pRNsiN2qZKtQ2wYFGo1pSoQ0gMAQuSjszxi72OshEKt&sig=AHIEtbQbD_NJhlP37-1OYZ8XfAHqeY6VPQ
Back to top
View user's profile Send private message
twelfthnight
n00b
n00b


Joined: 26 Aug 2010
Posts: 6
Location: Germany / Nuernberg

PostPosted: Fri Sep 03, 2010 8:56 am    Post subject: Reply with quote

Habe jetzt Anfrage an das englische Forum gestellt:

https://forums.gentoo.org/viewtopic-t-842992.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum