Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xulrunner 2.0 b4-r2 fails to compile
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
ComaWhite
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2008
Posts: 125

PostPosted: Sun Aug 29, 2010 5:07 pm    Post subject: Xulrunner 2.0 b4-r2 fails to compile Reply with quote

Code:

         echo "#define IMG_BUILD_ENCODER_png" ;   echo "#define IMG_BUILD_ENCODER_jpeg" ; } > nsImgBumgBuildDefines.tmp
Creating /var/tmp/portage/net-libs/xulrunner-2.0_beta5_pre-r2/work/mozilla-central/modules/libpr0n/build/.deps
mv: cannot stat `nsImgBuildDefines.tmp': No such file or directory
make[4]: *** [export] Error 1
make[4]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta5_pre-r2/work/mozilla-central/modules/libpr0n/build'
make[3]: *** [export] Error 2
make[3]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta5_pre-r2/work/mozilla-central/modules/libpr0n'
make[2]: *** [export_tier_platform] Error 2
make[2]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta5_pre-r2/work/mozilla-central'
make[1]: *** [tier_platform] Error 2
make[1]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta5_pre-r2/work/mozilla-central'
make: *** [default] Err


I'm using GCC-4.5.1 btw.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sun Aug 29, 2010 6:06 pm    Post subject: Re: Xulrunner 2.0 b4-r2 fails to compile Reply with quote

ComaWhite wrote:
Code:

         echo "#define IMG_BUILD_ENCODER_png" ;   echo "#define IMG_BUILD_ENCODER_jpeg" ; } > nsImgBumgBuildDefines.tmp
Creating /var/tmp/portage/net-libs/xulrunner-2.0_beta5_pre-r2/work/mozilla-central/modules/libpr0n/build/.deps
mv: cannot stat `nsImgBuildDefines.tmp': No such file or directory
make[4]: *** [export] Error 1
make[4]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta5_pre-r2/work/mozilla-central/modules/libpr0n/build'
make[3]: *** [export] Error 2
make[3]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta5_pre-r2/work/mozilla-central/modules/libpr0n'
make[2]: *** [export_tier_platform] Error 2
make[2]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta5_pre-r2/work/mozilla-central'
make[1]: *** [tier_platform] Error 2
make[1]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta5_pre-r2/work/mozilla-central'
make: *** [default] Err


I'm using GCC-4.5.1 btw.

Quote:
mozilla-central/modules/libpr0n/build/.deps
mv: cannot stat `nsImgBuildDefines.tmp': No such file or directory


is that really straight from the horse's mouth ? :lol:

anyways:

- try compiling it with custom-optimization enabled or disabled
- FEATURES="-sandbox -usersandbox"
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Genewb
Apprentice
Apprentice


Joined: 09 Jan 2007
Posts: 165

PostPosted: Sun Aug 29, 2010 6:32 pm    Post subject: Re: Xulrunner 2.0 b4-r2 fails to compile Reply with quote

ComaWhite wrote:
Code:

         echo "#define IMG_BUILD_ENCODER_png" ;   echo "#define IMG_BUILD_ENCODER_jpeg" ; } > nsImgBumgBuildDefines.tmp
Creating /var/tmp/portage/net-libs/xulrunner-2.0_beta5_pre-r2/work/mozilla-central/modules/libpr0n/build/.deps
mv: cannot stat `nsImgBuildDefines.tmp': No such file or directory
make[4]: *** [export] Error 1
make[4]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta5_pre-r2/work/mozilla-central/modules/libpr0n/build'
make[3]: *** [export] Error 2
make[3]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta5_pre-r2/work/mozilla-central/modules/libpr0n'
make[2]: *** [export_tier_platform] Error 2
make[2]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta5_pre-r2/work/mozilla-central'
make[1]: *** [tier_platform] Error 2
make[1]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta5_pre-r2/work/mozilla-central'
make: *** [default] Err


I'm using GCC-4.5.1 btw.

I suggest you update make to 3.82. Worked for moi.
_________________
I don't give a darn about "experience", just functional copyleft software.
Back to top
View user's profile Send private message
gqman69
n00b
n00b


Joined: 11 Jul 2007
Posts: 50

PostPosted: Mon Aug 30, 2010 7:18 pm    Post subject: Re: Xulrunner 2.0 b4-r2 fails to compile Reply with quote

I can confirm that make 3.82 works.


Genewb wrote:
ComaWhite wrote:
Code:

         echo "#define IMG_BUILD_ENCODER_png" ;   echo "#define IMG_BUILD_ENCODER_jpeg" ; } > nsImgBumgBuildDefines.tmp
Creating /var/tmp/portage/net-libs/xulrunner-2.0_beta5_pre-r2/work/mozilla-central/modules/libpr0n/build/.deps
mv: cannot stat `nsImgBuildDefines.tmp': No such file or directory
make[4]: *** [export] Error 1
make[4]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta5_pre-r2/work/mozilla-central/modules/libpr0n/build'
make[3]: *** [export] Error 2
make[3]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta5_pre-r2/work/mozilla-central/modules/libpr0n'
make[2]: *** [export_tier_platform] Error 2
make[2]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta5_pre-r2/work/mozilla-central'
make[1]: *** [tier_platform] Error 2
make[1]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta5_pre-r2/work/mozilla-central'
make: *** [default] Err


I'm using GCC-4.5.1 btw.

I suggest you update make to 3.82. Worked for moi.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Nov 26, 2010 12:09 am    Post subject: Re: Xulrunner 2.0 b4-r2 fails to compile Reply with quote

gqman69 wrote:
I can confirm that make 3.82 works.





I just hit the same problem and upgrading (after having downgraded to fix issues with the kernel and other programs) fixed it for me, too

thanks !
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum