Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[OpenRC] modules chargés automatiquement...comment? (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3102
Location: Paris

PostPosted: Wed Sep 01, 2010 1:08 pm    Post subject: [OpenRC] modules chargés automatiquement...comment? (résolu) Reply with quote

Bonjour,

Histoire de troubleshooter tranquillou, je souhaite maîtriser le chargement de mes modules et leurs options.
J'ai bien la doc OpenRC qui m'indique /etc/conf.d/modules, mais je m'aperçois avec surprise qu'il est vide de chez vide, et que quoi que j'en fasse, des modules sont chargés automatiquement au boot (à raison, mais quand même, je ne lui ai rien demandé :P)

Mais si je ne veux pas qu'ils se chargent ces modules, moi, hein?
Je ne trouve pas trace des anciens coldplug/hotplug, du coup je suis dans le brouillard, je n'ai pas trouvé d'option dans le noyau lui permettant de charger de lui même certains modules.

Comment c'est ti qu'elle fait la boîte à tonnerre, et comment que je vais ti faire pour l'en empêcher? :)
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312


Last edited by El_Goretto on Wed Sep 01, 2010 2:43 pm; edited 1 time in total
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Wed Sep 01, 2010 2:14 pm    Post subject: Reply with quote

Y a quelques trucs chargés là
grep -r modprobe /lib/rc* ;)

Après, y a des trucs genre "nvidia" qui est chargé au démarrage de X par exemple
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3102
Location: Paris

PostPosted: Wed Sep 01, 2010 2:42 pm    Post subject: Reply with quote

Woohooo, j'ai rebranché le cerveau!

Bon, c'est udev qui charge mes modules par défaut, quand un périphérique adéquat est détecté.
Du coup, paf, je blacklist mes modules (/etc/modprobe.d/blacklist), puis repaf, je les déclare à charger automatiquement "mais si je veux" (/etc/conf.d/modules).

Pheeewww, chaud au front moi tout d'un coup.
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum