Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xorg-server ohne Hal [gelöst]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Gentoo-kid
Tux's lil' helper
Tux's lil' helper


Joined: 14 Oct 2009
Posts: 85
Location: Frankfurt

PostPosted: Thu Sep 02, 2010 9:55 am    Post subject: Xorg-server ohne Hal [gelöst] Reply with quote

Hallo,
nachdem ich jetz ein neues System aufgesetzt habe, möchte ich mir einen X-server bauen.

Gibt es aktuell ATI-Treiber für Xorg 1.8, ist der schon einigermassen stabil odre soll ich 1.7 nehmen?

Ich nutze nur die alten Ps2 Maus und Tastatur auf altem Rechner und würde gerne auf hal verzichten, udev nicht nutzen, sondern einfach
in der make.conf INPUT_DEVICES="keyboard mouse" haben.

Geht das überhaupt noch und wenn ja, was muss ich beachten?

Reicht USE="-hal" in die make.conf zu setzen
Welche Einträge muss ich verändern, damit Xorg nicht udev nutzt?



Danke schonmal für die Antwort


Last edited by Gentoo-kid on Thu Sep 09, 2010 4:49 pm; edited 1 time in total
Back to top
View user's profile Send private message
Treborius
Guru
Guru


Joined: 18 Oct 2005
Posts: 582
Location: Berlin

PostPosted: Thu Sep 02, 2010 6:16 pm    Post subject: Reply with quote

zu den treibern kann ich nichts sagen, nach dem linux desaster vor 2 jahren kaufe ich nur noch nvidia

zu hal und udev :

was willst du denn statt uvdev nehmen? das alte static-dev?

wohin willst du eigentlich? ein kde//gnome ohne hal/udev?
_________________
Systems running gentoo :
Desktop, Laptop, ZOTAC AD-10 media-center, odroid-xu4 server / wLan-router
Back to top
View user's profile Send private message
Gentoo-kid
Tux's lil' helper
Tux's lil' helper


Joined: 14 Oct 2009
Posts: 85
Location: Frankfurt

PostPosted: Thu Sep 02, 2010 8:09 pm    Post subject: Reply with quote

Ich würde udev gerne drinnlassen, hal rausnehmen.

Aber ich weiss noch nicht genau, wie das genze funktioniert:

Ist udev nur für die Erkennung von Geräten zuständig, muss es die ganze Zeit im Hintergrund laufen oder kann man es abschalten, wenn man es nicht braucht?

Ich will auf einem alten Rechner ein schlankes Basissystem einrichten,von dem aus man weiterbasteln kann.
(mit tar auf andere festplatten rüberkopieren für Freunde oder um selbst mal was auszuprobieren)

fluxbox oder pekwm, dvd-brenner, alter Monitor keinen Drucker/Scanner, alte PS2 Mouse und Tastatur.
Das einzige, was ab und zu mal hotgeplugt wird ist ein USB-Stick, selten mal eine SATA-Platte.
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Fri Sep 03, 2010 10:30 am    Post subject: Reply with quote

Udev brauchst du sowieso, da Dein Gentoo darauf basiert.

Und ab xorg-1.8 brauchst du "-hal" gar nicht zu setzen, da HAL seit xorg-1.8 sowieso nicht mehr von xorg benutzt wird.

Zur Frage, ob 1.7 oder 1.8:
Bei mir läuft die 1.8 schon seit Wochen/Monaten? ohne Probleme.
Back to top
View user's profile Send private message
Gentoo-kid
Tux's lil' helper
Tux's lil' helper


Joined: 14 Oct 2009
Posts: 85
Location: Frankfurt

PostPosted: Fri Sep 03, 2010 2:37 pm    Post subject: Reply with quote

Klahr, dann udev, kein hal.
Aber man liest immer mal was über ATI-Treiber, die nicht funktionieren, bzw die es nochnicht für xorg 1.8 gibt.
Die posts, die ich dazu gefunden habe, sind schon ein paar Monate alt.
Gibt es da aktuelle Erfahrungen
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4459

PostPosted: Fri Sep 03, 2010 3:28 pm    Post subject: Reply with quote

Gentoo-kid wrote:
Klahr, dann udev, kein hal.
Aber man liest immer mal was über ATI-Treiber, die nicht funktionieren, bzw die es nochnicht für xorg 1.8 gibt.
Die posts, die ich dazu gefunden habe, sind schon ein paar Monate alt.
Gibt es da aktuelle Erfahrungen

Die ati-treiber 10.7 und 10.8 unterstützen den xorg-server 1.8
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
Duncan Mac Leod
Apprentice
Apprentice


Joined: 02 May 2004
Posts: 251
Location: Germany

PostPosted: Fri Sep 03, 2010 5:23 pm    Post subject: Reply with quote

musv wrote:
Und ab xorg-1.8 brauchst du "-hal" gar nicht zu setzen, da HAL seit xorg-1.8 sowieso nicht mehr von xorg benutzt wird.


Na endlich! Weg mit HAL ;-) !
Back to top
View user's profile Send private message
Gentoo-kid
Tux's lil' helper
Tux's lil' helper


Joined: 14 Oct 2009
Posts: 85
Location: Frankfurt

PostPosted: Sat Sep 04, 2010 9:31 pm    Post subject: Reply with quote

Jetzt habe ich, nach Austausch der Grafikkarte den Xorg-server 1.7 ohne Hal installiert.

# env-update
# source /etc/profile

Anscheinend ist keinen twm und kein xterm mehr standardmässig dabei, also kam rxvt als konsole drauf.

Als Fenstermanager habe ich mir pekwm draufgemacht, fand ihn leicht und fluxbox kenne ich schon.
Dann habe ich die Einträge in der xorg.conf entsprechend abgeändert.

Soweit, so gut, ich komme auch in die Xsession rein, es startet mir auch irgendetwas, jedenfalls sehe ich einen Mauszeiger, den ich auch bewegen kann.
Leider noch nicht mehr: kein Menu und weder xrvt, noch sonst etwas, um wieder rauszukommen.
:?:
Back to top
View user's profile Send private message
Louisdor
Veteran
Veteran


Joined: 14 Dec 2003
Posts: 1231
Location: im Brandenburgischen

PostPosted: Sun Sep 05, 2010 6:57 am    Post subject: Reply with quote

Gentoo-kid wrote:
Soweit, so gut, ich komme auch in die Xsession rein, es startet mir auch irgendetwas, jedenfalls sehe ich einen Mauszeiger, den ich auch bewegen kann.
Leider noch nicht mehr: kein Menu und weder xrvt, noch sonst etwas, um wieder rauszukommen.
:?:
Schau mal hier: Das X-Server Konfigurations HOWTO - 3.5 Verwenden von startx

Ciao,
aleX!

_________________
"Ich bin ich."
Back to top
View user's profile Send private message
Gentoo-kid
Tux's lil' helper
Tux's lil' helper


Joined: 14 Oct 2009
Posts: 85
Location: Frankfurt

PostPosted: Sun Sep 05, 2010 8:40 am    Post subject: Reply with quote

Habe ich doch genau nach der Anleitung gemacht.
Es scheint aber irgend etwas nicht funktioniert zu haben, die Frage ist nur, wo der Fehler liegt, bzw wo er schonmal nicht liegen kann.
Back to top
View user's profile Send private message
Louisdor
Veteran
Veteran


Joined: 14 Dec 2003
Posts: 1231
Location: im Brandenburgischen

PostPosted: Sun Sep 05, 2010 10:47 am    Post subject: Reply with quote

Gentoo-kid wrote:
Jetzt habe ich, nach Austausch der Grafikkarte den Xorg-server 1.7 ohne Hal installiert.

# env-update
# source /etc/profile

Anscheinend ist keinen twm und kein xterm mehr standardmässig dabei, also kam rxvt als konsole drauf.

Als Fenstermanager habe ich mir pekwm draufgemacht, fand ihn leicht und fluxbox kenne ich schon.
Dann habe ich die Einträge in der xorg.conf entsprechend abgeändert.
Wenn Du mit startx startest, dann solltest Du auch die .xinitrc des Users oder die globale anschauen und eventuell anpassen. Als letzte Zeile müßte pekwm in der ~/.xinitrc so z.B.:
Code:
xsetroot -solid Grey40   # Hintergrundfarbe
rxvt &   # RXVT Terminal
pekwm
drinstehen. Damit sollte PekWM auch starten.

Ciao,
aleX!

_________________
"Ich bin ich."
Back to top
View user's profile Send private message
Gentoo-kid
Tux's lil' helper
Tux's lil' helper


Joined: 14 Oct 2009
Posts: 85
Location: Frankfurt

PostPosted: Sun Sep 05, 2010 12:57 pm    Post subject: Reply with quote

Genauso steht es ja drinn.
Die Maus habe ich auch, aber weder Terminal noch pekwm-Menu habe ich.
Back to top
View user's profile Send private message
Louisdor
Veteran
Veteran


Joined: 14 Dec 2003
Posts: 1231
Location: im Brandenburgischen

PostPosted: Sun Sep 05, 2010 1:55 pm    Post subject: Reply with quote

Stehen denn auf der Konsole (tty1) von der aus Du startx eingibst, wenn Du aus X wieder zurück auf die Konsole kommst, irgendwelche Meldungen?
Ansonsten würde ich versuchen pekwm nochmal neu zu installieren.

Ciao,
aleX!

_________________
"Ich bin ich."
Back to top
View user's profile Send private message
Gentoo-kid
Tux's lil' helper
Tux's lil' helper


Joined: 14 Oct 2009
Posts: 85
Location: Frankfurt

PostPosted: Mon Sep 06, 2010 9:57 am    Post subject: Reply with quote

Ok, irgendetwas ist bei der Xorg-installation anders gewesen.

Xterm war nicht standardmässig dabei, twm nicht.

Den Ordner gibt es nicht:
Code:
  /usr/share/X11/app-defaults/



Die Dateien finde ich nicht,
Code:
  /.Xdefaults


Den Ordner bzw die Pakete habe ich nachinstalliert:
Code:
 /usr/share/fonts/corefonts



Fehlermeldung nachdem ich X verlassen habe, was mit strg alt backspace nicht ging, aber über einen Umweg mit strg alt F5 :


Code:
 rxvt can't load font 7x14  aber einen Ordner/Datei zum ändern der Konfiguration von ihm habe ich nicht gefunden.


Ausserdem habe ich baselayout2 und openrc, vieleicht gibt es da ein Fehler?
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3627
Location: Germany

PostPosted: Mon Sep 06, 2010 10:29 am    Post subject: Reply with quote

Gentoo-kid wrote:
Den Ordner gibt es nicht:
Code:
/usr/share/X11/app-defaults/

Käme hier zb aus
Code:
$ qfile /usr/share/X11/app-defaults
x11-apps/xmessage (/usr/share/X11/app-defaults)
x11-apps/bitmap (/usr/share/X11/app-defaults)
sys-apps/groff (/usr/share/X11/app-defaults)
Back to top
View user's profile Send private message
Falmer
n00b
n00b


Joined: 22 Mar 2006
Posts: 51
Location: im grünen Herzen Deutschlands ;-)

PostPosted: Mon Sep 06, 2010 1:02 pm    Post subject: Reply with quote

Das ein paar Pakete nicht mehr in der Standard-X-Installation dabei sind, hindert doch eigentlich nicht daran sie nachträglich zu installieren.

Habe ich am Wochenende gerade auch wieder mal getan.
Code:
emerge -av twm xterm xclock

vielleicht zusätzlich gleich noch
Code:
emerge -av xload xeyes xcalc

Die ersten Pakete brauchst Du zum fehlerfreien Ausführen von startx ohne weitere Einstellungen.
Back to top
View user's profile Send private message
Gentoo-kid
Tux's lil' helper
Tux's lil' helper


Joined: 14 Oct 2009
Posts: 85
Location: Frankfurt

PostPosted: Mon Sep 06, 2010 2:55 pm    Post subject: Reply with quote

Das will ich ja grade nicht, rxvt kann alles, was ich will und ist schön klein, xclock, twm sind wirklich hässlich.
Back to top
View user's profile Send private message
Gentoo-kid
Tux's lil' helper
Tux's lil' helper


Joined: 14 Oct 2009
Posts: 85
Location: Frankfurt

PostPosted: Thu Sep 09, 2010 4:48 pm    Post subject: Reply with quote

Und gelöst, nach editieren v Xorg-conf, nachinstallieren verschiedener Schriften und erstellen einiger Ordner und files.
Back to top
View user's profile Send private message
pablo_supertux
Advocate
Advocate


Joined: 25 Jan 2004
Posts: 2740
Location: Somewhere between reality and Middle-Earth and in Freiburg (Germany)

PostPosted: Thu Sep 09, 2010 10:49 pm    Post subject: Reply with quote

musv wrote:

Und ab xorg-1.8 brauchst du "-hal" gar nicht zu setzen, da HAL seit xorg-1.8 sowieso nicht mehr von xorg benutzt wird.



echt? wie geil, ich hab dieses HAL gedöns nie gemocht, es hat nie funktioniert und ohne einen Notebook oder anderen Rechner im selben Subnetz mit SSH musste man einen neustart machen, bis diese policy Datein richtig waren.

Wieso fliegt das raus? Wieso dann überhaupt den Aufwand, hal zu unterstützen?
_________________
A! Elbereth Gilthoniel!
silivren penna míriel
o menel aglar elenath,
Gilthoniel, A! Elbereth!
Back to top
View user's profile Send private message
Necoro
Veteran
Veteran


Joined: 18 Dec 2005
Posts: 1912
Location: München (Germany)

PostPosted: Thu Sep 09, 2010 11:25 pm    Post subject: Reply with quote

Ab xorg-1.10 haben sie denn sicherlich Support für "Yet another abstraction layer", der ab 1.11 mandatory wird ... und den sie ab 1.13 wieder rauskanten... usw usf :P *scnr*
_________________
Inter Deum Et Diabolum Semper Musica Est.
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Fri Sep 10, 2010 4:49 am    Post subject: Reply with quote

pablo_supertux wrote:
Wieso fliegt das raus? Wieso dann überhaupt den Aufwand, hal zu unterstützen?

http://en.wikipedia.org/wiki/HAL_(software)

"Wenn du merkst, dass du auf einem toten Pferd reitest, dann steig ab. "

Nur wurden eben mehr als 5 Jahre gebraucht, um dem Pferd überhaupt erstmal das Laufen beizubringen. Dadurch fiel das Absteigen natürlich etwas schwieriger.
Back to top
View user's profile Send private message
Gentoo-kid
Tux's lil' helper
Tux's lil' helper


Joined: 14 Oct 2009
Posts: 85
Location: Frankfurt

PostPosted: Fri Sep 10, 2010 9:35 am    Post subject: Reply with quote

Hallo, wisst ihr, wie ich einstellen kann, das die Bilder (im Browser -> Opera ) heller angezeigt werden?
dort geht es wohl nicht, also muesste es in xorg eine ewinstellung geben?

Danke schonmal.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum