Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[emerge]gnome-mount-0.8-r1 failed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Thu Sep 02, 2010 9:06 pm    Post subject: [emerge]gnome-mount-0.8-r1 failed Reply with quote

Code:
/bin/sh ../libtool --tag=CC   --mode=link i686-pc-linux-gnu-gcc  -O2 -march=pentium3 -pipe -W -Waggregate-return -Wmissing-prototypes -Wmissing-declarations -Wcast-align -Wbad-function-cast -Wdisabled-optimization -Wpointer-arith -Wredundant-decls -Wcast-qual  -Wl,-O1 -Wl,--as-needed -o gnome-mount gnome-mount.o -pthread -lgconf-2 -lgnome-keyring -ldbus-glib-1 -lhal-storage -lhal -ldbus-1 -lpthread -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0   -pthread -lnotify -lgtk-x11-2.0 -ldbus-glib-1 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgmodule-2.0 -ldbus-1 -lpthread -lgobject-2.0 -lgthread-2.0 -lrt -lglib-2.0   ../src/copy-paste/libpassword_dialog.la
libtool: link: i686-pc-linux-gnu-gcc -O2 -march=pentium3 -pipe -W -Waggregate-return -Wmissing-prototypes -Wmissing-declarations -Wcast-align -Wbad-function-cast -Wdisabled-optimization -Wpointer-arith -Wredundant-decls -Wcast-qual -Wl,-O1 -Wl,--as-needed -o gnome-mount gnome-mount.o -pthread -pthread  /usr/lib/libgconf-2.so /usr/lib/libORBit-2.so /usr/lib/libgnome-keyring.so /usr/lib/libeggdbus-1.so /usr/lib/libgcrypt.so /usr/lib/libgpg-error.so /usr/lib/libhal-storage.so /usr/lib/libhal.so -L/usr/lib /usr/lib/libnotify.so -lpng12 -lnsl /usr/lib/libgtk-x11-2.0.so /usr/lib/libdbus-glib-1.so /usr/lib/libgdk-x11-2.0.so /usr/lib/libatk-1.0.so /usr/lib/libgdk_pixbuf-2.0.so /usr/lib/libgio-2.0.so -lresolv /usr/lib/libpangocairo-1.0.so /usr/lib/libpangoft2-1.0.so /usr/lib/libcairo.so /usr/lib/libpixman-1.so /usr/lib/libpng14.so /usr/lib/libxcb-render-util.so /usr/lib/libxcb-render.so /usr/lib/libXrender.so /usr/lib/libX11.so /usr/lib/libxcb.so /usr/lib/libXau.so /usr/lib/libXdmcp.so /usr/lib/libpango-1.0.so -lm /usr/lib/libfontconfig.so /usr/lib/libfreetype.so -lz /usr/lib/libexpat.so /usr/lib/libgmodule-2.0.so -ldl /usr/lib/libdbus-1.so /usr/lib/libgobject-2.0.so /usr/lib/libgthread-2.0.so -lpthread -lrt /usr/lib/libglib-2.0.so ../src/copy-paste/.libs/libpassword_dialog.a -pthread
/usr/lib/gcc/i686-pc-linux-gnu/4.4.3/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lpng12
collect2: ld returned 1 exit status
make[3]: *** [gnome-mount] Error 1
make[3]: Leaving directory `/var/tmp/portage/gnome-base/gnome-mount-0.8-r1/work/gnome-mount-0.8/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/gnome-base/gnome-mount-0.8-r1/work/gnome-mount-0.8/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gnome-base/gnome-mount-0.8-r1/work/gnome-mount-0.8'
make: *** [all] Error 2
 * ERROR: gnome-base/gnome-mount-0.8-r1 failed:
 *   compile failure
 *
 * Call stack:
 *     ebuild.sh, line   54:  Called src_compile
 *   environment, line 3084:  Called gnome2_src_compile
 *   environment, line 2432:  Called die
 * The specific snippet of code:
 *       emake || die "compile failure"
 *
 * If you need support, post the output of 'emerge --info =gnome-base/gnome-mount-0.8-r1',
 * the complete build log and the output of 'emerge -pqv =gnome-base/gnome-mount-0.8-r1'.
 * The complete build log is located at '/var/tmp/portage/gnome-base/gnome-mount-0.8-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/gnome-base/gnome-mount-0.8-r1/temp/environment'.
 * S: '/var/tmp/portage/gnome-base/gnome-mount-0.8-r1/work/gnome-mount-0.8'

>>> Failed to emerge gnome-base/gnome-mount-0.8-r1, Log file:

>>>  '/var/tmp/portage/gnome-base/gnome-mount-0.8-r1/temp/build.log'

 * Messages for package gnome-base/gnome-mount-0.8-r1:

 * ERROR: gnome-base/gnome-mount-0.8-r1 failed:
 *   compile failure
 *
 * Call stack:
 *     ebuild.sh, line   54:  Called src_compile
 *   environment, line 3084:  Called gnome2_src_compile
 *   environment, line 2432:  Called die
 * The specific snippet of code:
 *       emake || die "compile failure"
 *
 * If you need support, post the output of 'emerge --info =gnome-base/gnome-mount-0.8-r1',
 * the complete build log and the output of 'emerge -pqv =gnome-base/gnome-mount-0.8-r1'.
 * The complete build log is located at '/var/tmp/portage/gnome-base/gnome-mount-0.8-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/gnome-base/gnome-mount-0.8-r1/temp/environment'.
 * S: '/var/tmp/portage/gnome-base/gnome-mount-0.8-r1/work/gnome-mount-0.8'

Je ne sais pas pourquoi ce paquet a besoin d'être mis à jour depuis mon dernier emerge world.
J'utilise KDE...
Mais bon ça coince avec ce paquet ainsi qu'avec celui là x11-misc/pcmanfm-0.9.7-r1
Comment on contourne ça ?
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Thu Sep 02, 2010 9:26 pm    Post subject: Reply with quote

Quote:
cannot find -lpng12

Une maj de libpng mal finie visiblement
Commence par un petit revdep-rebuild, puis peut-etre lancer /usr/portage/media-libs/libpng/files/libpng-1.4.x-update.sh derrière
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Fri Sep 03, 2010 10:43 am    Post subject: Reply with quote

Ah merci j'avais pas vu !
Une question !
Y a t-il une commande ou un outil (equery?) qui permet de savoir quel paquet exige un autre paquet de façon ascendante ?

Je m'explique.
gnome-mount ne fait pas parti de mon world (en plus je suis sous KDE) pourtant il est nécessaire qu'il soit installé sur mon système... pourquoi ? à cause de qui ou plutôt de quel paquet ? La réponse doit être un paquet de mon world !

Alors, y a t-il une commande qui réponde à cette question ?
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Fri Sep 03, 2010 10:53 am    Post subject: Reply with quote

equery depends gnome-mount
qdepend -Q gnome-mount
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Fri Sep 03, 2010 2:52 pm    Post subject: Reply with quote

curieux !
Code:
ataualpa ben # equery depends gnome-mount
[ Searching for packages depending on gnome-mount... ]
ataualpa ben # qdepends -Q gnome-mount
ataualpa ben #


edit :
Code:
ataualpa ben # equery depends net-print/cups
[ Searching for packages depending on net-print/cups... ]
app-emulation/wine-1.3.0 (cups? net-print/cups)
app-text/ghostscript-gpl-8.71-r1 (cups? >=net-print/cups-1.3.8)
net-fs/samba-3.4.6 (cups? net-print/cups)
net-print/gutenprint-5.1.4 (cups? >=net-print/cups-1.1.14)
net-wireless/bluez-4.66-r1 (cups? net-print/cups)
x11-libs/gtk+-2.20.1-r1 (cups? net-print/cups)
x11-libs/qt-gui-4.6.2 (cups? net-print/cups)

est-ce que la liste de soft qui sort indique que cups :
1- nécessite la liste précédente pour fonctionner ?
2- est nécessaire aux soft de la liste précédente ?
Je suppose que c'est la réponse 2- mais pouvez-vous juste me le confirmer ?
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Mon Sep 06, 2010 12:03 pm    Post subject: Reply with quote

Up !
:roll:
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7942
Location: ~Brussels - Belgique

PostPosted: Mon Sep 06, 2010 1:27 pm    Post subject: Reply with quote

As-tu appliqué les recommandations liés à libpng (voir le forum) ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Tue Sep 07, 2010 3:32 pm    Post subject: Reply with quote

Évidemment que non ! :?
Faudrait avoir du temps pour ça :cry:
Je comprends maintenant pourquoi depuis deux jours KDE compile sur ma machine !
Je crois avoir là un bon exemple de ce qui commence à m'agacer avec cette distribution.
Code:
ben@ataualpa ~ $ emerge -s libpng
Searching...
[ Results for search key : libpng ]
[ Applications found : 2 ]

*  media-libs/libpng
      Latest version available: 1.4.3
      Latest version installed: 1.4.3
      Size of files: 526 kB
      Homepage:      http://www.libpng.org/
      Description:   Portable Network Graphics library
      License:       as-is

*  media-plugins/gst-plugins-libpng
      Latest version available: 0.10.22
      Latest version installed: [ Not Installed ]
      Size of files: 2,637 kB
      Homepage:      http://gstreamer.freedesktop.org/
      Description:   GStreamer encoder/decoder for PNG images
      License:       GPL-2


libpng est donc déjà upgradé quel est ton conseil ?
Vas-tu me dire que toute la compilation en cours ne sert à rien (dis le moi vite 72/88 je peux encore limiter la casse) ?
:cry: :arrow:
J'ai un revdep-rebuild de prévu à la suite !
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7942
Location: ~Brussels - Belgique

PostPosted: Tue Sep 07, 2010 4:04 pm    Post subject: Reply with quote

Salut,

Libpng est utilisé par énormément de pauquets, la mise à jour a fait énormément de dégâts. Il FAUT compiler ces paquets, sinon ton système est instable.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Tue Sep 07, 2010 7:09 pm    Post subject: Reply with quote

si tu n'as aucun soft qui dépend de gnome-mount, c'est qu'il ne sert à rien, où que tu l'as installé à la main (sans le -1 qui plus est)
Back to top
View user's profile Send private message
Picani
Apprentice
Apprentice


Joined: 05 Jul 2009
Posts: 180

PostPosted: Fri Sep 10, 2010 3:56 pm    Post subject: Reply with quote

Essaye :
Code:
# emerge --depclean -a
voir s'il te vire gnome-mount.
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Mon Sep 13, 2010 7:51 am    Post subject: Reply with quote

Ce pb s'est résolu de lui même.
J'ai désinstallé lxde en parallèle et le tout est rentré dans l'ordre.
Merci pour l'aide.

Que fait un emerge -e ?
J'ai lu la doc mais j'ai pas compris la nuance ?
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7942
Location: ~Brussels - Belgique

PostPosted: Mon Sep 13, 2010 8:16 am    Post subject: Reply with quote

emerge -e recompile tout !
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum