Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[world update] dbus Problem
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
pablo_supertux
Advocate
Advocate


Joined: 25 Jan 2004
Posts: 2740
Location: Somewhere between reality and Middle-Earth and in Freiburg (Germany)

PostPosted: Wed Sep 08, 2010 1:21 am    Post subject: [world update] dbus Problem Reply with quote

Hi

Ich hab gerade ein world Update gemacht und leider gehen einge Sachen nicht und weiß nicht recht, wonach ich suchen soll, um diese zu lösen.

Ich verwende gdm, fluxbox und gnome-terminal.

Nach dem Update konnte ich gnone-terminal nicht mehr starten, denn ich bekam folgende Meldung

1. gnome-terminal

Code:

$ gnome-terminal
process 9075: arguments to dbus_connection_ref() were incorrect, assertion "connection != NULL" failed in file dbus-connection.c line 2556.
This is normally a bug in some application using the D-Bus library.
  D-Bus not built with -rdynamic so unable to print a backtrace
Aborted


Ich hab bemerkt, dass der dbus Dienst nicht lief, hab ihn gestartet, aber die Fehlermeldung kommt immer noch. Ich hab einen Neustart gemacht aber das Problem ist dasselbe.

2. gdm startet normal, ich tipp meine Loggin-Daten ein und der Bildschirm bleibt blau (meine Hintergrundsfarbe), fluxbox (hab leider keinen anderen Windowmanager zum Testen) startet aber nicht. Normalerweise wird ~/.fluxbox/startup gestartet, welches dann fluxbox startet. Ich habe noch nicht nachgeschaut, ob das Skript überhaupt läuft.

Wenn ich dann gdm stoppe und startx eingebe, dann bekomme ich den Fehler, dass fluxbox den X Server nicht findet, klar, weil keiner gestaret wird. Also muss ich per Hand zuerst X starten und dann fluxbox. Zur Not tut es auch, find's aber bescheuert, muss ich sagen.

ich dachte, vielleicht liegt es an irgendwelchen Libs, die neu kompiliert werden müssen, dann habe ich revdep-rebuild ausgeführt und folgendes bekommen

Code:

[ebuild   R   ] media-libs/gegl-0.0.22
[ebuild   R   ] app-text/xpdf-3.02-r4
[ebuild   R   ] media-gfx/inkscape-0.47
[ebuild   R   ] media-libs/xine-lib-1.1.18.1
[ebuild   R   ] www-client/links-2.2
[ebuild   R   ] x11-libs/qt-3.3.8b-r2
[ebuild   R   ] app-cdr/cdrdao-1.2.3
[ebuild   R   ] dev-tex/luatex-0.50.0-r1
[ebuild   R   ] media-gfx/gimp-2.6.8
[ebuild   R   ] kde-base/kdelibs-3.5.10-r6


Auf dem ersten Blick nichts was mit meinem Problem zu tun hat.

Ich kann leider dieses Problem mit dbus nicht lösen, hab keine Ahnung, wonach ich suchen soll und wo ich starten kann. Hat jemand ne Idee, was da faul läuft? (Vielleicht ein gnome dependency, die neu gebaut werden muss?)
_________________
A! Elbereth Gilthoniel!
silivren penna míriel
o menel aglar elenath,
Gilthoniel, A! Elbereth!
Back to top
View user's profile Send private message
pablo_supertux
Advocate
Advocate


Joined: 25 Jan 2004
Posts: 2740
Location: Somewhere between reality and Middle-Earth and in Freiburg (Germany)

PostPosted: Wed Sep 08, 2010 1:38 am    Post subject: Reply with quote

Oh mann!!!!


ich hab das Problem gefixt. Ich dachte schon, dass es etwas mit eine gnome/glib Abhängigkeit zusammenhing, und das war's auch. Ich musste nur dev-libs/dbus-glib neu kompilieren, das hat alles gelöst.

Ich habe aber dennoch ein Problem festgestellt, das erst jetzt gekommen ist (gestern hat es noch funktioniert)

Ich verwende scim, um Japanisch eingeben zu können, mir ist es wichtig, dass es auch in OpenOffice geht. Das hat auch immer getan, doch jetzt kann ich es nicht mehr verwenden, wenn ich z.b. oowriter starte, dann bekomme ich

Code:

$ oowrite
** (soffice:4202): WARNING **: unable to get gail version number

(soffice:4202): Gtk-WARNING **: /usr/lib/openoffice/program/../basis-link/ure-link/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /usr/lib/libscim-1.0.so.8)

(soffice:4202): Gtk-WARNING **: Loading IM context type 'scim' failed

(soffice:4202): Gtk-WARNING **: /usr/lib/openoffice/program/../basis-link/ure-link/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /usr/lib/libscim-1.0.so.8)

(soffice:4202): Gtk-WARNING **: Loading IM context type 'scim' failed

(soffice:4202): Gtk-WARNING **: /usr/lib/openoffice/program/../basis-link/ure-link/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /usr/lib/libscim-1.0.so.8)

(soffice:4202): Gtk-WARNING **: Loading IM context type 'scim' failed

(soffice:4202): Gtk-WARNING **: /usr/lib/openoffice/program/../basis-link/ure-link/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /usr/lib/libscim-1.0.so.8)

(soffice:4202): Gtk-WARNING **: Loading IM context type 'scim' failed


und kann dort scim nicht verwenden. Überall sonst geht es. Ich verwende app-office/openoffice-bin (da ich keine Lust alles zu kompilieren habe). Heißt es, bis es ein Update vom -bin ebuild, wird das nicht gehen? Das wäre schrecklich. :oops:
_________________
A! Elbereth Gilthoniel!
silivren penna míriel
o menel aglar elenath,
Gilthoniel, A! Elbereth!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum