Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
TeVii S470 DVBS Karte und MythTv
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
deranonyme
Guru
Guru


Joined: 09 Jul 2005
Posts: 364

PostPosted: Thu Sep 09, 2010 4:14 pm    Post subject: TeVii S470 DVBS Karte und MythTv Reply with quote

Hallo

Da ich mir ein M2N Mainboard von ASUS gegönnte habe konnte ich meine Technosat Skystar 2 nicht mehr nutzen, da ich jetzt PCI 2.2 Slots habe, die keine 5 Volt mehr anbieten. Also habe ich mich belesen und gefunden das die TeVii S470 vom Kernel unterstützt wird. Denkste wenn ich den derzeitigen stabel 2.6.34-r6 nutze bekomme ich folgende Meldung:
Code:
Sep  9 17:27:16 franks kernel: cx23885 driver version 0.0.2 loaded
Sep  9 17:27:16 franks kernel: ACPI: PCI Interrupt Link [LNEB] enabled at IRQ 19
Sep  9 17:27:16 franks kernel: cx23885 0000:03:00.0: PCI INT A -> Link[LNEB] -> GSI 19 (level, low) -> IRQ 19
Sep  9 17:27:16 franks kernel: CORE cx23885[0]: subsystem: d470:9022, board: TeVii S470 [card=15,autodetected]
Sep  9 17:27:16 franks kernel: udev: renamed network interface eth0 to eth1
Sep  9 17:27:16 franks kernel: cx23885_dvb_register() allocating 1 frontend(s)
Sep  9 17:27:16 franks kernel: cx23885[0]: cx23885 based dvb card
Sep  9 17:27:16 franks kernel: DVB: Unable to find symbol ds3000_attach()
Sep  9 17:27:16 franks kernel: cx23885[0]: frontend initialization failed
Sep  9 17:27:16 franks kernel: cx23885_dvb_register() dvb_register failed err = -1
Sep  9 17:27:16 franks kernel: cx23885_dev_setup() Failed to register dvb adapters on VID_B
Sep  9 17:27:16 franks kernel: cx23885_dev_checkrevision() Hardware revision = 0xb0
Sep  9 17:27:16 franks kernel: cx23885[0]/0: found at 0000:03:00.0, rev: 2, irq: 19, latency: 0, mmio: 0xdfe00000
Sep  9 17:27:16 franks kernel: cx23885 0000:03:00.0: setting latency timer to 64


Deshalb meine Frage: hat jemand diese Karte unter Gentoo zum Laufen gebracht und wie?

Danke Frank
Back to top
View user's profile Send private message
Dorsai!
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 276
Location: Bavaria

PostPosted: Thu Sep 09, 2010 5:01 pm    Post subject: Reply with quote

Lad dir die Quellen des DVB-S2 Stacks von
http://mercurial.intuxication.org/hg/s2-liplianin
herunter und kompilier die Module.

Falls du Genkernel nutzt bau danach das Initramfs neu mit:
Code:
genkernel initramfs


Edit/Ergänzung:
Es sieht für mich so aus, als würde deine aktuelle Revision einen anderen Tuner nutzen oder anders minimal abweichen. Darum obiger Vorschlag. Meistens sind aktuelle Revisionen von eigentlich im Kernel unterstützten Karten im Liplianin Zwei schon unterstützt.
Back to top
View user's profile Send private message
deranonyme
Guru
Guru


Joined: 09 Jul 2005
Posts: 364

PostPosted: Thu Sep 09, 2010 5:08 pm    Post subject: Reply with quote

Dorsai! wrote:
Lad dir die Quellen des DVB-S2 Stacks von
http://mercurial.intuxication.org/hg/s2-liplianin
herunter und kompilier die Module.
.


Das ist das Ergebnis:
Code:
make[2]: Entering directory `/usr/src/linux-2.6.34-gentoo-r6'
  CC [M]  /home/frank/test/s2-liplianin-8c8997d531c6/v4l/tuner-xc2028.o
  CC [M]  /home/frank/test/s2-liplianin-8c8997d531c6/v4l/tuner-simple.o
  CC [M]  /home/frank/test/s2-liplianin-8c8997d531c6/v4l/tuner-types.o
  CC [M]  /home/frank/test/s2-liplianin-8c8997d531c6/v4l/mt20xx.o
  CC [M]  /home/frank/test/s2-liplianin-8c8997d531c6/v4l/tda8290.o
  CC [M]  /home/frank/test/s2-liplianin-8c8997d531c6/v4l/tea5767.o
  CC [M]  /home/frank/test/s2-liplianin-8c8997d531c6/v4l/tea5761.o
  CC [M]  /home/frank/test/s2-liplianin-8c8997d531c6/v4l/tda9887.o
  CC [M]  /home/frank/test/s2-liplianin-8c8997d531c6/v4l/tda827x.o
  CC [M]  /home/frank/test/s2-liplianin-8c8997d531c6/v4l/au0828-core.o
In file included from /home/frank/test/s2-liplianin-8c8997d531c6/v4l/au0828.h:22,
                 from /home/frank/test/s2-liplianin-8c8997d531c6/v4l/au0828-core.c:29:
include/linux/usb.h:1384: error: static declaration of 'usb_buffer_alloc' follows non-static declaration
include/linux/usb.h:1378: note: previous declaration of 'usb_buffer_alloc' was here
include/linux/usb.h:1389: error: static declaration of 'usb_buffer_free' follows non-static declaration
include/linux/usb.h:1380: note: previous declaration of 'usb_buffer_free' was here
make[3]: *** [/home/frank/test/s2-liplianin-8c8997d531c6/v4l/au0828-core.o] Fehler 1
make[2]: *** [_module_/home/frank/test/s2-liplianin-8c8997d531c6/v4l] Error 2
make[2]: Leaving directory `/usr/src/linux-2.6.34-gentoo-r6'
make[1]: *** [default] Fehler 2
make[1]: Leaving directory `/home/frank/test/s2-liplianin-8c8997d531c6/v4l'
make: *** [all] Fehler 2


Irgendwie sitze ich fest. Hatte gestern mit der 2.6.34-r1 einen laufenden Treiber, der aber immer noch noch keinen Sendersuchlauf hinbekam.

Frank
Back to top
View user's profile Send private message
boris64
Veteran
Veteran


Joined: 04 Oct 2003
Posts: 1770
Location: vechelde / peine

PostPosted: Thu Sep 09, 2010 5:14 pm    Post subject: Reply with quote

Ich habe diese Karte ebenso und die funktioniert seit
Kernel-2.6.33 (oder war's .34?) mit dem im Kernel
vorhandenen Modul cx23885 ohne Probleme.

Du hast da auch eine Fehlermeldung, sieht irgendwie aus, als ob
dir irgendwas fehlen(?) würde.
Code:
...
DVB: Unable to find symbol ds3000_attach()...


Hast du die benötigte Firmware installiert?
(dvb-fe-ds3000.fw -> http://tevii.com/tevii_ds3000.tar.gz)

So würde das ganze aussehen, wenn's klappt.
Code:
[    1.095954] cx23885 driver version 0.0.2 loaded
[    1.095973] cx23885 0000:04:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[    1.096293] CORE cx23885[0]: subsystem: d470:9022, board: TeVii S470 [card=15,autodetected]
[    1.223733] cx23885_dvb_register() allocating 1 frontend(s)
[    1.223736] cx23885[0]: cx23885 based dvb card
[    1.225209] DVB: registering new adapter (cx23885[0])
[    1.252323] cx23885_dev_checkrevision() Hardware revision = 0xb0
[    1.252330] cx23885[0]/0: found at 0000:04:00.0, rev: 2, irq: 16, latency: 0, mmio: 0xfea00000
[    1.252337] cx23885 0000:04:00.0: setting latency timer to 64
[    1.252406] cx23885 0000:04:00.0: irq 41 for MSI/MSI-X

_________________
boris64.net 200x / visit my desktop / try these tiny kernel patches ;)
Back to top
View user's profile Send private message
deranonyme
Guru
Guru


Joined: 09 Jul 2005
Posts: 364

PostPosted: Thu Sep 09, 2010 5:43 pm    Post subject: Reply with quote

boris64 wrote:
Ich habe diese Karte ebenso und die funktioniert seit
Kernel-2.6.33 (oder war's .34?) mit dem im Kernel
vorhandenen Modul cx23885 ohne Probleme.

Du hast da auch eine Fehlermeldung, sieht irgendwie aus, als ob
dir irgendwas fehlen(?) würde.
Code:
...
DVB: Unable to find symbol ds3000_attach()...


Hast du die benötigte Firmware installiert?
(dvb-fe-ds3000.fw -> http://tevii.com/tevii_ds3000.tar.gz)

So würde das ganze aussehen, wenn's klappt.
Code:
[    1.095954] cx23885 driver version 0.0.2 loaded
[    1.095973] cx23885 0000:04:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[    1.096293] CORE cx23885[0]: subsystem: d470:9022, board: TeVii S470 [card=15,autodetected]
[    1.223733] cx23885_dvb_register() allocating 1 frontend(s)
[    1.223736] cx23885[0]: cx23885 based dvb card
[    1.225209] DVB: registering new adapter (cx23885[0])
[    1.252323] cx23885_dev_checkrevision() Hardware revision = 0xb0
[    1.252330] cx23885[0]/0: found at 0000:04:00.0, rev: 2, irq: 16, latency: 0, mmio: 0xfea00000
[    1.252337] cx23885 0000:04:00.0: setting latency timer to 64
[    1.252406] cx23885 0000:04:00.0: irq 41 for MSI/MSI-X


Ja, die Firmware hab ich.
Kernel hab ich so konfiguriert:
Code:
Device Drivers  --->
 Multimedia support  --->
  <*>   Video For Linux
  <*>   DVB for Linux
  [*]   Load and attach frontend and tuner driver modules as needed
  [*]   Video capture adapters  --->
    [*]   Autoselect pertinent encoders/decoders and other helper chips
    <M>   Conexant cx23885 (2388x successor) support

Kannst du mal mit deiner Config vergleichen? Bei mir versucht er dann immer ein nicht vorhandenes Frontend zu laden.

Danke Frank
Back to top
View user's profile Send private message
boris64
Veteran
Veteran


Joined: 04 Oct 2003
Posts: 1770
Location: vechelde / peine

PostPosted: Thu Sep 09, 2010 6:07 pm    Post subject: Reply with quote

Hm, meine Config ist dieselbe (abgesehen davon,
dass ich alles im Kernel habe [*])
_________________
boris64.net 200x / visit my desktop / try these tiny kernel patches ;)
Back to top
View user's profile Send private message
deranonyme
Guru
Guru


Joined: 09 Jul 2005
Posts: 364

PostPosted: Thu Sep 09, 2010 6:16 pm    Post subject: Reply with quote

boris64 wrote:
Hm, meine Config ist dieselbe (abgesehen davon,
dass ich alles im Kernel habe [*])


Weißt du noch von welcher Quelle du die Firmware hast? Tevii selbst oder eher liplianin?

Danke Frank
Back to top
View user's profile Send private message
boris64
Veteran
Veteran


Joined: 04 Oct 2003
Posts: 1770
Location: vechelde / peine

PostPosted: Thu Sep 09, 2010 6:26 pm    Post subject: Reply with quote

Diese hier (also direkt von Tevii)
-> http://tevii.com/tevii_ds3000.tar.gz
_________________
boris64.net 200x / visit my desktop / try these tiny kernel patches ;)
Back to top
View user's profile Send private message
deranonyme
Guru
Guru


Joined: 09 Jul 2005
Posts: 364

PostPosted: Thu Sep 09, 2010 6:59 pm    Post subject: Reply with quote

boris64 wrote:
Diese hier (also direkt von Tevii)
-> http://tevii.com/tevii_ds3000.tar.gz


Hast du auch ein 64 Bit AMD System? Sonst fällt mir nichts mehr ein.

Frank
Back to top
View user's profile Send private message
boris64
Veteran
Veteran


Joined: 04 Oct 2003
Posts: 1770
Location: vechelde / peine

PostPosted: Thu Sep 09, 2010 7:09 pm    Post subject: Reply with quote

Jau. Hast du eventuell mal einen neueren Kernel ausprobiert?
_________________
boris64.net 200x / visit my desktop / try these tiny kernel patches ;)
Back to top
View user's profile Send private message
deranonyme
Guru
Guru


Joined: 09 Jul 2005
Posts: 364

PostPosted: Thu Sep 09, 2010 7:10 pm    Post subject: Reply with quote

boris64 wrote:
Jau. Hast du eventuell mal einen neueren Kernel ausprobiert?


Noch nicht, aber der 2.6.35-gentoo-r5 liegt bereit.
Ok hier das gute Ergebnis mit 2.6.34-r6:
Code:
Sep  9 21:12:33 franks kernel: cx23885 0000:03:00.0: PCI INT A -> Link[LNEB] -> GSI 19 (level, low) -> IRQ 19
Sep  9 21:12:33 franks kernel: CORE cx23885[0]: subsystem: d470:9022, board: TeVii S470 [card=15,autodetected]
Sep  9 21:12:33 franks kernel: cx23885_dvb_register() allocating 1 frontend(s)
Sep  9 21:12:33 franks kernel: cx23885[0]: cx23885 based dvb card
Sep  9 21:12:33 franks kernel: DS3000 chip version: 0.192 attached.
Sep  9 21:12:33 franks kernel: DVB: registering new adapter (cx23885[0])
Sep  9 21:12:33 franks kernel: DVB: registering adapter 0 frontend 0 (Montage Technology DS3000/TS2020)...
Sep  9 21:12:33 franks kernel: cx23885_dev_checkrevision() Hardware revision = 0xb0
Sep  9 21:12:33 franks kernel: cx23885[0]/0: found at 0000:03:00.0, rev: 2, irq: 19, latency: 0, mmio: 0xdfe00000
Sep  9 21:12:33 franks kernel: cx23885 0000:03:00.0: setting latency timer to 64


Das sollte stimmen! Danke

Und hier das Problem:
Code:
 # dvbscan /usr/share/dvb/dvb-s/Astra-19.2E -vv
scanning /usr/share/dvb/dvb-s/Astra-19.2E
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
initial transponder 12551500 V 22000000 5
>>> tune to: 12551:v:0:22000
DiSEqC: switch pos 0, 13V, hiband (index 2)
DVB-S IF freq is 1951500
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
WARNING: >>> tuning failed!!!
>>> tune to: 12551:v:0:22000 (tuning failed)
DiSEqC: switch pos 0, 13V, hiband (index 2)
DVB-S IF freq is 1951500
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
>>> tuning status == 0x00
WARNING: >>> tuning failed!!!
ERROR: initial tuning failed
dumping lists (0 services)
Done.


Ich kann keine Sender abstimmen. Hast du da noch einen Tip? Wenn ich richtig gelesen habe sollt die Karte defekt sein :-)

Frank
Back to top
View user's profile Send private message
boris64
Veteran
Veteran


Joined: 04 Oct 2003
Posts: 1770
Location: vechelde / peine

PostPosted: Thu Sep 09, 2010 10:27 pm    Post subject: Reply with quote

deranonyme wrote:
Ok hier das gute Ergebnis mit 2.6.34-r6:

Huh, hat's jetzt doch mit dem alten Kernel funktioniert?
Wenn ja, wo war der Haken?

deranonyme wrote:
Ich kann keine Sender abstimmen. Hast du da noch einen Tip? Wenn ich richtig gelesen habe sollt die Karte defekt sein :-)
Frank

Antennenkabel dran? Ok, nur'n Scherz? :roll:

Wenn ja, hast du die Karte mal unter einem anderen System
(z.B.Windows) ausprobiert? Eventuell gibt's ja auch irgendeine
Linux-LiveCD mit aktuellem Kernel und dvbapps.
Oder hast du mal mit einem anderen Programm (z.B. Kaffeine!)
nach Sendern gesucht? Von einem Hardware-Fehler würde
ich eher als letztes ausgehen (oder hast du da für deinen
Verdacht eine überzeugende Quelle?).
_________________
boris64.net 200x / visit my desktop / try these tiny kernel patches ;)
Back to top
View user's profile Send private message
deranonyme
Guru
Guru


Joined: 09 Jul 2005
Posts: 364

PostPosted: Fri Sep 10, 2010 2:39 am    Post subject: Reply with quote

boris64 wrote:
deranonyme wrote:
Ok hier das gute Ergebnis mit 2.6.34-r6:

Huh, hat's jetzt doch mit dem alten Kernel funktioniert?
Wenn ja, wo war der Haken?

Keine Ahnung. vielleicht war es das make clean vorher?
boris64 wrote:

deranonyme wrote:
Ich kann keine Sender abstimmen. Hast du da noch einen Tip? Wenn ich richtig gelesen habe sollt die Karte defekt sein :-)
Frank



Wenn ja, hast du die Karte mal unter einem anderen System
(z.B.Windows) ausprobiert? Eventuell gibt's ja auch irgendeine
Linux-LiveCD mit aktuellem Kernel und dvbapps.
Oder hast du mal mit einem anderen Programm (z.B. Kaffeine!)
nach Sendern gesucht? Von einem Hardware-Fehler würde
ich eher als letztes ausgehen (oder hast du da für deinen
Verdacht eine überzeugende Quelle?).


Ich bin ein schlechter Mensch ich habe nur Linux! Und Mythubuntu bringt genau meinen Fehler den ich vorher hatte. Kaffeine "Findet kein passendes Gerät". :(
Ok, muss jetzt erst mal Geld verdienen.

Frank
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum