Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kde-testing] and [kde-crazy] KDE4 overlays thread (part 5)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 9, 10, 11 ... 19, 20, 21  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
TheDodger
Tux's lil' helper
Tux's lil' helper


Joined: 12 Aug 2002
Posts: 126
Location: Hamburg

PostPosted: Wed Dec 29, 2010 5:37 pm    Post subject: Reply with quote

genstorm wrote:
afaik the whole KDE repository is gradually being migrated to git, there will be more temporary breakage in the future.


I have today all kde:live packages - without kepim and strigi - emerged.
No Problems ...

But i think, in the near future comes the problems ...
Back to top
View user's profile Send private message
22decembre
Guru
Guru


Joined: 08 May 2010
Posts: 308
Location: Paris, banlieue sud (Massy et alentours)

PostPosted: Thu Dec 30, 2010 12:31 pm    Post subject: Reply with quote

someone has k3b running ?
_________________
Portable Gentoo installé depuis ~fevrier 2010, kde4 ( doc : http://www.22decembre.eu/gentoo-portable/)
Serveur Maison Gentoo depuis ~avril 2010 (doc : http://www.22decembre.eu/gentoo-serveur/)
http://www.22decembre.eu
Back to top
View user's profile Send private message
mkyral
Apprentice
Apprentice


Joined: 06 May 2007
Posts: 153
Location: Czech Republic

PostPosted: Fri Dec 31, 2010 3:38 pm    Post subject: Reply with quote

22decembre wrote:
someone has k3b running ?


I have. But it is the git version. I had to update the live ebuild to work with git. It was somewhere in forum or bugzilla.
Back to top
View user's profile Send private message
TheDodger
Tux's lil' helper
Tux's lil' helper


Joined: 12 Aug 2002
Posts: 126
Location: Hamburg

PostPosted: Fri Dec 31, 2010 9:34 pm    Post subject: Reply with quote

mkyral wrote:
22decembre wrote:
someone has k3b running ?


I have. But it is the git version. I had to update the live ebuild to work with git. It was somewhere in forum or bugzilla.


This Thread, Page6.
The Ugly-Patch comes from me ...
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3250
Location: Gainesville, Florida

PostPosted: Tue Jan 04, 2011 3:10 pm    Post subject: Reply with quote

4.5.95 (rc2) tagged, so hopefully rc2 tomorrow as per the posted schedule. :D
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
22decembre
Guru
Guru


Joined: 08 May 2010
Posts: 308
Location: Paris, banlieue sud (Massy et alentours)

PostPosted: Tue Jan 04, 2011 6:41 pm    Post subject: Reply with quote

I have just said I won't upgrade on kde-overlay anymore (motivation, motivation...) :( snif
_________________
Portable Gentoo installé depuis ~fevrier 2010, kde4 ( doc : http://www.22decembre.eu/gentoo-portable/)
Serveur Maison Gentoo depuis ~avril 2010 (doc : http://www.22decembre.eu/gentoo-serveur/)
http://www.22decembre.eu
Back to top
View user's profile Send private message
sparc
n00b
n00b


Joined: 18 Aug 2005
Posts: 72
Location: Stockholm, Sweden

PostPosted: Tue Jan 04, 2011 10:55 pm    Post subject: Reply with quote

hi,

I have been using the overlay and today I got oxygen-icons-4.5.5 not found. I searched some of the ftp servers only to find that they were all missing the 4.5.5 version all together. This happened before with 4.5.4 and had to wait for the ebuilds to go mainstream before being able to update.

Is it a common error, is it the ebuild, or is it me? Are you all getting the source from some specific server? Should I get it manually?
Back to top
View user's profile Send private message
StringCheesian
l33t
l33t


Joined: 21 Oct 2003
Posts: 887

PostPosted: Wed Jan 05, 2011 12:41 am    Post subject: Reply with quote

sparc wrote:
hi,

I have been using the overlay and today I got oxygen-icons-4.5.5 not found. I searched some of the ftp servers only to find that they were all missing the 4.5.5 version all together. This happened before with 4.5.4 and had to wait for the ebuilds to go mainstream before being able to update.

Is it a common error, is it the ebuild, or is it me? Are you all getting the source from some specific server? Should I get it manually?


That's normal. It's because KDE 4.5.5 hasn't actually been released yet (see the lack of a "4.5.5" directory here).

It is scheduled for release today, so I guess the ebuilds aren't masked because they would just be unmasked a few hours later anyway. It saves people the hassle of manually unmasking or waiting if they are unmasked late.
Back to top
View user's profile Send private message
hf.farhad
n00b
n00b


Joined: 18 Oct 2010
Posts: 9

PostPosted: Wed Jan 05, 2011 7:35 am    Post subject: kalzium build problem Reply with quote

hi, kde-base/kalzium-9999 ebuilds shoud be updated, It seems that svn repository structure has changed and emerge fails when it's trying to export the libkdeedu/libscience.

Code:

U    kbruch/src/exercisefactorize.h
U    kbruch/src/CMakeLists.txt
A    kbruch/src/PrimeFactorsLineEdit.cpp
Updated to revision 1211958.
 *    working copy: /usr/portage/distfiles/svn-src/kdeedu/kdeedu

 * Exporting parts of working copy to /var/tmp/portage/kde-base/kalzium-9999/work/kalzium-9999
rsync: link_stat "/usr/portage/distfiles/svn-src/kdeedu/kdeedu/libkdeedu/libscience" failed: No such file or directory (2)
rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1042) [sender=3.0.7]
 * ERROR: kde-base/kalzium-9999 failed:
 *   subversion: can't export subdirectory 'libkdeedu/libscience/' to '/var/tmp/portage/kde-base/kalzium-9999/work/kalzium-9999/libkdeedu'.
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_unpack
 *   environment, line 4349:  Called kde4-meta_src_unpack
 *   environment, line 3515:  Called kde4-meta_src_extract
 *   environment, line 3417:  Called die
 * The specific snippet of code:
 *               rsync --recursive ${rsync_options} "${ESVN_WC_PATH}/${kmnamedir}${subdir%/}" "${S}/${targetdir}" || die "${ESVN}: can't export subdirectory '${subdir}' to '${S}/${targetdir}'.";
 *
 * If you need support, post the output of 'emerge --info =kde-base/kalzium-9999',
 * the complete build log and the output of 'emerge -pqv =kde-base/kalzium-9999'.
 * This ebuild used the following eclasses from overlays:
 *   /var/lib/layman/kde/eclass/kde4-meta.eclass
 *   /var/lib/layman/kde/eclass/kde4-base.eclass
 *   /var/lib/layman/kde/eclass/kde4-functions.eclass
 * This ebuild is from an overlay named 'kde': '/var/lib/layman/kde/'
 * The complete build log is located at '/var/tmp/portage/kde-base/kalzium-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/kalzium-9999/temp/environment'.
 * S: '/var/tmp/portage/kde-base/kalzium-9999/work/kalzium-9999'

>>> Failed to emerge kde-base/kalzium-9999, Log file:
Back to top
View user's profile Send private message
Lustmored
Apprentice
Apprentice


Joined: 28 May 2010
Posts: 206
Location: Poland

PostPosted: Wed Jan 05, 2011 9:38 am    Post subject: Reply with quote

I'm using cave and today it welcomes me with:

while parsing kde-base/kde-meta wrote:
* When parsing from offset '2330':
* When parsing from offset '2350':
* Error parsing ' !kdeprefix? ( >=kde-base/kate-4.5.95[aqua=,-kdeprefix] ) kdeprefix? ( >=kde-base/kate-4.5.95:4.6[aqua=,kdeprefix] ) !kdeprefix? ( >=kde-base/kdeadmin-meta-4.5.95[aqua=,-kdeprefix] ) kdeprefix? ( >=kde-base/kdeadmin-meta-4.5.95:4.6[aqua=,kdeprefix] ) !kdeprefix? ( >=kde-base/kdeartwork-meta-4.5.95[aqua=,-kdeprefix] ) kdeprefix? ( >=kde-base/kdeartwork-meta-4.5.95:4.6[aqua=,kdeprefix] ) !kdeprefix? ( >=kde-base/kdebase-meta-4.5.95[aqua=,-kdeprefix] ) kdeprefix? ( >=kde-base/kdebase-meta-4.5.95:4.6[aqua=,kdeprefix] ) !kdeprefix? ( >=kde-base/kdeedu-meta-4.5.95[aqua=,-kdeprefix] ) kdeprefix? ( >=kde-base/kdeedu-meta-4.5.95:4.6[aqua=,kdeprefix] ) !kdeprefix? ( >=kde-base/kdegames-meta-4.5.95[aqua=,-kdeprefix] ) kdeprefix? ( >=kde-base/kdegames-meta-4.5.95:4.6[aqua=,kdeprefix] ) !kdeprefix? ( >=kde-base/kdegraphics-meta-4.5.95[aqua=,-kdeprefix] ) kdeprefix? ( >=kde-base/kdegraphics-meta-4.5.95:4.6[aqua=,kdeprefix] ) !kdeprefix? ( >=kde-base/kdemultimedia-meta-4.5.95[aqua=,-kdeprefix] ) kdeprefix? ( >=kde-base/kdemultimedia-meta-4.5.95:4.6[aqua=,kdeprefix] ) !kdeprefix? ( >=kde-base/kdenetwork-meta-4.5.95[aqua=,-kdeprefix] ) kdeprefix? ( >=kde-base/kdenetwork-meta-4.5.95:4.6[aqua=,kdeprefix] ) !kdeprefix? ( >=kde-base/kdeplasma-addons-4.5.95[aqua=,-kdeprefix] ) kdeprefix? ( >=kde-base/kdeplasma-addons-4.5.95:4.6[aqua=,kdeprefix] ) !kdeprefix? ( >=kde-base/kdetoys-meta-4.5.95[aqua=,-kdeprefix] ) kdeprefix? ( >=kde-base/kdetoys-meta-4.5.95:4.6[aqua=,kdeprefix] ) !kdeprefix? ( >=kde-base/kdeutils-meta-4.5.95[aqua=,-kdeprefix] ) kdeprefix? ( >=kde-base/kdeutils-meta-4.5.95:4.6[aqua=,kdeprefix] ) accessibility? ( !kdeprefix? ( >=kde-base/kdeaccessibility-meta-4.5.95[aqua=,-kdeprefix] ) kdeprefix? ( >=kde-base/kdeaccessibility-meta-4.5.95:4.6[aqua=,kdeprefix] ) ) nls? ( !kdeprefix? ( >=kde-base/kde-l10n-4.5.95[aqua=,-kdeprefix] ) kdeprefix? ( >=kde-base/kde-l10n-4.5.95:4.6[aqua=,kdeprefix] ) ) sdk? ( !kdeprefix? ( >=kde-base/kdebindings-meta-4.5.95[aqua=,-kdeprefix] ) kdeprefix? ( >=kde-base/kdebindings-meta-4.5.95:4.6[aqua=,kdeprefix] ) !kdeprefix? ( >=kde-base/kdesdk-meta-4.5.95[aqua=,-kdeprefix] ) kdeprefix? ( >=kde-base/kdesdk-meta-4.5.95:4.6[aqua=,kdeprefix] ) !kdeprefix? ( >=kde-base/kdewebdev-meta-4.5.95[aqua=,-kdeprefix] ) kdeprefix? ( >=kde-base/kdewebdev-meta-4.5.95:4.6[aqua=,kdeprefix] ) ) semantic-desktop? ( || (>=kde-base/kde-meta-4.5.93 >=kde-base/kdepim-meta-4.4.9 ) ) !kdeprefix? ( !kde-base/kde-meta:4.1[-kdeprefix] ) !kdeprefix? ( !kde-base/kde-meta:4.2[-kdeprefix] ) !kdeprefix? ( !kde-base/kde-meta:4.3[-kdeprefix] ) !kdeprefix? ( !kde-base/kde-meta:4.4[-kdeprefix] ) !kdeprefix? ( !kde-base/kde-meta:4.5[-kdeprefix] ) !kdeprefix? ( !kde-base/kde-meta:live[-kdeprefix] ) ': !kdeprefix? ( >=kde-base/kate-4.5.95[aqua=,-kdeprefix] ) kdeprefix? ( >=kde-base/kate-4.5.95:4.6[aqua=,kdeprefix] ) !kdeprefix? ( >=kde-base/kdeadmin-meta-4.5.95[aqua=,-kdeprefix] ) kdeprefix? ( >=kde-base/kdeadmin-meta-4.5.95:4.6[aqua=,kdeprefix] ) !kdeprefix? ( >=kde-base/kdeartwork-meta-4.5.95[aqua=,-kdeprefix] ) kdeprefix? ( >=kde-base/kdeartwork-meta-4.5.95:4.6[aqua=,kdeprefix] ) !kdeprefix? ( >=kde-base/kdebase-meta-4.5.95[aqua=,-kdeprefix] ) kdeprefix? ( >=kde-base/kdebase-meta-4.5.95:4.6[aqua=,kdeprefix] ) !kdeprefix? ( >=kde-base/kdeedu-meta-4.5.95[aqua=,-kdeprefix] ) kdeprefix? ( >=kde-base/kdeedu-meta-4.5.95:4.6[aqua=,kdeprefix] ) !kdeprefix? ( >=kde-base/kdegames-meta-4.5.95[aqua=,-kdeprefix] ) kdeprefix? ( >=kde-base/kdegames-meta-4.5.95:4.6[aqua=,kdeprefix] ) !kdeprefix? ( >=kde-base/kdegraphics-meta-4.5.95[aqua=,-kdeprefix] ) kdeprefix? ( >=kde-base/kdegraphics-meta-4.5.95:4.6[aqua=,kdeprefix] ) !kdeprefix? ( >=kde-base/kdemultimedia-meta-4.5.95[aqua=,-kdeprefix] ) kdeprefix? ( >=kde-base/kdemultimedia-meta-4.5.95:4.6[aqua=,kdeprefix] ) !kdeprefix? ( >=kde-base/kdenetwork-meta-4.5.95[aqua=,-kdeprefix] ) kdeprefix? ( >=kde-base/kdenetwork-meta-4.5.95:4.6[aqua=,kdeprefix] ) !kdeprefix? ( >=kde-base/kdeplasma-addons-4.5.95[aqua=,-kdeprefix] ) kdeprefix? ( >=kde-base/kdeplasma-addons-4.5.95:4.6[aqua=,kdeprefix] ) !kdeprefix? ( >=kde-base/kdetoys-meta-4.5.95[aqua=,-kdeprefix] ) kdeprefix? ( >=kde-base/kdetoys-meta-4.5.95:4.6[aqua=,kdeprefix] ) !kdeprefix? ( >=kde-base/kdeutils-meta-4.5.95[aqua=,-kdeprefix] ) kdeprefix? ( >=kde-base/kdeutils-meta-4.5.95:4.6[aqua=,kdeprefix] ) accessibility? ( !kdeprefix? ( >=kde-base/kdeaccessibility-meta-4.5.95[aqua=,-kdeprefix] ) kdeprefix? ( >=kde-base/kdeaccessibility-meta-4.5.95:4.6[aqua=,kdeprefix] ) ) nls? ( !kdeprefix? ( >=kde-base/kde-l10n-4.5.95[aqua=,-kdeprefix] ) kdeprefix? ( >=kde-base/kde-l10n-4.5.95:4.6[aqua=,kdeprefix] ) ) sdk? ( !kdeprefix? ( >=kde-base/kdebindings-meta-4.5.95[aqua=,-kdeprefix] ) kdeprefix? ( >=kde-base/kdebindings-meta-4.5.95:4.6[aqua=,kdeprefix] ) !kdeprefix? ( >=kde-base/kdesdk-meta-4.5.95[aqua=,-kdeprefix] ) kdeprefix? ( >=kde-base/kdesdk-meta-4.5.95:4.6[aqua=,kdeprefix] ) !kdeprefix? ( >=kde-base/kdewebdev-meta-4.5.95[aqua=,-kdeprefix] ) kdeprefix? ( >=kde-base/kdewebdev-meta-4.5.95:4.6[aqua=,kdeprefix] ) ) semantic-desktop? ( || (>=kde-base/kde-meta-4.5.93 >=kde-base/kdepim-meta-4.4.9 ) ) !kdeprefix? ( !kde-base/kde-meta:4.1[-kdeprefix] ) !kdeprefix? ( !kde-base/kde-meta:4.2[-kdeprefix] ) !kdeprefix? ( !kde-base/kde-meta:4.3[-kdeprefix] ) !kdeprefix? ( !kde-base/kde-meta:4.4[-kdeprefix] ) !kdeprefix? ( !kde-base/kde-meta:4.5[-kdeprefix] ) !kdeprefix? ( !kde-base/kde-meta:live[-kdeprefix] ) (paludis::erepository::EDepParseError)


Is there everything all right with recent commits to kde-overlay?

Oh! Found IT!

Quote:
semantic-desktop? ( || (>=kde-base/kde-meta-4.5.93 >=kde-base/kdepim-meta-4.4.9 ) )


should be probably:

Quote:
semantic-desktop? ( || (>=kde-base/kdepim-meta-4.5.93 >=kde-base/kdepim-meta-4.4.9 ) )


Or not... after change it still fails with the same :(
Back to top
View user's profile Send private message
bers
n00b
n00b


Joined: 28 Nov 2008
Posts: 49

PostPosted: Wed Jan 05, 2011 3:54 pm    Post subject: phonon-xine-9999 Reply with quote

Code:
>>> Emerging (1 of 1) media-sound/phonon-xine-9999 from kde
 * Package:    media-sound/[quote]phonon-xine-9999[/quote]
 * Repository: kde
 * Maintainer: kde@gentoo.org
 * USE:        amd64 elibc_glibc kernel_linux multilib userland_GNU xcb
 * FEATURES:   ccache preserve-libs sandbox
>>> Unpacking source...
 * GIT update -->
 *    repository:               git://anongit.kde.org/phonon-xine
 *    at the commit:            3a95c40918690a111269ccf8aca919154afdd8b3
 *    branch:                   master
 *    storage directory:        "/usr/portage/distfiles/git-src/phonon-xine"
Cloning into /var/tmp/portage/media-sound/phonon-xine-9999/work/phonon-xine-9999...
done.
>>> Unpacked to /var/tmp/portage/media-sound/phonon-xine-9999/work/phonon-xine-9999
>>> Source unpacked in /var/tmp/portage/media-sound/phonon-xine-9999/work
>>> Preparing source in /var/tmp/portage/media-sound/phonon-xine-9999/work/phonon-xine-9999 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/media-sound/phonon-xine-9999/work/phonon-xine-9999 ...
>>> Working in BUILD_DIR: "/var/tmp/portage/media-sound/phonon-xine-9999/work/phonon-xine-9999_build"
cmake -C /var/tmp/portage/media-sound/phonon-xine-9999/temp/gentoo_common_config.cmake -DCMAKE_INSTALL_PREFIX=/usr -DWITH_GLib2=OFF -DCMAKE_BUILD_TYPE=Gentoo -DCMAKE_INSTALL_DO_STRIP=OFF -DCMAKE_USER_MAKE_RULES_OVERRIDE=/var/tmp/portage/media-sound/phonon-xine-9999/temp/gentoo_rules.cmake  /var/tmp/portage/media-sound/phonon-xine-9999/work/phonon-xine-9999
loading initial cache file /var/tmp/portage/media-sound/phonon-xine-9999/temp/gentoo_common_config.cmake
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-gcc
-- Check for working C compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-g++
-- Check for working CXX compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-g++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
CMake Error at cmake/FindPhonon.cmake:50 (message):
  ERROR: Either pkg-config can not find its phonon config, or you are not
  using a recent enough Phonon version.
Call Stack (most recent call first):
  CMakeLists.txt:10 (find_package)


media-sound/phonon-9999 already installed
Back to top
View user's profile Send private message
ravloony
n00b
n00b


Joined: 04 Feb 2005
Posts: 54
Location: France

PostPosted: Wed Jan 05, 2011 6:00 pm    Post subject: Reply with quote

haveimooed wrote:
kdepimlibs-4.5.90 fails during compile:
Code:
make[2]: *** No rule to make target `/org.freedesktop.Akonadi.NotificationManager.xml', needed by `akonadi/notificationmanagerinterface.cpp'.  Stop.


Same here. Any fixes for this?
_________________
No sig yet, sig ebuild up soon :-)
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3250
Location: Gainesville, Florida

PostPosted: Thu Jan 06, 2011 5:28 am    Post subject: Reply with quote

Now compiling 4.5.95 (rc2) from overlay. :D

EDIT: Finished my basic kde install of emerge -v1 @kdedeps-4.6 @kdebase-4.6 @kdeartwork-4.6 @kdeadmin-4.6 @kdegraphics-4.6 plus a few other kdeutils packages, and marble. All seems normal. Had a little problem with a new dep (libgphoto2), which bugzilla had a work-around. Had to use CAMERA="" emerge libgphoto2 with the name of one camera listed in the ebuild put in the quotes. If you didn't do that, it fails while trying to build all the default cameras, and libgphoto2 is needed for kamera, or it fails and kamera is apparently a dep for other packages in my set list.
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
bers
n00b
n00b


Joined: 28 Nov 2008
Posts: 49

PostPosted: Thu Jan 06, 2011 8:28 am    Post subject: Reply with quote

>>> Emerging (4 of 107) kde-base/kdelibs-4.5.95 from kde
* kdelibs-4.5.95.tar.bz2 RMD160 SHA1 SHA256 size ;-) ... [ ok ]
* Package: kde-base/kdelibs-4.5.95
* Repository: kde
* USE: acl alsa amd64 bzip2 elibc_glibc fam handbook jpeg2k kernel_linux lzma mmx multilib nls opengl policykit semantic-desktop spell sse sse2 ssl udev userland_GNU
* FEATURES: ccache preserve-libs sandbox
>>> Unpacking source...
>>> Unpacking kdelibs-4.5.95.tar.bz2 to /var/tmp/portage/kde-base/kdelibs-4.5.95/work
>>> Source unpacked in /var/tmp/portage/kde-base/kdelibs-4.5.95/work
>>> Preparing source in /var/tmp/portage/kde-base/kdelibs-4.5.95/work/kdelibs-4.5.95 ...
* QA: File or directory "/var/lib/layman/kde/kde-base/kdelibs/files/dist/01_gentoo_set_xdg_menu_prefix.patch" does not exist.
* QA: Check your PATCHES array or add missing file/directory.
* QA: File or directory "/var/lib/layman/kde/kde-base/kdelibs/files/dist/02_gentoo_append_xdg_config_dirs-1.patch" does not exist.
* QA: Check your PATCHES array or add missing file/directory.
* Applying kdelibs-4.5.90-mimetypes.patch ... [ ok ]
* QA: File or directory "/var/lib/layman/kde/kde-base/kdelibs/files/kdelibs-4.4.90-xslt.patch" does not exist.
* QA: Check your PATCHES array or add missing file/directory.
* ERROR: kde-base/kdelibs-4.5.95 failed:
* Some patches failed. See above messages.
Back to top
View user's profile Send private message
Gibbo_07
n00b
n00b


Joined: 15 Nov 2009
Posts: 38
Location: Brisbane, AU

PostPosted: Thu Jan 06, 2011 8:37 am    Post subject: Reply with quote

4.5.95 compiled fine here except for kdeartwork-wallpapers which had file collisions - I had to rm /usr/share/wallpapers/Ethais for it to merge.

Also dolphin-plugins which I still can't get compiled:
Code:
>>> Source configured.
>>> Compiling source in /var/tmp/portage/kde-base/dolphin-plugins-4.5.95/work/dolphin-plugins-4.5.95 ...
>>> Working in BUILD_DIR: "/var/tmp/portage/kde-base/dolphin-plugins-4.5.95/work/dolphin-plugins-4.5.95_build"
make -j3
>>> Source compiled.
>>> Test phase [not enabled]: kde-base/dolphin-plugins-4.5.95

>>> Install dolphin-plugins-4.5.95 into /var/tmp/portage/kde-base/dolphin-plugins-4.5.95/image/ category kde-base
>>> Working in BUILD_DIR: "/var/tmp/portage/kde-base/dolphin-plugins-4.5.95/work/dolphin-plugins-4.5.95_build"
make -j3 DESTDIR=/var/tmp/portage/kde-base/dolphin-plugins-4.5.95/image/ install
make: *** No rule to make target `install'.  Stop.
emake failed
 * ERROR: kde-base/dolphin-plugins-4.5.95 failed:
 *   died running make install, base_src_install
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_install
 *   environment, line 4348:  Called kde4-meta_src_install
 *   environment, line 3505:  Called kde4-base_src_install
 *   environment, line 3080:  Called cmake-utils_src_install
 *   environment, line 1217:  Called _execute_optionaly 'src_install'
 *   environment, line  592:  Called enable_cmake-utils_src_install
 *   environment, line 1663:  Called base_src_install
 *   environment, line  857:  Called die
 * The specific snippet of code:
 *       emake DESTDIR="${D}" "$@" install || die "died running make install, $FUNCNAME";
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Thu Jan 06, 2011 9:59 am    Post subject: Reply with quote

Does anybody knows what has happened to 4.5.5? Release should have been on Tuesday...
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
sparc
n00b
n00b


Joined: 18 Aug 2005
Posts: 72
Location: Stockholm, Sweden

PostPosted: Thu Jan 06, 2011 11:47 am    Post subject: Reply with quote

StringCheesian wrote:
sparc wrote:
hi,

I have been using the overlay and today I got oxygen-icons-4.5.5 not found. I searched some of the ftp servers only to find that they were all missing the 4.5.5 version all together. This happened before with 4.5.4 and had to wait for the ebuilds to go mainstream before being able to update.

Is it a common error, is it the ebuild, or is it me? Are you all getting the source from some specific server? Should I get it manually?


That's normal. It's because KDE 4.5.5 hasn't actually been released yet (see the lack of a "4.5.5" directory here).

It is scheduled for release today, so I guess the ebuilds aren't masked because they would just be unmasked a few hours later anyway. It saves people the hassle of manually unmasking or waiting if they are unmasked late.


And the ebuilds are gone. Exact same thing happened with 4.5.4. If you ask me this looks like someone is over-optimistic on release dates and the distro-specific-migration effort. All in all I am starting to think that the people behind this overlay are just playing around. I hope this is not the case.

PS on the initial post: it did not occur to me to look at the official kde repos. Stable ebuilds means released software. That's final. If it's there I should be able to install it. If however, you guys maintaining this overlay are just doing it for kicks (thus prioritizing the less-effort-but-wrong way of doing things) you should announce so because many people are sustaining jobs out of your effort and they, like me, cannot afford such clumsiness. Because in the end it is only logical to assume that this lazy approach spans across every aspect of your work.

Finally, I'm not in any way trying to be hostile; I respect your effort and I wish I'd have the time to contribute. I'm just frustrated and I'm sorry for that.
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Thu Jan 06, 2011 11:57 am    Post subject: Reply with quote

sparc wrote:
And the ebuilds are gone. Exact same thing happened with 4.5.4. If you ask me this looks like someone is over-optimistic on release dates and the distro-specific-migration effort. All in all I am starting to think that the people behind this overlay are just playing around. I hope this is not the case.


[12:56:18]|[root@tobi-desktop]|/home/tobi
$ls /var/lib/layman/kde/kde-base/kdelibs/
total 92
drwxr-xr-x 3 root root 4096 Jan 6 09:53 .
drwxr-xr-x 294 root root 8192 Nov 25 16:59 ..
-rw-r--r-- 1 root root 6251 Jan 6 09:53 Manifest
drwxr-xr-x 3 root root 4096 Dec 23 20:15 files
-rw-r--r-- 1 root root 9254 Jan 5 18:46 kdelibs-4.5.5.ebuild
-rw-r--r-- 1 root root 9397 Jan 5 18:46 kdelibs-4.5.95.ebuild
-rw-r--r-- 1 root root 9192 Sep 14 22:13 kdelibs-4.5.9999.ebuild
-rw-r--r-- 1 root root 9386 Dec 28 23:57 kdelibs-4.6.9999.ebuild
-rw-r--r-- 1 root root 9386 Dec 28 23:57 kdelibs-9999.ebuild
-rw-r--r-- 1 root root 250 Nov 15 20:55 metadata.xml

They are still in the overlay?
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
duryodhana
n00b
n00b


Joined: 13 Jan 2008
Posts: 66

PostPosted: Thu Jan 06, 2011 12:18 pm    Post subject: Reply with quote

Gibbo_07 wrote:
4.5.95 compiled fine here except for kdeartwork-wallpapers which had file collisions - I had to rm /usr/share/wallpapers/Ethais for it to merge.

Also dolphin-plugins which I still can't get compiled:
Code:
>>> Source configured.
>>> Compiling source in /var/tmp/portage/kde-base/dolphin-plugins-4.5.95/work/dolphin-plugins-4.5.95 ...
>>> Working in BUILD_DIR: "/var/tmp/portage/kde-base/dolphin-plugins-4.5.95/work/dolphin-plugins-4.5.95_build"
make -j3
>>> Source compiled.
>>> Test phase [not enabled]: kde-base/dolphin-plugins-4.5.95

>>> Install dolphin-plugins-4.5.95 into /var/tmp/portage/kde-base/dolphin-plugins-4.5.95/image/ category kde-base
>>> Working in BUILD_DIR: "/var/tmp/portage/kde-base/dolphin-plugins-4.5.95/work/dolphin-plugins-4.5.95_build"
make -j3 DESTDIR=/var/tmp/portage/kde-base/dolphin-plugins-4.5.95/image/ install
make: *** No rule to make target `install'.  Stop.
emake failed
 * ERROR: kde-base/dolphin-plugins-4.5.95 failed:
 *   died running make install, base_src_install
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_install
 *   environment, line 4348:  Called kde4-meta_src_install
 *   environment, line 3505:  Called kde4-base_src_install
 *   environment, line 3080:  Called cmake-utils_src_install
 *   environment, line 1217:  Called _execute_optionaly 'src_install'
 *   environment, line  592:  Called enable_cmake-utils_src_install
 *   environment, line 1663:  Called base_src_install
 *   environment, line  857:  Called die
 * The specific snippet of code:
 *       emake DESTDIR="${D}" "$@" install || die "died running make install, $FUNCNAME";




Kde 4.6 RC2 compiled fine here too. But the world clock plasmoid caused plasma crashes. I had to remove this completely to have plasma desktop working.
Back to top
View user's profile Send private message
Lustmored
Apprentice
Apprentice


Joined: 28 May 2010
Posts: 206
Location: Poland

PostPosted: Thu Jan 06, 2011 1:08 pm    Post subject: Reply with quote

I am still certainly sure, that in kde-meta this:

Quote:
semantic-desktop? ( || ( >=kde-base/kde-meta-4.5.93 >=kde-base/kdepim-meta-4.4.9 ) )


Should be:

Quote:
semantic-desktop? ( || ( >=kde-base/kdepim-meta-4.5.93 >=kde-base/kdepim-meta-4.4.9 ) )


Any KDE team member please fix it :wink:
Back to top
View user's profile Send private message
Voltago
Advocate
Advocate


Joined: 02 Sep 2003
Posts: 2584
Location: userland

PostPosted: Thu Jan 06, 2011 4:04 pm    Post subject: Reply with quote

Weirdest thing: Since 4.6 beta1, the kdm login window sometimes does not show up (I suspect some dbus/polkit issue). With gentoo-sources-2.6.37, kdm breaks completely and the login window never shows up... Anybody seen anything like this?
Back to top
View user's profile Send private message
mirekm
Apprentice
Apprentice


Joined: 12 Feb 2004
Posts: 187
Location: Gliwice

PostPosted: Thu Jan 06, 2011 5:14 pm    Post subject: Reply with quote

pykde-4.5.95 compilation fails with PyQt4 dependency:
Here is needed >=PyQt4-4.8.2

Code:

- Python Libraries: /usr/lib64/libpython2.6.so
-- Python Include Path: /usr/include/python2.6
-- Build Kross Python... yes
-- Found SIP version: 4.12
-- Found PyQt4 version: 4.8.1
-- The version of PyQt found is too old. 4.8.2 or later is required.
-- Build PyKDE4... no

-----------------------------------------------------------------------------
-- The following external packages were located on your system.
-- This installation will have the extra features provided by these packages.
-----------------------------------------------------------------------------

Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Thu Jan 06, 2011 5:45 pm    Post subject: Reply with quote

mirekm wrote:
pykde-4.5.95 compilation fails with PyQt4 dependency:
Here is needed >=PyQt4-4.8.2


[I] dev-python/PyQt4
Available versions: 4.7.3 (~)4.7.7-r1 4.8.1 (~)4.8.1-r1 (~)4.8.2_pre20101221[2] (~)4.8.2

Then unmask it?
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
Geos_One
Apprentice
Apprentice


Joined: 15 Sep 2005
Posts: 250
Location: Austria,Graz

PostPosted: Thu Jan 06, 2011 6:58 pm    Post subject: install error Reply with quote

kde-base/dolphin-plugins-4.5.95 dont want to install
any suggestions

Code:
-- <<< Gentoo configuration >>>
Build type      Gentoo
Install path    /usr
Compiler flags:
C               -march=k8 -msse3 -O2 -pipe   -Wno-long-long -std=iso9899:1990 -Wundef -Wcast-align -Werror-implicit-function-declaration -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -Wformat-security -Wmissing-format-attribute -fno-common
C++             -march=k8 -msse3 -O2 -pipe   -Wnon-virtual-dtor -Wno-long-long -ansi -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security -fno-exceptions -DQT_NO_EXCEPTIONS -fno-check-new -fno-common -Werror=return-type -Woverloaded-virtual -fno-threadsafe-statics -fvisibility=hidden -fvisibility-inlines-hidden
Linker flags:
Executable      -Wl,--enable-new-dtags -Wl,--hash-style=gnu -Wl,-O1 -Wl,--as-needed
Module          -Wl,--enable-new-dtags -Wl,--fatal-warnings -Wl,--no-undefined -lc -Wl,--hash-style=gnu -Wl,-O1 -Wl,--as-needed
Shared          -Wl,--enable-new-dtags -Wl,--fatal-warnings -Wl,--no-undefined -lc -Wl,--hash-style=gnu -Wl,-O1 -Wl,--as-needed

-- Configuring done
-- Generating done
-- Build files have been written to: /var/tmp/portage/kde-base/dolphin-plugins-4.5.95/work/dolphin-plugins-4.5.95_build
>>> Source configured.
>>> Compiling source in /var/tmp/portage/kde-base/dolphin-plugins-4.5.95/work/dolphin-plugins-4.5.95 ...
>>> Working in BUILD_DIR: "/var/tmp/portage/kde-base/dolphin-plugins-4.5.95/work/dolphin-plugins-4.5.95_build"
make -j3
>>> Source compiled.
>>> Test phase [not enabled]: kde-base/dolphin-plugins-4.5.95

>>> Install dolphin-plugins-4.5.95 into /var/tmp/portage/kde-base/dolphin-plugins-4.5.95/image/ category kde-base
>>> Working in BUILD_DIR: "/var/tmp/portage/kde-base/dolphin-plugins-4.5.95/work/dolphin-plugins-4.5.95_build"
make -j3 DESTDIR=/var/tmp/portage/kde-base/dolphin-plugins-4.5.95/image/ install
make: *** No rule to make target `install'.  Stop.
emake failed
 * ERROR: kde-base/dolphin-plugins-4.5.95 failed:
 *   died running make install, base_src_install


thx in av
Back to top
View user's profile Send private message
flame__
n00b
n00b


Joined: 24 Aug 2005
Posts: 4
Location: Warsaw, Poland

PostPosted: Fri Jan 07, 2011 1:08 am    Post subject: Reply with quote

Voltago wrote:
With gentoo-sources-2.6.37, kdm breaks completely and the login window never shows up... Anybody seen anything like this?

Same thing here. But only on netbook with intel card, desktop with nvidia works normally. If reboot back to 2.6.36-r6 kdm is working again.
Does anyone have any ideas why is it happening and how to fix it?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 9, 10, 11 ... 19, 20, 21  Next
Page 10 of 21

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum