Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kde-testing] and [kde-crazy] KDE4 overlays thread (part 5)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 16, 17, 18, 19, 20, 21  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
mkyral
Apprentice
Apprentice


Joined: 06 May 2007
Posts: 153
Location: Czech Republic

PostPosted: Thu Jun 16, 2011 2:08 pm    Post subject: Re: --- Reply with quote

bers wrote:
Well, thank you.
And does anyone know when will the kde 4.7 beta2?


There is some delay :-(

http://techbase.kde.org/Schedules/KDE4/4.7_Release_Schedule#Wednesday.2C_June_8.2C_2011:_KDE_4.7_Beta_2_Release
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7108
Location: Austria

PostPosted: Thu Jun 16, 2011 8:10 pm    Post subject: Reply with quote

Still struggling with the git migration it seems, when you can read things like that:
Code:
Bump okular to real 4.6.4 with one big patch, since upstream packaged the
code of ~4.6.1 into the 4.6.4 tarball

as seen in http://packages.gentoo.org/package/kde-base/okular
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
firephoto
Veteran
Veteran


Joined: 29 Oct 2003
Posts: 1604
Location: +48° 5' 23.40", -119° 48' 30.00"

PostPosted: Thu Jun 16, 2011 8:21 pm    Post subject: Reply with quote

They're talking about skipping beta2 and going to RC now on the release mailinglist which if it means creating the 4.7 branch is just what I've been waiting for. ;)
_________________
#gentoo-kde on freenode
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7108
Location: Austria

PostPosted: Thu Jun 16, 2011 8:37 pm    Post subject: Reply with quote

RC1 usually is 4.6.90.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
firephoto
Veteran
Veteran


Joined: 29 Oct 2003
Posts: 1604
Location: +48° 5' 23.40", -119° 48' 30.00"

PostPosted: Thu Jun 16, 2011 9:43 pm    Post subject: Reply with quote

genstorm wrote:
RC1 usually is 4.6.90.


4.7 branch as in git and subversion. I've been on the latest branch and haven't built from a tarball in... years I guess. It's a lot easier to get fixes without waiting for the next minor release and it's always in good shape which trunk isn't at times. I just maintain sets for all the installed live kde-base ebuilds and one for everything else.

From the quietness here and on irc I'm guessing I'm one of the very few on live branch ebuilds these days or else everyone has the good luck I do with them (most of the time). ;)
_________________
#gentoo-kde on freenode
Back to top
View user's profile Send private message
bers
n00b
n00b


Joined: 28 Nov 2008
Posts: 49

PostPosted: Fri Jun 17, 2011 6:17 am    Post subject: Reply with quote

firephoto wrote:
They're talking about skipping beta2 and going to RC now on the release mailinglist which if it means creating the 4.7 branch is just what I've been waiting for. ;)


Ok, let's wait :)
Back to top
View user's profile Send private message
ejs76
Tux's lil' helper
Tux's lil' helper


Joined: 07 Feb 2004
Posts: 148

PostPosted: Wed Jun 22, 2011 9:20 pm    Post subject: Reply with quote

4.6.90 (RC1) has just been tagged:

http://websvn.kde.org/tags/KDE/?sortdir=down#dirlist

So they're only one day behind on their original schedule. And following the schedule the tarballs should be released tomorrow.
_________________
~amd64
PhenomII x4 955 | MSI 790GX-G65 | ATI Radeon 5770 | 8GB DDR3 1333
Back to top
View user's profile Send private message
ejs76
Tux's lil' helper
Tux's lil' helper


Joined: 07 Feb 2004
Posts: 148

PostPosted: Sat Jun 25, 2011 12:40 pm    Post subject: Reply with quote

4.6.90 tarballs are out:

ftp://ftp.kde.org/pub/kde/unstable/4.6.90/src/
_________________
~amd64
PhenomII x4 955 | MSI 790GX-G65 | ATI Radeon 5770 | 8GB DDR3 1333
Back to top
View user's profile Send private message
Korhul
n00b
n00b


Joined: 09 May 2005
Posts: 74
Location: Czech Republic

PostPosted: Fri Jul 01, 2011 7:33 pm    Post subject: Reply with quote

Just tried to compile digikam 2.0.0_rc by copying ebuilds for beta6 to my local overlay. It fails with:

Code:
[ 11%] [ 11%] [ 11%] [ 12%] Building CXX object digikam/CMakeFiles/digikamcore.dir/__/libs/threadimageio/pgfutils.o
Building CXX object digikam/CMakeFiles/digikamcore.dir/__/libs/widgets/common/ditemtooltip.o                                                             
Building CXX object digikam/CMakeFiles/digikamcore.dir/__/libs/widgets/common/dpopupmenu.o                                                               
Building CXX object digikam/CMakeFiles/digikamcore.dir/__/libs/widgets/common/dlogoaction.o                                                               
/var/tmp/portage/media-gfx/digikam-2.0.0_rc/work/digikam-2.0.0-rc/core/libs/threadimageio/pgfutils.cpp: In function ‘bool Digikam::writePGFImageData(const QImage&, QByteArray&, int)’:
/var/tmp/portage/media-gfx/digikam-2.0.0_rc/work/digikam-2.0.0-rc/core/libs/threadimageio/pgfutils.cpp:154: error: invalid conversion from ‘UINT32*’ to ‘int’
/var/tmp/portage/media-gfx/digikam-2.0.0_rc/work/digikam-2.0.0-rc/core/libs/threadimageio/pgfutils.cpp:154: error:   initializing argument 2 of ‘void CPGFImage::Write(CPGFStream*, int, bool (*)(double, bool, void*), UINT32*, void*)’
make[2]: *** [digikam/CMakeFiles/digikamcore.dir/__/libs/threadimageio/pgfutils.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [digikam/CMakeFiles/digikamcore.dir/all] Error 2
make: *** [all] Error 2
Back to top
View user's profile Send private message
firephoto
Veteran
Veteran


Joined: 29 Oct 2003
Posts: 1604
Location: +48° 5' 23.40", -119° 48' 30.00"

PostPosted: Fri Jul 01, 2011 7:38 pm    Post subject: Reply with quote

Korhul wrote:
Just tried to compile digikam 2.0.0_rc by copying ebuilds for beta6 to my local overlay. It fails with:



Same here, building against 4.7 (branch) updated yesterday. I bumped the libkface and libkmap too.

Qt 4.7.4 too.

This is also my first attempt at digikam 2 so I don't know if anything similar has happened previously with the betas.
_________________
#gentoo-kde on freenode
Back to top
View user's profile Send private message
Korhul
n00b
n00b


Joined: 09 May 2005
Posts: 74
Location: Czech Republic

PostPosted: Fri Jul 01, 2011 7:59 pm    Post subject: Reply with quote

Beta6 works for me. But there's bug that prevents face recognition from working. Should be working in RC. I have also bumped libkmap and libkface.
Back to top
View user's profile Send private message
houtworm
Guru
Guru


Joined: 08 Mar 2003
Posts: 353
Location: Den Haag, Netherlands

PostPosted: Fri Jul 01, 2011 11:54 pm    Post subject: Reply with quote

ok I tried 4.6.90 and that works, except that i had to use
USE="-python" emerge -u marble

Now I tried to install 4.7.49.9999 and again trouble with marble.
Code:
>>> Preparing source in /mnt/data/tmp/portage/kde-base/marble-4.7.49.9999/work/marble-4.7.49.9999 ...                 
 .[32;01m*.[0m Applying marble-4.6.2-magic.patch ...                                                                   
                                                                                                                       
 .[31;01m*.[0m Failed Patch: marble-4.6.2-magic.patch !                                                               
 .[31;01m*.[0m  ( /var/lib/layman/kde/kde-base/marble/files/marble-4.6.2-magic.patch )                                 
 .[31;01m*.[0m                                                                                                         
 .[31;01m*.[0m Include in your bugreport the contents of:                                                             
 .[31;01m*.[0m                                                                                                         
 .[31;01m*.[0m   /mnt/data/tmp/portage/kde-base/marble-4.7.49.9999/temp/marble-4.6.2-magic.patch.out


and in magic.patch.out:
Code:
***** marble-4.6.2-magic.patch *****                                                                                   
                                                                                                                       
====================================                                                                                   
                                                                                                                       
PATCH COMMAND:  patch -p0 -g0 -E --no-backup-if-mismatch < '/var/lib/layman/kde/kde-base/marble/files/marble-4.6.2-magi
                                                                                                                       
====================================                                                                                   
can't find file to patch at input line 4                                                                               
Perhaps you used the wrong -p or --strip option?                                                                       
The text leading up to this was:                                                                                       
--------------------------                                                                                             
|diff -ruN marble-4.6.2.orig/marble/src/plugins/positionprovider/CMakeLists.txt marble-4.6.2/marble/src/plugins/positio
|--- marble-4.6.2.orig/marble/src/plugins/positionprovider/CMakeLists.txt       2011-01-19 23:06:11.000000000 +0100   
|+++ marble-4.6.2/marble/src/plugins/positionprovider/CMakeLists.txt    2011-04-11 03:56:00.449066967 +0200           
--------------------------                                                                                             
No file to patch.  Skipping patch.                                                                                     
2 out of 2 hunks ignored                                                                                               
==================================== 
[rest skipped..]


masking marble-4.7.49.9999 is even worse:
Code:
The following keyword changes are necessary to proceed:
#required by kde-base/kdeedu-meta-4.7.49.9999, required by kde-base/kde-meta-4.7.49.9999, required by @selected, required by @world (argument)
>=kde-base/marble-9999 **


so.. without marble it is not possible to install kde-4.7.49.9999

Is there any way to install marble-4.7.49.9999? Or to skip it?

--Kees
_________________
niemand is onbekwamer, dan een timmerman zonder hamer

Kees
Back to top
View user's profile Send private message
Biert
n00b
n00b


Joined: 14 Sep 2006
Posts: 45
Location: The Netherlands

PostPosted: Tue Jul 05, 2011 11:07 pm    Post subject: Reply with quote

I noticed that some ebuilds for the KDE Telepathy project are in the overlay now. It seems to me some are missing though, to the point where some basic functionality is missing.

In order for the telepathy-presence-applet to work, telepathy-presence-dataengine should be installed as well. Then there are the integration daemon (telepathy-nepomuk-service), and some more pieces.

https://projects.kde.org/projects/playground/network/telepathy has a list of the subprojects involved. I've created basic ebuilds for most of them in my personal overlay and they all work (telepathy-kde had some icon file collisions though). Seems to work well, although I've not tested much yet. At least I can set my nickname and status via the plasmoid now :P

I'll happily supply the ebuilds I've cooked up for anyone interested.
_________________
http://www.last.fm/user/Biert/
Back to top
View user's profile Send private message
houtworm
Guru
Guru


Joined: 08 Mar 2003
Posts: 353
Location: Den Haag, Netherlands

PostPosted: Tue Jul 05, 2011 11:25 pm    Post subject: Reply with quote

today came a new magic patch for marble.
Yeah! now it works.
Ok, now I try to install the rest of 4.7
_________________
niemand is onbekwamer, dan een timmerman zonder hamer

Kees
Back to top
View user's profile Send private message
NForce
Tux's lil' helper
Tux's lil' helper


Joined: 07 Nov 2009
Posts: 79
Location: Kaunas, Lithuania

PostPosted: Thu Jul 07, 2011 9:23 am    Post subject: Reply with quote

Does amarok 2.4.1 compile for you guys with 4.7rc1?
Also, what about grub integration? I don't see a menu to select what to reboot into
Back to top
View user's profile Send private message
Biert
n00b
n00b


Joined: 14 Sep 2006
Posts: 45
Location: The Netherlands

PostPosted: Thu Jul 07, 2011 12:58 pm    Post subject: Reply with quote

NForce wrote:
Does amarok 2.4.1 compile for you guys with 4.7rc1?

Fails for me too
Code:
Linking CXX shared module ../../../../lib/amarok_data_engine_upcomingEvents.so
distcc[12765] ERROR: compile (null) on localhost failed
In file included from /var/tmp/portage/media-sound/amarok-2.4.1/work/amarok-2.4.1/src/context/scriptengine/javascript/simplejavascriptapplet.cpp:43:
/var/tmp/portage/media-sound/amarok-2.4.1/work/amarok-2.4.1/src/context/scriptengine/javascript/bind_dataengine.h:32: error: redefinition of 'struct QMetaTypeId<Plasma::Service*>'
/usr/include/plasma/service.h:321: error: previous definition of 'struct QMetaTypeId<Plasma::Service*>'
In file included from /var/tmp/portage/media-sound/amarok-2.4.1/work/amarok-2.4.1/src/context/scriptengine/javascript/simplejavascriptapplet.cpp:43:
/var/tmp/portage/media-sound/amarok-2.4.1/work/amarok-2.4.1/src/context/scriptengine/javascript/bind_dataengine.h:33: error: redefinition of 'struct QMetaTypeId<Plasma::ServiceJob*>'
/usr/include/KDE/Plasma/../../plasma/servicejob.h:136: error: previous definition of 'struct QMetaTypeId<Plasma::ServiceJob*>'
make[2]: *** [src/context/scriptengine/javascript/CMakeFiles/amarok_appletscript_simple_javascript.dir/simplejavascriptapplet.o] Error 1
make[1]: *** [src/context/scriptengine/javascript/CMakeFiles/amarok_appletscript_simple_javascript.dir/all] Error 2


NForce wrote:
Also, what about grub integration? I don't see a menu to select what to reboot into

I think it's only grub2 integration, current Gentoo stable (and keyword, for that matter) is grub-0.97. You'll have to unmask grub-1.98, 1.99 or 9999 for the integration

https://ksmanis.wordpress.com/2011/04/21/hello-planet-and-grub2-support-for-kdm/
_________________
http://www.last.fm/user/Biert/
Back to top
View user's profile Send private message
Lustmored
Apprentice
Apprentice


Joined: 28 May 2010
Posts: 206
Location: Poland

PostPosted: Thu Jul 07, 2011 7:52 pm    Post subject: Reply with quote

I have grub2. Integration does not work :(

Also Amarok fails too, trying newly released beta (not in overlay... yet?). 72% now ;)

[EDIT]
Yes - amarok-2.4.1.90 builds fine with KDE 4.6.90 :) Hopefully ebuild will land soon.

I have also problem with pykde4-4.6.90-r1 during install phase. Anyone?

Also after overlay cleanup my kde-meta and kde-l10n wants to be downgraded. They weren't upgraded to 4.6.90?
Back to top
View user's profile Send private message
NForce
Tux's lil' helper
Tux's lil' helper


Joined: 07 Nov 2009
Posts: 79
Location: Kaunas, Lithuania

PostPosted: Fri Jul 08, 2011 11:52 am    Post subject: Reply with quote

Yeah, I use grub2 too - integration does not work
Back to top
View user's profile Send private message
Herring42
Guru
Guru


Joined: 10 Mar 2004
Posts: 373
Location: Buckinghamshire

PostPosted: Sat Jul 09, 2011 9:16 am    Post subject: Reply with quote

Lustmored wrote:

I have also problem with pykde4-4.6.90-r1 during install phase. Anyone?


Yes, I'm having problems here too :-(
_________________
"The problem with quotes on the internet is that it is difficult
to determine whether or not they are genuine." -- Abraham Lincoln
Back to top
View user's profile Send private message
lmarcini
Guru
Guru


Joined: 21 Jul 2004
Posts: 531
Location: Champagne sur Seine (France)

PostPosted: Sat Jul 09, 2011 10:26 am    Post subject: Reply with quote

Herring42 wrote:
Lustmored wrote:

I have also problem with pykde4-4.6.90-r1 during install phase. Anyone?


Yes, I'm having problems here too :-(


Same problem here with pykde4-4.6.90-r1 and amarok-2.4.1...
_________________
umount /dev/brain
Back to top
View user's profile Send private message
Loko123
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2011
Posts: 91

PostPosted: Sun Jul 10, 2011 7:46 pm    Post subject: Reply with quote

lmarcini wrote:
Herring42 wrote:
Lustmored wrote:

I have also problem with pykde4-4.6.90-r1 during install phase. Anyone?


Yes, I'm having problems here too :-(


Same problem here with pykde4-4.6.90-r1 and amarok-2.4.1...


amarok-9999 compiled fine here. (9999) But phonon-xine fails and also marble & system-config-printer-kde.

But I enjoy KDE SC 4.7 RC 2 :)
Back to top
View user's profile Send private message
Lustmored
Apprentice
Apprentice


Joined: 28 May 2010
Posts: 206
Location: Poland

PostPosted: Sun Jul 10, 2011 8:32 pm    Post subject: Reply with quote

You have tarballs somehow? 8O
Back to top
View user's profile Send private message
cruzki123
Apprentice
Apprentice


Joined: 16 May 2008
Posts: 249

PostPosted: Sun Jul 10, 2011 8:40 pm    Post subject: Reply with quote

Loko123 wrote:
lmarcini wrote:
Herring42 wrote:
Lustmored wrote:

I have also problem with pykde4-4.6.90-r1 during install phase. Anyone?


Yes, I'm having problems here too :-(


Same problem here with pykde4-4.6.90-r1 and amarok-2.4.1...


amarok-9999 compiled fine here. (9999) But phonon-xine fails and also marble & system-config-printer-kde.

But I enjoy KDE SC 4.7 RC 2 :)


Where did you find the tarballs?
Back to top
View user's profile Send private message
lmarcini
Guru
Guru


Joined: 21 Jul 2004
Posts: 531
Location: Champagne sur Seine (France)

PostPosted: Mon Jul 11, 2011 8:15 am    Post subject: Reply with quote

cruzki123 wrote:
Loko123 wrote:
lmarcini wrote:
Herring42 wrote:
Lustmored wrote:

I have also problem with pykde4-4.6.90-r1 during install phase. Anyone?


Yes, I'm having problems here too :-(


Same problem here with pykde4-4.6.90-r1 and amarok-2.4.1...


amarok-9999 compiled fine here. (9999) But phonon-xine fails and also marble & system-config-printer-kde.

But I enjoy KDE SC 4.7 RC 2 :)


Where did you find the tarballs?


Yes: where ? ;-)

PS : Amarok 2.4.1.90 compiles fine now!

EDIT : tarballs are available now!
_________________
umount /dev/brain
Back to top
View user's profile Send private message
Herring42
Guru
Guru


Joined: 10 Mar 2004
Posts: 373
Location: Buckinghamshire

PostPosted: Mon Jul 11, 2011 11:29 am    Post subject: Reply with quote

lmarcini wrote:
EDIT : tarballs are available now!


Yay!

Compiling now :-)

EDIT: All done :-D
_________________
"The problem with quotes on the internet is that it is difficult
to determine whether or not they are genuine." -- Abraham Lincoln
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 16, 17, 18, 19, 20, 21  Next
Page 17 of 21

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum