Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mplayer x264
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
yseq
n00b
n00b


Joined: 17 Sep 2010
Posts: 15

PostPosted: Fri Sep 17, 2010 4:43 pm    Post subject: mplayer x264 Reply with quote

Hallo,
auf einer amd64 Installation ist es mir nicht möglich, den mplayer mit x264 support zu installieren.
Die Ausgabe von emerge -pv mplayer sieht so aus:
Code:
@home ~ # emerge -pv mplayer

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] media-video/mplayer-1.0_rc4_p20091026-r1  USE="3dnow 3dnowext a52 aac alsa ass cddb cdio dirac dts dv dvb dvd dvdnav enca encode faac faad ftp gif iconv jpeg live mmx mp3 network osdmenu png quicktime rar real rtc samba schroedinger shm speex sse sse2 theora toolame tremor truetype twolame unicode vorbis x264 xvid -X -aalib (-altivec) -amr -bidi -bindist -bl -bs2b -cdparanoia -cpudetection -custom-cpuopts -debug -dga -directfb -doc -dxr3 -esd -fbcon -ggi -gmplayer -ipv6 -jack -joystick -ladspa -libcaca -lirc -lzo -mad -md5sum -mmxext -mng -nas -nut -openal -opengl -oss -pnm -pulseaudio -pvr -radio -sdl -ssse3 (-svga) -teletext -tga -v4l -v4l2 (-vdpau) (-vidix) (-win32codecs) -xanim -xinerama -xscreensaver -xv -xvmc -zoran" VIDEO_CARDS="mga tdfx (-nvidia) -s3virge" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB



Zeile z.Z. in package.use:
Code:
media-video/mplayer 3dnowext dvb gif jpeg png -lirc -qt -kde -gnome -X -arts -opengl -gtk -gtk2 -xmms -xv -xscreensaver -arts


Aber komplett ohne obige Zeile dasselbe.

Ergebnis immer das selbe:
Code:
@home ~ # mencoder -ovc help
MEncoder 1.0rc2-4.1.2 (C) 2000-2007 MPlayer Team
CPU: AMD Phenom(tm) II X4 945 Processor (Family: 16, Model: 4, Stepping: 2)
CPUflags: Type: 16 MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE SSE2

115 audio & 237 video codecs

Available codecs:
   copy     - frame copy, without re-encoding. Doesn't work with filters.
   frameno  - special audio-only file for 3-pass encoding, see DOCS.
   raw      - uncompressed video. Use fourcc option to set format explicitly.
   lavc     - libavcodec codecs - best quality!



jemand eine gute Idee?
Grüße
Back to top
View user's profile Send private message
dermund
Apprentice
Apprentice


Joined: 28 Aug 2007
Posts: 205
Location: Sprawl

PostPosted: Tue Sep 28, 2010 8:00 pm    Post subject: Reply with quote

Hallo yseq,

Du kannst mal testen ob revdep-rebuild was findet.

Welche Version von media-libs/x264 hast du?
Back to top
View user's profile Send private message
mastacloak
Apprentice
Apprentice


Joined: 01 Aug 2004
Posts: 174
Location: Berlin / Germany

PostPosted: Tue Sep 28, 2010 8:59 pm    Post subject: Re: mplayer x264 Reply with quote

Hast Du schonmal Deine Versionen verglichen?

yseq wrote:

Code:
[ebuild   R   ] media-video/mplayer-1.0_rc4_p20091026-r1


Code:
@home ~ # mencoder -ovc help
MEncoder 1.0rc2-4.1.2 (C) 2000-2007 MPlayer Team


Ggf. liegt bei Dir noch irgendwo eine lokale Version von mplayer/mencoder rum?

Bei mir ist der Version-String für media-video/mplayer-1.0_rc4_p20091026-r1 (amd64) übrigens
Code:
MPlayer SVN-r29796-4.4.3 (C) 2000-2009 MPlayer Team
Back to top
View user's profile Send private message
69719
l33t
l33t


Joined: 20 Sep 2004
Posts: 865

PostPosted: Wed Sep 29, 2010 7:37 am    Post subject: Reply with quote

Ich gehe von aus, dass du irgendwie versucht hast mplayer/mencoder händisch zu installieren.
Portage will Version media-video/mplayer-1.0_rc4_p20091026-r1 neu installieren und beim Aufruf von der bash wird ein MEncoder 1.0rc2-4.1.2 gestartet.
Back to top
View user's profile Send private message
yseq
n00b
n00b


Joined: 17 Sep 2010
Posts: 15

PostPosted: Wed Sep 29, 2010 8:45 am    Post subject: Reply with quote

Dank Euch allen.
Hatte vor längerem (kann mich gar nicht erinnern) versucht den mplayer so zu kompilieren. Da es nicht hinhaute, daran kann ich mich erinnern 8O , und ich nicht soo häufig kompiliere, und ich seinerzeit ... und was nicht noch alles. Jedenfalls lag es an dem gescheiterten Versuch. :oops:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum