Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xorg-Server und mein Keyboard
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Hilzerak
n00b
n00b


Joined: 17 Sep 2010
Posts: 8

PostPosted: Fri Sep 17, 2010 10:08 am    Post subject: Xorg-Server und mein Keyboard Reply with quote

Hallo
nachdem ich mich fast zu tot gegoogelt habe, wende ich mich nun an euch.
Hoffe ihr könnt mir helfen.
Nachdem ich "startx" asugeführt habe um den Server zu starten fährt dieser hoch stellt alles korrekt da ect...
Mein Problem ist die Tastatur.
Diese wird einfach nicht erkannt.
Fehlermeldungen beim Booten des Servers:

Code:
Current version of pixman: 0.18.2
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Sep 17 12:01:01 2010
(==) Using config file: "/etc/X11/xorg.conf"
error setting MTRR (base = 0xf8000000, size = 0x00400000, type = 1) Inappropriate ioctl for device (25)
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Error:            No Symbols named "xorg" in the include file "de"
>                   Exiting
>                   Abandoning symbols file "default"
Errors from xkbcomp are not fatal to the X server
keys: Ungültige Taste/Sondertaste (Modifier) in Zeile 28): Mod1 Tab :NextWindow {groups}
keys: Ungültige Taste/Sondertaste (Modifier) in Zeile 29): Mod1 Shift Tab :PrevWindow {groups}
...



In der HAL habe ich es sowohl mit als auch ohne Policies für das Keyboard probiert, kein Unterschied.


Grüße
Back to top
View user's profile Send private message
Falmer
n00b
n00b


Joined: 22 Mar 2006
Posts: 51
Location: im grünen Herzen Deutschlands ;-)

PostPosted: Fri Sep 17, 2010 10:37 am    Post subject: Reply with quote

Hi,

um hier etwas sagen zu können, solltest Du die auf Deinem System verwendete Version des xorg-server angeben.
Die aktuelle Version (bei mir 1.90) benutzt das USE-Flag hal nicht mehr.
Als input-Treiber wird bei mir nur noch evdev benötigt.
Back to top
View user's profile Send private message
Hilzerak
n00b
n00b


Joined: 17 Sep 2010
Posts: 8

PostPosted: Fri Sep 17, 2010 1:38 pm    Post subject: Reply with quote

Version ist 1.7.7
Das Flag hatte ich gesetzt.
Als input-Treiber habe ich auch "evdev" gesetzt.
In meiner xorg.conf steht:

Code:
Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
        ModulePath   "/usr/lib/xorg/modules"
        FontPath     "/usr/share/fonts/misc/"
        FontPath     "/usr/share/fonts/TTF/"
        FontPath     "/usr/share/fonts/OTF"
        FontPath     "/usr/share/fonts/Type1/"
        FontPath     "/usr/share/fonts/100dpi/"
        FontPath     "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
        Load  "dbe"
        Load  "glx"
        Load  "dri2"
        Load  "record"
        Load  "extmod"
        Load  "dri"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
 Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "ShadowFB"                  # [<bool>]
        #Option     "DefaultRefresh"            # [<bool>]
 #Option     "ModeSetClearScreen"        # [<bool>]
        Identifier  "Card0"
        Driver      "vesa"
        VendorName  "Microsoft Corporation"
        BoardName   "Unknown Board"
        BusID       "PCI:0:8:0"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes "10x800"
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     4
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     8
        EndSubSection
EndSection   



EDIT: Verlesen Version ist 1.7.7
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4468

PostPosted: Fri Sep 17, 2010 4:11 pm    Post subject: Reply with quote

Wenn du nur evdev als treiber für xorg installiert hast, wiso hast du dann den treiber kbd für das kayboard und mouse für die Mouse angegeben?
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
Hilzerak
n00b
n00b


Joined: 17 Sep 2010
Posts: 8

PostPosted: Fri Sep 17, 2010 6:33 pm    Post subject: Reply with quote

Die hab ich nicht angegeben die waren in der autogenerrierten .confg
Die Maus funktioniert ja auch wunderbar.
Nur die Tastatur eben überhauptnicht...
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3649
Location: Germany

PostPosted: Fri Sep 17, 2010 9:37 pm    Post subject: Reply with quote

Um was für ein Keyboard geht es denn genau, hast du Hersteller und Typ verfügbar?
Welche Input Driver sind tatsächlich installiert?, poste am besten die Ausgabe von
Code:
eix -Ic xf86-input

Und auch die /var/log/Xorg.0.log wäre hilfreich, um sie hier zu posten nutze aber bitte einen paste Service
zb
Code:
emerge -av wgetpaste (sofern noch nicht installiert)
dann ein
cat /var/log/Xorg.0.log | wgetpaste
und die ausgegebene URL hier im Forum bereitstellen
...
und auch die Ausgabe von
# /etc/init.d/hald status
Back to top
View user's profile Send private message
Treborius
Guru
Guru


Joined: 18 Oct 2005
Posts: 582
Location: Berlin

PostPosted: Sat Sep 18, 2010 6:44 am    Post subject: Reply with quote

versuch mal
Code:

Option      "XkbRules"  "xfree86"


in die xorg.conf einzufügen

die fehlermeldung
Code:

No Symbols named "xorg" in the include file "de"


deutet auf sowas hin

edit : hab kein linux zur hand, aber sollte in die keyboard input-device section
_________________
Systems running gentoo :
Desktop, Laptop, ZOTAC AD-10 media-center, odroid-xu4 server / wLan-router
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3649
Location: Germany

PostPosted: Sat Sep 18, 2010 10:28 am    Post subject: Reply with quote

Hilzerak wrote:
In der HAL habe ich es sowohl mit als auch ohne Policies für das Keyboard probiert, kein Unterschied.
Es wird ja vermutlich hotplugging via HAL genutzt? (ist zZt noch Standard)
Wenn dem so ist werden die Input Devices Settings der xorg.conf doch eh nicht genutzt! (sie könnten ganz entfernt werden)

Sprich, um dir hier weiterhelfen zu können werden weitere Infos benötigt.
Back to top
View user's profile Send private message
Hilzerak
n00b
n00b


Joined: 17 Sep 2010
Posts: 8

PostPosted: Mon Sep 20, 2010 7:14 am    Post subject: Reply with quote

Quote:
Um was für ein Keyboard geht es denn genau, hast du Hersteller und Typ verfügbar?
Welche Input Driver sind tatsächlich installiert?, poste am besten die Ausgabe von
Code:
eix -Ic xf86-input


Der Befehlt funktioniert leider nicht, Kommando nicht gefunden.


Quote:
versuch mal
Code:

Option "XkbRules" "xfree86"


Leider bleibt das Problem bestehen.



Quote:
Es wird ja vermutlich hotplugging via HAL genutzt? (ist zZt noch Standard)
Wenn dem so ist werden die Input Devices Settings der xorg.conf doch eh nicht genutzt! (sie könnten ganz entfernt werden)

Sprich, um dir hier weiterhelfen zu können werden weitere Infos benötigt.


Ich habe 3 Policys aktuell die was damit zu tun haben könnten: "10-xinput-configuration.fdi", "10-x11-input.fdi", "10-input-policy.fdi"
Hier mal die Policy "10-x11-input.fdi":
Code:
<?xml version="1.0" encoding="ISO-8859-1"?>
<deviceinfo version="0.2">
  <device>

    <!-- KVM emulates a USB graphics tablet which works in absolute coordinate $
    <match key="input.product" contains="QEMU USB Tablet">
       <merge key="input.x11_driver" type="string">evdev</merge>
    </match>

    <!-- FIXME: Support tablets too. -->
    <match key="info.capabilities" contains="input.mouse">
      <merge key="input.x11_driver" type="string">mouse</merge>
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
             string="Linux">
        <merge key="input.x11_driver" type="string">evdev</merge>
      </match>
    </match>

    <match key="info.capabilities" contains="input.tablet">
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
             string="Linux">
        <merge key="input.x11_driver" type="string">evdev</merge>
      </match>
    </match>

    <match key="info.capabilities" contains="input.touchpad">
      <merge key="input.x11_driver" type="string">mouse</merge>
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
             string="Linux">
        <merge key="input.x11_driver" type="string">evdev</merge>
      </match>
    </match>

    <match key="info.capabilities" contains="input.keys">
      <!-- If we're using Linux, we use evdev by default (falling back to
           keyboard otherwise). -->
      <merge key="input.x11_driver" type="string">keyboard</merge>
      <merge key="input.xkb.options" type="string">terminate:ctrl_alt_bksp</mer$
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
             string="Linux">
        <merge key="input.x11_driver" type="string">evdev</merge>
<merge key="input.xkb.rules" type="string">evdev</merge>
      <merge key="input.xkb.model" type="string">evdev</merge>
      <merge key="input.xkb.layout" type="string">de</merge>
          <merge key="input.xkb.variant" type="string">xorg</merge>
      </match>
    </match>
  </device>
</deviceinfo>




Ich habe auch mal den Befehl "hal-device /org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port_logicaldev_input"
ausgeführt hier mal die Auszüge:
Code:

udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port_logicaldev_input'
  input.xkb.options = 'terminate:ctrl_alt_bksp'  (string)
  linux.hotplug_type = 2  (0x2)  (int)
  linux.subsystem = 'input'  (string)
  input.originating_device = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port'  (string)
  input.x11_options.XkbLayout = 'ee'  (string)
  info.category = 'input'  (string)
  info.capabilities = { 'input', 'input.keyboard', 'input.keypad', 'input.keys', 'button' } (string list)
  info.subsystem = 'input'  (string)
  info.product = 'AT Translated Set 2 keyboard'  (string)
  linux.sysfs_path = '/sys/devices/platform/i8042/serio0/input/input1/event1'  (string)
  info.parent = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port'  (string)
  input.product = 'AT Translated Set 2 keyboard'  (string)
  info.udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port_logicaldev_input'  (string)
  input.device = '/dev/input/event1'  (string)
  linux.device_file = '/dev/input/event1'  (string)
  info.addons.singleton = { 'hald-addon-input' } (string list)
  input.xkb.rules = 'evdev'  (string)
  input.xkb.model = 'evdev'  (string)
  input.xkb.layout = 'de'  (string)
  input.xkb.variant = 'xorg'  (string)
  input.x11_driver = 'evdev'  (string)


EDIT: Der Status von HAL ist:
Code:
* Caching service dependencies ...                                       [ ok ]
 * status:  started
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3649
Location: Germany

PostPosted: Mon Sep 20, 2010 7:48 am    Post subject: Reply with quote

Hilzerak wrote:
Ich habe 3 Policys aktuell die was damit zu tun haben könnten: "10-xinput-configuration.fdi", "10-x11-input.fdi", "10-input-policy.fdi"
Das könnte vielleicht schon das Problem sein, eventuell hast du mehrere hal Policyes die sich gegenseitig widersprechen, dann funktioniert am Ende oftmals gar nichts mehr. Versuche es am besten erst mal ganz ohne hal Policy , dann sollte grundsätzliches idR erst mal funktionieren.
Magst du nicht noch deine Xorg.0.log nachreichen?
Back to top
View user's profile Send private message
Hilzerak
n00b
n00b


Joined: 17 Sep 2010
Posts: 8

PostPosted: Mon Sep 20, 2010 7:57 am    Post subject: Reply with quote

Lustigerweise scheint dies wirklich der Fall gewesen zu sein, denn als ich alle 3 gelöscht hatte geht die Tastatur plötzlich wieder :)
Nun hab ich noch das Problem mit dem Keylayout, welches die ganze Sache ja erst verursacht hatte.
Da ich nicht wieder ohne funktionierende Tastatur dastehen will, wo genau muss ich den was jetzt abändern?
Global habe ich alles schon "eingedeutscht" nur in der X-Session halt nicht.
Da ich jetzt ja keine Policy mehr habe in der ich das einrichten kann, muss ich nun doch wieder an die "xconf"?

Vielen Dank an alle!
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3649
Location: Germany

PostPosted: Mon Sep 20, 2010 8:19 am    Post subject: Reply with quote

Na prima

Erstelle dir am besten eine hal Policy in der du nur das angibst was gegenüber den default Settings geändert werden soll.

Versuche es mal mit diesem Beispiel:
/etc/hal/fdi/policy/10-x11-input.fdi
Code:
<?xml version="1.0" encoding="utf-8"?>
<deviceinfo version="0.2">
   <match key="info.capabilities" contains="input.keys">
     <merge key="input.x11_options.XkbRules" type="string">evdev</merge>
      <merge key="input.x11_options.XkbModel" type="string">evdev</merge>
       <merge key="input.x11_options.XkbLayout" type="string">de</merge>
        <merge key="input.x11_options.XkbVariant" type="string">nodeadkeys</merge>
         <merge key="input.xkb.options" type="string">terminate:ctrl_alt_bksp</merge>
   </match>
</deviceinfo>
Back to top
View user's profile Send private message
Hilzerak
n00b
n00b


Joined: 17 Sep 2010
Posts: 8

PostPosted: Mon Sep 20, 2010 8:26 am    Post subject: Reply with quote

Vielen Dank dafür!
Funktioniert super bis auf "äöü" etc.
Sollte das nicht die "nodeadkeys"-Option eigentlich ändern?
Wenn ja hat dies leider nicht geklappt.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3649
Location: Germany

PostPosted: Thu Sep 23, 2010 6:03 am    Post subject: Reply with quote

Hi

Hast du das mit den Umlauten inzwischen hinbekommen?
Und nein, an "nodeadkeys" sollte es nicht liegen, du könntest die Zeile mit der Option aber auch raus nehmen sofern "nodeadkeys" nicht gewünscht ist.

Magst du ansonsten ein wenig genauer beschreiben wo genau Umlaute nicht funktionieren?!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum