Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kdelibs-3.5.10 and openssl-1.0.0a-r3 [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
swann25
n00b
n00b


Joined: 04 Dec 2006
Posts: 50
Location: Bucharest, Romania

PostPosted: Thu Sep 30, 2010 8:42 am    Post subject: kdelibs-3.5.10 and openssl-1.0.0a-r3 [SOLVED] Reply with quote

Hi all.

Yesterday, after the upgrade of openssl, I've spent some long time trying to fix compilation of kdelibs-3.5.10 (I keep an old version of it, from kde-sunset overlay, because I need Amarok 1.4, the 2. version being very unpleasant for me).
Revdep-rebuild asked for kdelibs-3.5.10 to be rebuilded but compilation failed due to a dependency on the ASN1_METHOD which is deprecated; after spending some time on google, I've found that already exists a patch for this problem: kdelibs-3.5-openssl-1.0.0.patch.

These are the steps for applying the patch:
1) go to PORTDIR_OVERLAY/kde-sunset/kde-base/kdelibs dir (from make.conf)
e.g: /var/lib/layman/kde-sunset/kde-base/kdelibs
2) check in "files" dir if a file "*-openssl-1.0.0.patch" exists (if not, you should update the overlay: layman -S)
3) nano kdelibs-3.5.10-r6.ebuild
- add in "src_unpack()" function the following line:
epatch "${FILESDIR}/${PN}-3.5-openssl-1.0.0.patch"
4) run "ebuild kdelibs-3.5.10-r6.ebuild digest"
5) emerge kdelibs

I thought that is worth sharing, maybe somebody will run into this problem.
Back to top
View user's profile Send private message
tomk
Bodhisattva
Bodhisattva


Joined: 23 Sep 2003
Posts: 7221
Location: Sat in front of my computer

PostPosted: Thu Sep 30, 2010 10:02 am    Post subject: Reply with quote

Moved from Desktop Environments to Unsupported Software, topics related to overlay ebuilds belong in US.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
MurphyG
n00b
n00b


Joined: 19 Oct 2010
Posts: 16

PostPosted: Tue Oct 19, 2010 12:12 pm    Post subject: Re: kdelibs-3.5.10 and openssl-1.0.0a-r3 [SOLVED] Reply with quote

swann25 wrote:

Revdep-rebuild asked for kdelibs-3.5.10 to be rebuilded but compilation failed due to a dependency on the ASN1_METHOD which is deprecated; after spending some time on google, I've found that already exists a patch for this problem: kdelibs-3.5-openssl-1.0.0.patch.

Thanks for sharing, this helped me solve the same problem today. In the meanwhile there's a kdelibs-3.5.10-r10 ebuild, which already incorporates the patch; all I had to do was to un-keyword it.
Back to top
View user's profile Send private message
MurphyG
n00b
n00b


Joined: 19 Oct 2010
Posts: 16

PostPosted: Tue Oct 19, 2010 1:31 pm    Post subject: Re: kdelibs-3.5.10 and openssl-1.0.0a-r3 [SOLVED] Reply with quote

Addendum: The same applies to the kcontrol-3.5.10 ebuild; use -r1.
Back to top
View user's profile Send private message
IceSunrise
n00b
n00b


Joined: 03 Mar 2008
Posts: 24
Location: Russia, Saint-Petersburg

PostPosted: Fri Nov 19, 2010 9:55 am    Post subject: Reply with quote

Thanks a lot for your topic, it helps me!
Back to top
View user's profile Send private message
rafo
Apprentice
Apprentice


Joined: 18 Nov 2003
Posts: 161
Location: Sollentuna, Sweden

PostPosted: Sun Nov 21, 2010 10:38 am    Post subject: Reply with quote

Thanks indeed! I thought that pitch black darkness had fallen over my sunset KDE-3.5. Now it seems I can keep it alive a little longer. This is what it must be like to drive a vintage car.

Hoping to switch to Trinity in the future, http://www.gossamer-threads.com/lists/gentoo/desktop/218466
Back to top
View user's profile Send private message
IceSunrise
n00b
n00b


Joined: 03 Mar 2008
Posts: 24
Location: Russia, Saint-Petersburg

PostPosted: Fri Nov 26, 2010 2:16 pm    Post subject: Reply with quote

Sorry, I don't know if this is related problem or not, but after upgrading openssl to 1.0.0b in krusader and konqueror sftp client stop working. I just get the message "Error encountered while talking to ssh." and that's all. I even don't know, how I can debug this problem. There are no errors in the sshd log and everything works properly from the console. Can anyone help me?
Code:

ssh -V
OpenSSH_5.6p1, OpenSSL 1.0.0b 16 Nov 2010


I've tried to restart kde session and sshd daemon but it didn't help. I'm going to restart the whole computer this evening, but this is windows way :)
Back to top
View user's profile Send private message
rafo
Apprentice
Apprentice


Joined: 18 Nov 2003
Posts: 161
Location: Sollentuna, Sweden

PostPosted: Mon Nov 29, 2010 2:50 pm    Post subject: Reply with quote

I may have the same problem in my kde-sunset environment. First of all, OpenSSH is basically in fine shape and I can do command-line sftp.

Also FileZilla is sftp capable.

In Konqueror, when I type an URL of the form 'sftp://HOST/', I get a popup "Error encountered while talking to ssh. [OK]".

Version info:

# equery list konqueror
[ Searching for package 'konqueror' in all categories among: ]
* installed packages
[I--] [ ] kde-base/konqueror-3.5.10 (3.5)
# equery list openssl
[ Searching for package 'openssl' in all categories among: ]
* installed packages
[I--] [ ] dev-libs/openssl-0.9.8o-r2 (0.9.8)
[I--] [ ] dev-libs/openssl-1.0.0b-r1 (0)
[I--] [ ] dev-python/pyopenssl-0.10-r1 (0)
# equery list openssh
[ Searching for package 'openssh' in all categories among: ]
* installed packages
[I--] [ ] net-misc/openssh-5.6_p1-r2 (0)
Back to top
View user's profile Send private message
Liphtier
n00b
n00b


Joined: 12 Nov 2007
Posts: 13

PostPosted: Mon Sep 19, 2011 11:02 am    Post subject: Reply with quote

Hi!

Emerged the patched kdelibs - still can't use sftp in konqueror and quanta

The message displayed is "Error encountered while talking to ssh"
When running konqueror from konsole, the actual error seen is :
Code:
kio_sftp: ERROR: KSshProcess::version(): pclose failed

Code:

equery list kdelibs konqueror openssl openssh
 * Searching for kdelibs ...
[I-O] [  ] kde-base/kdelibs-3.5.10-r10:3.5
[IP-] [  ] kde-base/kdelibs-4.6.5-r1:4

 * Searching for konqueror ...
[I-O] [  ] kde-base/konqueror-3.5.10:3.5
[IP-] [  ] kde-base/konqueror-4.6.5:4

 * Searching for openssl ...
[IP-] [  ] dev-libs/openssl-1.0.0e:0

 * Searching for openssh ...
[IP-] [  ] net-misc/openssh-5.8_p1-r1:0


I saw during emerge that the kdelibs-3.5-openssl-1.0.0.patch is applied - and doesn't help.

Does this problem still have a solution?

BTW, as the workaround I use sshfs to mount the remote fs as local, but it is quite not a comfortable way, especially when I have to deal with multiple hosts
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum