Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Trying to compile Handbrake again, where is aclocal?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Tactical Fart
n00b
n00b


Joined: 27 Aug 2007
Posts: 37

PostPosted: Fri Oct 01, 2010 12:41 am    Post subject: Trying to compile Handbrake again, where is aclocal? Reply with quote

I'm trying to compile HandBrake again. A little more than year I showed a few simple commands that would emerge what's needed and then checkout the subversion and compile it and all of the good stuff. But now I get a compile error when I try to build it. Here's the output from the compile logs.
Code:

time begin: Thu Sep 30 00:13:01 2010
launch: /usr/bin/gmake -j1
/bin/mkdir -p libhb
/usr/bin/m4 -Iproject ../libhb/project.h.m4 > libhb/project.h
/bin/cp ../libhb/common.h libhb/common.h
/bin/cp ../libhb/deccc608sub.h libhb/deccc608sub.h
/bin/cp ../libhb/downmix.h libhb/downmix.h
/bin/cp ../libhb/dvd.h libhb/dvd.h
/bin/cp ../libhb/eedi2.h libhb/eedi2.h
/bin/cp ../libhb/hb.h libhb/hb.h
/bin/cp ../libhb/hbffmpeg.h libhb/hbffmpeg.h
/bin/cp ../libhb/internal.h libhb/internal.h
/bin/cp ../libhb/lang.h libhb/lang.h
/bin/cp ../libhb/ports.h libhb/ports.h
/bin/mkdir -p ../download
/usr/bin/wget -O ../download/a52dec-0.7.4.tar.gz http://download.m0k.org/handbrake/contrib/a52dec-0.7.4.tar.gz
--2010-09-30 00:13:01--  http://download.m0k.org/handbrake/contrib/a52dec-0.7.4.tar.gz
Resolving download.m0k.org... 88.191.20.206
Connecting to download.m0k.org|88.191.20.206|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 242978 (237K) [application/octet-stream]
Saving to: `../download/a52dec-0.7.4.tar.gz'

     0K .......... .......... .......... .......... .......... 21% 72.6K 3s
    50K .......... .......... .......... .......... .......... 42%  250K 1s
   100K .......... .......... .......... .......... .......... 63%  362K 1s
   150K .......... .......... .......... .......... .......... 84%  125K 0s
   200K .......... .......... .......... .......              100% 1.63M=1.4s

2010-09-30 00:13:03 (164 KB/s) - `../download/a52dec-0.7.4.tar.gz' saved [242978/242978]

/bin/mkdir -p contrib/a52dec
/bin/rm -fr ./contrib/a52dec/a52dec/
/bin/tar xfC ../download/a52dec-0.7.4.tar.gz ./contrib/a52dec/
touch contrib/a52dec/.stamp.extract
/usr/bin/patch -t -N -p1 -d ./contrib/a52dec/a52dec/ < ../contrib/a52dec/A00-dpl2.patch
patching file include/a52.h
patching file liba52/a52_internal.h
patching file liba52/downmix.c
touch contrib/a52dec/.stamp.patch
set -e; cd ./contrib/a52dec/a52dec/; rm -fr aclocal.m4 autom4te.cache; autoreconf -fiv; CC=/usr/bin/gcc CFLAGS="" CXX=/usr/bin/g++ CXXFLAGS="" CPPFLAGS="" LDFLAGS="" ./configure --prefix=/home/tactical/hb-trunk/build/contrib/ --disable-dependency-tracking --disable-shared --enable-static
autoreconf-2.65: Entering directory `.'
autoreconf-2.65: configure.in: not using Gettext
autoreconf-2.65: running: aclocal  --output=aclocal.m4t
am-wrapper: /usr/bin/aclocal-1.4 is missing or not executable.
            Please try emerging the correct version of automake.
autoreconf-2.65: aclocal failed with exit status: 1
gmake: *** [contrib/a52dec/.stamp.configure] Error 1
time end: Thu Sep 30 00:13:04 2010
duration: 3 seconds (3.31s)
result: FAILURE (code 2)

When I asked for help, JohnAStebbins over at HandBrake's forums said the error is in the following two lines.
Code:
am-wrapper: /usr/bin/aclocal-1.4 is missing or not executable.
            Please try emerging the correct version of automake.


When I checked /usr/bin, the only aclocal files I could see are @aclocal, aclocal-1.10, and aclocal-1.11. There are no ebuilds for aclocal, and everything is up to date. What did I screw up this time?
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Oct 01, 2010 12:48 am    Post subject: Reply with quote

try the live-ebuild:

https://bugs.gentoo.org/show_bug.cgi?id=89432
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
slackline
Veteran
Veteran


Joined: 01 Apr 2005
Posts: 1422
Location: /uk/sheffield

PostPosted: Sun Oct 03, 2010 7:58 pm    Post subject: Reply with quote

Live ebuild has the same problem, still looking for aclocal-1.4
_________________
"Science is what we understand well enough to explain to a computer.  Art is everything else we do." - Donald Knuth
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Mon Oct 04, 2010 10:43 am    Post subject: Reply with quote

Quote:
Please try emerging the correct version of automake.

Code:
emerge -av1 automake:1.4
should do it.
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum