Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
fbiocondecor_setstate failed, errorcode 22 auf amd64
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
mvaterlaus
Apprentice
Apprentice


Joined: 01 Oct 2010
Posts: 202
Location: Switzerland

PostPosted: Fri Oct 01, 2010 3:50 pm    Post subject: fbiocondecor_setstate failed, errorcode 22 auf amd64 Reply with quote

Hi,
ich hab ein Problem mit fbcondecor. Ich möchte ein bootsplash einrichten mit dem theme natural_gentoo und
der Auflösung 1440x900-32. Leider erhalte ich folgende Fehlermeldung:
Code:

fbiocondecor_setstate failed errorcode 22.

Wenn ich mit diesem initramfs boote, habe ich weder die eyecandies noch eine gute Auflösung (meist 320x200).

Mein System:
lenovo thinkpad t510 64-bit
nvidia nvs 3100M
Ich verwende die amd64 Architektur


Folgende sachen sind installiert/konfiguriert

v86d 0.1.9 USE=x86emu
splashutils 1.5.4.3-r3 USE=fbcondecor png truetype
kernel gentoo-sources 2.6.34-r6
nvidia-drivers 195.36.31


Kernel options
Code:

General Setup
   - Initial Ram filesystem and Ram disk support
   - (/usr/share/v86d/initramfs) initramfs source files
Device Drivers
   - connector - unified userspace <--> kernelspace linker
   --> graphics support
      - direct rendering manager
      - userspace vesa vga graphics support
      --> support for frame buffer devices
         - enable firmware EDID
      -->console display driver support
         - framebuffer console support
         - support for the framebuffer console decorations
      


Meine grub.conf:
Code:

kernel /boot/kernel-2.6.34-r6 root=/dev/sda6 video=uvesafb:1440x900-32,mtrr:3,ywrap splash=verbose,theme:natural_gentoo CONSOLE=/dev/tty1
initrd (hd0,2)/boot/bootsplash

Das fbcondecor script ist dem runlevel boot zugeteilt.

Im grunde hab ich alles nach folgenden Anleitungen gemacht:

http://en.gentoo-wiki.com/wiki/Fbsplash
http://dev.gentoo.org/~spock/projects/uvesafb/
http://www.gentoo.org/doc/de/nvidia-guide.xml
http://fbsplash.berlios.de/wiki/doku.php?id=docs:distros:gentoo

Ich komm im moment einfach nicht dahinter, wieso das nicht funktioniert. Und mit einer Auflösung von 320x200 X zu
installieren ist irgendwie mühsam. Ich hoffe, ihr könnt mir weiter helfen.

grüsse
mathias
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2042
Location: My own world! I and Gentoo!

PostPosted: Fri Oct 01, 2010 4:43 pm    Post subject: Reply with quote

Probiers erstmal ohne splash, arbeite nur mit dem framebuffer.
Denn der fbcondecor (fbsplash) kann nicht arbeiten wenn die Auflösung nicht sauber gesetzt wurde.

Dein Fehler in der video-zeile ist allerdings "mttr", du hast mtrr eingetrangen, das ist falsch ;)
Code:
video=uvesafb:1440x900-32@60,mttr:3,ywrap


Dann müsste es auch so klappen.
_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic
Back to top
View user's profile Send private message
ScytheMan
l33t
l33t


Joined: 30 Nov 2005
Posts: 605

PostPosted: Fri Oct 01, 2010 5:44 pm    Post subject: Reply with quote

imho ist mtrr korrekt.
http://en.gentoo-wiki.com/wiki/Framebuffer

mit video=uvesafb:1400x1050-32@60 bootet mein kernel.


jedoch kann uvesafb kein widescreen, probiermal eine andere auflösung aus.
Back to top
View user's profile Send private message
mvaterlaus
Apprentice
Apprentice


Joined: 01 Oct 2010
Posts: 202
Location: Switzerland

PostPosted: Fri Oct 01, 2010 6:02 pm    Post subject: Reply with quote

ja, mtrr ist korrekt. es lag an der widescreen auflösung. mit 1024x768 läufts.
danke für die schnellen antworten.

mfg
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2042
Location: My own world! I and Gentoo!

PostPosted: Fri Oct 01, 2010 6:10 pm    Post subject: Reply with quote

Hmmm okay, mein Fehler.
_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3627
Location: Germany

PostPosted: Fri Oct 01, 2010 6:14 pm    Post subject: Reply with quote

Die von deiner Grafikkarte unterstützten Auflösungen und Farbtiefen kannst du auch unter
Code:
cat /sys/bus/platform/drivers/uvesafb/uvesafb.0/vbe_modes
einsehen.
Back to top
View user's profile Send private message
mvaterlaus
Apprentice
Apprentice


Joined: 01 Oct 2010
Posts: 202
Location: Switzerland

PostPosted: Sat Oct 02, 2010 11:25 am    Post subject: Reply with quote

hi josef.95
danke für den tipp mit den auflösungen. ich hab nun entdeckt, dass uvesafb doch
einige widescreen formate unterstützt und verwende nun 1280x800-32.

grüsse
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum