Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Update von openssl lässt NXserver aussteigen
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
wuesti
Apprentice
Apprentice


Joined: 07 Mar 2009
Posts: 191

PostPosted: Tue Oct 05, 2010 4:16 pm    Post subject: [solved] Update von openssl lässt NXserver aussteigen Reply with quote

Moin!

Nach dem letzten Update von openssl funktioniert der sonst zuverlässig laufende nxserver-freeedition nicht mehr.

Installiert sind:
net-misc/nxserver-freeedition-3.4.0.8
dev-libs/openssl-0.9.8o-r2 (Abhängikeit von nxserver-freeedition)
und
dev-libs/openssl-1.0.0a-r3 (letztes Update)

Der Start erfolgt fehlerfrei (Statistik ist nicht installiert):
Code:
# /etc/init.d/nxserver start
 * Starting nxserver ...
NX> 122 Service started.
NX> 999 Bye.
NX> 723 Cannot start NX statistics:
NX> 709 NX statistics are disabled for this server.
NX> 999 Bye.   


Beim Verbinden mit nxclient erscheint folgende Fehlermeldung unter Details:
Code:
NX> 203 NXSSH running with pid: 13287
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 285 Setting the preferred NX options
NX> 200 Connected to address: 127.0.0.1 on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
NX> 204 Authentication failed.


Auch beim erhöhten Loglevel erscheint keine Fehlermeldung in /var/log/messages

-> Es erscheint mir ein Problem mit den Keys zu sein, weil der User nx schon von ssh abgelehnt wird.

Kann jemand helfen?


Last edited by wuesti on Tue Oct 05, 2010 5:43 pm; edited 1 time in total
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Tue Oct 05, 2010 4:26 pm    Post subject: Reply with quote

Was ist, wenn du einen neuen Key erstellen lässt?
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4459

PostPosted: Tue Oct 05, 2010 4:30 pm    Post subject: Reply with quote

da openssl-0.9.x und openssl-1.x in verschiedene slots installiert werden kann, kannst du einfach die 0.9.8 version separat installieren.
Eigentlich sollte hier ein revdep-rebuild oder eine reinstallation von nxclient (welche die openssl anhängikeit hat) das problem behebn.
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
wuesti
Apprentice
Apprentice


Joined: 07 Mar 2009
Posts: 191

PostPosted: Tue Oct 05, 2010 4:31 pm    Post subject: Reply with quote

Code:
/usr/NX/scripts/setup/nxserver --keygen
NX> 704 Starting: server-keygen operation at: Di Okt 05 18:28:58 2010.
NX> 704 Generating new ssh-keys. Please wait.
NX> 704 Keys generated correctly. Backing up files.
NX> 704 Back up of keys made. Updating files.
NX> 704 Keys updated. NX clients should now use key:
NX> 704 /usr/NX/share/keys/default.id_dsa.key
NX> 704 to get connected to this NX server.


Beim Anmelden gibt es die gleiche Fehlermeldung.
Back to top
View user's profile Send private message
wuesti
Apprentice
Apprentice


Joined: 07 Mar 2009
Posts: 191

PostPosted: Tue Oct 05, 2010 4:43 pm    Post subject: Reply with quote

firefly wrote:
da openssl-0.9.x und openssl-1.x in verschiedene slots installiert werden kann, kannst du einfach die 0.9.8 version separat installieren.
Eigentlich sollte hier ein revdep-rebuild oder eine reinstallation von nxclient (welche die openssl anhängikeit hat) das problem behebn.

Beide Versionen sind installiert. revdep-rebuild hat viele ebuilds gefunden, die erneuert werden mussten.
Back to top
View user's profile Send private message
Yamakuzure
Advocate
Advocate


Joined: 21 Jun 2006
Posts: 2273
Location: Bardowick, Germany

PostPosted: Tue Oct 05, 2010 4:55 pm    Post subject: Reply with quote

Am ende des openssl Updates steht:
Code:
>>> Original instance of package unmerged safely.
 * Running 'c_rehash /etc/ssl/certs/' to rebuild hashes #333069 ...
 [ ok ]
 * Old versions of installed libraries were detected on your system.
 * In order to avoid breaking packages that depend on these old libs,
 * the libraries are not being removed.  You need to run revdep-rebuild
 * in order to remove these old dependencies.  If you do not have this
 * helper program, simply emerge the 'gentoolkit' package.
 *
 *   # revdep-rebuild --library libcrypto.so.0.9.8
 *   # revdep-rebuild --library libssl.so.0.9.8
 *
 * Once you've finished running revdep-rebuild, it should be safe to
 * delete the old libraries.  Here is a copy & paste for the lazy:
 *   # rm '/usr/lib64/libcrypto.so.0.9.8'
 *   # rm '/usr/lib64/libssl.so.0.9.8'
>>> Regenerating /etc/ld.so.cache...
... könnte das der Grund sein?

Edith jammert: Mist, zu langsam!
_________________
Important German:
  1. "Aha" - German reaction to pretend that you are really interested while giving no f*ck.
  2. "Tja" - German reaction to the apocalypse, nuclear war, an alien invasion or no bread in the house.
Back to top
View user's profile Send private message
wuesti
Apprentice
Apprentice


Joined: 07 Mar 2009
Posts: 191

PostPosted: Tue Oct 05, 2010 5:01 pm    Post subject: Reply with quote

Yamakuzure wrote:
Am ende des openssl Updates steht:
Code:
>>> Original instance of package unmerged safely.
 * Running 'c_rehash /etc/ssl/certs/' to rebuild hashes #333069 ...
 [ ok ]
 * Old versions of installed libraries were detected on your system.
 * In order to avoid breaking packages that depend on these old libs,
 * the libraries are not being removed.  You need to run revdep-rebuild
 * in order to remove these old dependencies.  If you do not have this
 * helper program, simply emerge the 'gentoolkit' package.
 *
 *   # revdep-rebuild --library libcrypto.so.0.9.8
 *   # revdep-rebuild --library libssl.so.0.9.8
 *
 * Once you've finished running revdep-rebuild, it should be safe to
 * delete the old libraries.  Here is a copy & paste for the lazy:
 *   # rm '/usr/lib64/libcrypto.so.0.9.8'
 *   # rm '/usr/lib64/libssl.so.0.9.8'
>>> Regenerating /etc/ld.so.cache...
... könnte das der Grund sein?


Das ist so gewesen, habe mich daran gehalten und damit eine Lawine von Neuinstallationen und mehreren revdep-rebuilds ausgelöst. Die fehlende Funktion von nxserver habe ich aber heute erst erkannt.
Back to top
View user's profile Send private message
wuesti
Apprentice
Apprentice


Joined: 07 Mar 2009
Posts: 191

PostPosted: Tue Oct 05, 2010 5:19 pm    Post subject: Reply with quote

Kleines Experiment:
Code:
nxssh username@localhost
Password:
Last login: Tue Oct  5 18:00:19 CEST 2010 from computername.local on pts/2

Code:
nxssh nx@localhost
Password:
Password:
Password:
Permission denied (publickey,keyboard-interactive).
Back to top
View user's profile Send private message
wuesti
Apprentice
Apprentice


Joined: 07 Mar 2009
Posts: 191

PostPosted: Tue Oct 05, 2010 5:41 pm    Post subject: Reply with quote

Umgekehrt wird ein Schuh daraus. Keine neuen Keys generieren sondern:
Code:
/usr/NX/bin/nxserver --keyrestore

Das habe ich aus http://www.nomachine.com/ar/view.php?ar_id=AR01C00126

Nun funktioniert es.

Vielen Dank für die Hilfe!
wuesti
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum