Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] python-updater failed
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Gladdle
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 268
Location: Cleebronn, Germany

PostPosted: Wed Oct 13, 2010 12:24 pm    Post subject: [solved] python-updater failed Reply with quote

Ich habe versucht meinen alten Server wieder online zu bekommen, der drei Jahre brach lag. Leider habe ich ein Problem bei python-updater. Per eselect python habe ich schon die aktuellste Version ausgesucht (Stable x86, also32Bit version):
Code:
Avialble Python interpreters:
[1]  python2.7
[2]  python 3.1 *


Doch jedes mal bei python-updater kommt folgender Fehler:
Code:
 * Starting Python Updater...
 * Main active version of Python:  3.1
 * Active version of Python 2:     2.7
 * Active version of Python 3:     3.1
 *   Adding to list: app-admin/webapp-config:0
 *   Adding to list: app-office/openoffice-bin:0
 *   Adding to list: app-office/openoffice-bin:0
 *   Adding to list: app-portage/mirrorselect:0
 *   Adding to list: dev-java/antlr:0
 *   Adding to list: dev-java/javatoolkit:0
 *   Adding to list: dev-libs/boost:1.41
 *     check: manual [Added to list manually, see CHECKS in manpage for more information.]
 *   Adding to list: dev-libs/libxml2:2
 *   Adding to list: dev-libs/libxslt:0
 *   Adding to list: dev-python/gst-python:0.10
 *   Adding to list: dev-python/pygobject:2
 *   Adding to list: dev-python/pygtksourceview:2
 *   Adding to list: dev-python/pyopengl:0
 *   Adding to list: dev-util/scons:0
 *   Adding to list: dev-vcs/git:0
 *   Adding to list: gnome-extra/libgsf:0
 *   Adding to list: media-gfx/blender:0
 *   Adding to list: media-libs/alsa-lib:0
 *   Adding to list: media-libs/lcms:0
 *   Adding to list: net-analyzer/net-snmp:0
 *   Adding to list: net-irc/xchat:2
 *   Adding to list: net-libs/farsight2:0

bzip2: Compressed file ends unexpectedly;
    perhaps it is corrupted?  *Possible* reason follows.
bzip2: Success
    Input file = /var/db/pkg/sys-apps/file-5.03/environment.bz2, output file = (stdout)

It is possible that the compressed file(s) have become corrupted.
You can use the -tvv option to test integrity of such files.

You can use the `bzip2recover' program to attempt to recover
data from undamaged sections of corrupted files.


bzip2: Compressed file ends unexpectedly;
    perhaps it is corrupted?  *Possible* reason follows.
bzip2: Success
    Input file = /var/db/pkg/sys-apps/file-5.03/environment.bz2, output file = (stdout)

It is possible that the compressed file(s) have become corrupted.
You can use the -tvv option to test integrity of such files.

You can use the `bzip2recover' program to attempt to recover
data from undamaged sections of corrupted files.

 * PVR missing


Hat jemand eine Ahnung was das sein kann? emerge laeufft wegen ein paar python problemen nimmer durch. Ist leider nicht die make.conf, etc. in meiner Signatur, wenn diese gebraucht wird bitte melden.
_________________
Meine Gentoo Linux Konfiguration: Notebook (ACER Aspire 9920G)


Last edited by Gladdle on Wed Oct 13, 2010 12:39 pm; edited 1 time in total
Back to top
View user's profile Send private message
Gladdle
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 268
Location: Cleebronn, Germany

PostPosted: Wed Oct 13, 2010 12:38 pm    Post subject: Reply with quote

Okay, folgendes gilt auch fuer mich:
http://www.gidf.de/googleistdeinfreund.png

Ich habe hier die Loesung gefunden und angepasst:
Code:
rm /var/db/pkg/sys-apps/file-5.03/environment.bz2
emerge --oneshot sys-apps/file
python-updater

_________________
Meine Gentoo Linux Konfiguration: Notebook (ACER Aspire 9920G)
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3631
Location: Germany

PostPosted: Wed Oct 13, 2010 1:34 pm    Post subject: Reply with quote

Gladdle wrote:
Per eselect python habe ich schon die aktuellste Version ausgesucht (Stable x86, also32Bit version):
Code:
Avialble Python interpreters:
[1]  python2.7
[2]  python 3.1 *

Aktuell wird eigentlich noch von abgeraten die main active Version schon auf python3.1 zu setzen.
Siehe zb auch in den News zu Python 3.1
Code:
eselect news list
eselect news read [N]
Back to top
View user's profile Send private message
Gladdle
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 268
Location: Cleebronn, Germany

PostPosted: Thu Oct 14, 2010 12:31 pm    Post subject: Reply with quote

Downgegraded, python-updater erneut gestartet und das System laeufft super, keine probleme mehr, Danke :)
_________________
Meine Gentoo Linux Konfiguration: Notebook (ACER Aspire 9920G)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum