Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Anti-aliasing in OO seems gone after system upgrade
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
philip
Guru
Guru


Joined: 10 Jun 2003
Posts: 535
Location: Sweden

PostPosted: Wed Oct 20, 2010 6:20 pm    Post subject: [Solved] Anti-aliasing in OO seems gone after system upgrade Reply with quote

After emerge -uDN world, my smooth fonts in OpenOffice are gone. Fonts are jagged and ugly. This goes especially for Luxi Sans that I have used in the past.

OO --> Tools --> Options --> Openoffice.org --> View --> "Screen font antialiasing" is on (box checked) at 1 pixel (turning this off makes the fonts even worse).

In /etc/X11/xorg.conf I have
(but I do not think this matters - all other applications show nice fonts)

Code:
# Multiple FontPath entries are allowed (which are concatenated together),
# as well as specifying multiple comma-separated entries in one FontPath
# command (or a combination of both methods)
#
#
    Fontpath   "/usr/share/fonts/default/ghostscript/"
    FontPath   "/usr/share/fonts/misc/"
    FontPath   "/usr/share/fonts/TTF/"
    FontPath   "/usr/share/fonts/Type1/"
    FontPath   "/usr/share/fonts/CID/"
    FontPath   "/usr/share/fonts/75dpi/"
    FontPath   "/usr/share/fonts/100dpi/"
    FontPath   "/usr/share/fonts/local/"
    FontPath   "/usr/share/fonts/arphicfonts/"
    FontPath   "/usr/share/fonts/baekmuk/"
    FontPath   "/usr/share/fonts/baekmuk-fonts/"
    FontPath   "/usr/share/fonts/corefonts/"
    FontPath   "/usr/share/fonts/cronyx/"
    FontPath   "/usr/share/fonts/cyrillic/"
    FontPath   "/usr/share/fonts/default/"
    FontPath   "/usr/share/fonts/encodings/"
    FontPath   "/usr/share/fonts/freefont/"
    FontPath   "/usr/share/fonts/freefonts/"
    FontPath   "/usr/share/fonts/intlfonts/"
    FontPath   "/usr/share/fonts/kochi-substitute/"
    FontPath   "/usr/share/fonts/OTF/"
    FontPath   "/usr/share/fonts/Speedo/"
    FontPath   "/usr/share/fonts/terminus/"
    FontPath   "/usr/share/fonts/ttf/"
    FontPath   "/usr/share/fonts/ttf-bitstream-vera/"
    FontPath   "/usr/share/fonts/ukr/"
    FontPath   "/usr/share/fonts/util/"


Has anyone experienced the same thing? Any cure?
_________________
/Phil


Last edited by philip on Tue Oct 26, 2010 6:02 pm; edited 1 time in total
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Sun Oct 24, 2010 2:15 am    Post subject: Reply with quote

Maybe your system-wide font antialiasing settings in /etc/fonts are off.
Back to top
View user's profile Send private message
philip
Guru
Guru


Joined: 10 Jun 2003
Posts: 535
Location: Sweden

PostPosted: Sun Oct 24, 2010 10:07 pm    Post subject: Reply with quote

How can I check that?
_________________
/Phil
Back to top
View user's profile Send private message
gqman69
n00b
n00b


Joined: 11 Jul 2007
Posts: 50

PostPosted: Mon Oct 25, 2010 4:36 pm    Post subject: Reply with quote

eselect fontconfig list
Back to top
View user's profile Send private message
philip
Guru
Guru


Joined: 10 Jun 2003
Posts: 535
Location: Sweden

PostPosted: Mon Oct 25, 2010 6:47 pm    Post subject: Reply with quote

This is what I get:

Code:
# eselect fontconfig list
Available fontconfig .conf files  ( * is enabled ):
  [1]   10-autohint.conf
  [2]   10-no-sub-pixel.conf
  [3]   10-sub-pixel-bgr.conf
  [4]   10-sub-pixel-rgb.conf
  [5]   10-sub-pixel-vbgr.conf
  [6]   10-sub-pixel-vrgb.conf
  [7]   10-unhinted.conf
  [8]   20-fix-globaladvance.conf *
  [9]   20-unhint-small-dejavu-sans.conf
  [10]  20-unhint-small-dejavu-sans-mono.conf
  [11]  20-unhint-small-dejavu-serif.conf
  [12]  20-unhint-small-vera.conf *
  [13]  25-ttf-arphic-ukai-render.conf
  [14]  25-ttf-arphic-uming-bitmaps.conf
  [15]  25-ttf-arphic-uming-render.conf
  [16]  25-unhint-nonlatin.conf
  [17]  30-metric-aliases.conf *
  [18]  30-urw-aliases.conf *
  [19]  35-ttf-arphic-ukai-aliases.conf
  [20]  35-ttf-arphic-uming-aliases.conf
  [21]  40-nonlatin.conf *
  [22]  41-ttf-arphic-ukai.conf
  [23]  41-ttf-arphic-uming.conf
  [24]  45-latin.conf *
  [25]  49-sansserif.conf *
  [26]  50-user.conf *
  [27]  51-local.conf *
  [28]  57-dejavu-sans.conf
  [29]  57-dejavu-sans-mono.conf
  [30]  57-dejavu-serif.conf
  [31]  60-latin.conf *
  [32]  64-ttf-arphic-uming.conf
  [33]  65-fonts-persian.conf *
  [34]  65-khmer.conf
  [35]  65-nonlatin.conf *
  [36]  69-unifont.conf *
  [37]  70-no-bitmaps.conf
  [38]  70-yes-bitmaps.conf
  [39]  75-ttf-arphic-ukai-select.conf
  [40]  80-delicious.conf *
  [41]  90-synthetic.conf *
  [42]  90-ttf-arphic-ukai-embolden.conf
  [43]  90-ttf-arphic-uming-embolden.conf


I am not acquainted with eselect fontconfig and
# eselect fontconfig help
did not reveal much.

I presume a "star" means that the feature is selected?

What is recommended to select or de-selct to get good font graphics performance?
_________________
/Phil
Back to top
View user's profile Send private message
philip
Guru
Guru


Joined: 10 Jun 2003
Posts: 535
Location: Sweden

PostPosted: Tue Oct 26, 2010 3:04 pm    Post subject: Reply with quote

I followed this advice: http://www.kev009.com/wp/2009/12/getting-beautiful-fonts-in-gentoo-linux/

I discovered I had not set the follwing USE flags type1 cleartype corefonts and I did so by:

# euse --enable type1 cleartype corefonts

When I came to the step of rebuilding packages with emerge -uDNa world, my system indicated that x11-libs/cairo needed to be re-built. After doing this the fonts in Openoffice improved radically, especially the Luxi Sans that I have had problems with.
_________________
/Phil
Back to top
View user's profile Send private message
gqman69
n00b
n00b


Joined: 11 Jul 2007
Posts: 50

PostPosted: Sat Oct 30, 2010 10:48 pm    Post subject: Reply with quote

I also have a local.conf in /etc/fonts

Code:


<?xml version="1.0"?>

<!DOCTYPE fontconfig SYSTEM "fonts.dtd">

<fontconfig>

    <match target="font">
        <edit name="autohint" mode="assign"><bool>true</bool></edit>
        <edit name="hinting" mode="assign"><bool>true</bool></edit>
        <edit name="hintstyle" mode="assign"><const>hintfull</const></edit>
        <edit name="rgba" mode="assign"><const>rgb</const></edit>
        <edit mode="assign" name="antialias"><bool>true</bool></edit>
        <edit mode="assign" name="lcdfilter">
            <const>lcddefault</const>
        </edit>
    </match>

    <match target="font">
        <test name="weight" compare="more"><const>medium</const></test>
        <edit name="autohint" mode="assign"><bool>false</bool></edit>
    </match>

</fontconfig>



Gives me sharp looking fonts.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum