Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE unterdrückt Helligkeitseinstellung des Laptop-LCDs
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
attix
n00b
n00b


Joined: 24 Jan 2008
Posts: 37

PostPosted: Sun Oct 24, 2010 11:42 am    Post subject: KDE unterdrückt Helligkeitseinstellung des Laptop-LCDs Reply with quote

Hallo,

ich hab wahrscheinlich nur ein kleineres Problem, allerdings bekomm ich es allein dennoch nicht ans Fliegen. Hab Gentoo auf meinem nagelneuen Lenovo G560 installiert und eigentlich funktioniert auch alles wunderbar. Sämtliche Fn-Tasten tun ihren Dienst... bis auf die Helligkeitsregulierung des Displays. Es ist nun aber auch nicht so, dass sie überhaupt nicht funktionieren würde. Sie funktioniert solange, bis ich mich in KDE (4.4.) eingeloggt habe und alle Dienste usw. gestartet wurden. Ab diesem Moment verhindert irgendein Dienst oder sonstwas seitens KDE die Helligkeitsregulierung des Displays. Es ist zum verrückt werden...


Vielen Dank schonmal,

attix
Back to top
View user's profile Send private message
bas89
Apprentice
Apprentice


Joined: 02 Mar 2010
Posts: 243
Location: Germany ;)

PostPosted: Sun Oct 24, 2010 12:41 pm    Post subject: Reply with quote

Probier mal, die Thinkpad-Einträge in den Systemeinstellungen, Tastatureinstellungen zu benutzen. Wenn das nichts bringt, funktioniert eigentlich der Regler in Powerdevil (Die Batterie in der „Taskleiste“) zur Helligkeitsregulierung?
Versuch in den Globalen Kurzbefehlen in den Systemeinstellungen unter „KDE-Dienst“ neue Shortcuts für die Helligkeit zu vergeben.

Btw: Hier mit einem Dell Inspiron klappt alles ootb.
Back to top
View user's profile Send private message
Hollowman
Guru
Guru


Joined: 19 Apr 2007
Posts: 584

PostPosted: Sun Oct 24, 2010 1:11 pm    Post subject: Reply with quote

Hallo

Hast du Powerdevil überhaupt installiert? Das sollte in KDE super gehen. Der macht bei nichtbenutzung dunkel und wenn du dann die Maus bewegst macht er wieder hell.

Sebastian
Back to top
View user's profile Send private message
attix
n00b
n00b


Joined: 24 Jan 2008
Posts: 37

PostPosted: Sun Oct 24, 2010 1:40 pm    Post subject: Reply with quote

Hallo,

schonmal vielen Dank für Eure Mühe.
Das Ändern der Tastatureinstellungen bringt leider überhaupt nichts. Der Regler der Batterieanzeige zeigt auch keinerlei Funktion... bzw. eventuell, während KDE noch startet, das kann ich aber leider nicht testen. In dem Augenblick, in dem das Applet zur Akkuüberwachung benutzbar ist, ist die Helligkeit des Displays leider schon nicht mehr regelbar. Aber nochmal :

Es funktioniert grundsätzlich! Lasse ich das System nur bis zum Loginscreen von KDE hochfahren, funktioniert alles wunderbar... AUCH die Regulierung der Displayhelligkeit. Logge ich mich ein, lässt sich die Helligkeit noch ein paar Sekunden weiter regulieren... wenn KDE dann aber "vollständig gestartet" ist, lässt sie sich urplötzlich nicht mehr regulieren. Weder über die Funktionstaste (Fn + Hoch/Runter), noch über den Helligkeitsregler der Akkuüberwachung. Während des Einloggens funktionierte das aber noch, wie gesagt -.-

Powerdevil ist installiert, ansonsten funktionieren auch alle Features des Applets... nur eben die blöde Helligkeit nicht. Alle anderen Fn-Kombinationen der Lenovo Tastatur funktionieren im Übrigen auch weiterhin.

Vielleicht noch erwähnenswert : ich nutze zur Ansteuerung des Backlights nicht das thinkpad_acpi Modul, sondern nur Standard-ACPI mit dem "backlight_acpi=vendor" Kernelparameter.
_________________
arch : amd64
kernel : 2.6.34-gentoo-r12
desktop : KDE 4.4.5.
system : Lenovo G560 | Core i3 | Nvidia G310M
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3687
Location: Hamburg

PostPosted: Tue Oct 26, 2010 4:46 pm    Post subject: Reply with quote

attix wrote:
Vielleicht noch erwähnenswert : ich nutze zur Ansteuerung des Backlights nicht das thinkpad_acpi Modul, sondern nur Standard-ACPI mit dem "backlight_acpi=vendor" Kernelparameter.
Kompilier doch beides als Modul ein, dann sollten die beiden Module alles weitere unter sich ausmachen :
Code:
tfoerste@n22 ~ $ dmesg | grep -i think | grep back
thinkpad_acpi: Standard ACPI backlight interface available, not loading native one.
Back to top
View user's profile Send private message
attix
n00b
n00b


Joined: 24 Jan 2008
Posts: 37

PostPosted: Tue Oct 26, 2010 5:18 pm    Post subject: Reply with quote

toralf wrote:
Kompilier doch beides als Modul ein, dann sollten die beiden Module alles weitere unter sich ausmachen


Jo, mittlerweile hab ich schon alles mögliche rauf und wieder runter probiert... und komme leider immer zu dem selben Ergebnis. Sobald KDE geladen ist, verweigert die Helligkeitsregulierung den Dienst. Hab jetzt auch schon ne Menge weiter darüber gelesen... und irgendwie soll das wohl damit zu tun haben, dass Lenovo einen bestimmten ACPI-Stack - der für die softwareseitige Regulierung des Backlights zuständig sein soll - nicht implementiert hat.

Was mich halt wundert ist, dass es bis zum Loginscreen von KDE funktioniert. Witzigerweise schweigen sich "xev" und "acpi_listen" zu der Tastenkombination Fn + hoch/runter aber aus... jedenfalls sobald KDE hochgefahren ist. Recht merkwürdig alles. Denke trotz allem Gelesenen, dass der Fehler eher auf der Seite von KDE zu suchen ist. So richtig viel ergeben die Recherchen aber auch nicht. Hatte gehofft, dass die Lenovo Laptops etwas verbreiteter wären :-/
_________________
arch : amd64
kernel : 2.6.34-gentoo-r12
desktop : KDE 4.4.5.
system : Lenovo G560 | Core i3 | Nvidia G310M
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3687
Location: Hamburg

PostPosted: Tue Oct 26, 2010 5:32 pm    Post subject: Reply with quote

attix wrote:
Hatte gehofft, dass die Lenovo Laptops etwas verbreiteter wären :-/
Und zwar zu recht - viele Kernelentwickler haben ThinkPads - gesponsort fürs OpenLab (früher von IBM).
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4459

PostPosted: Tue Oct 26, 2010 6:15 pm    Post subject: Reply with quote

attix wrote:
toralf wrote:
Kompilier doch beides als Modul ein, dann sollten die beiden Module alles weitere unter sich ausmachen


Jo, mittlerweile hab ich schon alles mögliche rauf und wieder runter probiert... und komme leider immer zu dem selben Ergebnis. Sobald KDE geladen ist, verweigert die Helligkeitsregulierung den Dienst. Hab jetzt auch schon ne Menge weiter darüber gelesen... und irgendwie soll das wohl damit zu tun haben, dass Lenovo einen bestimmten ACPI-Stack - der für die softwareseitige Regulierung des Backlights zuständig sein soll - nicht implementiert hat.

Was mich halt wundert ist, dass es bis zum Loginscreen von KDE funktioniert. Witzigerweise schweigen sich "xev" und "acpi_listen" zu der Tastenkombination Fn + hoch/runter aber aus... jedenfalls sobald KDE hochgefahren ist. Recht merkwürdig alles. Denke trotz allem Gelesenen, dass der Fehler eher auf der Seite von KDE zu suchen ist. So richtig viel ergeben die Recherchen aber auch nicht. Hatte gehofft, dass die Lenovo Laptops etwas verbreiteter wären :-/

Sicher dass es nur mit KDE so ist? Was ist, wenn du nur einen WM startest (wie z.b. fluxbox) funktioniert es dann?
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
attix
n00b
n00b


Joined: 24 Jan 2008
Posts: 37

PostPosted: Tue Oct 26, 2010 6:31 pm    Post subject: Reply with quote

firefly wrote:
Sicher dass es nur mit KDE so ist? Was ist, wenn du nur einen WM startest (wie z.b. fluxbox) funktioniert es dann?

Gute Frage, hab ich noch nicht probiert. Hatte nur bei meinen Recherchen des öfteren gelesen, dass es mit dem "gnome-power-manager" o.ä. funktioniert. Kann aber sein, dass das vielleicht für die Thinkpad-Reihe galt und nicht für die Ideapads. Werd heute leider nicht mehr dazu kommen, es mit fluxbox mal zu testen. Viel ändern würde es aber ja nicht, wenn es dort auch nicht funktioniert. Eher im Gegenteil... wenn es dort funktionieren würde, könnte man das Problem weiter eingrenzen.
_________________
arch : amd64
kernel : 2.6.34-gentoo-r12
desktop : KDE 4.4.5.
system : Lenovo G560 | Core i3 | Nvidia G310M
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum