Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Warum habe ich statt eth0 die Schnittstelle eth2?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Gucky_der_Mausbiber
Guru
Guru


Joined: 10 Apr 2005
Posts: 359
Location: Wetzlar, Hessen

PostPosted: Fri Oct 29, 2010 8:33 am    Post subject: [solved] Warum habe ich statt eth0 die Schnittstelle eth2? Reply with quote

Moinsen,
habe mir gestern ein neues Mainboard besorgt und will darauf auch gleich gentoo installieren. In dem Gerät sind 2 x Netwerkkarten eingebaut. Einmal onboard eine Atheros Gigabit-Karte und einmal als PCI Variante ne Standart 100MBit Karte von D-Link (via-rhine).
Beide Karten werden per Kernel-Modul geladen, jetzt sollte man anehmen das man danach eth0 & eth1 vorfindet, ist aber nicht so.
Die PCI-Karte wird korrekt (wie beim Board davor) als eth1 erkannt, die onboard Karte hingegen nicht als eth0 (wie mit dem Board vorher) sondern als eth2 erkannt.
Wie kann sowas den sein?
Es ist jetzt nicht das große Probleme, muss ich eben alles anstatt auf eth0 auf eth2 stellen, aber trotzdem verwirrt es mich.
Gibt es eine Möglichkeit das ganze auf eth0 umzubiegen?
_________________
intel quad core, nvidia 8800gts, intel hd audio+sb live, gnome 2.24


Last edited by Gucky_der_Mausbiber on Fri Oct 29, 2010 7:48 pm; edited 1 time in total
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Fri Oct 29, 2010 9:17 am    Post subject: Reply with quote

wenn du udev verwendest, dann schau mal hier rein "/etc/udev/rules.d/70-persistent-net.rules"
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6281

PostPosted: Fri Oct 29, 2010 9:20 am    Post subject: Reply with quote

Welche Karte als welches Device geladen wird, wird in /etc/udev/rules.d/70-persistent-net.rules festgelegt: Einfach an Deine Bedürfnisse anpassen (ev. solltest Du in diesem File auch die Kriterien anpassen, nach denen dies festgelegt wird, also etwa anstelle der Kartennummer nur Treiber oder Busnummer o.ä., damit Du Dich im Falle eines Kartenwechsel nicht wieder wunderst, weshalb die neue Karte dann mit eth2 eingetragen wird)
Back to top
View user's profile Send private message
Gucky_der_Mausbiber
Guru
Guru


Joined: 10 Apr 2005
Posts: 359
Location: Wetzlar, Hessen

PostPosted: Fri Oct 29, 2010 10:00 am    Post subject: Reply with quote

Erstmal Danke für die schnellen Antworten.

Ich werde mir das ganze heute abend nochmal anschauen und berichten :)
_________________
intel quad core, nvidia 8800gts, intel hd audio+sb live, gnome 2.24
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Fri Oct 29, 2010 10:45 am    Post subject: Reply with quote

Ja Gucky, mach das.

Ich würde die /etc/udev/rules.d/70-persistent-net.rules Datei aber erst mal löschen und rebooten, denn ich geh mal davon aus dass es sich noch um eine alte, sprich von vor der Hardwaränderung, handelt.
Denn dann wird sie neu erzeugt, und du wirst deine aktuellen NIC's dort mit ihren MAC's als eth0+eth1 vorfinden, da bin ich ganz sicher.
Sollte es dir dann nicht passen, brauchst du nur noch die Bezeichnung eth0 mit 1 zu tauschen und spätestens dann ist es so zugeordnet wie du es dir vorgestellt hast.

Gruß, Andy.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Gucky_der_Mausbiber
Guru
Guru


Joined: 10 Apr 2005
Posts: 359
Location: Wetzlar, Hessen

PostPosted: Fri Oct 29, 2010 11:40 am    Post subject: Reply with quote

Danke :D
_________________
intel quad core, nvidia 8800gts, intel hd audio+sb live, gnome 2.24
Back to top
View user's profile Send private message
Gucky_der_Mausbiber
Guru
Guru


Joined: 10 Apr 2005
Posts: 359
Location: Wetzlar, Hessen

PostPosted: Fri Oct 29, 2010 7:48 pm    Post subject: Reply with quote

Danke,
nach dem löschen der Datei und anschließenden Reboot war die Welt wieder in Ordnung :)
_________________
intel quad core, nvidia 8800gts, intel hd audio+sb live, gnome 2.24
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum