Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Compiz 0.9.2 doesn't start
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
smove
n00b
n00b


Joined: 03 Jul 2005
Posts: 52
Location: Germany

PostPosted: Fri Oct 29, 2010 3:29 pm    Post subject: Compiz 0.9.2 doesn't start Reply with quote

Hi,

I installed compiz 0.9.2 from the latest deskopt-effects-overlay ebuilds.
If I try to start compiz via compiz --replace --sm-disable ccp it doesn't start.

I debugged it and here is the output:
http://xurv.org/~smove/files/compiz_crash-30006.out

Does someone have any ideas why it doesn't start?
Any lib needed to be updated or something?

greetz
smv
Back to top
View user's profile Send private message
Saundersx
Apprentice
Apprentice


Joined: 11 Apr 2005
Posts: 251

PostPosted: Fri Oct 29, 2010 9:40 pm    Post subject: Reply with quote

I can't say for sure this will fix your problem but a 9.2.1 bugfix release will be out any day now. The author recommends waiting for that.

http://smspillaz.wordpress.com/
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sat Oct 30, 2010 2:07 am    Post subject: Reply with quote

those tarballs seem broken

it also doesn't work for me:

use the live ebuilds from tallica-overlay

running here right now :)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1704
Location: United Kingdom

PostPosted: Sun Oct 31, 2010 10:19 am    Post subject: Compiz 0.9.2 Reply with quote

kernelOfTruth, in your post in another thread (https://forums.gentoo.org/viewtopic-p-6466137.html#6466137) you mentioned that you were having some serious problems with Compiz 0.9.x. Have those problems been fixed, then? Is the version you are currently using 0.9.2 or 0.9.2.1?
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sun Oct 31, 2010 11:34 am    Post subject: Re: Compiz 0.9.2 Reply with quote

Fitzcarraldo wrote:
kernelOfTruth, in your post in another thread (https://forums.gentoo.org/viewtopic-p-6466137.html#6466137) you mentioned that you were having some serious problems with Compiz 0.9.x. Have those problems been fixed, then? Is the version you are currently using 0.9.2 or 0.9.2.1?


Hi Fitzcarraldo :)

not completely yet - I'm compiling via live-ebuilds from tallica-overlay (like already mentioned)

and meanwhile the normal application-switcher without mipmap activated works now,

scale (or what its name is) when going to a corner of the screen to show all apps (afaik) has been working all the time

but when enabling desktop wall/expo the content of the windows still isn't updated


maybe someone could test the cube mode ? (for me it doesn't work) it most likely would also show this erroneous behavior


I don't know why enabling

* mipmap
and
* application switching stuff (in general)

would cause such problems (side-effects of porting it to c++ maybe ?)


also: there are some small focus-issues which I need to observe some more during use
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Rongidge
n00b
n00b


Joined: 19 Dec 2009
Posts: 9

PostPosted: Thu Nov 04, 2010 5:11 pm    Post subject: Reply with quote

I'm experiencing a strange problem with compiz (0.9.2 from desktop-effects overlay and live ebuild from tallica overlay).
the problem is: it does nothing. no window decoration, no resizing, no moving, no errors.
ps ax | grep compiz however shows compiz running. I configured compiz via ccsm.

compiz --debug --replace only prints:
Code:
compiz (core) - Debug: Could not stat() file /home/<username>/.compiz-1/plugins/libcore.so : No such file or directory
compiz (core) - Debug: Could not stat() file /usr/lib64/compiz/libcore.so : No such file or directory


i looked it up since it looked quite serious, but it appears as if it is not an error.

so far i've tried:
reemerging
emerge -C, rm -rf ~/.config/.compiz, emerge

Code:
$ equery list compiz
[ Searching for package 'compiz' in all categories among: ]
 * installed packages
[I--] [ ~] dev-python/compizconfig-python-9999 (0)
[I--] [ ~] x11-libs/compizconfig-backend-gconf-9999 (0)
[I--] [ ~] x11-libs/libcompizconfig-9999 (0)
[I--] [ ~] x11-plugins/compiz-plugins-extra-9999 (0)
[I--] [ ~] x11-plugins/compiz-plugins-main-9999 (0)
[I--] [ ~] x11-plugins/compiz-plugins-unsupported-9999 (0)
[I--] [ ~] x11-wm/compiz-9999 (0)

$ equery list ccsm
[ Searching for package 'ccsm' in all categories among: ]
 * installed packages
[I--] [ ~] x11-apps/ccsm-9999 (0)


edit: It looks as if compiz is not using any configfiles, even though they exist. is there any way to tell compiz to use a specific configuration via commandline?
Back to top
View user's profile Send private message
acidrums4
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2009
Posts: 136
Location: Al otro lado del monitor

PostPosted: Sat Nov 06, 2010 2:35 am    Post subject: Reply with quote

I'm having the same problem. compiz tries to find its plugins from ~/.compiz-1/plugins/
I couldn't find such overlay named 'tallica' :(
Compiz-0.9.2 doesn't read any previous configuration file.
Back to top
View user's profile Send private message
Rongidge
n00b
n00b


Joined: 19 Dec 2009
Posts: 9

PostPosted: Tue Nov 09, 2010 8:45 pm    Post subject: Reply with quote

i'm not quite sure where the problem is, but when i use
Code:
compiz --replace --debug composite
compiz (core) - Debug: Could not stat() file /home/<username>/.compiz-1/plugins/libcore.so : No such file or directory
compiz (core) - Debug: Could not stat() file /usr/lib64/compiz/libcore.so : No such file or directory
compiz (core) - Debug: Could not stat() file /home/<username>/.compiz-1/plugins/libcomposite.so : No such file or directory

it loads up the composite extension and things like awn are working as supposed, so the problem seems to be that compiz can't read the config (for whatever reason).
ccsm is using the "ini" backend on my system, but the gconf-editor shows the same as ccsm (which i think reads the ini).
changed that now to the "gconf"-backend, but still no improvement.

will continue to look into it, i liked my colerful "action"-desktop.
Back to top
View user's profile Send private message
Rongidge
n00b
n00b


Joined: 19 Dec 2009
Posts: 9

PostPosted: Tue Nov 16, 2010 3:02 pm    Post subject: Reply with quote

i looked further into it and it really looks like compiz can't read his configs.
By starting compiz from commandline (like: compiz --replace composite) it loads the given addons, but the addons don't read any configs.
So I guess something is wrong with the parser (gconf or iniparser or whatever).
Can somebody with a similar emerge --info tell me if he got it working?

$ emerge --info compiz
Portage 2.1.8.3 (default/linux/amd64/10.0/desktop/gnome, gcc-4.4.4, glibc-2.11.2-r3, 2.6.34-gentoo-r12 x86_64)
=================================================================
System Settings
=================================================================
System uname: Linux-2.6.34-gentoo-r12-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T6400_@_2.00GHz-with-gentoo-1.12.14
Timestamp of tree: Sun, 07 Nov 2010 00:00:01 +0000
ccache version 2.4 [enabled]
app-shells/bash: 4.1_p7
dev-java/java-config: 2.1.11
dev-lang/python: 2.6.5-r3, 3.1.2-r4
dev-util/ccache: 2.4-r7
dev-util/cmake: 2.8.1-r2
sys-apps/baselayout: 1.12.14-r1
sys-apps/sandbox: 2.3-r1
sys-devel/autoconf: 2.13, 2.65-r1
sys-devel/automake: 1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils: 2.20.1-r1
sys-devel/gcc: 4.4.4-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool: 2.2.10
sys-devel/make: 3.81-r2
virtual/os-headers: 2.6.30-r1
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=core2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=core2"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests ccache distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/games /var/lib/layman/gamerlay /var/lib/layman/sunrise /var/lib/layman/desktop-effects /usr/local/portage /usr/local/portage/tallica"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl acpi alsa amd64 bash-completion berkdb branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss emerald encode esd evo exif extras fam ffmpeg firefox flac fontconfig fortran gconf gdbm gdu geoip gif gnome gnome-keyring gnutls gpm grub gstreamer gtk hal iconv id3 ipv6 jack java jpeg kate lame laptop lash lcms ldap libnotify libsamplerate mad matroska mikmod mmx mng modules mono mp3 mp4 mpeg mplayer mtp mudflap multilib musepack music nautilus ncurses networkmanager nls nptl nptlonly offensive ogg opengl openmp pam pango pcre pdf perl png policykit ppds pppd pulseaudio python qt3support qt4 radius rdesktop readline samba schroedinger sdl session spell sse sse2 ssl startup-notification svg symlink sysfs tcpd theora threads tiff truetype unicode usb v4l vala video vnc vorbis wavpack x264 xcb xcomposite xinerama xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" PHP_TARGETS="php5-2" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fglrx" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
Package Settings
=================================================================

x11-wm/compiz-9999 was built with the following:
USE="cairo dbus gnome gtk (multilib) svg -debug -fuse -kde"

another idea: does somebody know where compiz is looking for its config file? this whole "compiz-1" stuff looks suspicious.
Back to top
View user's profile Send private message
Jupiter1TX
Guru
Guru


Joined: 24 Feb 2006
Posts: 546
Location: 3rd Rock

PostPosted: Tue Nov 16, 2010 4:30 pm    Post subject: Reply with quote

Just a note to help understand compiz as far as i remember.

Without ccp in your command line compiz won't load your config.
With a new install it is generally a good idea to start and configure
ccsm 'compizconfig-settings-manager' BEFORE you start compiz
so as to ENABLE pertinent plugins 'composite, opengl, move and,
decoration'. Current compiz home folder is now '~/.config/compiz-1'
NOT ''~/.config/compiz'. If you have a local plugin folder, compiz
will look in and try to load those plugins first and could be a cause
for failure.

I've gotten 0.9.2 to work but kde decorator crashes it.
Moving a window causes it to crash as well.
_________________
Core i7 920 D0 | Asus P6T DLX | Patriot Viper 1600 6GB | Antec Quattro 850W
Geforce 8800GTX OC2 768MB | Dell 22" LCD | Koolance Exos2/Swiftech GTZ
GCC 4.6.1 | 3.7.x-geek | Xorg-7.4-x | KDE-4.7.x | Compiz
Back to top
View user's profile Send private message
Rongidge
n00b
n00b


Joined: 19 Dec 2009
Posts: 9

PostPosted: Wed Nov 17, 2010 9:24 pm    Post subject: Reply with quote

thanks, that helped.
now it starts with "compiz --replace ccp".

hope you find a solution to your problem too, but i don't think i can help you with it (running gnome).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum