Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Updating gpodder through sabayon overlay
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
rudi_aber
n00b
n00b


Joined: 06 Feb 2006
Posts: 21
Location: Aberystwyth, Wales

PostPosted: Sun Oct 31, 2010 3:24 pm    Post subject: Updating gpodder through sabayon overlay Reply with quote

I'm trying to get an up-to-date version of gpodder (current: 2.5 - latest in portage is 0.17). It happens to be included in the sabayon overlay, so I've installed that using layman, and then emerged gpodder (and a number of dependencies the new version needs). So far, so good - no hickups installing.

Unfortunately, when trying to run it, I get
Code:

Traceback (most recent call last):
  File "/usr/bin/gpodder", line 179, in <module>
    from gpodder import gui
  File "/usr/lib/python2.6/site-packages/gpodder/gui.py", line 72, in <module>
    from gpodder import my
  File "/usr/lib/python2.6/site-packages/gpodder/my.py", line 39, in <module>
    from gpodder import minidb
  File "/usr/lib/python2.6/site-packages/gpodder/minidb.py", line 31, in <module>
    import sqlite3.dbapi2 as sqlite
ImportError: No module named sqlite3.dbapi2


Has anybody seen this before, or can point me in the right direction?
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 9268

PostPosted: Mon Nov 01, 2010 1:25 am    Post subject: Reply with quote

Try upgrading dev-python/pysqlite if not already at the latest version.

Moved from Multimedia to Unsupported Software, given that it comes from a third party overlay.
Back to top
View user's profile Send private message
rudi_aber
n00b
n00b


Joined: 06 Feb 2006
Posts: 21
Location: Aberystwyth, Wales

PostPosted: Mon Nov 01, 2010 3:28 pm    Post subject: Reply with quote

desultory wrote:
Try upgrading dev-python/pysqlite if not already at the latest version.

Done (2.5.5 to 2.6.0), but makes no difference.

Quote:
Moved from Multimedia to Unsupported Software, given that it comes from a third party overlay.

Fair enough. It would make sense not to support it at all rather than support an ancient beta version.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum