Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] KDE4 Systemsettings akzeptiert keine Themes
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Wed Nov 03, 2010 11:38 am    Post subject: [solved] KDE4 Systemsettings akzeptiert keine Themes Reply with quote

Hallo,

ich hab ein neues Gentoo aufgesetzt:

- Windowmanager e16
- Nutzung KDE4-Apps und Umgebung

Wenn ich jetzt Systemsettings start, kann ich die Schriften, Farben usw. einstellen. Klappt auch alles.

Aber:
Wähl ein ein anderes Theme aus, wird das übernommen und in .kde4/share/config/kdeglobals übernommen:
Code:
[General]
BrowserApplication[$e]=!firefox
ColorScheme=Steel
shadeSortColumn=true
widgetStyle=qtcurve

Nur angezeigt wird mir hartnäckig der Oxygen-Style. Dabei ist es egal, ob ich CDE, Plastik, QtCurve,... einstell.

Auf meinem alten Rechner funktionierts. Allerdings hab ich da an der Config auch seit einigen KDE-Updates nichts geändert.

Ideen?


Last edited by musv on Wed Nov 03, 2010 3:03 pm; edited 1 time in total
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Wed Nov 03, 2010 2:15 pm    Post subject: Reply with quote

Ich habe das selbe Problem in fluxbox. Hab lange rumexperimentiert mit kcminit & Co - ohne Erfolg.
Die Lösung ist relativ banal: Verwende zum Style setzen qtconfig. Dort ein "Desktop Settings" eingestellt, und alle Qt (und damit auch kde) Programme ignorieren den in systemsettings eingestellten style...
Evtl. reicht es ja, irgend eine Variable zu setzen. Aber das schau ich jetzt nimmer ^^.
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Wed Nov 03, 2010 3:03 pm    Post subject: Reply with quote

Hab's grad mal hier auf meinem Arbeitsrechner ausprobiert, wo ich unter Arch dasselbe Problem hab. qtconfig tut's.

Was mir jetzt dabei so aufgefallen ist:

qtconfig ändert die Konfiguration in .config/Trolltech.conf

Genauer gesagt wird da eine Zeile angelegt:
Code:
style=QtCurve

Die ist auch auf meiner alten Installation vorhanden, in der neuen gib es zwar die Trolltech.conf, die besagte Zeile jedoch nicht.

Wäre das ein Fall für einen Bugreport?
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Wed Nov 03, 2010 4:42 pm    Post subject: Reply with quote

musv wrote:
Wäre das ein Fall für einen Bugreport?

Jein :D Der Default in qtconfig ist ja "Desktop Settings". Läuft der kde4-Desktop, nimmt sich qt halt den kde4-Style. Läuft kde4 nicht, muss sich Qt eben einen anderen Style nehmen. Ob kde4 läuft oder nicht, muss in irgend einer Umgebungsvariablen oder einem XProperty stehen. Das gehört noch recherchiert.
Das einzige was man evtl. reporten könnte, wäre dass eine kde4-Anwendung nicht im kde4-Style dargestellt wird. Nur hab ich keine Ahnung, in wie weit da der Qt-Style aus qtconfig in einer nicht-kde4-Umgebung berücksichtigt wird...
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Wed Mar 30, 2011 4:42 pm    Post subject: Reply with quote

Ich muss den Thread mal wieder öffnen. Nachdem ich jetzt ein Update ausgeführt hab, war der QtStyle wieder weg.

Ausangslage:
  • Keine Benutzung von KDE-Desktop sondern e16
  • Nutzung des KDE-Backends (KDM, Systemsettings, KDE-Apps)


Was hab ich gemacht:
  • Systemupdate von KDE-4.6.0 auf KDE-4.6.1


Symptome:
  • Style sieht aus wie Windows-Style
  • In Systemsettings sind Oxygen und QtCurve vorhanden, können ausgewählt werden, zeigen aber keine Änderung (nur in der Vorschau)
  • In qtconfig fehlen Oxygen und QtCurve, stattdessen steht ganz unten in der Liste "Unknown". Windows steht genau darüber, und das scheint auch der Grund zu sein, warum das als Standard-Theme angenommen wird.
  • In der .config/Trolltech.conf steht bei style noch immer style="QtCurve"


Lösung:
  • Die Variable QT_PLUGIN_PATH muss gesetzt werden, dann werden die Styles auch wieder erkannt. Warum das beim Update wieder verloren gegangen ist, keine Ahnung. Am besten schreibt man das irgendwo in /etc/env.d rein.


32bit (und 64bit, da lib Link auf lib64 ist):
Code:
QT_PLUGIN_PATH=/usr/lib/kde4/plugins/styles/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum