Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kde-base/kdelibs mit "-xcb" bauen?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
3PO
Veteran
Veteran


Joined: 26 Nov 2006
Posts: 1105
Location: Schwabenländle

PostPosted: Thu Nov 04, 2010 10:26 pm    Post subject: kde-base/kdelibs mit "-xcb" bauen? Reply with quote

Hallo Zusamen,

gibt es eine Möglichkeit die kdelibs ohne xcb zu bauen?

Ich habe "-xcb" in der make.conf stehen, leider läuft damit das wold update nicht:

Code:
gentoo ~ # emerge -avuDN world

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


 * IMPORTANT: 18 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=media-libs/xine-lib-1.1.15-r1[xcb?]".
!!! One of the following packages is required to complete your request:
- media-libs/xine-lib-1.2.9999 (Change USE: +xcb)
- media-sound/phonon-4.4.2 (Change USE: -xcb)
(dependency required by "media-sound/phonon-4.4.2" [ebuild])
(dependency required by "@selected")
(dependency required by "@world" [argument])

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

gentoo ~ #
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Fri Nov 05, 2010 7:13 am    Post subject: Reply with quote

Das hat aber nichts mehr mit kdelibs zu tun, sondern mit phonon<->xine-lib. Hast du zufällig in package.use dem phonon explizit ein "+xcb" verpasst? Ich nehms an. Aber warum willst du eigentlich kein xcb?
Back to top
View user's profile Send private message
3PO
Veteran
Veteran


Joined: 26 Nov 2006
Posts: 1105
Location: Schwabenländle

PostPosted: Fri Nov 05, 2010 3:22 pm    Post subject: Reply with quote

Hi,

nein ich habe phonon nicht explizit mir +xbc gebaut.

Ich möchte auf xcb verzichten, weil es beim VDR angeblich zu Problemen führt. (-> Tearing)

Siehe: --> http://www.vdr-portal.de/board/thread.php?postid=953159#post953159
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4459

PostPosted: Fri Nov 05, 2010 3:32 pm    Post subject: Reply with quote

3PO wrote:
Hi,

nein ich habe phonon nicht explizit mir +xbc gebaut.

Ich möchte auf xcb verzichten, weil es beim VDR angeblich zu Problemen führt. (-> Tearing)

Siehe: --> http://www.vdr-portal.de/board/thread.php?postid=953159#post953159


Aber für Portage sieht es so aus als ob für Phonon xcb gesetzt ist. Schau lieber nach ob du nicht doch für phonon in der /etc/portage7package.use das useflag xcb gesetzt hast.
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
3PO
Veteran
Veteran


Joined: 26 Nov 2006
Posts: 1105
Location: Schwabenländle

PostPosted: Fri Nov 05, 2010 4:06 pm    Post subject: Reply with quote

grep -r xcb /etc/portage/* gibt nichts aus.

"-xcb" ist in der make.conf unter USE gesetzt.

Aber dann:

Code:
vdr01 ~ # emerge -avuDN world

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


 * IMPORTANT: 18 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=media-sound/phonon-4.3.80[xcb]".
!!! One of the following packages is required to complete your request:
- media-sound/phonon-4.4.2 (Change USE: +xcb)
(dependency required by "kde-base/kdelibs-4.4.5" [installed])
(dependency required by "media-video/vlc-1.1.4.1" [ebuild])
(dependency required by "@selected")
(dependency required by "@world" [argument])

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

vdr01 ~ #
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Fri Nov 05, 2010 4:18 pm    Post subject: Reply with quote

Ein Blick ins ebuild verrät mir: kdelibs hat kein USE="xcb", verlangt aber phonon mit xcb gebaut, was wiederum xine-lib mit xcb braucht. Wenn du kein xcb in den Abhängigkeiten willst, musst du auf kdelibs verzichten :/
Back to top
View user's profile Send private message
3PO
Veteran
Veteran


Joined: 26 Nov 2006
Posts: 1105
Location: Schwabenländle

PostPosted: Fri Nov 05, 2010 4:29 pm    Post subject: Reply with quote

franzf wrote:
[...] Wenn du kein xcb in den Abhängigkeiten willst, musst du auf kdelibs verzichten :/


Und was würde das bedeuten, bzw. wie werde ich kdelibs "sauber" los
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4459

PostPosted: Fri Nov 05, 2010 4:34 pm    Post subject: Reply with quote

indem du alle kde programme deinstallierst?
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
3PO
Veteran
Veteran


Joined: 26 Nov 2006
Posts: 1105
Location: Schwabenländle

PostPosted: Fri Nov 05, 2010 4:39 pm    Post subject: Reply with quote

firefly wrote:
indem du alle kde programme deinstallierst?


Nun ja, das will ich eigentlich auch nicht. :(
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4459

PostPosted: Fri Nov 05, 2010 5:04 pm    Post subject: Reply with quote

dann bleibt dir nur das ganze mit xcb. Und da du von angeblichen Problemen mit VDR und xcb sprichst und daher anscheinend dieses Probleme nicht selbst festgestellt hast, solltest du lieber es selbst ausprobieren. Denn es kann ja sein, dass bei dir dieses Problem nicht auftritt.
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
3PO
Veteran
Veteran


Joined: 26 Nov 2006
Posts: 1105
Location: Schwabenländle

PostPosted: Fri Nov 05, 2010 5:40 pm    Post subject: Reply with quote

Natürlich habe ich das Problem, sonst würde ich ja nicht mit "-xcb" bauen wollen.

Gibt es denn wirklich keine Möglichkeit dieses dumme XCB los zu werden??
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Fri Nov 05, 2010 6:04 pm    Post subject: Reply with quote

Hast du eine nvidia-Karte? Wenn ja liegt das an Composite. Composite disablen und gut ists.
Hab auch lange damit gekämpft, und seitdem kwin im Fullscreen verlässlich Composite ausschaltet, hab ich kein Tearing mehr (natürlich nur im Fullscreen).
Back to top
View user's profile Send private message
3PO
Veteran
Veteran


Joined: 26 Nov 2006
Posts: 1105
Location: Schwabenländle

PostPosted: Fri Nov 05, 2010 6:26 pm    Post subject: Reply with quote

Das steht bei mir schon drin:

Code:
[....]
Section "Extensions"
    Option         "Composite" "Disable"
EndSection
Back to top
View user's profile Send private message
3PO
Veteran
Veteran


Joined: 26 Nov 2006
Posts: 1105
Location: Schwabenländle

PostPosted: Sat Nov 06, 2010 2:48 pm    Post subject: Reply with quote

Ih könnte ja mal das ebuild modifizieren?

von:

Code:
.....
   aqua? ( >=media-sound/phonon-4.3.80 )
   !aqua? (
      >=media-sound/phonon-4.3.80[xcb]
.....

auf

Code:
.....
   aqua? ( >=media-sound/phonon-4.3.80 )
   !aqua? (
      >=media-sound/phonon-4.3.80
.....


...Oder sollte man das lieber lassen?

Es muss doch einen Weg geben, das doofe xcb los zu werden!? :evil:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum