Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Battle of Wesnoth - kein deutsch trotz LINGUAS="de"
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2032
Location: Heidelberg - Germany

PostPosted: Fri Nov 05, 2010 11:03 am    Post subject: Battle of Wesnoth - kein deutsch trotz LINGUAS="de" Reply with quote

Hallo Ihr alle beieinander,

mal wieder ein Problem. Mein 7 jähriger Sohn mag Spiele lieber in Deutsch. Ich wollte ihm Battle of Wesnoth installieren und habe LINGUAS="de" in der make.conf. Trotzdem ist das Spiel nur in Englisch da. Was muß man noch tun, damit die deutsche Version installiert wird? Auf Kubuntu ist eine deutsche Version verfügbar, also sollte es gehen.
Back to top
View user's profile Send private message
sirro
Veteran
Veteran


Joined: 20 Jul 2003
Posts: 1472
Location: aachen.nrw.de.eu

PostPosted: Fri Nov 05, 2010 7:34 pm    Post subject: Reply with quote

Das ebuild von Battle of Wesnoth unterstützt anscheinend kein LINGUAS.

Hast du das Use-flag "nls" gesetzt? Das sollte eigentlich für native language support sorgen. Vermutlich werden alle Sprachen auf einmal installiert.


Ich weiß nicht wie das bei portage/emerge aussieht, aber bei paludis/cave sieht man in der Ausgabe wie bei use-flags ob linguas unterstützt wird.
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2225
Location: Germany

PostPosted: Fri Nov 05, 2010 7:36 pm    Post subject: Reply with quote

1. Entweder es ist nicht vorhanden (Szenario nicht lokalisiert usw.)

2. LANG oder LC_ALL vielleicht merkwürdig gesetzt?

Edit: Das Useflag nsl hab ich auch gesetzt und bei mir startet es in deutsch.
Back to top
View user's profile Send private message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2032
Location: Heidelberg - Germany

PostPosted: Mon Nov 08, 2010 2:25 pm    Post subject: Reply with quote

LANG und LC_ALL waren gar nicht definiert. Ich habe jetzt mal in /etc/conf.d/02locale LANG=german eingetragen. Wenn ich LC_ALL definiere, bekomme ich Fehlermeldungen, dass Dateien fehlen. Ehrlich gesagt, blick ich da noch nicht durch, da ich mich bisher noch nicht um sowas kümmern mußte. Worin grenzt sich LINGUAS, LANG und LC_ALL voneinander ab?

BTW: Definition von LANG hat auch nicht geholfen.

-Erdie
Back to top
View user's profile Send private message
Mr. Anderson
l33t
l33t


Joined: 22 Apr 2004
Posts: 761

PostPosted: Wed Nov 17, 2010 1:26 am    Post subject: Reply with quote

So weit ich das sehe, muss zur Übersetzungszeit das nls-USE-Flag gesetzt sein. Zur Laufzeit hilft es, wenn LC_ALL=de_DE.utf8 oder ähnlich gesetzt ist. (zum Beispiel über die /etc/env.d/02locale oder wesnoth starten mit LC_ALL=de_DE.utf8 wesnoth). Außerdem lässt sich im Spiel nach dem Start in den Einstellungen die Sprache umschalten.

Hat man im Spiel die Sprache umgestellt, wird das meines Wissens gespeichert und beim nächsten Start wird diese Sprache wieder automatisch geladen, unabhängig davon wie LC_ALL gesetzt ist.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Wed Nov 17, 2010 2:52 am    Post subject: Reply with quote

Erdie wrote:
Ich habe jetzt mal in /etc/conf.d/02locale LANG=german eingetragen. Wenn ich LC_ALL definiere, bekomme ich Fehlermeldungen, dass Dateien fehlen.
Dann fehlen dir evtl. noch die locale der glibc?!
Folgende solltest du etwa zur verfügung stellen
Code:
$ grep -v ^# /etc/locale.gen

en_US ISO-8859-1
en_US.UTF-8 UTF-8
de_DE ISO-8859-1
de_DE@euro ISO-8859-15
de_DE.UTF-8 UTF-8
Beachte das nach dem hinzufügen diese noch mit einem
Code:
# locale-gen
generiert werden müssen, damit sollte dein System dann mit diesen umgehen können.

BTW:
LC_ALL sollte man möglichst nicht setzen, auch nicht in einer Startdatei.
Ich hab das Spiel nicht installiert, aber versuche mal ein Start via
Code:
$ LC_MESSAGES=de_DE.UTF-8 wesnoth
oder
$ LANG=de_DE.UTF-8 wesnoth

Ansonsten schaue zb auch noch mal hier
Back to top
View user's profile Send private message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2032
Location: Heidelberg - Germany

PostPosted: Wed Nov 17, 2010 6:23 pm    Post subject: Reply with quote

Mr. Anderson wrote:
So weit ich das sehe, muss zur Übersetzungszeit das nls-USE-Flag gesetzt sein. Zur Laufzeit hilft es, wenn LC_ALL=de_DE.utf8 oder ähnlich gesetzt ist. (zum Beispiel über die /etc/env.d/02locale oder wesnoth starten mit LC_ALL=de_DE.utf8 wesnoth). Außerdem lässt sich im Spiel nach dem Start in den Einstellungen die Sprache umschalten.

Hat man im Spiel die Sprache umgestellt, wird das meines Wissens gespeichert und beim nächsten Start wird diese Sprache wieder automatisch geladen, unabhängig davon wie LC_ALL gesetzt ist.


Ja, das Problem ist, dass ich im Spiel die Sprache zwar auf Deutsch stellen kann, es aber bei Englisch bleibt. Ich versuche es mal mit local.gen
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum