Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
/usr/sbin/smartctl und 3ware
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3116
Location: Berlin

PostPosted: Sat Nov 06, 2010 12:46 pm    Post subject: /usr/sbin/smartctl und 3ware Reply with quote

Hallo,
ich habe mit smartctl die Temperatur meines Raid überwacht.
Code:
olaf@flammenflitzer ~ $ cat .conkyrc | grep 3ware
${color black} Festplatte Raid 3ware /dev/sda Temp: ${color red} ${execi 10 /usr/sbin/smartctl  -d 3ware,0 -A /dev/twe0 | grep Temperature_Celsius | cut -c 88-90}°C
Das funktioniert nicht mehr.
Code:
olaf@flammenflitzer ~ $ /usr/sbin/smartctl  -d 3ware,0 -A /dev/twe0
smartctl 5.40 2010-10-16 r3189 [x86_64-pc-linux-gnu] (local build)
Copyright (C) 2002-10 by Bruce Allen, http://smartmontools.sourceforge.net
Node /dev/twe0 does not exist and must be created. Check the udev rules.
problem creating 3ware device nodes /dev/twe0mknod: Permission denied
Smartctl open device: /dev/twe0 [3ware_disk_00] failed: setup_3ware_nodes("twe", "3w-xxxx") failed

Code:
flammenflitzer olaf # lspci | grep 3ware
04:01.0 RAID bus controller: 3ware Inc 7xxx/8xxx-series PATA/SATA-RAID (rev 01)
Code:
flammenflitzer olaf # cat /proc/devices | grep twe
253 twe
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3627
Location: Germany

PostPosted: Sat Nov 06, 2010 1:59 pm    Post subject: Reply with quote

Hi
Wenn ich das richtig mitbekommen hab werden die Devices nun mit /dev/twa benannt, also nicht mehr als "twe"

/edit:
Code:
# grep -e twe -e twa /proc/devices
253 twa
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3627
Location: Germany

PostPosted: Sun Nov 07, 2010 1:11 am    Post subject: Reply with quote

Argh sorry, ich hatte übersehen das es sich bei dir um einen 3ware Controller der 7xxx/8xxx Serie handelt, bei diesen sollte /dev/twe doch richtig sein. (siehe zb auch in der man smartctl)
Also vergiss meine oberen Beitrag bitte wieder.

Würde der
Code:
# smartctl -d 3ware,0 -A /dev/twe0
Befehl denn als root klappen?
Back to top
View user's profile Send private message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3116
Location: Berlin

PostPosted: Sun Nov 07, 2010 3:59 pm    Post subject: Reply with quote

funktioniert als root
Code:
flammenflitzer olaf # smartctl -d 3ware,0 -A /dev/twe0
smartctl 5.40 2010-10-16 r3189 [x86_64-pc-linux-gnu] (local build)
Copyright (C) 2002-10 by Bruce Allen, http://smartmontools.sourceforge.net

Node /dev/twe0 does not exist and must be created. Check the udev rules.
Node /dev/twe1 does not exist and must be created. Check the udev rules.
Node /dev/twe2 does not exist and must be created. Check the udev rules.
Node /dev/twe3 does not exist and must be created. Check the udev rules.
Node /dev/twe4 does not exist and must be created. Check the udev rules.
Node /dev/twe5 does not exist and must be created. Check the udev rules.
Node /dev/twe6 does not exist and must be created. Check the udev rules.
Node /dev/twe7 does not exist and must be created. Check the udev rules.
Node /dev/twe8 does not exist and must be created. Check the udev rules.
Node /dev/twe9 does not exist and must be created. Check the udev rules.
Node /dev/twe10 does not exist and must be created. Check the udev rules.
Node /dev/twe11 does not exist and must be created. Check the udev rules.
Node /dev/twe12 does not exist and must be created. Check the udev rules.
Node /dev/twe13 does not exist and must be created. Check the udev rules.
Node /dev/twe14 does not exist and must be created. Check the udev rules.
Node /dev/twe15 does not exist and must be created. Check the udev rules.
=== START OF READ SMART DATA SECTION ===
SMART Attributes Data Structure revision number: 10
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
  1 Raw_Read_Error_Rate     0x000f   056   049   006    Pre-fail  Always       -       0
  3 Spin_Up_Time            0x0003   096   096   000    Pre-fail  Always       -       0
  4 Start_Stop_Count        0x0032   096   096   020    Old_age   Always       -       4584
  5 Reallocated_Sector_Ct   0x0033   100   100   036    Pre-fail  Always       -       0
  7 Seek_Error_Rate         0x000f   087   062   030    Pre-fail  Always       -       498872540
  9 Power_On_Hours          0x0032   091   091   000    Old_age   Always       -       8221
 10 Spin_Retry_Count        0x0013   100   100   097    Pre-fail  Always       -       0
 12 Power_Cycle_Count       0x0032   097   097   020    Old_age   Always       -       3919
194 Temperature_Celsius     0x0022   037   061   000    Old_age   Always       -       37
195 Hardware_ECC_Recovered  0x001a   056   049   000    Old_age   Always       -       0
197 Current_Pending_Sector  0x0012   100   100   000    Old_age   Always       -       0
198 Offline_Uncorrectable   0x0010   100   100   000    Old_age   Offline      -       0
199 UDMA_CRC_Error_Count    0x003e   200   199   000    Old_age   Always       -       1
200 Multi_Zone_Error_Rate   0x0000   100   253   000    Old_age   Offline      -       0
202 Data_Address_Mark_Errs  0x0032   100   253   000    Old_age   Always       -       0

Sollte nicht /dev/twe6 vorhanden sein? Als user funktioniert es nicht. (mehr)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum