Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
umts und net.ppp0
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
JoHo42
l33t
l33t


Joined: 14 Feb 2004
Posts: 944
Location: Germany

PostPosted: Sat Jul 11, 2009 7:40 am    Post subject: umts und net.ppp0 Reply with quote

Hi Leute,

ich moechte mir ganz gerne umtsmon einrichten.
Allderdings bekomme ich eine ppp0 Verbindung nicht ans laufen.
Wenn ich umtsmon starte und dann versuche damit eine Verbindung aufzubauen,
fragt der irgendwie nach ppp0.
Ich habe jetzt versucht von eine ppp0 Datei einzurichten,
allerdings bekomme ich das nicht ans laufen.

Hat jemand eine net ppp0 Beispiel fuer mich,
die mit einer UMTS Modem verbindung laeuft.
Ich denke, dass das Problem bei den INIT Strings liegt.

Gruss Joerg
Back to top
View user's profile Send private message
rc
Apprentice
Apprentice


Joined: 16 Dec 2003
Posts: 234

PostPosted: Sat Jul 11, 2009 9:09 am    Post subject: Reply with quote

Hi,

ich benutze hier wvdial für UMTS.
wvdial hat dabei die Aufgaben
  • erstens der "Initialisierung" (PIN eingeben)
  • und zweitens der Einwahl.

Bei der Einwahl baut wvdial dann eine point-to-point Verbindung mittels pppd auf.
Danach ist IIRC auch das ppp0 interface vorhanden.

Die wvdial config sieht hier wie folgt aus:
Code:
[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = Analog Modem
Baud = 460800
New PPPD = yes
Modem = /dev/ttyUSB0
ISDN = 0

[Dialer umts-pin]
Init3 = AT+CPIN=xxxx
Dial Attempts = 1

[Dialer umts]
Password = eplus
Username = gprs
Dial Command = ATD
Carrier Check = no
Phone = *99***1#
Stupid Mode = 1
Init4 = AT+CGDCONT=1,"IP","internet.eplus.de"
Dial Attempts = 2


Das ganze wird dann einfach via
Code:

wvdial umts-pin
wvdial umts

gestartet.

Zum auflegen reicht es wvdial mit STRG+C zu beenden.
Dabei baut wvdial auch die Verbindung korrekt wieder ab (auflegen usw.).


Grüße

rc
Back to top
View user's profile Send private message
JoHo42
l33t
l33t


Joined: 14 Feb 2004
Posts: 944
Location: Germany

PostPosted: Sat Jul 11, 2009 9:34 am    Post subject: Reply with quote

Hi,

ich moechte umtmon ans laufen bekommen.
Dafuer brauche ich allerdings das PPP Programm.

Gruss Joerg
Back to top
View user's profile Send private message
bbgermany
Veteran
Veteran


Joined: 21 Feb 2005
Posts: 1792
Location: Oranienburg/Germany

PostPosted: Sat Jul 11, 2009 9:39 am    Post subject: Reply with quote

Hi,

oder direkt via /etc/conf.dnet:

Code:

config_ppp0=( "ppp" )
link_ppp0="/dev/ttyUSB0" # Hier das genutze Device eintragen
username_ppp0='eplus' # Username und Passwort spielen bei den meisten Anbietern
password_ppp0='gprs' # keine Rolle, da über die SIM-Karte abgerechnet wird
pppd_ppp0=(
 "debug"
 "defaultroute"
 "ipcp-accept-remote"
 "ipcp-accept-local"
 "lock"
 "460800"
 "modem crtscts"
 "usepeerdns"
)
chat_ppp0=(
 'ABORT' 'BUSY'
 'ABORT' 'ERROR'
 'ABORT' 'NO ANSWER'
 'ABORT' 'NO CARRIER'
 'ABORT' 'NO DIALTONE'
 'ABORT' 'Invalid Login'
 'ABORT' 'Login incorrect'
 'TIMEOUT' '1'
 '' 'ATZ'
 'OK' 'AT&F'
 'OK' 'ATE1'
 'OK' 'AT+CPIN?'
 'CPIN: READY-AT+CPIN=1234-OK' 'AT+COPS?' # Hier ggf. die PIN eintragen
 'OK' 'AT_OPSYS=3,2' # Je nach Präferenz anpassen
 'OK' 'AT+CSQ'
 'OK' 'AT+CGDCONT=1,"IP","internet.eplus.de","0.0.0.0"'
 'TIMEOUT' '60'
 'OK' 'ATD*99#'
 'CONNECT' ''
 'TIMEOUT' '5'
 '~--' ''
)


MfG. Stefan
_________________
1st: i5-4570, 16GB, 1.75TB
2nd: i5-4570, 16GB, 620GB
3rd: i5-4570, 16GB, 10,5TB
4th: Asus N61VN, 8GB, 240GB
5th: C2D T7200, 2GB, 16GB USB + NFS
Back to top
View user's profile Send private message
JoHo42
l33t
l33t


Joined: 14 Feb 2004
Posts: 944
Location: Germany

PostPosted: Sat Jul 11, 2009 3:04 pm    Post subject: Reply with quote

Hi,

ne ich brauche die net.ppp0 Datei wohl doch nicht.
Ich versuche heir das umtsmon ans laufen zu bekommen.
Das Programm braucht ppp und benutzt dies auch,
allerdings bekomme ich keine Verbindung damit ans laufen.

Das Programm gibt immer ppp Fehlermeldungen raus.

Ich suche halt ein Programm, welches die MB mitschreibt,
um zu kontrollieren wie viel MB ich im Monat uebertrage.
Das umtsmon scheint dies zu koennen.

vnstat geht nicht. Wenn das wvdial geschlossen wird,
kann der die Daten nicht mehr Speichern weil die PPP Verbindung
da nicht mehr ist.

Gruss Joerg
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3668
Location: Germany

PostPosted: Sat Jul 11, 2009 4:57 pm    Post subject: Reply with quote

JoHo42 wrote:
Hi,
Ich suche halt ein Programm, welches die MB mitschreibt,
um zu kontrollieren wie viel MB ich im Monat uebertrage.
Das umtsmon scheint dies zu koennen.
Dies macht gkrellm zb auch recht gut..und ganz nebenbei..
falls du dich damit anfreunden kannst,
evtl. reicht dir das ja schon?
Back to top
View user's profile Send private message
JoHo42
l33t
l33t


Joined: 14 Feb 2004
Posts: 944
Location: Germany

PostPosted: Sun Jul 19, 2009 4:10 pm    Post subject: Reply with quote

Hi Leute,

wie kann ich aus gtkrellm wvdial starten?
Ich habe das mal im Menu unter starten ppp0 eingetragen,
danach kann ich auch auf ppp0 klicken im gtkrelmm Fester.
Aber da passiert leider nichts.

Wie kann ich also wvdial ueber gtkrellm starten?

Gruss Joerg
Back to top
View user's profile Send private message
slick
Bodhisattva
Bodhisattva


Joined: 20 Apr 2003
Posts: 3495

PostPosted: Fri Jul 31, 2009 10:44 am    Post subject: Reply with quote

Hat jemand den passenden Eintrag (siehe Post von bbgermany) für die /etc/conf.d/net für T-Mobile UMTS?
Back to top
View user's profile Send private message
bbgermany
Veteran
Veteran


Joined: 21 Feb 2005
Posts: 1792
Location: Oranienburg/Germany

PostPosted: Fri Jul 31, 2009 8:53 pm    Post subject: Reply with quote

Na aber sicher ;) (zumindest glaube ich das dies es sein sollte):

APN: internet.t-mobile
Username und PW: tm (kannst du alles nehmen)
"Telefonnummer": *99***1#

MfG. Stefan
_________________
1st: i5-4570, 16GB, 1.75TB
2nd: i5-4570, 16GB, 620GB
3rd: i5-4570, 16GB, 10,5TB
4th: Asus N61VN, 8GB, 240GB
5th: C2D T7200, 2GB, 16GB USB + NFS
Back to top
View user's profile Send private message
Robelix
l33t
l33t


Joined: 21 Jul 2002
Posts: 760
Location: in a World created by a Flying Spaghetti Monster

PostPosted: Sat Aug 01, 2009 2:25 pm    Post subject: Reply with quote

Umtsmon habe ich auch schon mehrmals versucht, es hat bei mir immer den Effekt, daß der ppp sofort nach _erfolgreichem_ Verbindungsaufbau wieder beendet wird. Eine Erklärung dafür konnte ich noch nicht finden.
Kppp dagegen läuft brav, dürfte aber mangels Traffic-Log keine Alternative für dich sein.
(Huawei E160 mit yesss.at)
_________________
mysql> SELECT question FROM life, universe, everything WHERE answer=42;
Empty set (2079460347 sec)
Back to top
View user's profile Send private message
eisenmann
n00b
n00b


Joined: 08 Jan 2006
Posts: 31

PostPosted: Wed Sep 23, 2009 2:32 pm    Post subject: Reply with quote

Hi Leute,

da bisher alle versuche mit der umts einwahl nichts gebracht hben wollte ich das mal hier probieren. hier bewegt sich wenigstens was. Aber leider auch nicht so richtig.

So siehts nach den /etc/init.d/net.ppp0 aus:

Code:

Sep 23 16:28:04 mars chat[25849]: abort on (BUSY)
Sep 23 16:28:04 mars chat[25849]: abort on (ERROR)
Sep 23 16:28:04 mars chat[25849]: abort on (NO ANSWER)
Sep 23 16:28:04 mars chat[25849]: abort on (NO CARRIER)
Sep 23 16:28:04 mars chat[25849]: abort on (NO DIALTONE)
Sep 23 16:28:04 mars chat[25849]: abort on (Invalid Login)
Sep 23 16:28:04 mars chat[25849]: abort on (Login incorrect)
Sep 23 16:28:04 mars chat[25849]: timeout set to 1 seconds
Sep 23 16:28:04 mars chat[25849]: expect (OK)
Sep 23 16:28:05 mars chat[25849]: alarm
Sep 23 16:28:05 mars chat[25849]: Failed
Sep 23 16:28:05 mars pppd[24860]: Connect script failed


in der /etc/conf.d/net ist folgendes eingestellt:

Code:
config_ppp0=( "ppp" )
link_ppp0="/dev/ttyHS0" # Hier das genutze Device eintragen
username_ppp0='VFD2' # Username und Passwort spielen bei den meisten Anbietern
password_ppp0='WAP' # keine Rolle, da ?ber die SIM-Karte abgerechnet wird
pppd_ppp0=(
"debug"
"defaultroute"
"ipcp-accept-remote"
"ipcp-accept-local"
"lock"
"460800"
"modem crtscts"
"usepeerdns"
"crtscts"
"novj"
        )
chat_ppp0=(
'ABORT' 'BUSY'
'ABORT' 'ERROR'
'ABORT' 'NO ANSWER'
'ABORT' 'NO CARRIER'
'ABORT' 'NO DIALTONE'
'ABORT' 'Invalid Login'
'ABORT' 'Login incorrect'
'TIMEOUT' '1'
#'ATZ'
'OK' 'AT&F'
'OK' 'ATE1'
'OK' 'AT+CPIN?'
#'SAY' 'enter PIN'
#'CPIN: READY-AT+CPIN=xxxx-OK' 'AT+COPS?' # Hier ggf. die PIN eintragen
#'OK' 'AT_OPSYS=3,2' # Je nach Pr?ferenz anpassen
'OK' 'AT+CSQ'
'OK' 'AT+CGDCONT=1,"IP","web.vodafon.de","0.0.0.0"'
'TIMEOUT' '60'
'OK' 'ATD*99***1#'
#'SAY' 'Calling Vodafon'
'CONNECT' ''
'TIMEOUT' '5'
#'~--' ''
     )


die pin hab ich über wvdail eingegeben.

Was mache ich falsch?

Gruß?
Back to top
View user's profile Send private message
hank2000
n00b
n00b


Joined: 06 Dec 2003
Posts: 18
Location: Lake of Constance, Germany

PostPosted: Wed Sep 23, 2009 10:32 pm    Post subject: Reply with quote

probier mal

Code:

...
        'TIMEOUT' '5'
        '' 'ATZ'
        'OK' 'AT&F'
...


HTH
Back to top
View user's profile Send private message
eisenmann
n00b
n00b


Joined: 08 Jan 2006
Posts: 31

PostPosted: Thu Sep 24, 2009 7:25 am    Post subject: Reply with quote

Hi,
das war auf jedenfall ein guter Tipp denn es geht schon viel weiter siehe hier die

/var/log/mess[/code]ages

Code:

Sep 24 09:12:52 mars pppd[14051]: Plugin passwordfd.so loaded.
Sep 24 09:12:52 mars pppd[14052]: pppd 2.4.4 started by root, uid 0
Sep 24 09:12:53 mars chat[14059]: abort on (BUSY)
Sep 24 09:12:53 mars chat[14059]: abort on (ERROR)
Sep 24 09:12:53 mars chat[14059]: abort on (NO ANSWER)
Sep 24 09:12:53 mars chat[14059]: abort on (NO CARRIER)
Sep 24 09:12:53 mars chat[14059]: abort on (NO DIALTONE)
Sep 24 09:12:53 mars chat[14059]: abort on (Invalid Login)
Sep 24 09:12:53 mars chat[14059]: abort on (Login incorrect)
Sep 24 09:12:53 mars chat[14059]: timeout set to 5 seconds
Sep 24 09:12:53 mars chat[14059]: send (ATZ^M)
Sep 24 09:12:53 mars chat[14059]: expect (OK)
Sep 24 09:12:53 mars chat[14059]: ATZ^M^M
Sep 24 09:12:53 mars chat[14059]: OK
Sep 24 09:12:53 mars chat[14059]:  -- got it
Sep 24 09:12:53 mars chat[14059]: send (AT&F^M)
Sep 24 09:12:53 mars chat[14059]: expect (OK)
Sep 24 09:12:53 mars chat[14059]: ^M
Sep 24 09:12:53 mars chat[14059]: AT&F^M^M
Sep 24 09:12:53 mars chat[14059]: OK
Sep 24 09:12:53 mars chat[14059]:  -- got it
Sep 24 09:12:53 mars chat[14059]: send (ATE1^M)
Sep 24 09:12:54 mars chat[14059]: expect (OK)
Sep 24 09:12:54 mars chat[14059]: ^M
Sep 24 09:12:54 mars chat[14059]: ATE1^M^M
Sep 24 09:12:54 mars chat[14059]: OK
Sep 24 09:12:54 mars chat[14059]:  -- got it
Sep 24 09:12:54 mars chat[14059]: send (AT+CSQ^M)
Sep 24 09:12:54 mars chat[14059]: expect (OK)
Sep 24 09:12:54 mars chat[14059]: ^M
Sep 24 09:12:54 mars chat[14059]: AT+CSQ^M^M
Sep 24 09:12:54 mars chat[14059]: +CSQ: 23,99^M
Sep 24 09:12:54 mars chat[14059]: ^M
Sep 24 09:12:54 mars chat[14059]: OK
Sep 24 09:12:54 mars chat[14059]:  -- got it
Sep 24 09:12:54 mars chat[14059]: send (AT+CGDCONT=1,"IP","web.vodafon.de","0.0.0.0"^M)
Sep 24 09:12:54 mars chat[14059]: timeout set to 60 seconds
Sep 24 09:12:54 mars chat[14059]: expect (OK)
Sep 24 09:12:54 mars chat[14059]: ^M
Sep 24 09:12:54 mars chat[14059]: AT+CGDCONT=1,"IP","web.vodafon.de","0.0.0.0"^M^M
Sep 24 09:12:54 mars chat[14059]: OK
Sep 24 09:12:54 mars chat[14059]:  -- got it
Sep 24 09:12:54 mars chat[14059]: send (ATD*99***1#^M)
Sep 24 09:12:54 mars chat[14059]: expect (CONNECT)
Sep 24 09:12:54 mars chat[14059]: ^M
Sep 24 09:13:54 mars chat[14059]: alarm
Sep 24 09:13:54 mars chat[14059]: Failed
Sep 24 09:13:54 mars pppd[14052]: Connect script failed


Vielleicht liegt es an diese komischen "^M" Wo die allerdings her kommen weis ich nicht. In der config stehen sie nicht.

Code:

config_ppp0=( "ppp" )
link_ppp0="/dev/ttyHS0" # Hier das genutze Device eintragen
username_ppp0='VFD2' # Username und Passwort spielen bei den meisten Anbietern
password_ppp0='WAP' # keine Rolle, da ?ber die SIM-Karte abgerechnet wird
pppd_ppp0=(
"debug"
"defaultroute"
"ipcp-accept-remote"
"ipcp-accept-local"
"lock"
"460800"
"modem crtscts"
"usepeerdns"
"crtscts"
"novj"
        )
chat_ppp0=(
'ABORT' 'BUSY'
'ABORT' 'ERROR'
'ABORT' 'NO ANSWER'
'ABORT' 'NO CARRIER'
'ABORT' 'NO DIALTONE'
'ABORT' 'Invalid Login'
'ABORT' 'Login incorrect'
'TIMEOUT' '5'
'' 'ATZ'
'OK' 'AT&F'
'OK' 'ATE1'
#'OK' 'AT+CPIN?'
#'SAY' 'enter PIN'
#'CPIN: READY-AT+CPIN=xxxx-OK' 'AT+COPS?' # Hier ggf. die PIN eintragen
#'OK' 'AT_OPSYS=3,2' # Je nach Pr?ferenz anpassen
'OK' 'AT+CSQ'
'OK' 'AT+CGDCONT=1,"IP","web.vodafon.de","0.0.0.0"'
'TIMEOUT' '60'
'OK' 'ATD*99***1#'
#'SAY' 'Calling Vodafon'
'CONNECT' ''
'TIMEOUT' '5'
'~--' ''
     )


Jetzt kommt er ja bis zum wählen und dann macht er nicht weiter.
Back to top
View user's profile Send private message
spielc
Guru
Guru


Joined: 20 Apr 2004
Posts: 452

PostPosted: Thu Sep 24, 2009 8:03 pm    Post subject: Reply with quote

eisenmann wrote:

Code:

config_ppp0=( "ppp" )
link_ppp0="/dev/ttyHS0" # Hier das genutze Device eintragen
username_ppp0='VFD2' # Username und Passwort spielen bei den meisten Anbietern
password_ppp0='WAP' # keine Rolle, da ?ber die SIM-Karte abgerechnet wird
pppd_ppp0=(
"debug"
"defaultroute"
"ipcp-accept-remote"
"ipcp-accept-local"
"lock"
"460800"
"modem crtscts"
"usepeerdns"
"crtscts"
"novj"
        )
chat_ppp0=(
'ABORT' 'BUSY'
'ABORT' 'ERROR'
'ABORT' 'NO ANSWER'
'ABORT' 'NO CARRIER'
'ABORT' 'NO DIALTONE'
'ABORT' 'Invalid Login'
'ABORT' 'Login incorrect'
'TIMEOUT' '5'
'' 'ATZ'
'OK' 'AT&F'
'OK' 'ATE1'
#'OK' 'AT+CPIN?'
#'SAY' 'enter PIN'
#'CPIN: READY-AT+CPIN=xxxx-OK' 'AT+COPS?' # Hier ggf. die PIN eintragen
#'OK' 'AT_OPSYS=3,2' # Je nach Pr?ferenz anpassen
'OK' 'AT+CSQ'
'OK' 'AT+CGDCONT=1,"IP","web.vodafon.de","0.0.0.0"'
'TIMEOUT' '60'
'OK' 'ATD*99***1#'
#'SAY' 'Calling Vodafon'
'CONNECT' ''
'TIMEOUT' '5'
'~--' ''
     )


Jetzt kommt er ja bis zum wählen und dann macht er nicht weiter.


Ich hatte ein ähnliches Problem. Bei mir war das Problem das baselayout irgendwie nicht mit dem Chat-Skript in der /etc/conf.d/net klargekommen ist. Als ich dann einfach das Chat-Skript in ein eigenes File ausgelagert habe und folgendes zum Konfigurationsteil von pppd_ppp0 hinzugefügt habe, hats endlich funktioniert:

Code:

"connect '/usr/sbin/chat -f /etc/ppp/mobook-pin || /usr/sbin/chat -f /etc/ppp/mobook-nopin'"

_________________
Raise your beers up high...
Back to top
View user's profile Send private message
sirro
Veteran
Veteran


Joined: 20 Jul 2003
Posts: 1472
Location: aachen.nrw.de.eu

PostPosted: Thu Sep 24, 2009 8:33 pm    Post subject: Reply with quote

eisenmann wrote:
Vielleicht liegt es an diese komischen "^M" Wo die allerdings her kommen weis ich nicht. In der config stehen sie nicht.

^M ist oft ein Zeichen für Windows-Zeilenenden. Z.B. app-text/dos2unix kannst du die umwandeln (vorher sichern, kann aber eigentlich nichts schief gehen ;-))
Back to top
View user's profile Send private message
slick
Bodhisattva
Bodhisattva


Joined: 20 Apr 2003
Posts: 3495

PostPosted: Sat Aug 07, 2010 5:17 pm    Post subject: Reply with quote

Hilfe!

Hat jemand bitte ein copy&paste freundliches, funktionierendes Setup für den O2 Surfstick möglichst via /etc/conf.d/net und möglichst nicht wvdial? Habe diverse Howtos durchprobiert (und mir den Sa. damit versaut), aber irgendwie habe ich anscheinend immer das falsche Chatscript oder dergleichen. Ich gebs auf.

Stick ist ein ZTE und /dev/ttyUSB0-2 sind vorhanden.

Dankeschön.
Back to top
View user's profile Send private message
slick
Bodhisattva
Bodhisattva


Joined: 20 Apr 2003
Posts: 3495

PostPosted: Sun Aug 08, 2010 9:49 am    Post subject: Reply with quote

Habe es hinbekommen. Problem war das ich immer /dev/ttyUSB0 angesprochen habe, statt /dev/ttyUSB2. Jetzt geht alles.

PIN habe ich deaktiviert. usb-modeswitch habe ich nicht benötigt. Einfach Kernel passend konfigurieren und einstecken, 10 sek. warten, fertig.

/etc/conf.d/net wrote:
config_ppp0=( "ppp" )
link_ppp0="/dev/ttyUSB2"
pppd_ppp0=(
"connect '/usr/sbin/chat -v -f /etc/ppp/peers/umts-chatscript-connect'"
"disconnect '/usr/sbin/chat -v -f /etc/ppp/peers/umts-chatscript-disconnect'"
"defaultroute"
"460800"
"local"
"debug"
"noipdefault"
"noauth"
)


/etc/ppp/peers/umts-chatscript-connect wrote:
REPORT CONNECT
ABORT BUSY
ABORT "NO CARRIER"
ABORT "NO DIALTONE"
"" ATZ
OK "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"
OK AT+CGDCONT=1,"IP","surfo2"
OK ATD*99#
CONNECT


/etc/ppp/peers/umts-chatscript-disconnect wrote:
ABORT "BUSY"
ABORT "ERROR"
ABORT "NO DIALTONE"
SAY "\nSending break to the modem\n"
"" "\K"
"" "\K"
"" "\K"
"" "+++ATH"
"" "+++ATH"
"" "+++ATH"


dmesg wrote:
usb 1-4: new high speed USB device using ehci_hcd and address 6
usb 1-4: New USB device found, idVendor=19d2, idProduct=2000
usb 1-4: New USB device strings: Mfr=3, Product=2, SerialNumber=4
usb 1-4: Product: ZTE WCDMA Technologies MSM
usb 1-4: Manufacturer: ZTE,Incorporated
usb 1-4: SerialNumber: XXXXXXXXXXXX
scsi8 : usb-storage 1-4:1.0
scsi 8:0:0:0: CD-ROM ZTE USB SCSI CD-ROM 2.31 PQ: 0 ANSI: 2
scsi 8:0:0:1: Direct-Access ZTE MMC Storage 2.31 PQ: 0 ANSI: 2
sr1: scsi-1 drive
sr 8:0:0:0: Attached scsi CD-ROM sr1
sr 8:0:0:0: Attached scsi generic sg4 type 5
sd 8:0:0:1: Attached scsi generic sg9 type 0
sd 8:0:0:1: [sdd] Attached SCSI removable disk
usb 1-4: USB disconnect, address 6
usb 1-4: new high speed USB device using ehci_hcd and address 7
usb 1-4: New USB device found, idVendor=19d2, idProduct=0016
usb 1-4: New USB device strings: Mfr=3, Product=2, SerialNumber=4
usb 1-4: Product: ZTE WCDMA Technologies MSM
usb 1-4: Manufacturer: ZTE,Incorporated
usb 1-4: SerialNumber: XXXXXXXXXXXXX
option 1-4:1.0: GSM modem (1-port) converter detected
usb 1-4: GSM modem (1-port) converter now attached to ttyUSB0
option 1-4:1.1: GSM modem (1-port) converter detected
usb 1-4: GSM modem (1-port) converter now attached to ttyUSB1
option 1-4:1.2: GSM modem (1-port) converter detected
usb 1-4: GSM modem (1-port) converter now attached to ttyUSB2
scsi9 : usb-storage 1-4:1.3
scsi 9:0:0:0: Direct-Access ZTE MMC Storage 2.31 PQ: 0 ANSI: 2
sd 9:0:0:0: Attached scsi generic sg4 type 0
sd 9:0:0:0: [sdd] Attached SCSI removable disk
Back to top
View user's profile Send private message
herrlado
n00b
n00b


Joined: 08 Nov 2010
Posts: 1

PostPosted: Mon Nov 08, 2010 10:28 pm    Post subject: Reply with quote

Moin.

Ich habe hier diverse Varianten ausprobiert.
Mein Problem ist die PIN Eingabe. Wenn ich erst mals net.ppp0 starte wir das die PIN
eingegeben, dann aber kommt Connection Failed.

Ich muss danach net.ppp0 restart machen und schon lauft das Teil.

Ist etwas nervig, obwohl man damit leben koennte. Wie sieht es mit der PIN Eingaben bei euch aus?

Gruss,
Lado
Back to top
View user's profile Send private message
slick
Bodhisattva
Bodhisattva


Joined: 20 Apr 2003
Posts: 3495

PostPosted: Tue Nov 09, 2010 4:00 pm    Post subject: Reply with quote

Pin-Eingabe hab ich an einem Windows mittels der Software abgeschaltet. Es soll auch gehen die Karte ins Handy einlegen und darüber die Pin einfach deaktivieren.
Back to top
View user's profile Send private message
schmutzfinger
Veteran
Veteran


Joined: 26 Oct 2003
Posts: 1287
Location: Dresden/Germany

PostPosted: Mon Nov 22, 2010 7:33 pm    Post subject: Reply with quote

Ich benutze pon und poff aus dem ppp Paket. Zum Auflegen habe ich ein kleines Script geschrieben. Bevor es poff aufruft schreibt es die Trafficdaten in eine Datei. Der Kern merkt sich für jeden Interface wieviel Traffic drüber ging und das kann man mit ifconfig auslesen.

Code:

/bin/date >> traffic_log
/sbin/ifconfig ppp0 | /bin/grep "RX bytes" >> traffic_log
/usr/bin/sudo /usr/sbin/poff base


Dazu habe ich ein Script geschrieben um die Datei "traffic_log" auszuwerten. Das summiert einfach alle Einträge, die es darin findet. Leider funktioniert das nur wenn ich die Verbindung mit meinem Script trenne. Wenn die Verbindung abbricht dann verliere ich den Traffic für die ganze Sitzung. Die Lösung dazu ist eigentlich einfach aber ich war bisher zu faul das umzubauen. pppd schreibt am Ende eine Sitzung den Traffic ins syslog und da kann man die Daten jeder Zeit rausholen. Egal ob man selbst auflegt oder die Verbindung verliert.

Quote:

[pppd] Connect time 237.3 minutes.
[pppd] Sent 5182958 bytes, received 40203862 bytes.
[pppd] Connection terminated.
[pppd] Exit.


Ein script was diese Daten aus den Logs sammelt sollte am besten von pppd selbst ausgeführt werden. Dazu scheint die Option "disconnect script" interessant zu sein.
Wenn man metalog nutzt kann man das sicherlich mit einer regexp auch ganz einfach in den syslog-Dienst direkt einbauen.
Back to top
View user's profile Send private message
schmutzfinger
Veteran
Veteran


Joined: 26 Oct 2003
Posts: 1287
Location: Dresden/Germany

PostPosted: Mon Nov 22, 2010 7:42 pm    Post subject: Reply with quote

slick wrote:
Pin-Eingabe hab ich an einem Windows mittels der Software abgeschaltet. Es soll auch gehen die Karte ins Handy einlegen und darüber die Pin einfach deaktivieren.


Die Software hat wohl nix weiter gemacht als dem Modem "AT+CLCK=SC,0" zu schicken.
http://3g-modem.wetpaint.com/page/common+AT-commands
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum