Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Diverse Schwierigkeiten im Drucksystem
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1169
Location: Buchholz/GER

PostPosted: Sat Nov 13, 2010 7:49 am    Post subject: Diverse Schwierigkeiten im Drucksystem Reply with quote

Moin,
ich muss mich mal hilfesuchend an Euch wenden. Ich habe seit geraumer Zeit (seit wann, weiss ich nicht genau) diverse Schwierigkeiten mit meinem Drucksystem. Bestimmte Seiten druckt mir cups (egal, welche Version, an cups selbst liegt es also eher nicht) quasi übereinander, so, als würde er fünf Seiten auf das gleiche Blatt drucken ... immer ein paar Millimeter verschoben. Ganz merkwürdig.

Wenn ich beispielsweise einen Gutschein von Amazon ausdrucke, ist die Hintergrundfarbe schwarz (anstatt weiss), und mit hellschwarz bedruckt ... die Lesbarkeit ist - ach was - stark eingeschränkt. Ich habe schon Downgrades von cups durchgeführt, aber das hat's nicht gebracht.

Wer könnte noch Auslöser für solche Merkwürdigkeiten sein. Hat jemand 'ne schöne emerge-Zeile, um das komplette Drucksystem runterzukegeln, damit ich es mal neu installieren kann? Drucker ist ein HP PhotoSmart C7180, angesprochen via Ethernet. Drucken von anderen Clients (Ubuntu, Debian sid) funktioniert problemlos, also eher kein Hardwaredefekt.
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
schmutzfinger
Veteran
Veteran


Joined: 26 Oct 2003
Posts: 1287
Location: Dresden/Germany

PostPosted: Mon Nov 22, 2010 6:48 pm    Post subject: Reply with quote

Gerade für HP Drucker gibt es meist mehr als nur einen Treiber zur Auswahl. Vielleicht ist der, den du in gentoo nutzt einfach nicht der richtige. Kopiere dir einfach mal das .ppd von einem Rechner und ersetze es auf dem gentoo-System.
Also kopiere ubunut-kiste:/etc/cups/ppd/{Druckername_in_Ubunut}.ppd nach gentoo-kiste:/etc/cups/ppd/{Druckername_in_Gentoo}.ppd.
Dann cups neu starten und probieren.

Sollte das dein Problem lösen dann kannst du es im Prinzip auch schon so lassen. Wenn du beim Erstellen eines neue Druckers einen Treiber auswählst dann kopiert cups den Treiber auch nur dorthin und nennt ihn wie den Drucker.

In einem Netzwerk mit mehreren Linux-Rechnern würde ich allerdings vorschlagen nur auf einem Server tatsächlich cupsd laufen zu lassen. Den anderen sagt man dann nur noch wer ihr Server ist (man client.conf) und sie haben alle Drucker/Einstellungen und müssen nichtmal cupsd laufen haben.
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1169
Location: Buchholz/GER

PostPosted: Mon Nov 22, 2010 7:13 pm    Post subject: Reply with quote

Hi,
danke fürs (späte) Feedback. Ich habe das Problem mittlerweile durch Neuinstallation mit gleichzeitigem Rückschritt von unstable auf stable gelöst. Ich hatte noch so zwei, drei Sachen, die mir unstable ein bisschen lästig gemacht haben und momentan fehlt mir Zeit und Muße, dem jeweils einzeln auf den Grund zu gehen. Zurück nach stable -> alles gut.
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
FelixPetzold
n00b
n00b


Joined: 10 May 2010
Posts: 24
Location: Paderborn/Germany

PostPosted: Tue Nov 23, 2010 3:25 pm    Post subject: Reply with quote

Das betrifft auch stable Gentoo. Wenn du wissen willst, woran es lag, schau dir mal folgendes an:
http://www.gentoofreunde.org/supportforum/viewtopic.php?f=10&t=301
http://www.gentoofreunde.org/node/524
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1169
Location: Buchholz/GER

PostPosted: Tue Nov 23, 2010 3:28 pm    Post subject: Reply with quote

1) Ein Wechsel auf hpijs hat bei mir damals auf unstable nichts gebracht
2) Jetzt unter stable gehts, obwohl die USE-Flags nicht verändert sind
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1169
Location: Buchholz/GER

PostPosted: Thu Nov 25, 2010 2:54 pm    Post subject: Reply with quote

FelixPetzold wrote:
Das betrifft auch stable Gentoo. Wenn du wissen willst, woran es lag, schau dir mal folgendes an:
http://www.gentoofreunde.org/supportforum/viewtopic.php?f=10&t=301
http://www.gentoofreunde.org/node/524

Eigens um das nachzuvollziehen, wechsle ich gerade nochmal von stable auf ~amd64. Naja, ok, gut, nicht nur deswegen. :D

Mir ist derweil aufgefallen, dass ich letztes mal hpijs aktiviert, hpcups aber nicht deaktiviert habe. Vielleicht lags daran?
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
schmutzfinger
Veteran
Veteran


Joined: 26 Oct 2003
Posts: 1287
Location: Dresden/Germany

PostPosted: Fri Nov 26, 2010 8:16 pm    Post subject: Reply with quote

Hast du das funktionierende ppd einfach mal kopiert und probiert? Damit kommst du sicher schneller zum Ziel als durch wildes Rumraten und USE-Flag Kombinationen ausprobieren.
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1169
Location: Buchholz/GER

PostPosted: Fri Nov 26, 2010 8:22 pm    Post subject: Reply with quote

Ich wüsste nicht, warum sich das PPD jemals verändert haben sollte. Abgesehen davon ist mir vorerst 'Rumraten' (wobei es das nicht ganz richtig trifft) mit USE-Flags lieber, als Dateien am Paketmanagement vorbei ins System zu kopieren.
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
schmutzfinger
Veteran
Veteran


Joined: 26 Oct 2003
Posts: 1287
Location: Dresden/Germany

PostPosted: Fri Nov 26, 2010 9:04 pm    Post subject: Reply with quote

Es geht vielmehr darum, dass du eventuell auf deinen vielen Rechnern vielleicht nicht überall den selben Treiber nutzt. Dann guck mal, ob es ein diff zwischen dem guten und dem schlechten ppd gibt. (/etc sollte dem Paketsystem reichlich egal sein)
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1169
Location: Buchholz/GER

PostPosted: Fri Nov 26, 2010 9:09 pm    Post subject: Reply with quote

Ich habe nur einen Rechner, darauf nur ein Gentoo-System und folglich jeweils auch nur eine Version der verwendeten PPD. Falls das irgendwo anders rübergekommen sein sollte ... war nicht meine Absicht.
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
schmutzfinger
Veteran
Veteran


Joined: 26 Oct 2003
Posts: 1287
Location: Dresden/Germany

PostPosted: Fri Nov 26, 2010 9:21 pm    Post subject: Reply with quote

Ja im ersten post stand was von ubuntu und debian.
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1169
Location: Buchholz/GER

PostPosted: Sat Nov 27, 2010 6:30 am    Post subject: Reply with quote

Das sind die Kisten anderer Familienmitgliedern. Mir gehts nur um meine Gentoo-Box, die druckt unter stable 1a und unter unstable gabs halt Probleme (die offenbar (vgl. die o.g. Links) auch andere hatten).
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum