Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
compiz-bcop is blocking compz-0.9.2
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
matomato76
n00b
n00b


Joined: 19 Nov 2010
Posts: 11

PostPosted: Fri Nov 19, 2010 7:59 am    Post subject: compiz-bcop is blocking compz-0.9.2 Reply with quote

Thanks in advance. ^^;;

I tried to update compiz from 0.8.6 to 0.9.2. It looks that compiz and most of packages are installed. However, compiz-bcop is not installed, emitting the following message.

------------------
Calculating dependencies... done!
[ebuild N ] x11-libs/compiz-bcop-0.8.4 0 kB [1]
[blocks B ] x11-libs/compiz-bcop ("x11-libs/compiz-bcop" is blocking x11-wm/compiz-0.9.2)

Total: 1 package (1 new), Size of downloads: 0 kB
Conflict: 1 block (1 unsatisfied)
Portage tree and overlays:
[0] /usr/portage
[1] /usr/local/portage

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

('ebuild', '/', 'x11-libs/compiz-bcop-0.8.4', 'merge') pulled in by
compiz-bcop

('installed', '/', 'x11-wm/compiz-0.9.2', 'nomerge') pulled in by
x11-wm/compiz required by world


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

--------------

What happened to me?

I can set options with ccdm. However, whenever I run compiz by "compiz ccp --sm-disable --replace", I got segmentation fault. Or, whenver tried fusion-icon, the error message as follows;

-----
* Detected Session: gnome
* Searching for installed applications...
Backend : gconf
Integration : true
Profile : default
Traceback (most recent call last):
File "/usr/bin/fusion-icon", line 57, in <module>
from FusionIcon.interface import choose_interface
File "/usr/lib/python2.6/site-packages/FusionIcon/interface.py", line 22, in <module>
from util import env
File "/usr/lib/python2.6/site-packages/FusionIcon/util.py", line 421, in <module>
decorators = CompizDecorators(_installed)
File "/usr/lib/python2.6/site-packages/FusionIcon/util.py", line 228, in __init__
self.command = context.Plugins['decoration'].Display['command']
KeyError: 'decoration'
-----

Isn't the option set correctly due to the missing compiz-bcop?

I don't know why emerge compiz-bcop complains in such a way. The only thing that I am suspicious about is that I made local overlay for 'screensaver', whose RDEPEND is compiz-bcop, and ebuild screensave digest. Then, I simply deleted the directory. Did it affect the dependency tree of portage so that I got the broken dependency and that's why compiz-bcop complains?

Please, help me. T.T I am about to re-install this gentoo, as you know, it will take several days!

Thank you.
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 9268

PostPosted: Mon Nov 22, 2010 5:57 am    Post subject: Reply with quote

The overlay you are using should have the required dependencies, try checking for keywording a masking requirements, once those are satisfied you should be able to install complete the update you are attempting.

Moved from Portage & Programming to Unsupported Software, given that the ebuilds in question are not in the tree.
Back to top
View user's profile Send private message
andrewthomas
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2010
Posts: 93

PostPosted: Fri Nov 26, 2010 2:22 pm    Post subject: Reply with quote

The fusion-icon is not going to work, since it is a python package and compiz-0.9.2 is written in c++, so just unmerge it. As to the bcop, probably the same. What happens when you start compiz with
Code:
compiz --replace ccp
Back to top
View user's profile Send private message
matomato76
n00b
n00b


Joined: 19 Nov 2010
Posts: 11

PostPosted: Mon Nov 29, 2010 7:39 am    Post subject: Thank you for your help Reply with quote

First of all, I am sorry for putting my posting on the Portage & Programming board. I didn't know that I shouldn't do it since this is the first time that I install gentoo and post something on this site. Thank you for letting me know and moving my posting to the proper place.

In addition to that, thank you for telling me what's going on in my system. After bcop and fusion-icon were un-merged, compiz 0.9.2 has been successfully installed. However, "compiz --replace ccp" causes segmentation faults.

Right now, since I do not have much time for trouble shooting, I've reverted my system by removing the desktop-effects overlay. I wish I would have a chance to deal with this problem again, in near future.

Thank you so much, anyway.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum