Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved]KDE Window Manager
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
guije
Apprentice
Apprentice


Joined: 18 Sep 2006
Posts: 192

PostPosted: Wed Nov 24, 2010 11:04 am    Post subject: [solved]KDE Window Manager Reply with quote

Hallo,

wie kommt es eigentlich das ich bei jedem logon Compositing per Alt+Shift+F12 starten muß?

Die Meldung vom Window Manager lautet:

Compositing has been suspended by another application.
You can resume using the Alt+Shift+F12 shortcut.

_________________
Linux localhost 2.6.39-gentoo-r3 #10 SMP Sun Nov 6 11:04:07 GMT 2011 i686 AMD Athlon(tm) XP 2600+ AuthenticAMD GNU/Linux


Last edited by guije on Sun Nov 28, 2010 8:35 am; edited 1 time in total
Back to top
View user's profile Send private message
Yamakuzure
Advocate
Advocate


Joined: 21 Jun 2006
Posts: 2273
Location: Bardowick, Germany

PostPosted: Wed Nov 24, 2010 11:25 am    Post subject: Reply with quote

Das passiert, wenn etwas mit dem Treiber nicht stimmt und die Funktionstests fehlschlagen (*). Zum Beispiel macht mein Laptop das, wenn ich Gallium3D verwenden möchte (i965, mesa-7.9, OpenGL-backend).

Was steht denn in deiner ~/.kde4/share/config/kwinrc unter "[Compositing]" ?

(*) Es kann aber natürlich auch andere Gründe geben, jedoch kenne ich nur kwin und powerdevil, die die Effekte selber abschalten.
_________________
Important German:
  1. "Aha" - German reaction to pretend that you are really interested while giving no f*ck.
  2. "Tja" - German reaction to the apocalypse, nuclear war, an alien invasion or no bread in the house.
Back to top
View user's profile Send private message
guije
Apprentice
Apprentice


Joined: 18 Sep 2006
Posts: 192

PostPosted: Thu Nov 25, 2010 1:08 am    Post subject: Reply with quote

Code:
[$Version]
update_info=kwin3_plugin.upd:kde3.2,kwin_focus1.upd:kwin_focus1,kwin.upd:kde3.0r1,kwin.upd:kde3.2Xinerama,kwin_on_off.upd:kwin_on_off,kwin_focus2.upd:kwin_focus2

[Compositing]
AnimationSpeed=3
Backend=OpenGL
CheckIsSafe=true
DisableChecks=false
Enabled=true
GLDirect=true
GLMode=TFP
GLTextureFilter=1
GLVSync=true
HiddenPreviews=5
XRenderSmoothScale=false

_________________
Linux localhost 2.6.39-gentoo-r3 #10 SMP Sun Nov 6 11:04:07 GMT 2011 i686 AMD Athlon(tm) XP 2600+ AuthenticAMD GNU/Linux
Back to top
View user's profile Send private message
Yamakuzure
Advocate
Advocate


Joined: 21 Jun 2006
Posts: 2273
Location: Bardowick, Germany

PostPosted: Thu Nov 25, 2010 10:12 am    Post subject: Reply with quote

Du könntest noch
Code:
OpenGLIsUnsafe=false
hinzufügen. Aber ich glaube es liegt eher an etwas Anderem:

Grundsätzlich fallen mir nur zwei Gründe ein, warum es bei dir so ist:
  1. Du hast einen Laptop, und das Standard-Profil ist "Powersave"
    --> Powerdevil deaktiviert die Effekte um Strom zu sparen.
  2. Du hast eine ATI GraKa und benutzt fglrx
    --> Das ist bei diesem Treiber (derzeit) so, Google liefert eine Menge "Beschwerden" deswegen.
Zu 1.: Einfach das Standard-Profil ändern. ;)
Zu 2.: In deiner ~/.kde4/share/config/kwinrc die Zeile
Code:
DisableChecks=false
durch
Code:
DisableChecks=true
ersetzen. (Oder, falls du gerade in KDE eingeloggt bist, einfach in den Systemeinstellungen->Arbeitsflächen-Effekte->Erweitert den Haken bei "Funktionsprüfungen deaktivieren" setzen.)
_________________
Important German:
  1. "Aha" - German reaction to pretend that you are really interested while giving no f*ck.
  2. "Tja" - German reaction to the apocalypse, nuclear war, an alien invasion or no bread in the house.
Back to top
View user's profile Send private message
guije
Apprentice
Apprentice


Joined: 18 Sep 2006
Posts: 192

PostPosted: Sun Nov 28, 2010 8:35 am    Post subject: Reply with quote

Danke, hat geklappt mit 2. ~/.kde4/share/config/kwinrc

Code:
DisableChecks=true

_________________
Linux localhost 2.6.39-gentoo-r3 #10 SMP Sun Nov 6 11:04:07 GMT 2011 i686 AMD Athlon(tm) XP 2600+ AuthenticAMD GNU/Linux
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum