Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kde-base/kdelibs-3.5.10-r6 failed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2571
Location: Edmonton, AB

PostPosted: Sun Nov 28, 2010 6:54 am    Post subject: kde-base/kdelibs-3.5.10-r6 failed Reply with quote

revdep-rebuild is trying to rebuild few kde3.5 dependency I need for "kbarcode" but it fails
Code:
ndef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -DNDEBUG -DNO_DEBUG -O2 -O2 -march=athlon-xp -pipe -fomit-frame-pointer -Wformat-security -Wmissing-format-attribute -Wno-non-virtual-dtor -fno-exceptions -fno-check-new -fno-common  -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION  -c -o ksslcertificate.lo ksslcertificate.cc
In file included from ksslcertificate.cc:62:
./kopenssl.h:453: error: ISO C++ forbids declaration of 'ASN1_METHOD' with no type
./kopenssl.h:453: error: expected ';' before '*' token
./kopenssl.h:526: error: expected ';' before '(' token
./kopenssl.h:532: error: 'STACK' has not been declared
./kopenssl.h:538: error: 'STACK' has not been declared
./kopenssl.h:544: error: expected ';' before '(' token
./kopenssl.h:550: error: ISO C++ forbids declaration of 'STACK' with no type
./kopenssl.h:550: error: expected ';' before '*' token
./kopenssl.h:556: error: 'STACK' has not been declared
./kopenssl.h:562: error: ISO C++ forbids declaration of 'STACK' with no type
./kopenssl.h:562: error: expected ';' before '*' token
./kopenssl.h:828: error: ISO C++ forbids declaration of 'STACK' with no type
./kopenssl.h:828: error: expected ';' before '*' token
./kopenssl.h:829: error: 'STACK' has not been declared
ksslcertificate.cc: In member function 'void KSSLCertificate::getEmails(QStringList&) const':
ksslcertificate.cc:228: error: 'STACK' was not declared in this scope
ksslcertificate.cc:228: error: 's' was not declared in this scope
ksslcertificate.cc:228: error: 'class KOpenSSLProxy' has no member named 'X509_get1_email'
ksslcertificate.cc:231: error: 'class KOpenSSLProxy' has no member named 'sk_value'
In file included from ksslsettings.cc:47:
./kopenssl.h:453: error: ISO C++ forbids declaration of 'ASN1_METHOD' with no type
./kopenssl.h:453: error: expected ';' before '*' token
./kopenssl.h:526: error: expected ';' before '(' token
./kopenssl.h:532: error: 'STACK' has not been declared
./kopenssl.h:538: error: 'STACK' has not been declared
./kopenssl.h:544: error: expected ';' before '(' token
./kopenssl.h:550: error: ISO C++ forbids declaration of 'STACK' with no type
./kopenssl.h:550: error: expected ';' before '*' token
./kopenssl.h:556: error: 'STACK' has not been declared
./kopenssl.h:562: error: ISO C++ forbids declaration of 'STACK' with no type
./kopenssl.h:562: error: expected ';' before '*' token
./kopenssl.h:828: error: ISO C++ forbids declaration of 'STACK' with no type
./kopenssl.h:828: error: expected ';' before '*' token
./kopenssl.h:829: error: 'STACK' has not been declared
ksslsettings.cc: In member function 'QString KSSLSettings::getCipherList()':
ksslsettings.cc:157: error: no matching function for call to 'KOpenSSLProxy::sk_num(_STACK*)'
./kopenssl.h:538: note: candidates are: int KOpenSSLProxy::sk_num(int*)
ksslsettings.cc:159: error: 'class KOpenSSLProxy' has no member named 'sk_value'
ksslcertificate.cc: In member function 'QByteArray KSSLCertificate::toNetscape()':
ksslcertificate.cc:1006: error: 'ASN1_HEADER' was not declared in this scope
ksslcertificate.cc:1006: error: expected ';' before 'ah'
ksslcertificate.cc:1012: error: 'ah' was not declared in this scope
ksslcertificate.cc:1014: error: 'class KOpenSSLProxy' has no member named 'X509_asn1_meth'
ksslcertificate.cc: In member function 'QStringList KSSLCertificate::subjAltNames() const':
ksslcertificate.cc:1093: error: no matching function for call to 'KOpenSSLProxy::sk_num(_STACK*)'
./kopenssl.h:538: note: candidates are: int KOpenSSLProxy::sk_num(int*)
ksslcertificate.cc:1096: error: 'class KOpenSSLProxy' has no member named 'sk_value'
ksslcertificate.cc:1106: error: no matching function for call to 'KOpenSSLProxy::sk_free(stack_st_GENERAL_NAME*&)'
./kopenssl.h:532: note: candidates are: void KOpenSSLProxy::sk_free(int*)
make[5]: *** [ksslcertificate.lo] Error 1
make[5]: *** Waiting for unfinished jobs....
make[5]: *** [ksslsettings.lo] Error 1
In file included from kssl.cc:47:
./kopenssl.h:453: error: ISO C++ forbids declaration of 'ASN1_METHOD' with no type
./kopenssl.h:453: error: expected ';' before '*' token
./kopenssl.h:526: error: expected ';' before '(' token
./kopenssl.h:532: error: 'STACK' has not been declared
./kopenssl.h:538: error: 'STACK' has not been declared
./kopenssl.h:544: error: expected ';' before '(' token
./kopenssl.h:550: error: ISO C++ forbids declaration of 'STACK' with no type
./kopenssl.h:550: error: expected ';' before '*' token
./kopenssl.h:556: error: 'STACK' has not been declared
./kopenssl.h:562: error: ISO C++ forbids declaration of 'STACK' with no type
./kopenssl.h:562: error: expected ';' before '*' token
./kopenssl.h:828: error: ISO C++ forbids declaration of 'STACK' with no type
./kopenssl.h:828: error: expected ';' before '*' token
./kopenssl.h:829: error: 'STACK' has not been declared
kssl.cc: In member function 'void KSSL::setPeerInfo()':
kssl.cc:616: error: 'class KOpenSSLProxy' has no member named 'sk_dup'
make[5]: *** [kssl.lo] Error 1
make[5]: Leaving directory `/var/tmp/portage/kde-base/kdelibs-3.5.10-r6/work/kdelibs-3.5.10/kio/kssl'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/var/tmp/portage/kde-base/kdelibs-3.5.10-r6/work/kdelibs-3.5.10/kio/kssl'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/var/tmp/portage/kde-base/kdelibs-3.5.10-r6/work/kdelibs-3.5.10/kio/kssl'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/kde-base/kdelibs-3.5.10-r6/work/kdelibs-3.5.10/kio'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/kde-base/kdelibs-3.5.10-r6/work/kdelibs-3.5.10'
make: *** [all] Error 2
emake failed
 * ERROR: kde-base/kdelibs-3.5.10-r6 failed:
 *   died running emake, kde_src_compile:make
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 4827:  Called kde_src_compile
 *   environment, line 3479:  Called kde_src_compile 'all'
 *   environment, line 3494:  Called kde_src_compile 'make'
 *   environment, line 3486:  Called die
 * The specific snippet of code:
 *                   emake || die "died running emake, $FUNCNAME:make"

All application rebuild OK in new portage except few against libcrypto.so.0.9.8 libssl.so.0.9.8
the revedep-rebuild is trying to rebuild against
Code:
[ 32% ]  *   broken /usr/kde/3.5/bin/cupsdconf (requires libcrypto.so.0.9.8
libssl.so.0.9.8)
 *   broken /usr/kde/3.5/bin/cupsdoprint (requires libcrypto.so.0.9.8
libssl.so.0.9.8)
 *   broken /usr/kde/3.5/lib/kde3/cupsdconf.so (requires libcrypto.so.0.9.8
libssl.so.0.9.8)
[ 33% ]  *   broken /usr/kde/3.5/lib/kde3/kdeprint_cups.so (requires libcrypto.so.0.9.8
libssl.so.0.9.8)
[ 34% ]  *   broken /usr/kde/3.5/lib/libkdeinit_cupsdconf.so (requires libcrypto.so.0.9.8
libssl.so.0.9.8)
[ 37% ]  *   broken /usr/lib/asterisk/modules/chan_iax2.so (requires libcrypto.so.0.9.8)
[ 38% ]  *   broken /usr/lib/asterisk/modules/pbx_dundi.so (requires libcrypto.so.0.9.8)
 *   broken /usr/lib/asterisk/modules/res_crypto.so (requires libcrypto.so.0.9.8)
[ 41% ]  *   broken /usr/libexec/cups/backend/nxipp (requires libcrypto.so.0.9.8
libssl.so.0.9.8)
[ 71% ]  *   broken /usr/lib/libldap-2.3.so.0 (requires libcrypto.so.0.9.8
libssl.so.0.9.8)
[ 72% ]  *   broken /usr/lib/libldap_r-2.3.so.0 (requires libcrypto.so.0.9.8
libssl.so.0.9.8)
[ 81% ]  *   broken /usr/lib/perl5/site_perl/5.8.8/i686-linux/auto/Net/TCLink/TCLink.so (requires libcrypto.so.0.9.8
libssl.so.0.9.8)
[ 96% ]  *   broken /usr/sbin/asterisk (requires libcrypto.so.0.9.8
libssl.so.0.9.8)

and it fails on: kde-base/kdelibs-3.5.10-r6
_________________
#Thelma
Back to top
View user's profile Send private message
sebaro
Veteran
Veteran


Joined: 03 Jul 2006
Posts: 1129
Location: Romania

PostPosted: Sun Nov 28, 2010 7:37 am    Post subject: Reply with quote

Did you upgrade openssl to 1.0.0. Maybe kde3 doesn't build with it. Emerge 0.9.8 too.
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2571
Location: Edmonton, AB

PostPosted: Sun Nov 28, 2010 8:06 am    Post subject: Reply with quote

sebaro wrote:
Did you upgrade openssl to 1.0.0. Maybe kde3 doesn't build with it. Emerge 0.9.8 too.

Yes, I have both versions installed
Code:
eix dev-libs/openssl
[D] dev-libs/openssl
     Available versions:  0.9.8k 0.9.8k-r1 {bindist gmp kerberos sse2 test zlib}
     Installed versions:  0.9.8p(0.9.8)(12:47:04 AM 11/28/2010)(zlib -bindist -gmp -kerberos -sse2 -test) 1.0.0b-r1(02:30:15 PM 11/27/2010)(zlib -bindist -gmp -kerberos -rfc3779 -sse2 -test)

For good measure I've rebuild "dev-libs/openssl-0.9.8p" but it fails with the same error message.
Would downgrading to "openssl-0.9.8k-r1" help?
_________________
#Thelma
Back to top
View user's profile Send private message
sebaro
Veteran
Veteran


Joined: 03 Jul 2006
Posts: 1129
Location: Romania

PostPosted: Sun Nov 28, 2010 8:47 am    Post subject: Reply with quote

The problem seems to be here
Code:
./kopenssl.h:453: error: ISO C++ forbids declaration of 'ASN1_METHOD' with no type

"ASN1_METHOD" as been removed from 0.9.8n version up.
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2571
Location: Edmonton, AB

PostPosted: Sun Nov 28, 2010 9:08 am    Post subject: Reply with quote

I've tried to emerge version: emerge -pv =dev-libs/openssl-0.9.8k-r1
as it seems to be available but I get:
These are the packages that would be merged, in order:

eix showing it is available:
Code:
[D] dev-libs/openssl
     Available versions:  0.9.8k 0.9.8k-r1 {bindist gmp kerberos sse2 test zlib}
     Installed versions:  0.9.8p(0.9.8)(12:47:04 AM 11/28/2010)(zlib -bindist -gmp -kerberos -sse2 -test) 1.0.0b-r1(02:30:15 PM 11/27/2010)(zlib -bindist -gmp -kerberos -rfc3779 -sse2 -test)

_________________
#Thelma
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2571
Location: Edmonton, AB

PostPosted: Sun Nov 28, 2010 9:34 am    Post subject: Reply with quote

sebaro wrote:
The problem seems to be here
Code:
./kopenssl.h:453: error: ISO C++ forbids declaration of 'ASN1_METHOD' with no type

"ASN1_METHOD" as been removed from 0.9.8n version up.


The strange part is that equery d openssl show
Code:
kde-base/kdelibs-3.5.10-r6 (<dev-libs/openssl-1.0.0)
                           (>=dev-libs/openssl-0.9.7d)

so my current install version: dev-libs/openssl-0.9.8p
should be enough so satisfy this requirement.
_________________
#Thelma
Back to top
View user's profile Send private message
sebaro
Veteran
Veteran


Joined: 03 Jul 2006
Posts: 1129
Location: Romania

PostPosted: Sun Nov 28, 2010 9:46 am    Post subject: Reply with quote

Ebuilds older than 0.9.8o are not in portage anymore.
You can get <0.9.8o from here:
http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/dev-libs/openssl/?hideattic=0

KDE3 ebuilds are no longer maintain so I don't think they are tested with all openssl versions from 0.9.x to 1.0.0.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43072
Location: 56N 3W

PostPosted: Sun Nov 28, 2010 10:47 pm    Post subject: Reply with quote

Moved from Portage & Programming to Unsupported Software.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Punchcutter
Guru
Guru


Joined: 11 Feb 2007
Posts: 329

PostPosted: Sun Dec 26, 2010 6:45 am    Post subject: Reply with quote

I'm trying to downgrade my openssl so that I can install kdelibs-3.5.10-r6. I don't know much about this stuff, but...

I've downloaded the ebuild from the above suggested site, and the source tarball from the openssl project site. And I've unmerged 0.9.8q ! But when I try to merge the new one, I get:

Code:
# emerge -v =dev-libs/openssl-0.9.8k-r1

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     UD] dev-libs/openssl-0.9.8k-r1 [1.0.0c] USE="zlib -bindist -gmp -kerberos -sse2 -test (-rfc3779%)" 0 kB

Total: 1 package (1 downgrade), Size of downloads: 0 kB


>>> Verifying ebuild manifests
!!! A file is not listed in the Manifest: '/usr/portage/dev-libs/openssl/openssl-0.9.8k-r1.ebuild'


How do I get my ebuild into the Manifest?? Thanks!
Back to top
View user's profile Send private message
ComaWhite
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2008
Posts: 125

PostPosted: Sun Dec 26, 2010 7:15 am    Post subject: Reply with quote

Punchcutter wrote:
I'm trying to downgrade my openssl so that I can install kdelibs-3.5.10-r6. I don't know much about this stuff, but...

I've downloaded the ebuild from the above suggested site, and the source tarball from the openssl project site. And I've unmerged 0.9.8q ! But when I try to merge the new one, I get:

Code:
# emerge -v =dev-libs/openssl-0.9.8k-r1

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     UD] dev-libs/openssl-0.9.8k-r1 [1.0.0c] USE="zlib -bindist -gmp -kerberos -sse2 -test (-rfc3779%)" 0 kB

Total: 1 package (1 downgrade), Size of downloads: 0 kB


>>> Verifying ebuild manifests
!!! A file is not listed in the Manifest: '/usr/portage/dev-libs/openssl/openssl-0.9.8k-r1.ebuild'

How do I get my ebuild into the Manifest?? Thanks!


sudo ebuild <ebuild> digest
Back to top
View user's profile Send private message
Punchcutter
Guru
Guru


Joined: 11 Feb 2007
Posts: 329

PostPosted: Sun Dec 26, 2010 8:40 pm    Post subject: Reply with quote

Thank you. Easy enough :) I have run into another problem with building the old openssl, but as it doesn't seem directly related to this thread, I've moved the discussion to a new thread.
Back to top
View user's profile Send private message
Punchcutter
Guru
Guru


Joined: 11 Feb 2007
Posts: 329

PostPosted: Mon Dec 27, 2010 10:14 am    Post subject: Reply with quote

I'm not sure whether the answer to MY question is the same thing OP needs here, but please note that KDE 3 in kde-sunset does work with openssl 1.0.x. There's no need to downgrade. Please see here. I needed to add package keyword for kdelibs and kcontrol:
Code:
<kde-base/kdelibs-4.0 ~x86
<kde-base/kcontrol-4.0 ~x86

and I was good to go.
Back to top
View user's profile Send private message
nicarran
n00b
n00b


Joined: 30 Dec 2010
Posts: 1

PostPosted: Thu Dec 30, 2010 4:17 am    Post subject: Reply with quote

Thanks! you saved me a lot of time.
Back to top
View user's profile Send private message
Punchcutter
Guru
Guru


Joined: 11 Feb 2007
Posts: 329

PostPosted: Thu Dec 30, 2010 5:10 am    Post subject: Reply with quote

Thanks for saying so, and welcome to the forum. I always come to the forum to get answers to my problems, and almost always I can find what I need. It's rare that I have the chance to "give back", but when I can, it's very nice to know that it helped someone.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum