Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Zirkulare Abhängigkeit?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
bas89
Apprentice
Apprentice


Joined: 02 Mar 2010
Posts: 243
Location: Germany ;)

PostPosted: Tue Nov 30, 2010 10:39 pm    Post subject: [solved] Zirkulare Abhängigkeit? Reply with quote

Tschuldigt, es ist sicher ein lapidarer Fehler, aber was mache ich falsch? Hab ich einen Knoten im Kopf oder Portage?
Code:

root@laptop /home/bas89 :) # emerge qt-assistant -a

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild   R   ] x11-libs/qt-assistant-4.6.3

!!! One or more updates have been skipped due to a dependency conflict:

x11-libs/qt-core:4

  (x11-libs/qt-core-4.7.1-r1, ebuild scheduled for merge) conflicts with
    ~x11-libs/qt-core-4.6.3[-aqua,-debug] required by (x11-libs/qt-multimedia-4.6.3, installed)


!!! The following update(s) have been skipped due to unsatisfied dependencies
!!! triggered by backtracking:

x11-libs/qt-assistant:4
x11-libs/qt-webkit:4

Would you like to merge these packages? [Yes/No] n

Quitting.

root@laptop /home/bas89 :) # emerge -a x11-libs/qt-multimedia

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild   R   ] x11-libs/qt-multimedia-4.6.3

!!! One or more updates have been skipped due to a dependency conflict:

x11-libs/qt-gui:4

  (x11-libs/qt-gui-4.7.1-r1, ebuild scheduled for merge) conflicts with
    ~x11-libs/qt-gui-4.6.3[-aqua] required by (x11-libs/qt-assistant-4.6.3, installed)


!!! The following update(s) have been skipped due to unsatisfied dependencies
!!! triggered by backtracking:

x11-libs/qt-multimedia:4

Would you like to merge these packages? [Yes/No]

Das steht in der package.keywords:
Code:

# ---
# BEGIN: x11-libs/qt-core-4.7.1
# ---
~x11-libs/qt-declarative-4.7.1
~x11-libs/qt-core-4.7.1
~x11-libs/qt-dbus-4.7.1
~x11-libs/qt-gui-4.7.1
~x11-libs/qt-multimedia-4.7.1
~x11-libs/qt-opengl-4.7.1
~x11-libs/qt-qt3support-4.7.1
~x11-libs/qt-script-4.7.1
~x11-libs/qt-sql-4.7.1
~x11-libs/qt-test-4.7.1
~x11-libs/qt-webkit-4.7.1
~x11-libs/qt-xmlpatterns-4.7.1
~x11-libs/qt-svg-4.7.1
~dev-python/PyQt4-4.7.7
~x11-libs/qt-assistant-4.7.1

# ---
# END: x11-libs/qt-core-4.7.1
# ---


Genauso hier:
Code:
e
root@laptop /home/bas89 :) # emerge qt-webkit -a

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild   R   ] x11-libs/qt-webkit-4.6.3-r1

!!! One or more updates have been skipped due to a dependency conflict:

x11-libs/qt-gui:4

  (x11-libs/qt-gui-4.7.1-r1, ebuild scheduled for merge) conflicts with
    ~x11-libs/qt-gui-4.6.3[-aqua] required by (x11-libs/qt-assistant-4.6.3, installed)


!!! The following update(s) have been skipped due to unsatisfied dependencies
!!! triggered by backtracking:

x11-libs/qt-webkit:4

Would you like to merge these packages? [Yes/No] n

Quitting.

root@laptop /home/bas89 :) # eix qt-webkit
[U] x11-libs/qt-webkit
     Available versions:  (4) 4.5.3 ~4.5.3-r1 ~4.5.3-r2 4.5.3-r3 4.6.2 4.6.2-r1 ~4.6.3 4.6.3-r1 ~4.6.3-r2 ~4.7.0 ~4.7.0-r1 (~)4.7.1-r1
        {aqua dbus debug +exceptions +jit kde pch}
     Installed versions:  4.6.3-r1(4)(02:09:04 19.10.2010)(dbus exceptions kde -aqua -debug -pch)
     Homepage:            http://qt.nokia.com/
     Description:         The Webkit module for the Qt toolkit

root@laptop /home/bas89 :) # eix qt-gui
[U] x11-libs/qt-gui
     Available versions:  (4) 4.5.3-r2 4.6.2 ~4.6.2-r1 4.6.3 [M]4.6.3-r1 4.6.3-r2 ~4.7.0 ~4.7.0-r1 (~)4.7.1 (~)4.7.1-r1
        {+accessibility aqua cups dbus debug egl +exceptions +glib gtk mng nas nis pch private-headers qt3support (+)raster tiff trace xinerama}                                                                                                                                   
     Installed versions:  4.6.3-r2(4)(20:05:14 15.11.2010)(accessibility cups dbus exceptions glib gtk mng qt3support raster tiff xinerama -aqua -debug -nas -nis -pch -trace)
     Homepage:            http://qt.nokia.com/
     Description:         The GUI module for the Qt toolkit

root@laptop /home/bas89 :) # eix qt-assistant
[U] x11-libs/qt-assistant
     Available versions:  (4) 4.5.3 4.6.2 ~4.6.2-r2 4.6.3 ~4.7.0 (~)4.7.1
        {aqua compat debug doc +exceptions +glib pch qt3support trace}
     Installed versions:  4.6.3(4)(02:54:30 19.10.2010)(exceptions -aqua -debug -pch -trace)
     Homepage:            http://qt.nokia.com/
     Description:         The assistant help module for the Qt toolkit


Last edited by bas89 on Tue Nov 30, 2010 11:47 pm; edited 1 time in total
Back to top
View user's profile Send private message
AmonAmarth
l33t
l33t


Joined: 03 Mar 2005
Posts: 727

PostPosted: Tue Nov 30, 2010 11:21 pm    Post subject: Reply with quote

hast du den qt kram (fälschlicherweise!) in der world file stehen?
/var/lib/portage/world
Back to top
View user's profile Send private message
bas89
Apprentice
Apprentice


Joined: 02 Mar 2010
Posts: 243
Location: Germany ;)

PostPosted: Tue Nov 30, 2010 11:21 pm    Post subject: Reply with quote

Das ist der Trick:
Code:
 
root@laptop /home/bas89 :) # eix -I qt- --only-names
x11-libs/qt-assistant
x11-libs/qt-core
x11-libs/qt-dbus
x11-libs/qt-gui
x11-libs/qt-multimedia
x11-libs/qt-opengl
x11-libs/qt-qt3support
x11-libs/qt-script
x11-libs/qt-sql
x11-libs/qt-svg
x11-libs/qt-test
x11-libs/qt-webkit
x11-libs/qt-xmlpatterns
root@laptop /home/bas89 :) # emerge -u x11-libs/qt-assistant x11-libs/qt-core x11-libs/qt-dbus x11-libs/qt-gui x11-libs/qt-multimedia x11-libs/qt-opengl x11-libs/qt-qt3support x11-libs/qt-script x11-libs/qt-sql x11-libs/qt-svg x11-libs/qt-test x11-libs/qt-webkit x11-libs/qt-xmlpatterns  -a

Schade, dass portage das nicht selber schafft!
Back to top
View user's profile Send private message
bas89
Apprentice
Apprentice


Joined: 02 Mar 2010
Posts: 243
Location: Germany ;)

PostPosted: Tue Nov 30, 2010 11:26 pm    Post subject: Reply with quote

AmonAmarth wrote:
hast du den qt kram (fälschlicherweise!) in der world file stehen?
/var/lib/portage/world


Ja, Tatsache, da stehen zwei Einträge drin
Code:

x11-libs/qt-gui
x11-libs/qt-sql

Kann ich die einfach rauslöschen, kommt damit Portage klar?
Back to top
View user's profile Send private message
AmonAmarth
l33t
l33t


Joined: 03 Mar 2005
Posts: 727

PostPosted: Tue Nov 30, 2010 11:41 pm    Post subject: Reply with quote

ja, qt sollte eigentlich nicht in der world file stehen, es sei denn, du weißt genau wieso. qt sollte im Regelfall als Abhängigkeit von den jeweiligen libs oder Programmen gezogen werden.

EDIT: benutzt demnächst um Abhängigkeiten von Hand nach zu installieren "emerge -1" (oneshot), sonst müllst du deine world file wieder zu!
Back to top
View user's profile Send private message
bas89
Apprentice
Apprentice


Joined: 02 Mar 2010
Posts: 243
Location: Germany ;)

PostPosted: Tue Nov 30, 2010 11:50 pm    Post subject: Reply with quote

Ah, alles klar. Ich dank dir :) Wenn du einen Weihnachtskalender hast, mach das erste Türchen auf! ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum