Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[INSTALL] config proxy http [RESOLU]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
engil
Tux's lil' helper
Tux's lil' helper


Joined: 22 Nov 2005
Posts: 117
Location: France

PostPosted: Wed Dec 08, 2010 11:24 am    Post subject: [INSTALL] config proxy http [RESOLU] Reply with quote

Bonjour à tous,

voilà mon problème : j'essaie de configurer une Gentoo en VM au boulot, mais j'ai un souci pour sortir sur le net ...

Il y a un proxy http avec authentification, et je ne vois pas trop comment le déclarer proprement.

J'ai essayé d'exporter la variable HTTP_PROXY qui va bien, mais ce n'est pour l'instant pas concluant ...

J'ai bien récupéré une adresse IP via DHCP, la passerelle est ok, je peux pinger des éléments en interne, mais pas moyen de sortir.

Je pense que c'est l'authentification auprès du proxy qui pose problème, j'ai mis quelquechose comme ça :
Code:

export HTTP_PROXY="user:pass@adr.du.proxy:8080"


Est-ce qu'il me manque quelquechose ? Comment voir ce qui se passe précisement ? Je suis sur le livecd-minimal, et les DNS sont OK.

Si quelqu'un a une idée ...

Merci d'avance !


Last edited by engil on Thu Dec 09, 2010 2:15 pm; edited 1 time in total
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Wed Dec 08, 2010 1:16 pm    Post subject: Reply with quote

Aucune expérience du proxy configuré de cette manière, mais tu as essayé avec le protocol dans l'adresse du serveur? (ajouter http:// quoi...)
Back to top
View user's profile Send private message
engil
Tux's lil' helper
Tux's lil' helper


Joined: 22 Nov 2005
Posts: 117
Location: France

PostPosted: Wed Dec 08, 2010 1:33 pm    Post subject: Reply with quote

Arf, merci, en fait j'ai mal recopié :D

J'ai bien mis http_proxy="http://foo:bar@url:port" ...

N'y a t'il pas un fichier où renseigner les paramètres ? Au moins pour faire fonctionner links ?
Back to top
View user's profile Send private message
nico_calais
l33t
l33t


Joined: 09 Jun 2005
Posts: 628
Location: Saint Julien en Genevois

PostPosted: Thu Dec 09, 2010 11:10 am    Post subject: Reply with quote

Pour faire fonctionner links :

Code:
#links --help |grep proxy
 -http-proxy <host:port>
  Host and port number of the HTTP proxy, or blank.

_________________
"Unix IS user friendly... It's just selective about who its friends are." — Tollef Fog Heen tollef@add.no
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3102
Location: Paris

PostPosted: Thu Dec 09, 2010 2:07 pm    Post subject: Reply with quote

Bien entendu, il faut que ton proxy soit en mode authentification "basic" et non "ntlm", parce que sinon tu vas peiner un tantinet avec links et pas mal d'autre programmes (mais il y a des contournements).
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
engil
Tux's lil' helper
Tux's lil' helper


Joined: 22 Nov 2005
Posts: 117
Location: France

PostPosted: Thu Dec 09, 2010 2:14 pm    Post subject: Reply with quote

@all : Yeah merci pour les réponses, j'ai vu après la parade pour links ... mais ça ne semble pas fonctionner non plus.

Qu'à cela ne tienne ! J'ai récupéré ce que j'avais besoin via wget, qui lui semble comprendre la variable d'environnement.

Du coup emerge fonctionne ! Je viens de compiler le kernel là ...

Merci à tous, je met le topic en résolu :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum