Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
cant emerge ecore
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
sinisterdomestik
l33t
l33t


Joined: 28 Aug 2003
Posts: 683
Location: Texas

PostPosted: Sat Dec 18, 2010 12:42 am    Post subject: cant emerge ecore Reply with quote

I know there are a million threads on this, and I checked them all....yes, all one million of them!, and I cant figure out what/why my enlightenment emerge is failing.

I followed the e wiki and got to the emerge enlightenment and get to the ecore package when it fails with this error:
Code:
Making all in ecore_evas
make[4]: Entering directory `/var/tmp/portage/dev-libs/ecore-9999/work/ecore/src/lib/ecore_evas'
  CC     ecore_evas.lo
  CC     ecore_evas_util.lo
  CC     ecore_evas_x.lo
In file included from ecore_evas_util.c:10:0:
ecore_evas_private.h:50:40: fatal error: Evas_Engine_XRender_X11.h: No such file or directory
compilation terminated.
In file included from ecore_evas_x.c:24:0:
ecore_evas_private.h:50:40: fatal error: Evas_Engine_XRender_X11.h: No such file or directory
compilation terminated.
make[4]: *** [ecore_evas_util.lo] Error 1
make[4]: *** Waiting for unfinished jobs....
In file included from ecore_evas.c:17:0:
ecore_evas_private.h:50:40: fatal error: Evas_Engine_XRender_X11.h: No such file or directory
compilation terminated.
make[4]: *** [ecore_evas_x.lo] Error 1
make[4]: *** [ecore_evas.lo] Error 1
make[4]: Leaving directory `/var/tmp/portage/dev-libs/ecore-9999/work/ecore/src/lib/ecore_evas'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/dev-libs/ecore-9999/work/ecore/src/lib'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/dev-libs/ecore-9999/work/ecore/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/dev-libs/ecore-9999/work/ecore'
make: *** [all] Error 2
emake failed
 * ERROR: dev-libs/ecore-9999 failed:
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 3038:  Called enlightenment_src_compile
 *   environment, line 1677:  Called die
 * The specific snippet of code:
 *       emake || die;
 *
 * If you need support, post the output of 'emerge --info =dev-libs/ecore-9999',
 * the complete build log and the output of 'emerge -pqv =dev-libs/ecore-9999'.
 * This ebuild is from an overlay named 'enlightenment': '/var/lib/layman/enlightenment/'
 * The complete build log is located at '/var/tmp/portage/dev-libs/ecore-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-libs/ecore-9999/temp/environment'.
 * S: '/var/tmp/portage/dev-libs/ecore-9999/work/ecore'

>>> Failed to emerge dev-libs/ecore-9999, Log file:

>>>  '/var/tmp/portage/dev-libs/ecore-9999/temp/build.log'

 * Messages for package dev-vcs/git-1.7.3.4:

 * These additional scripts need some dependencies:
 *   git-quiltimport  : dev-util/quilt
 *   git-instaweb     : || ( www-servers/lighttpd www-servers/apache )

 * Messages for package dev-libs/ecore-9999:

 * ERROR: dev-libs/ecore-9999 failed:
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 3038:  Called enlightenment_src_compile
 *   environment, line 1677:  Called die
 * The specific snippet of code:
 *       emake || die;
 *
 * If you need support, post the output of 'emerge --info =dev-libs/ecore-9999',
 * the complete build log and the output of 'emerge -pqv =dev-libs/ecore-9999'.
 * This ebuild is from an overlay named 'enlightenment': '/var/lib/layman/enlightenment/'
 * The complete build log is located at '/var/tmp/portage/dev-libs/ecore-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-libs/ecore-9999/temp/environment'.
 * S: '/var/tmp/portage/dev-libs/ecore-9999/work/ecore'

 * GNU info directory index is up-to-date.


My emerge enlightenment shows these packages to emerge
Code:

BlackBeauty ~ # emerge -uDNp enlightenment

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] dev-libs/ecore-9999 [1.0.0_beta2]
[ebuild  N    ] dev-libs/eeze-9999  USE="nls -doc -static-libs"
[ebuild     U ] media-libs/edje-9999 [1.0.0_beta2]
[ebuild     U ] dev-libs/efreet-9999 [1.0.0_beta2]
[ebuild     U ] dev-libs/e_dbus-9999 [1.0.0_beta2] USE="-test-binaries%"
[ebuild  NS   ] x11-wm/enlightenment-9999 [1.0.7] USE="e_modules_battery e_modules_clock e_modules_comp e_modules_conf-applications e_modules_conf-borders e_modules_conf-clientlist e_modules_conf-colors e_modules_conf-desk e_modules_conf-desklock e_modules_conf-desks e_modules_conf-dialogs e_modules_conf-display e_modules_conf-dpms e_modules_conf-edgebindings e_modules_conf-engine e_modules_conf-fonts e_modules_conf-icon-theme e_modules_conf-imc e_modules_conf-interaction e_modules_conf-intl e_modules_conf-keybindings e_modules_conf-menus e_modules_conf-mime e_modules_conf-mouse e_modules_conf-mouse-cursor e_modules_conf-mousebindings e_modules_conf-paths e_modules_conf-performance e_modules_conf-profiles e_modules_conf-scale e_modules_conf-screensaver e_modules_conf-shelves e_modules_conf-startup e_modules_conf-theme e_modules_conf-transitions e_modules_conf-wallpaper e_modules_conf-wallpaper2 e_modules_conf-window-display e_modules_conf-window-focus e_modules_conf-window-manipulation e_modules_conf-window-remembers e_modules_conf-winlist e_modules_connman e_modules_cpufreq e_modules_dropshadow e_modules_everything e_modules_everything-apps e_modules_everything-calc e_modules_everything-files e_modules_everything-settings e_modules_everything-windows e_modules_fileman e_modules_fileman_opinfo e_modules_gadman e_modules_ibar e_modules_ibox e_modules_illume2 e_modules_mixer e_modules_msgbus e_modules_pager e_modules_start e_modules_syscon e_modules_systray e_modules_temperature e_modules_winlist e_modules_wizard hal nls pam udev -acpi -bluetooth -doc -e_modules_illume -e_modules_ofono -exchange -spell -static-libs"


Please help with any suggestions or fixes as this is driving me nuts!
_________________
Thou shalt NEVER speak of removing thine Linux
Back to top
View user's profile Send private message
tomk
Bodhisattva
Bodhisattva


Joined: 23 Sep 2003
Posts: 7221
Location: Sat in front of my computer

PostPosted: Sat Dec 18, 2010 11:36 am    Post subject: Reply with quote

Moved from Desktop Environments to Unsupported Software, questions about overlay packages belong in US.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
skellr
l33t
l33t


Joined: 18 Jun 2005
Posts: 859
Location: The Village, Portmeirion

PostPosted: Sat Dec 18, 2010 1:50 pm    Post subject: Reply with quote

/usr/include/evas-1/Evas_Engine_XRender_X11.h

Are you really missing this file? It should belong to media-libs/evas perhaps with USE X.
I would reinstall evas.
Back to top
View user's profile Send private message
sinisterdomestik
l33t
l33t


Joined: 28 Aug 2003
Posts: 683
Location: Texas

PostPosted: Sat Dec 18, 2010 2:22 pm    Post subject: Reply with quote

Tried that, still the same error. Looked for the actual file and found it though
Code:
sinister@BlackBeauty ~ $ locate *XRender_X11.h
/usr/include/evas-1/Evas_Engine_XRender_X11.h
/usr/portage/distfiles/svn-src/enlightenment/evas/src/modules/engines/xrender_x11/Evas_Engine_XRender_X11.h
Other than that, Im not sure what im supposed to be doing!
_________________
Thou shalt NEVER speak of removing thine Linux
Back to top
View user's profile Send private message
skellr
l33t
l33t


Joined: 18 Jun 2005
Posts: 859
Location: The Village, Portmeirion

PostPosted: Sat Dec 18, 2010 3:11 pm    Post subject: Reply with quote

Well, it's not helping much sitting over there in distfiles. :) (ohh, I missed that you have it in include/)

Is the X USE flag enabled for evas? There must be some reason it's not installing it.

But then again it is development code. you could have checked it out at a bad time and missed some changes. Running the rebuild script thats in the scripts directory of the overlay might be a quick way to restart from the begining.

Edit: and your using the "enlightenment" overlay? not "efl" I hope.
Back to top
View user's profile Send private message
skellr
l33t
l33t


Joined: 18 Jun 2005
Posts: 859
Location: The Village, Portmeirion

PostPosted: Sat Dec 18, 2010 3:23 pm    Post subject: Reply with quote

I would uninstall everything from the 1.0.0_beta2 then try installing 9999. Sorry I don't have a better suggestion.
Back to top
View user's profile Send private message
sinisterdomestik
l33t
l33t


Joined: 28 Aug 2003
Posts: 683
Location: Texas

PostPosted: Tue Dec 21, 2010 3:39 am    Post subject: Reply with quote

Sorry, just got computer set back up after moving.

I tried all those suggestions, and still getting the same error.

Running rebuild in the scripts dir shows
Code:
BlackBeauty scripts # ./rebuild
 * Keep in mind, this script is just for live CVS users
 * Building complete list of all E17 packages ...                                                                           [ ok ]
 * Building list of all installed E17 packages ...                                                                          [ ok ]
 * Installed packages:
 * dev-libs/eet dev-libs/eina dev-libs/embryo media-libs/evas media-libs/imlib2
 * Punting all installed packages
dev-libs/eet: 9999 none none
dev-libs/eina: 9999 none none
dev-libs/embryo: 9999 none none
media-libs/evas: 9999 none none
media-libs/imlib2: 9999 none none

All selected packages: dev-libs/embryo-9999 media-libs/imlib2-9999 dev-libs/eina-9999 media-libs/evas-9999 dev-libs/eet-9999
>>> Waiting 5 seconds before starting...
>>> (Control-C to abort)...
>>> Unmerging in:  5 4 3 2 1
>>> Unmerging dev-libs/eet-9999...
>>> Unmerging dev-libs/eina-9999...
>>> Unmerging dev-libs/embryo-9999...
>>> Unmerging media-libs/evas-9999...
>>> Unmerging media-libs/imlib2-9999...
 * GNU info directory index is up-to-date.
 * Starting new install of packages ... hold on to your pants

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] dev-libs/eina-9999  USE="mempool-chained mempool-pass-through nls threads (-altivec) -debug -default-mempool -doc -mempool-buddy -mempool-ememoa-fixed -mempool-ememoa-unknown -mempool-fixed-bitmap -mmx -sse -sse2 -static-libs"
[ebuild  N    ] dev-libs/embryo-9999  USE="nls -doc -static-libs"
[ebuild  N    ] media-libs/imlib2-9999  USE="X bzip2 jpeg mp3 nls png zlib -doc -gif -mmx -tiff"
[ebuild  N    ] dev-libs/eet-9999  USE="nls ssl threads -debug -doc -examples -gnutls -static-libs"
[ebuild  N    ] media-libs/evas-9999  USE="X cache eet fontconfig jpeg nls png threads (-altivec) -bidi -directfb -doc -fbcon -gif -gles -mmx -opengl -sdl -sse -static-libs -svg -tiff -xcb -xpm"

Would you like to merge these packages? [Yes/No]
and continueing shows same error one ecore starts to emerge (not shown because its not on the system anymore!)
_________________
Thou shalt NEVER speak of removing thine Linux
Back to top
View user's profile Send private message
sinisterdomestik
l33t
l33t


Joined: 28 Aug 2003
Posts: 683
Location: Texas

PostPosted: Thu Dec 23, 2010 1:21 am    Post subject: Reply with quote

Should have posted this sooner, but with the error being that it cant find Evas_Engine_XRender_X11.h, I did a search to see where the file was located at
Code:
BlackBeauty ~ # locate Evas_Engine_XRender_X11.h
/root/e17_src/evas/src/modules/engines/xrender_x11/Evas_Engine_XRender_X11.h
/root/e17_src/evas/src/modules/engines/xrender_x11/.svn/prop-base/Evas_Engine_XRender_X11.h.svn-base
/root/e17_src/evas/src/modules/engines/xrender_x11/.svn/text-base/Evas_Engine_XRender_X11.h.svn-base
/usr/include/evas-1/Evas_Engine_XRender_X11.h
/usr/portage/distfiles/svn-src/enlightenment/evas/src/modules/engines/xrender_x11/Evas_Engine_XRender_X11.h
/usr/portage/distfiles/svn-src/enlightenment/evas/src/modules/engines/xrender_x11/.svn/prop-base/Evas_Engine_XRender_X11.h.svn-base
/usr/portage/distfiles/svn-src/enlightenment/evas/src/modules/engines/xrender_x11/.svn/text-base/Evas_Engine_XRender_X11.h.svn-base
Not sure if I need to copy the file to somewhere else, but this is....annoying lol
_________________
Thou shalt NEVER speak of removing thine Linux
Back to top
View user's profile Send private message
skellr
l33t
l33t


Joined: 18 Jun 2005
Posts: 859
Location: The Village, Portmeirion

PostPosted: Thu Dec 23, 2010 1:42 pm    Post subject: Reply with quote

Yeah, it's strange as you have it there in /usr/include so it should be found.
Code:
/usr/include/evas-1/Evas_Engine_XRender_X11.h


Are there any files in /usr/local it might be reading?
Back to top
View user's profile Send private message
sinisterdomestik
l33t
l33t


Joined: 28 Aug 2003
Posts: 683
Location: Texas

PostPosted: Thu Dec 23, 2010 11:31 pm    Post subject: Reply with quote

Code:
sinister@BlackBeauty ~ $ ls /usr/local
bin  games  lib  man  sbin  share  src
sinister@BlackBeauty ~ $ ls /usr/local/src/
sinister@BlackBeauty ~ $ ls /usr/local/bin
transmission-cli     transmission-daemon  transmission-gtk     transmission-show
transmission-create  transmission-edit    transmission-remote  winetricks
sinister@BlackBeauty ~ $ ls /usr/local/lib
sinister@BlackBeauty ~ $ ls /usr/local/sbin
sinister@BlackBeauty ~ $ ls /usr/local/share
applications  doc  icons  locale  man  pixmaps  transmission
sinister@BlackBeauty ~ $ ls /usr/local/games
sinister@BlackBeauty ~ $ ls /usr/local/man 
man1  whatis

Im going to go with......no :(
_________________
Thou shalt NEVER speak of removing thine Linux
Back to top
View user's profile Send private message
skellr
l33t
l33t


Joined: 18 Jun 2005
Posts: 859
Location: The Village, Portmeirion

PostPosted: Fri Dec 24, 2010 5:45 pm    Post subject: Reply with quote

I noticed you had sources in root/ and was thinking you may have installed it outside package management. It doesn't look like it and I'm stumped on this one so far. Maybe your emerge --info might be useful for someone else that sees this.

:?
Back to top
View user's profile Send private message
sinisterdomestik
l33t
l33t


Joined: 28 Aug 2003
Posts: 683
Location: Texas

PostPosted: Fri Dec 24, 2010 10:01 pm    Post subject: Reply with quote

Code:
sinister@BlackBeauty ~ $ emerge --info
Portage 2.1.9.26 (default/linux/x86/10.0, gcc-4.5.1, glibc-2.12.1-r3, 2.6.36-gentoo-r5 i686)
=================================================================
System uname: Linux-2.6.36-gentoo-r5-i686-Intel-R-_Core-TM-2_Quad_CPU_Q8200_@_2.33GHz-with-gentoo-2.0.1
Timestamp of tree: Fri, 24 Dec 2010 04:00:01 +0000
app-shells/bash:     4.1_p9
dev-lang/python:     2.7.1, 3.1.3
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc:     0.6.8
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.9.6-r3, 1.11.1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.5.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.82
virtual/os-headers:  2.6.36.1 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"           
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo" 
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://www.cyberuse.com/gentoo/ http://gentoo.cites.uiuc.edu/pub/gentoo/ http://mirror.usu.edu/mirrors/gentoo/ http://gentoo.chem.wisc.edu/gentoo/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"                 
PKGDIR="/usr/portage/packages" 
PORTAGE_CONFIGROOT="/"         
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"       
PORTDIR="/usr/portage"         
PORTDIR_OVERLAY="/var/lib/layman/enlightenment"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl alsa berkdb bzip2 cli cracklib crypt cups cxx dbus dri fortran gdbm gpm hal iconv ipv6 jpeg modules mp3 mudflap ncurses nls nptl nptlonly nvidia openmp pam pcre perl png pppd python readline session ssl sysfs tcpd threads unicode x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-2" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Hope this helps, I keep trying to emerge it once a day, see if it "fixes" itself to no avail :(
_________________
Thou shalt NEVER speak of removing thine Linux
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3256

PostPosted: Fri Dec 24, 2010 10:53 pm    Post subject: Reply with quote

Can you post the complete build log somewhere. Also, your emerge -pv of all packages upto ecore.
_________________
emerge --quiet redefined | E17 vids: I, II | Now using kde5 | e is unstable :-/
Back to top
View user's profile Send private message
szczerb
Veteran
Veteran


Joined: 24 Feb 2007
Posts: 1700
Location: Poland => Lodz

PostPosted: Sat Dec 25, 2010 1:53 am    Post subject: Reply with quote

Those live (9999) ebuilds can be tricky. Have you tried the beta3? I've built it just fine on my gentoo laptop with portage and manually on my ubuntu (sigh...hope to find the time to put sth else there...) box at work.

BTW seems like you have two mempool-* flags enabled for eina. You sure that it's ok?
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3256

PostPosted: Sat Dec 25, 2010 1:57 am    Post subject: Reply with quote

szczerb wrote:
Those live (9999) ebuilds can be tricky. Have you tried the beta3? I've built it just fine on my gentoo laptop with portage and manually on my ubuntu (sigh...hope to find the time to put sth else there...) box at work.

BTW seems like you have two mempool-* flags enabled for eina. You sure that it's ok?
Live ebuilds are the least tricky actually. And portage handles live builds wonderfully. As for the mempool flags, they are the recommended ones (by e devs) and hence are enabled by default in the ebuild (with a +mempool... ).
_________________
emerge --quiet redefined | E17 vids: I, II | Now using kde5 | e is unstable :-/
Back to top
View user's profile Send private message
sinisterdomestik
l33t
l33t


Joined: 28 Aug 2003
Posts: 683
Location: Texas

PostPosted: Sat Dec 25, 2010 2:15 am    Post subject: Reply with quote

http://pastebin.com/Hei1u6p9


build log
_________________
Thou shalt NEVER speak of removing thine Linux
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3256

PostPosted: Sat Dec 25, 2010 4:58 am    Post subject: Reply with quote

sinisterdomestik wrote:
http://pastebin.com/Hei1u6p9


build log
I built my ecore with exact same USE flags as yours (in amd64 though). And it built fine. I can't seem to figure out what is wrong. Can you also give me the output of emerge -pv eina eet evas ecore?
_________________
emerge --quiet redefined | E17 vids: I, II | Now using kde5 | e is unstable :-/
Back to top
View user's profile Send private message
sinisterdomestik
l33t
l33t


Joined: 28 Aug 2003
Posts: 683
Location: Texas

PostPosted: Sat Dec 25, 2010 12:18 pm    Post subject: Reply with quote

Code:
sinister@BlackBeauty ~ $ emerge -pv eina eet evas dev-libs/ecore
                               
These are the packages that would be merged, in order:
                               
Calculating dependencies... done!
[ebuild   R   ] dev-libs/eina-9999  USE="mempool-chained mempool-pass-through nls threads (-altivec) -debug -default-mempool -doc -mempool-buddy -mempool-ememoa-fixed -mempool-ememoa-unknown -mempool-fixed-bitmap -mmx -sse -sse2 -static-libs" 0 kB [1]
[ebuild   R   ] dev-libs/eet-9999  USE="nls ssl threads -debug -doc -examples -gnutls -static-libs" 0 kB [1]
[ebuild   R   ] media-libs/evas-9999  USE="X cache eet fontconfig jpeg nls png svg threads xpm (-altivec) -bidi -directfb -doc -fbcon -gif -gles -mmx -opengl -sdl -sse -static-libs -tiff -xcb" 0 kB [1]
[ebuild  N    ] dev-libs/ecore-9999  USE="X evas inotify nls ssl threads -ares -curl -directfb -doc -fbcon -glib -gnutls -opengl -sdl -static-libs -tslib -xcb -xinerama -xprint -xscreensaver" 0 kB [1]
                               
Total: 4 packages (1 new, 3 reinstalls), Size of downloads: 0 kB
Portage tree and overlays:     
 [0] /usr/portage               
 [1] /var/lib/layman/enlightenment

_________________
Thou shalt NEVER speak of removing thine Linux
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3256

PostPosted: Sat Dec 25, 2010 5:50 pm    Post subject: Reply with quote

Your emerge -pv seems fine.
At this point, I cant figure out what is wrong. There are two things:

1. You can try enabling opengl and see if it affects anything. I noticed this in your compile output. Not sure whether there is a bug or not. (I don't know enough about makefiles to figure out)
Code:
checking whether ecore_evas OpenGL SDL support is to be built... yes
checking whether ecore_evas OpenGL SDL support is built... no


2. the other conclusion is that there might be some old libraries in your ssytem. you can try
a. removing all efl + e related packages.
b. then run updatedb on your system. Before running updatedb, modify the /etc/updatedb.conf to exclude the files in /usr/portage/distfiles (or even /usr/portage in general) and /var/lib/layman and /var/tmp/portage.
c. then run locate such as "locate --regex '[eE]vas'", repeat for eina, eet, and other efl related packages.
d. ensure from the locate output that you don't have any stale library or header files in your system.
_________________
emerge --quiet redefined | E17 vids: I, II | Now using kde5 | e is unstable :-/
Back to top
View user's profile Send private message
engil
Tux's lil' helper
Tux's lil' helper


Joined: 22 Nov 2005
Posts: 117
Location: France

PostPosted: Sat Dec 25, 2010 10:30 pm    Post subject: Reply with quote

Hi sinisterdomestik,

i'm not sure this will help, but if you are in ~arch you can try with a set, e.g. @enlightenment-live as described in the gentoo wiki.

Here's mine :
Code:


laptoo engil # emerge -1av @enlightenment-live

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] dev-libs/eina-9999  USE="mempool-chained mmx nls sse sse2 (-altivec) -debug -default-mempool -doc -mempool-buddy -mempool-ememoa-fixed -mempool-ememoa-unknown -mempool-fixed-bitmap -mempool-pass-through -static-libs -test -threads" 0 kB [1]
[ebuild   R   ] dev-libs/embryo-9999  USE="nls -doc -static-libs" 0 kB [1]
[ebuild   R   ] dev-libs/eet-9999  USE="nls -debug -doc -examples -gnutls -ssl -static-libs -test -threads" 0 kB [1]
[ebuild   R   ] media-libs/evas-9999  USE="X eet fontconfig gif jpeg mmx nls opengl png sse svg xcb xpm (-altivec) -bidi -cache -directfb -doc -fbcon -gles -sdl -static-libs -threads -tiff" 0 kB [1]
[ebuild   R   ] dev-libs/ecore-9999  USE="X curl evas glib inotify nls opengl xcb -ares -directfb -doc -fbcon -gnutls -sdl -ssl -static-libs -threads -tslib -xinerama -xprint -xscreensaver" 0 kB [1]
[ebuild   R   ] dev-libs/efreet-9999  USE="nls -doc -static-libs" 0 kB [1]
[ebuild   R   ] dev-libs/e_dbus-9999  USE="bluetooth connman hal libnotify nls -doc -ofono -static-libs -test-binaries -ukit" 0 kB [1]
[ebuild   R   ] media-libs/edje-9999  USE="nls -cache -debug -doc -static-libs -vim-syntax" 0 kB [1]
[ebuild   R   ] x11-wm/enlightenment-9999  USE="acpi bluetooth e_modules_battery e_modules_clock e_modules_comp e_modules_conf-applications e_modules_conf-borders e_modules_conf-clientlist e_modules_conf-colors e_modules_conf-desk e_modules_conf-desklock e_modules_conf-desks e_modules_conf-dialogs e_modules_conf-display e_modules_conf-dpms e_modules_conf-edgebindings e_modules_conf-engine e_modules_conf-fonts e_modules_conf-icon-theme e_modules_conf-imc e_modules_conf-interaction e_modules_conf-intl e_modules_conf-keybindings e_modules_conf-menus e_modules_conf-mime e_modules_conf-mouse e_modules_conf-mouse-cursor e_modules_conf-mousebindings e_modules_conf-paths e_modules_conf-performance e_modules_conf-profiles e_modules_conf-scale e_modules_conf-screensaver e_modules_conf-shelves e_modules_conf-startup e_modules_conf-theme e_modules_conf-transitions e_modules_conf-wallpaper e_modules_conf-wallpaper2 e_modules_conf-window-display e_modules_conf-window-focus e_modules_conf-window-manipulation e_modules_conf-window-remembers e_modules_conf-winlist e_modules_connman e_modules_cpufreq e_modules_dropshadow e_modules_everything e_modules_everything-apps e_modules_everything-settings e_modules_everything-windows e_modules_fileman e_modules_ibar e_modules_ibox e_modules_mixer e_modules_pager e_modules_start e_modules_syscon e_modules_systray e_modules_temperature e_modules_winlist e_modules_wizard exchange hal nls pam udev -doc -e_modules_everything-calc -e_modules_everything-files -e_modules_fileman_opinfo -e_modules_gadman -e_modules_illume -e_modules_illume2 -e_modules_msgbus -e_modules_ofono -spell -static-libs" 0 kB [1]

Total: 9 packages (9 reinstalls), Size of downloads: 0 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /var/lib/layman/enlightenment


Hope that helps !

Just my 0.02 cents ...
_________________
Lisa Simpson : Il doit être programmé pour éliminer la concurrence !
Bart Simpson : Comme Microsoft ?!
Lisa Simpson : Exactement !
Back to top
View user's profile Send private message
sinisterdomestik
l33t
l33t


Joined: 28 Aug 2003
Posts: 683
Location: Texas

PostPosted: Sun Dec 26, 2010 2:24 am    Post subject: Reply with quote

I tried doing it as a set, but
Code:
Preparing a Set
Note: This is a feature only availible in Portage versions 2.2 or greater.
and
Code:
BlackBeauty ~ # emerge -p portage

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] sys-apps/portage-2.1.9.26
so that wouldnt work. Im going to try unmerging everything and just starting over, seeing if that helps at all
_________________
Thou shalt NEVER speak of removing thine Linux
Back to top
View user's profile Send private message
sinisterdomestik
l33t
l33t


Joined: 28 Aug 2003
Posts: 683
Location: Texas

PostPosted: Mon Dec 27, 2010 1:59 am    Post subject: Reply with quote

Ok, I have tried re-emerging these packages umteen different times with the same result. Its a no go and I cnat for the life of me figure out why it cant find that ONE file....
_________________
Thou shalt NEVER speak of removing thine Linux
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3256

PostPosted: Mon Dec 27, 2010 4:56 am    Post subject: Reply with quote

sinisterdomestik wrote:
Ok, I have tried re-emerging these packages umteen different times with the same result. Its a no go and I cnat for the life of me figure out why it cant find that ONE file....
When was the last time you had installed e17 on this system? 2 years ago?
_________________
emerge --quiet redefined | E17 vids: I, II | Now using kde5 | e is unstable :-/
Back to top
View user's profile Send private message
sinisterdomestik
l33t
l33t


Joined: 28 Aug 2003
Posts: 683
Location: Texas

PostPosted: Mon Dec 27, 2010 5:30 am    Post subject: Reply with quote

This gentoo install is.....3 weeks old. So this would be the first...why?
_________________
Thou shalt NEVER speak of removing thine Linux
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3256

PostPosted: Mon Dec 27, 2010 6:08 am    Post subject: Reply with quote

sinisterdomestik wrote:
This gentoo install is.....3 weeks old. So this would be the first...why?
I was trying to figure out if you had installed e17 long ago and by chance some old headers were lying around. This file underwent some major move 2 years ago.

But since this is the first time you are installing e, I am at a loss. I can't figure out what is going on. Maybe you can try asking in enlightenment-users mailing list or the #e irc channel.
_________________
emerge --quiet redefined | E17 vids: I, II | Now using kde5 | e is unstable :-/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum