Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Emerge blender-2.49a fails
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message

Joined: 28 Oct 2010
Posts: 28
Location: ZH (CH)

PostPosted: Sun Dec 19, 2010 8:30 pm    Post subject: [solved] Emerge blender-2.49a fails Reply with quote

I would like to have blender installed on my system.
But as soon as i am trying to install with the command (emerge blender) then it fails with the following message:

source/blender/imbuf/intern/jp2.c:720: warning: ignoring return value of 'fwrite', declared with attribute warn_unused_result
Compiling ==> 'readimage.c'
scons: *** [/var/tmp/portage/media-gfx/blender-2.49a/work/build/linux2/source/blender/imbuf/intern/jp2.o] Error 1
scons: building terminated because of errors.
 * ERROR: media-gfx/blender-2.49a failed:
 *   !!! Please add "${S}/scons.config" when filing bugs reports \
 *      to
 * Call stack:
 *, line  56:  Called src_compile
 *   environment, line 4466:  Called die
 * The specific snippet of code:
 *       scons ${MAKEOPTS/-l[0-9]} || die '!!! Please add "${S}/scons.config" when filing bugs reports \
 *      to';

More info about the system environment
powerppc ~ # emerge --info =media-gfx/blender-2.49a
Portage (default/linux/powerpc/ppc64/10.0/32bit-userland/desktop/gnome, gcc-4.4.4, glibc-2.11.2-r3, 2.6.34-gentoo-r12 ppc64)
                        System Settings
System uname: Linux-2.6.34-gentoo-r12-ppc64-PPC970MP,_altivec_supported-with-gentoo-1.12.14
Timestamp of tree: Mon, 29 Nov 2010 11:00:01 +0000
app-shells/bash:     4.1_p7
dev-lang/python:     2.6.5-r3, 3.1.2-r4
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.14-r1
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.4-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.30-r1 (sys-kernel/linux-headers)
CFLAGS="-O2 -pipe -mcpu=970"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -mcpu=970"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acl alsa altivec berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam firefox flac fortran gcc64 gdbm gdu gif gnome gnome-keyring gpm gstreamer gtk hal iconv ipv6 jack jack-tmfs jpeg lcms ldap libnotify mad midi mikmod mng modules mp3 mp4 mpeg mudflap nautilus ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf perl png policykit ppc ppds pppd python qt3support readline sdl session sndfile spell sqlite ssl startup-notification svg sysfs tcpd tiff truetype unicode usb vorbis xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="aoa aoa-fabric-layout aoa-onyx aoa-soundbus aoa-soundbus-i2s aoa-tas aoa-toonie powermac usb-audio via82xx" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-2" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint mach64 mga nv r128 radeon savage tdfx trident voodoo" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

powerppc ~ #

Last edited by erge on Sat Jun 11, 2011 7:43 pm; edited 2 times in total
Back to top
View user's profile Send private message
Retired Dev
Retired Dev

Joined: 28 Apr 2002
Posts: 2774

PostPosted: Fri Dec 24, 2010 4:34 am    Post subject: Reply with quote

It's hard to say, can you include more of the text above that error message?
Gentoo PPC FAQ:
Back to top
View user's profile Send private message

Joined: 16 Oct 2007
Posts: 280
Location: Rome, Italy

PostPosted: Sat Mar 24, 2012 12:46 pm    Post subject: Reply with quote

Why this thread is marked as [solved]? Where is the solution?
Who hasn't a spine, should have a method.
Chi non ha carattere, deve pur avere un metodo.
Back to top
View user's profile Send private message

Joined: 02 Sep 2004
Posts: 2749
Location: Canada

PostPosted: Sat Mar 24, 2012 2:45 pm    Post subject: Reply with quote

Same here, revdep-rebuilding blender failed, what was the solution ?
Back to top
View user's profile Send private message

Joined: 25 Mar 2012
Posts: 8

PostPosted: Sun Mar 25, 2012 9:54 am    Post subject: Reply with quote

Disable jpeg2k USE flag for blender and then report a bug on bugzilla.
Back to top
View user's profile Send private message
sir KAT
Tux's lil' helper
Tux's lil' helper

Joined: 27 Aug 2005
Posts: 118
Location: Kraków

PostPosted: Sun Mar 25, 2012 8:19 pm    Post subject: Reply with quote

But there is no jpeg2k flag for blender 2.49b.
Back to top
View user's profile Send private message
Clad in Sky

Joined: 04 May 2007
Posts: 856
Location: Germany

PostPosted: Mon Mar 26, 2012 10:38 am    Post subject: Reply with quote

I have the same problem on AMD64. No solution, yet.

I now have blender compiled on my system. I used the unstable 2.60a package which has a jpeg2k use flag and disabled said flag. After that it worked.
Kali Ma
Now it's autumn of the aeons
Dance with your sword
Now it's time for the harvest
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum