Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gnome-base/librsvg-2.31.0" is blocking x11-libs/gdk-pixbuf-2
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1754

PostPosted: Mon Dec 27, 2010 11:34 am    Post subject: gnome-base/librsvg-2.31.0" is blocking x11-libs/gdk-pix Reply with quote

Hallo,

leider habe ich ein emerge Problem, welches ich nicht alleine lösen kann.
Bitte um Hilfe:
Code:

emerge librsvg gegl cheese gnome-panel gnome-control-center -pvt

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild   R   ] gnome-base/gnome-control-center-2.30.1  USE="policykit -debug -eds" 0 kB
[ebuild   R   ] gnome-base/gnome-panel-2.30.2  USE="networkmanager policykit -doc -eds" 0 kB
[ebuild   R   ] media-video/cheese-2.30.1  USE="doc v4l" 0 kB
[ebuild  N    ] media-libs/gegl-0.0.22  USE="cairo ffmpeg jpeg mmx png sdl sse svg v4l -debug -doc -openexr -raw" 0 kB
[ebuild  N    ]  gnome-base/librsvg-2.26.3  USE="doc zlib -tools" 0 kB
[blocks B     ] <gnome-base/librsvg-2.31.0 ("<gnome-base/librsvg-2.31.0" is blocking x11-libs/gdk-pixbuf-2.22.1)

Total: 5 packages (2 new, 3 reinstalls), Size of downloads: 0 kB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (x11-libs/gdk-pixbuf-2.22.1, installed) pulled in by
    x11-libs/gdk-pixbuf required by @selected

  (gnome-base/librsvg-2.26.3, ebuild scheduled for merge) pulled in by
    librsvg
    >=gnome-base/librsvg-2.18.0 required by (media-video/cheese-2.30.1, ebuild scheduled for merge)
    gnome-base/librsvg required by (gnome-base/gnome-panel-2.30.2, ebuild scheduled for merge)
    (and 2 more)



Wo hängt es?
Danke schon mal.
G. Roland
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Mon Dec 27, 2010 12:24 pm    Post subject: Reply with quote

gdk-pixbuf-2.22.1 blockt alle librsvg <2.31.0.
gdk-pixbuf-2.22.1 ist testing, >=librsvg-2.31.0 auch.
Also entweder gehst du auf Testing (unmask librsvg), oder zurück auf Stable (mask gdk-pixbuf, also aus package.keywords entfernen).
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Mon Dec 27, 2010 12:33 pm    Post subject: Reply with quote

Tinitus wrote:
Code:
(x11-libs/gdk-pixbuf-2.22.1, installed) pulled in by
    x11-libs/gdk-pixbuf required by @selected
Interessant wäre eventuell auch noch wer gdk-pixbuf (testing) denn überhaupt benötigt.
Schau doch auch mal was ein
Code:
equery d gdk-pixbuf
sagt.
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1754

PostPosted: Mon Dec 27, 2010 1:44 pm    Post subject: Reply with quote

Hallo,

danke schon mal für Eure Mühe!

Code:

equery d gdk-pixbuf
[ Searching for packages depending on gdk-pixbuf... ]
x11-libs/gtk+-2.22.1 (!aqua? x11-libs/gdk-pixbuf[X,introspection?,jpeg?,jpeg2k?,tiff?])
                     (aqua? x11-libs/gdk-pixbuf[introspection?,jpeg?,jpeg2k?,tiff?])
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Mon Dec 27, 2010 1:51 pm    Post subject: Reply with quote

gtk+-2.22.1 ist Testing. Es geharrt aber nicht auf eine bestimmte gdk-pixbuf-Version. Du solltest also problemlos die gdk-pixbuf wieder nach stable zurückführen können (mögliche ABI-Probleme unberücksichtigt -> revdep-rebuild).
Da du aber insgesamt recht viel Testing laufen lässt, kannst du auch librsvg nach Testing hieven. Natürlich nur, wenn nicht das halbe System auch nach Testing gebracht werden muss (z.B. gnome).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum