Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
eclean errors
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
h2sammo
Veteran
Veteran


Joined: 11 Mar 2009
Posts: 1025
Location: Michigan

PostPosted: Sat Jan 01, 2011 5:43 pm    Post subject: eclean errors Reply with quote

any ideas on how to solve this?

Code:
eclean distfiles
 * Building file list for distfiles cleaning...
 * Digest verification failed:
 * /var/lib/layman/stormfront/app-misc/SageSAConnMgr/SageSAConnMgr-2.2.1.ebuild
 * Reason: Filesize does not match recorded size
 * Got: 1980
 * Expected: 2075
 * Digest verification failed:
 * /var/lib/layman/stormfront/app-portage/glcu/glcu-0.9.7.1.ebuild
 * Reason: Filesize does not match recorded size
 * Got: 1193
 * Expected: 1190
 * Use PYTHON_DEPEND variable instead of NEED_PYTHON variable.
 * ERROR: dev-python/python-polib-0.1.0 failed:
 *   NEED_PYTHON variable is banned
 *
 * Call stack:
 *                   ebuild.sh, line 1974:  Called source '/var/lib/layman/zugaina/dev-python/python-polib/python-polib-0.1.0.ebuild'
 *   python-polib-0.1.0.ebuild, line    7:  Called inherit 'distutils'
 *                   ebuild.sh, line 1380:  Called qa_source '/usr/portage/eclass/distutils.eclass'
 *                   ebuild.sh, line   43:  Called source '/usr/portage/eclass/distutils.eclass'
 *            distutils.eclass, line   14:  Called inherit 'multilib' 'python'
 *                   ebuild.sh, line 1380:  Called qa_source '/usr/portage/eclass/python.eclass'
 *                   ebuild.sh, line   43:  Called source '/usr/portage/eclass/python.eclass'
 *               python.eclass, line  192:  Called die
 * The specific snippet of code:
 *      die "NEED_PYTHON variable is banned"
 *
 * If you need support, post the output of 'emerge --info =dev-python/python-polib-0.1.0',
 * the complete build log and the output of 'emerge -pqv =dev-python/python-polib-0.1.0'.
 * This ebuild is from an overlay: '/var/lib/layman/zugaina/'
 * S: '/var/tmp/portage/dev-python/python-polib-0.1.0/work/python-polib-0.1.0'
 * Use PYTHON_DEPEND variable instead of NEED_PYTHON variable.
 * ERROR: dev-python/python-ptrace-0.4.2 failed:
 *   NEED_PYTHON variable is banned
 *
 * Call stack:
 *                    ebuild.sh, line 1974:  Called source '/var/lib/layman/zugaina/dev-python/python-ptrace/python-ptrace-0.4.2.ebuild'
 *   python-ptrace-0.4.2.ebuild, line    7:  Called inherit 'distutils'
 *                    ebuild.sh, line 1380:  Called qa_source '/usr/portage/eclass/distutils.eclass'
 *                    ebuild.sh, line   43:  Called source '/usr/portage/eclass/distutils.eclass'
 *             distutils.eclass, line   14:  Called inherit 'multilib' 'python'
 *                    ebuild.sh, line 1380:  Called qa_source '/usr/portage/eclass/python.eclass'
 *                    ebuild.sh, line   43:  Called source '/usr/portage/eclass/python.eclass'
 *                python.eclass, line  192:  Called die
 * The specific snippet of code:
 *      die "NEED_PYTHON variable is banned"
 *
 * If you need support, post the output of 'emerge --info =dev-python/python-ptrace-0.4.2',
 * the complete build log and the output of 'emerge -pqv =dev-python/python-ptrace-0.4.2'.
 * This ebuild is from an overlay: '/var/lib/layman/zugaina/'
 * S: '/var/tmp/portage/dev-python/python-ptrace-0.4.2/work/python-ptrace-0.4.2'
 * Digest verification failed:
 * /var/lib/layman/stormfront/x11-themes/linspire-clear-kwin/linspire-clear-kwin-1.11.ebuild
 * Reason: Filesize does not match recorded size
 * Got: 613
 * Expected: 604
 * Your distfiles directory was already clean.
Back to top
View user's profile Send private message
h2sammo
Veteran
Veteran


Joined: 11 Mar 2009
Posts: 1025
Location: Michigan

PostPosted: Sat Jan 01, 2011 6:09 pm    Post subject: Reply with quote

maybe related:
Code:

main bobby # eix-update
Reading Portage settings ..
Building database (/var/cache/eix) ..
[0] "gentoo" /usr/portage/ (cache: metadata-flat)
     Reading category 154|154 (100%) Finished             
[1] "x11" /var/lib/layman/x11 (cache: parse|ebuild*#metadata-flat#assign)
     Reading category 154|154 (100%) Finished       
[2] "cj-overlay" /var/lib/layman/cj-overlay (cache: parse|ebuild*#metadata-flat#assign)
     Reading category 154|154 (100%) Finished             
[3] "zugaina" /var/lib/layman/zugaina (cache: parse|ebuild*#metadata-flat#assign)
     Reading category 154|154 (100%) Finished           
[4] "stormfront" /var/lib/layman/stormfront (cache: parse|ebuild*#metadata-flat#assign)
     Reading category  76|154 ( 49%): kde-misc .. * Please fix your package (kde-misc/ksshaskpass-0.4) to not use kde.eclass
/var/lib/layman/stormfront/kde-misc/ksshaskpass/ksshaskpass-0.4.ebuild: line 15: need-kde: command not found
     Reading category 151|154 ( 98%): x11-themes .. * Please fix your package (x11-themes/linspire-clear-kwin-1.11) to not use kde.eclass
/var/lib/layman/stormfront/x11-themes/linspire-clear-kwin/linspire-clear-kwin-1.11.ebuild: line 18: need-kde: command not found
     Reading category 154|154 (100%) Finished     
[5] "" /usr/local/portage (cache: parse|ebuild*#metadata-flat#assign)
     Reading category 154|154 (100%) Finished   
Applying masks ..
Calculating hash tables ..
Writing database file /var/cache/eix ..
Database contains 14390 packages in 154 categories.
Back to top
View user's profile Send private message
dol-sen
Developer
Developer


Joined: 30 Jun 2002
Posts: 2803
Location: Richmond, BC, Canada

PostPosted: Sun Jan 02, 2011 1:32 am    Post subject: Reply with quote

Well, you have some outdated ebuilds on your system clogging up the works. It is portage that is complaining in the case of eclean. Eclean itself did not error, it would just ignore the error messages printed by portage. Eclean uses portage for most info gathering. I don't know if those overlays have been updated to fix the outdated ebuilds to the new requirements. If not you may need to update the ebuilds for any pkgs you want to keep on your system.

Some of the errors are Filesize errors, so after checking for/fixing any corruption, running
Code:
ebuild /var/lib/layman/stormfront/app-misc/SageSAConnMgr/SageSAConnMgr-2.2.1.ebuild digest
...
on them should fix them. For others, the python eclass has been changed a bunch, so the ebuilds need to be updated as the error states.
_________________
Brian
Porthole, the Portage GUI frontend irc@freenode: #gentoo-guis, #porthole, Blog
layman, gentoolkit, CoreBuilder, esearch...
Back to top
View user's profile Send private message
jkomar
Apprentice
Apprentice


Joined: 24 Sep 2004
Posts: 192
Location: Calgary, Canada

PostPosted: Mon Apr 04, 2011 9:24 pm    Post subject: Reply with quote

h2sammo wrote:
maybe related:
Code:

[4] "stormfront" /var/lib/layman/stormfront (cache: parse|ebuild*#metadata-flat#assign)
     Reading category  76|154 ( 49%): kde-misc .. * Please fix your package (kde-misc/ksshaskpass-0.4) to not use kde.eclass
/var/lib/layman/stormfront/kde-misc/ksshaskpass/ksshaskpass-0.4.ebuild: line 15: need-kde: command not found
     Reading category 151|154 ( 98%): x11-themes .. * Please fix your package (x11-themes/linspire-clear-kwin-1.11) to not use kde.eclass
/var/lib/layman/stormfront/x11-themes/linspire-clear-kwin/linspire-clear-kwin-1.11.ebuild: line 18: need-kde: command not found
     Reading category 154|154 (100%) Finished     


In the case of these ones, there are some ebuilds here which are for kde-3. KDE3 support has now been pulled from the Gentoo tree and moved to kde-sunset, so the kde eclass went with it. I've put the kde eclass in the stormfront overlay now to allow these kde-3 supporting ebuilds to keep existing. These errors should disappear now.

Jason
_________________
www.jbox.ca
www.flashinthepan.ca
stormfront Portage/Paludis overlay
Back to top
View user's profile Send private message
aCOSwt
Bodhisattva
Bodhisattva


Joined: 19 Oct 2007
Posts: 2537
Location: Hilbert space

PostPosted: Mon Apr 04, 2011 9:33 pm    Post subject: Reply with quote

dol-sen wrote:
It is portage that is complaining in the case of eclean. Eclean itself did not error

Definitely... Unfair !
Sorry to be positive about this !
Why ?
dol-sen wrote:
Eclean uses portage for most info gathering

:!:
Back to top
View user's profile Send private message
dol-sen
Developer
Developer


Joined: 30 Jun 2002
Posts: 2803
Location: Richmond, BC, Canada

PostPosted: Tue Apr 05, 2011 6:05 am    Post subject: Reply with quote

aCOSwt wrote:
Why ?
dol-sen wrote:
Eclean uses portage for most info gathering

Because it needs to look up what is installed and what files belong to those installed pkgs in order to preserve their sources and patch files. Other things are done directly. Or in the case of cleaning binpkgs, it calls "emaint fix binhost" after removing pkgs to update the binpkg index file.
_________________
Brian
Porthole, the Portage GUI frontend irc@freenode: #gentoo-guis, #porthole, Blog
layman, gentoolkit, CoreBuilder, esearch...
Back to top
View user's profile Send private message
tomk
Bodhisattva
Bodhisattva


Joined: 23 Sep 2003
Posts: 7221
Location: Sat in front of my computer

PostPosted: Tue Apr 05, 2011 7:54 am    Post subject: Reply with quote

Moved from Portage & Programming to Unsupported Software. Support for problems arising from overlay ebuilds belong in US.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum