Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X kann nach update nicht mehr starten
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
FrancisA
Tux's lil' helper
Tux's lil' helper


Joined: 17 Dec 2010
Posts: 111

PostPosted: Sun Jan 02, 2011 9:49 pm    Post subject: X kann nach update nicht mehr starten Reply with quote

Hallo, ich kann jetzt den X Server nicht mehr starten. Ich habe porthole probiert und dabei update gewählt. Hat einige Minuten kompiliert (war eh etwas mit xorg). Nun kommt folgendes:

Code:

[    35.970]
X.Org X Server 1.9.2
Release Date: 2010-10-30
[    35.970] X Protocol Version 11, Revision 0
[    35.970] Build Operating System: Linux 2.6.37-rc8+ i686 Gentoo
[    35.970] Current Operating System: Linux localhost 2.6.37-rc8+ #5 SMP Sat Jan 1 13:31:36 CET 2011 i686
[    35.970] Kernel command line: root=/dev/sda9 ro
[    35.970] Build Date: 02 January 2011  10:02:32PM
[    35.970] 
[    35.970] Current version of pixman: 0.18.2
[    35.970]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[    35.970] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    35.970] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Jan  2 22:33:49 2011
[    35.970] (II) Loader magic: 0x81f3de0
[    35.970] (II) Module ABI versions:
[    35.970]    X.Org ANSI C Emulation: 0.4
[    35.970]    X.Org Video Driver: 8.0
[    35.970]    X.Org XInput driver : 11.0
[    35.970]    X.Org Server Extension : 4.0
[    35.971] (--) PCI:*(0:2:0:0) 1002:68c1:1025:037e rev 0, Mem @ 0xd0000000/268435456, 0xcfee0000/131072, I/O @ 0x00002000/256, BIOS @ 0x????????/131072
[    35.971] (==) Using default built-in configuration (30 lines)
[    35.971] (==) --- Start of built-in configuration ---
[    35.971]    Section "Device"
[    35.971]       Identifier   "Builtin Default ati Device 0"
[    35.971]       Driver   "ati"
[    35.971]    EndSection
[    35.971]    Section "Screen"
[    35.971]       Identifier   "Builtin Default ati Screen 0"
[    35.971]       Device   "Builtin Default ati Device 0"
[    35.971]    EndSection
[    35.971]    Section "Device"
[    35.971]       Identifier   "Builtin Default vesa Device 0"
[    35.971]       Driver   "vesa"
[    35.971]    EndSection
[    35.971]    Section "Screen"
[    35.971]       Identifier   "Builtin Default vesa Screen 0"
[    35.971]       Device   "Builtin Default vesa Device 0"
[    35.971]    EndSection
[    35.971]    Section "Device"
[    35.971]       Identifier   "Builtin Default fbdev Device 0"
[    35.971]       Driver   "fbdev"
[    35.971]    EndSection
[    35.971]    Section "Screen"
[    35.971]       Identifier   "Builtin Default fbdev Screen 0"
[    35.971]       Device   "Builtin Default fbdev Device 0"
[    35.971]    EndSection
[    35.971]    Section "ServerLayout"
[    35.971]       Identifier   "Builtin Default Layout"
[    35.971]       Screen   "Builtin Default ati Screen 0"
[    35.971]       Screen   "Builtin Default vesa Screen 0"
[    35.971]       Screen   "Builtin Default fbdev Screen 0"
[    35.971]    EndSection
[    35.971] (==) --- End of built-in configuration ---
[    35.971] (==) ServerLayout "Builtin Default Layout"
[    35.971] (**) |-->Screen "Builtin Default ati Screen 0" (0)
[    35.971] (**) |   |-->Monitor "<default monitor>"
[    35.971] (**) |   |-->Device "Builtin Default ati Device 0"
[    35.971] (==) No monitor specified for screen "Builtin Default ati Screen 0".
   Using a default monitor configuration.
[    35.971] (**) |-->Screen "Builtin Default vesa Screen 0" (1)
[    35.971] (**) |   |-->Monitor "<default monitor>"
[    35.971] (**) |   |-->Device "Builtin Default vesa Device 0"
[    35.971] (==) No monitor specified for screen "Builtin Default vesa Screen 0".
   Using a default monitor configuration.
[    35.971] (**) |-->Screen "Builtin Default fbdev Screen 0" (2)
[    35.971] (**) |   |-->Monitor "<default monitor>"
[    35.971] (**) |   |-->Device "Builtin Default fbdev Device 0"
[    35.971] (==) No monitor specified for screen "Builtin Default fbdev Screen 0".
   Using a default monitor configuration.
[    35.971] (==) Automatically adding devices
[    35.971] (==) Automatically enabling devices
[    35.971] (==) FontPath set to:
   /usr/share/fonts/misc/,
   /usr/share/fonts/TTF/,
   /usr/share/fonts/OTF/,
   /usr/share/fonts/Type1/,
   /usr/share/fonts/100dpi/,
   /usr/share/fonts/75dpi/
[    35.972] (==) ModulePath set to "/usr/lib/xorg/modules"
[    35.972] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[    35.972] (II) LoadModule: "extmod"
[    35.972] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[    35.972] (II) Module extmod: vendor="X.Org Foundation"
[    35.972]    compiled for 1.9.2, module version = 1.0.0
[    35.972]    Module class: X.Org Server Extension
[    35.972]    ABI class: X.Org Server Extension, version 4.0
[    35.972] (II) Loading extension MIT-SCREEN-SAVER
[    35.972] (II) Loading extension XFree86-VidModeExtension
[    35.972] (II) Loading extension XFree86-DGA
[    35.972] (II) Loading extension DPMS
[    35.972] (II) Loading extension XVideo
[    35.972] (II) Loading extension XVideo-MotionCompensation
[    35.972] (II) Loading extension X-Resource
[    35.972] (II) LoadModule: "dbe"
[    35.972] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[    35.972] (II) Module dbe: vendor="X.Org Foundation"
[    35.972]    compiled for 1.9.2, module version = 1.0.0
[    35.972]    Module class: X.Org Server Extension
[    35.972]    ABI class: X.Org Server Extension, version 4.0
[    35.972] (II) Loading extension DOUBLE-BUFFER
[    35.972] (II) LoadModule: "glx"
[    35.973] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    35.973] (II) Module glx: vendor="X.Org Foundation"
[    35.973]    compiled for 1.9.2, module version = 1.0.0
[    35.973]    ABI class: X.Org Server Extension, version 4.0
[    35.973] (==) AIGLX enabled
[    35.973] (II) Loading extension GLX
[    35.973] (II) LoadModule: "record"
[    35.973] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[    35.973] (II) Module record: vendor="X.Org Foundation"
[    35.973]    compiled for 1.9.2, module version = 1.13.0
[    35.973]    Module class: X.Org Server Extension
[    35.973]    ABI class: X.Org Server Extension, version 4.0
[    35.973] (II) Loading extension RECORD
[    35.973] (II) LoadModule: "dri"
[    35.973] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[    35.973] (II) Module dri: vendor="X.Org Foundation"
[    35.973]    compiled for 1.9.2, module version = 1.0.0
[    35.973]    ABI class: X.Org Server Extension, version 4.0
[    35.973] (II) Loading extension XFree86-DRI
[    35.973] (II) LoadModule: "dri2"
[    35.974] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[    35.974] (II) Module dri2: vendor="X.Org Foundation"
[    35.974]    compiled for 1.9.2, module version = 1.2.0
[    35.974]    ABI class: X.Org Server Extension, version 4.0
[    35.974] (II) Loading extension DRI2
[    35.974] (II) LoadModule: "ati"
[    35.974] (II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so
[    35.974] (II) Module ati: vendor="X.Org Foundation"
[    35.974]    compiled for 1.7.7, module version = 6.13.1
[    35.974]    Module class: X.Org Video Driver
[    35.974]    ABI class: X.Org Video Driver, version 6.0
[    35.974] (EE) module ABI major version (6) doesn't match the server's version (8)
[    35.974] (II) UnloadModule: "ati"
[    35.974] (II) Unloading /usr/lib/xorg/modules/drivers/ati_drv.so
[    35.974] (EE) Failed to load module "ati" (module requirement mismatch, 0)
[    35.974] (II) LoadModule: "vesa"
[    35.974] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    35.974] (II) Module vesa: vendor="X.Org Foundation"
[    35.974]    compiled for 1.7.7, module version = 2.3.0
[    35.974]    Module class: X.Org Video Driver
[    35.974]    ABI class: X.Org Video Driver, version 6.0
[    35.974] (EE) module ABI major version (6) doesn't match the server's version (8)
[    35.974] (II) UnloadModule: "vesa"
[    35.974] (II) Unloading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    35.974] (EE) Failed to load module "vesa" (module requirement mismatch, 0)
[    35.974] (II) LoadModule: "fbdev"
[    35.974] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    35.974] (II) Module fbdev: vendor="X.Org Foundation"
[    35.974]    compiled for 1.7.7, module version = 0.4.2
[    35.974]    ABI class: X.Org Video Driver, version 6.0
[    35.974] (EE) module ABI major version (6) doesn't match the server's version (8)
[    35.974] (II) UnloadModule: "fbdev"
[    35.974] (II) Unloading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    35.974] (EE) Failed to load module "fbdev" (module requirement mismatch, 0)
[    35.974] (EE) No drivers available.
[    35.974]
Fatal server error:
[    35.974] no screens found
[    35.974]
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[    35.975] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    35.975]

Vorher hatte ich den Radeon als Treiber.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Sun Jan 02, 2011 10:28 pm    Post subject: Reply with quote

Schau zb mal in einer Suchmaschine nach
Code:
gentoo xorg-server module ABI major version (6) doesn't match the server's version
Das oberste Ergebnis sollte weiterhelfen ;)

/edit:
Portage sollte dir beim xorg-server-1.9 Upgrade unter anderem auch etwa folgendes mitgeteilt haben
Code:
 * You must rebuild all drivers if upgrading from xorg-server 1.7
 * or earlier, because the ABI changed. If you cannot start X because
 * of module version mismatch errors, this is your problem.       

 * You can generate a list of all installed packages in the x11-drivers
 * category using this command:                                     
 * emerge portage-utils; qlist -I -C x11-drivers/
Back to top
View user's profile Send private message
fuchur
Guru
Guru


Joined: 12 Aug 2003
Posts: 578

PostPosted: Sun Jan 02, 2011 10:53 pm    Post subject: Reply with quote

Hi

Und schau auch mal nach ob du unter
Code:
Section "Module"
Load                "v4l"
hast.
Mit module v4l konnte ich xorg-server-1.9 auch nicht starten und
ich bekam auch keine eindeutige Fehlermeldung

MfG
Back to top
View user's profile Send private message
FrancisA
Tux's lil' helper
Tux's lil' helper


Joined: 17 Dec 2010
Posts: 111

PostPosted: Sun Jan 02, 2011 11:09 pm    Post subject: Reply with quote

fuchur wrote:
Hi

Und schau auch mal nach ob du unter
Code:
Section "Module"
Load                "v4l"
hast.
Mit module v4l konnte ich xorg-server-1.9 auch nicht starten und
ich bekam auch keine eindeutige Fehlermeldung

MfG


Ah danke; ich habe meine letzte Sicherung einfach einmal zurückgespielt. ;) Das ist mir (jetzt) noch zu kompliziert ;)
Back to top
View user's profile Send private message
fuchur
Guru
Guru


Joined: 12 Aug 2003
Posts: 578

PostPosted: Sun Jan 02, 2011 11:17 pm    Post subject: Reply with quote

Hi

FrancisA wrote:
fuchur wrote:
Hi

Und schau auch mal nach ob du unter
Code:
Section "Module"
Load                "v4l"
hast.
Mit module v4l konnte ich xorg-server-1.9 auch nicht starten und
ich bekam auch keine eindeutige Fehlermeldung

MfG


Ah danke; ich habe meine letzte Sicherung einfach einmal zurückgespielt. ;) Das ist mir (jetzt) noch zu kompliziert ;)


Kompliziert ist da nichts. Einfach mal in der Datei "/etc/X11/xorg.conf" nach
Code:
Load                "v4l"
suchen, wenn vorhanden ein "#" vor die
Zeile setzen.

MfG
Back to top
View user's profile Send private message
FrancisA
Tux's lil' helper
Tux's lil' helper


Joined: 17 Dec 2010
Posts: 111

PostPosted: Mon Jan 03, 2011 8:40 am    Post subject: Reply with quote

Danke für die Antworten.

Was ich nicht ganz verstehe. Ich habe kein /etc/X11/xorg.conf, von wo nimmt er die Einstellungen her

>f you cannot start X because of module version mismatch errors, this is your problem.

;) so das ist dann mein Problem

Also v4l deaktivieren. Der radeon Treiber wird ja im Kernel erstellt, das heisst, den Kernel nochmals compilieren? Habe ich das richtig verstanden?
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Mon Jan 03, 2011 11:04 am    Post subject: Reply with quote

FrancisA wrote:
>f you cannot start X because of module version mismatch errors, this is your problem.

;) so das ist dann mein Problem
Ja, heißt aber nur das du dich bitte selbst drum kümmern solltest die nun inkompatiblen Treiber ein mal passend zum neuen xorg-server zu bauen.
Klingt zunächst vielleicht schwierig, ist es aber nicht, denn es wird ja sogar schon ein fertig vorbereiteter Befehl mitgeliefert mit dem du deine installierten xorg-drivers (die du bitte neu bauen sollst) dir auflisten kannst.

Also:
Sofern noch nicht geschehen installiere dir den "Werkzeugkasten" portage-utils
Nun kannst du dir mit
Code:
qlist -I -C x11-drivers/
die installierten Treiber ausgeben lassen die wegen dem ABI Wechsel vom xorg-server neu gebaut werden müssen.

Am einfachsten ist, du kombinierst dies gleich mit einem emerge Kommando welches dir dann gleich die Treiber neu baut, also zb
Code:
# emerge -av1 $(qlist -I -C x11-drivers/)

Das sollte es dann gewesen sein ;)

FrancisA wrote:
Der radeon Treiber wird ja im Kernel erstellt, das heisst, den Kernel nochmals compilieren? Habe ich das richtig verstanden?
Nein, der radeon Treiber kommt aus dem Paket x11-drivers/xf86-video-ati , dieser sollte aber auch schon mit dem oben genannten Befehl passend mit remerged werden.

Für die weitere Konfiguration vom xorg-server-1.9 nutze dann bitte auch den Xorg-server 1.9 Upgrade Guide

Viel Erfolg
Back to top
View user's profile Send private message
FrancisA
Tux's lil' helper
Tux's lil' helper


Joined: 17 Dec 2010
Posts: 111

PostPosted: Sat Jan 15, 2011 8:10 pm    Post subject: Reply with quote

Jetzt bin ich wieder so weit, dass der XServer nicht startet (nach dem update). Den Hinweis mit
Code:
emerge -1av $(qlist -IC x11-drivers)
habe ich jedoch befolgt.

Ich habe, wies aussieht wieder das gleiche xorg log file wie oben gepostet...

Er hat jetzt /usr/share/X11/xorg.conf.d (xorg.conf gibts bei mir nicht?)


Fragend ... ;)

Nachtrag: Jetzt funktionierts, weiß aber nciht mehr genau, was es war. Ich habe nochmals ein depmod -a angewendet und die configuration files (die .chk000 files aufgelöst).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum