Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
vdpau funktioniert nicht mit nvidia-drivers 260.19.29
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2032
Location: Heidelberg - Germany

PostPosted: Mon Jan 03, 2011 4:16 pm    Post subject: vdpau funktioniert nicht mit nvidia-drivers 260.19.29 Reply with quote

Frohes neues Jahr nachträglich,

ich habe mir zum neuen Jahr ein Upgrade des Nvidia Treibers auf 260.19.29 gegönnt. Mit dem neuen Treiber scheint vdpau nicht mehr zu funktionieren, mplayer behauptet zwar vdpau zu nutzen, des Bild ruckelt jedoch bei HD Material und die CPU Last ist hoch. Ein Downgrade des Nvidia Treibers auf 195.36.31 bringt wieder die gewohnte Performance bei 10-20% CPU Last bei 800 MHz.
Ist das Problem bekannt bzw. kann es daran liegen, das ich xorg-x11 noch nicht auf 1.9.x hochgezogen habe? (Das wollte ich jetzt noch nicht tun)

Könnte es evtl. Sinn machen libvdpau nochmal zu bauen?

-Erdie
Back to top
View user's profile Send private message
root_tux_linux
l33t
l33t


Joined: 21 Dec 2003
Posts: 966

PostPosted: Mon Jan 03, 2011 5:22 pm    Post subject: Reply with quote

6% Auslast mit vdpau und mplayer


mplayer -vo vdpau -vc ffh264vdpau movie

x11-base/xorg-server-1.9.2
x11-drivers/nvidia-drivers-260.19.29
_________________
Intel Core i7 6700K@4.6GHz, Gigabyte GTX 980 Ti G1, Gigabyte Gaming 7, Hyper X Fury 32GB, 2 TB Samsung EVO 840 Basic
ASUS ROG Swift PG348Q Display
ASUS ROG ASUS G771JW Notebook
Back to top
View user's profile Send private message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2032
Location: Heidelberg - Germany

PostPosted: Mon Jan 03, 2011 5:36 pm    Post subject: Reply with quote

6% habe ich auch unefähr wenn ich Speedstepping abschalte. Aber nicht mit der Version 260.19.29. Allerdings habe ich nicht xorg 1.9, evtl liegt es doch daran.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Mon Jan 03, 2011 5:43 pm    Post subject: Reply with quote

Dann mach mal ein Update, der 1.9er ist schon stable :)
http://packages.gentoo.org/package/x11-base/xorg-server
Back to top
View user's profile Send private message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2032
Location: Heidelberg - Germany

PostPosted: Tue Jan 04, 2011 8:19 am    Post subject: Reply with quote

Bringt der 1.9er xorg gravierende Veränderungen? Ich habe Bedenken, weil ich meinen Rechner in ein paar Wochen produktiv brauche (Orchester Audioaufnahme). Solche Update mache ich lieber, wenn in der nächsten Zeit nichts kritisches ansteht.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Tue Jan 04, 2011 9:14 am    Post subject: Reply with quote

Gravierende Änderungen - hal ist rausgeflogen. Ich hab ein recht primitives Setup. Maus + Tastatur laufen über evdev, setup in xorg.conf.d, xorg.conf ist die um InputDevices bereingte von nvidia-xconfig erstellte. Funktionierte alles auf Anhieb.
Da dein Setup aber ansonsten funktioniert, würde ich bis zum Abschluss der Aufnahmen nichts dran drehen (wobei "ein paar Wochen" ziemlich viel Raum für Spekulationen und Fehlerbehebungen lässt :P)

Als alter Geigenvirtuose muss ich natürlich noch fragen, was denn aufgenommen werden soll :)
Back to top
View user's profile Send private message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2032
Location: Heidelberg - Germany

PostPosted: Tue Jan 04, 2011 9:38 am    Post subject: Reply with quote

Was aufgenommen werden soll? Kein Problem ;)

1. Mendelssohn Hebriden Ouvertüre
2. Ein Konzert für Viola, Tuba und Orchester von Horst Seehafer, die Uraufführung habe ich vor ein paar Wochen aufgenommen.
3.Die 7. Sinfonie von Beethoven

Gleich gibts Ärger mit der Moderation wegen Off-Topic *duck*

Also wenn dann mein Notebook nicht läuft weil xorg rumzickt, das wäre in der Tat ärgerlich lol.
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Tue Jan 04, 2011 6:58 pm    Post subject: Reply with quote

Hier funktioniert 260.19.29 ohne Probleme. CPU-Auslastung bei 1080p-Videos etwa bei etwa 15%.
Back to top
View user's profile Send private message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2032
Location: Heidelberg - Germany

PostPosted: Wed Jan 05, 2011 5:10 am    Post subject: Reply with quote

Mit xorg 1.9?
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Wed Jan 05, 2011 11:15 am    Post subject: Reply with quote

jap, ich hab xorg-1.9 schon einige Monate im Einsatz. Die Umstellung war denkbar einfach, da ich sowieso kein HAL installiert hatte. Von daher hab ich einfach die Sections aus der xorg.conf in die entsprechenden Sections xorg.conf.d ergänzt.
Back to top
View user's profile Send private message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2032
Location: Heidelberg - Germany

PostPosted: Wed Jan 05, 2011 3:19 pm    Post subject: Reply with quote

Ist die Umstellung auf xorg 1.9 denn ein Problem, wenn man HAL installiert hat?
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Wed Jan 05, 2011 3:55 pm    Post subject: Reply with quote

Erdie wrote:
Ist die Umstellung auf xorg 1.9 denn ein Problem, wenn man HAL installiert hat?

Nein, es ist nur eine kleine Umstellung, wenn du xorg-server so konfiguriert hast, dass es seine Devices mit hal konfiguriert.
Ich denke auch, dass dein System danach benutzbar ist. Die Konfiguration via xorg.conf.d-Files ist nicht wirklich kompliziert, und hier läuft 1.9 auf allen Rechnern seit langer Zeit 100% stabil. Wann war denn eigentlich dein letztes Update?
Back to top
View user's profile Send private message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2032
Location: Heidelberg - Germany

PostPosted: Fri Jan 07, 2011 9:15 am    Post subject: Reply with quote

Ich bin auf xorg-server 1.7.7-r1 mit HAL fdi files. In dem Migrationsguide steht:

Quote:
Systems which worked fine with the default HAL fdi will not need special configuration. If you created custom fdi files, then refer to the Xorg-server 1.8 Upgrade Guide how to migrate your configuration to udev


Demnach müßte ich ja eigentlich nicht viel machen, da ich keine neue Konfiguration brauche.

Grüße
Erdie
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Fri Jan 07, 2011 9:25 am    Post subject: Reply with quote

Ich hab ja oben noch gefragt, wann dein letztes Update war. Hauptsächlich deshalb, weil du noch kein stabiles xorg-server-1.9 bekommen hast. Entweder du hast das Update explizit über package.mask maskiert, oder das Update ist wirklich länger her.
Es gab nämlich ein paar richtig schöne Problemkinder, wie das libpng-Update von 1.2.x auf 1.4.x (ABI geändert AFAIR). Wenn da noch mehr solche "bösen" Updates warten würde ich ein Update verschieben auf nach den wichtigen Termin, da du wirklich viel neubauen musst.

Wenn nur das xorg-update wartet - das sollte wirklich recht problemlos über die Bühne gehen. Musst halt dran denken, deine Treiber (xf86-input-evdev usw) neu zu bauen, sonst kannst du deinen Rechner nicht mehr bedienen :P
Back to top
View user's profile Send private message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2032
Location: Heidelberg - Germany

PostPosted: Fri Jan 07, 2011 10:07 am    Post subject: Reply with quote

Das letzte Update ist Wochen her, ich bin momentan nicht zuhause und habe hier keinen 2.Rechner mit dem ich mich via ssh einloggen könnte, ich werde das deshalb erst machen wenn ich wieder zuhause bin. Maskiert habe ihc nichts. Danke für den Tipp :)
Back to top
View user's profile Send private message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2032
Location: Heidelberg - Germany

PostPosted: Sat Jan 29, 2011 3:36 pm    Post subject: Reply with quote

Jetzt habe ich den Salat. Komplettes Update gemacht auf xorg 1.9 incl. nvidia-driver und mplayer update. Vdpau funktioniert nicht mehr und eine Downgrade von nvidia-drivers geht auch nicht mehr, da xorg 1.9 mindestens nvidia v195.x voraussetzt. Wenn ich die aktuellen maskiere, will "er" auch xorg downgraden. Ich habs geahnt ...

Ich habe übrigens eine 8600GT Mobile, daran sollte es doch auch nicht liegen, oder?

Update:

habe herausgefunden, dass es mit mplayer -vo vdpau -ao alsa funktioniert. Nur der smplayer hat Probleme. Bei Verwendung des smplayer gibt mplayer folgendes log aus.

Code:

/usr/bin/mplayer -noquiet -nofs -nomouseinput -vc ffh264vdpau,ffmpeg12vdpau,ffwmv3vdpau,ffvc1vdpau, -lavdopts threads=2 -sub-fuzziness 1 -identify -slave -vo vdpau -ao alsa -nokeepaspect -framedrop -dr -double -input nodefault-bindings:conf=/dev/null -stop-xscreensaver -wid 46137761 -monitorpixelaspect 1 -ass -embeddedfonts -ass-line-spacing 0 -ass-font-scale 1 -ass-styles /home/martin/.config/smplayer/styles.ass -fontconfig -font Arial -subfont-autoscale 0 -subfont-osd-scale 20 -subfont-text-scale 20 -subcp ISO-8859-1 -vid 0 -aid 0 -subpos 100 -volume 100 -cache 2000 -osdlevel 0 -slices -channels 2 -af scaletempo -softvol -softvol-max 100 <mkv file steht hier>

MPlayer SVN-r32624-4.4.4 (C) 2000-2010 MPlayer Team
Terminal type `unknown' is not defined.

Playing <mkv file path steht hier>
Cache fill:  0.00% (0 bytes)   

libavformat file format detected.
[matroska,webm @ 0x13f8ea0] max_analyze_duration reached
[matroska,webm @ 0x13f8ea0] Estimating duration from bitrate, this may be inaccurate
ID_CHAPTER_ID=0
ID_CHAPTER_0_START=0
ID_CHAPTER_0_END=136011
ID_CHAPTER_0_NAME=00:00:00.000
ID_CHAPTER_ID=1
ID_CHAPTER_1_START=136011
ID_CHAPTER_1_END=713755
ID_CHAPTER_1_NAME=00:02:16.011
ID_CHAPTER_ID=2
ID_CHAPTER_2_START=713755
ID_CHAPTER_2_END=988988
ID_CHAPTER_2_NAME=00:11:53.755
ID_CHAPTER_ID=3
ID_CHAPTER_3_START=988988
ID_CHAPTER_3_END=1244827
ID_CHAPTER_3_NAME=00:16:28.988
ID_CHAPTER_ID=4
ID_CHAPTER_4_START=1244827
ID_CHAPTER_4_END=1439521
ID_CHAPTER_4_NAME=00:20:44.827
ID_CHAPTER_ID=5
ID_CHAPTER_5_START=1439521
ID_CHAPTER_5_END=1779027
ID_CHAPTER_5_NAME=00:23:59.521
ID_CHAPTER_ID=6
ID_CHAPTER_6_START=1779027
ID_CHAPTER_6_END=1926424
ID_CHAPTER_6_NAME=00:29:39.027
ID_CHAPTER_ID=7
ID_CHAPTER_7_START=1926424
ID_CHAPTER_7_END=2137802
ID_CHAPTER_7_NAME=00:32:06.424
ID_CHAPTER_ID=8
ID_CHAPTER_8_START=2137802
ID_CHAPTER_8_END=2387260
ID_CHAPTER_8_NAME=00:35:37.802
ID_CHAPTER_ID=9
ID_CHAPTER_9_START=2387260
ID_CHAPTER_9_END=2654610
ID_CHAPTER_9_NAME=00:39:47.260
ID_CHAPTER_ID=10
ID_CHAPTER_10_START=2654610
ID_CHAPTER_10_END=2878793
ID_CHAPTER_10_NAME=00:44:14.610
ID_CHAPTER_ID=11
ID_CHAPTER_11_START=2878793
ID_CHAPTER_11_END=3148228
ID_CHAPTER_11_NAME=00:47:58.793
ID_CHAPTER_ID=12
ID_CHAPTER_12_START=3148228
ID_CHAPTER_12_END=3392514
ID_CHAPTER_12_NAME=00:52:28.228
ID_CHAPTER_ID=13
ID_CHAPTER_13_START=3392514
ID_CHAPTER_13_END=3755168
ID_CHAPTER_13_NAME=00:56:32.514
ID_CHAPTER_ID=14
ID_CHAPTER_14_START=3755168
ID_CHAPTER_14_END=4019015
ID_CHAPTER_14_NAME=01:02:35.168
ID_CHAPTER_ID=15
ID_CHAPTER_15_START=4019015
ID_CHAPTER_15_END=4255501
ID_CHAPTER_15_NAME=01:06:59.015
ID_CHAPTER_ID=16
ID_CHAPTER_16_START=4255501
ID_CHAPTER_16_END=4484397
ID_CHAPTER_16_NAME=01:10:55.501
ID_CHAPTER_ID=17
ID_CHAPTER_17_START=4484397
ID_CHAPTER_17_END=4727431
ID_CHAPTER_17_NAME=01:14:44.397
ID_CHAPTER_ID=18
ID_CHAPTER_18_START=4727431
ID_CHAPTER_18_END=4856310
ID_CHAPTER_18_NAME=01:18:47.431
ID_CHAPTER_ID=19
ID_CHAPTER_19_START=4856310
ID_CHAPTER_19_END=5108353
ID_CHAPTER_19_NAME=01:20:56.310
ID_CHAPTER_ID=20
ID_CHAPTER_20_START=5108353
ID_CHAPTER_20_END=5227639
ID_CHAPTER_20_NAME=01:25:08.353
ID_CHAPTER_ID=21
ID_CHAPTER_21_START=5227639
ID_CHAPTER_21_END=5549544
ID_CHAPTER_21_NAME=01:27:07.639
ID_CHAPTER_ID=22
ID_CHAPTER_22_START=5549544
ID_CHAPTER_22_END=5891761
ID_CHAPTER_22_NAME=01:32:29.544
ID_CHAPTER_ID=23
ID_CHAPTER_23_START=5891761
ID_CHAPTER_23_END=6121782
ID_CHAPTER_23_NAME=01:38:11.761
ID_CHAPTER_ID=24
ID_CHAPTER_24_START=6121782
ID_CHAPTER_24_END=6500244
ID_CHAPTER_24_NAME=01:42:01.782
ID_CHAPTER_ID=25
ID_CHAPTER_25_START=6500244
ID_CHAPTER_25_END=6722674
ID_CHAPTER_25_NAME=01:48:20.244
ID_CHAPTER_ID=26
ID_CHAPTER_26_START=6722674
ID_CHAPTER_26_END=7007542
ID_CHAPTER_26_NAME=01:52:02.674
ID_CHAPTER_ID=27
ID_CHAPTER_27_START=7007542
ID_CHAPTER_27_END=7186012
ID_CHAPTER_27_NAME=01:56:47.542
ID_CHAPTER_ID=28
ID_CHAPTER_28_START=7186012
ID_CHAPTER_28_END=7281983
ID_CHAPTER_28_NAME=01:59:46.012
ID_CHAPTER_ID=29
ID_CHAPTER_29_START=7281983
ID_CHAPTER_29_END=7535714
ID_CHAPTER_29_NAME=02:01:21.983
ID_VIDEO_ID=0
[lavf] stream 0: video (h264), -vid 0
ID_AUDIO_ID=0
ID_AID_0_LANG=ger
ID_AID_0_NAME=German DTS-ES 6.1 @ 1.536 kbps (core of DTS-HR)
[lavf] stream 1: audio (dca), -aid 0, -alang ger, German DTS-ES 6.1 @ 1.536 kbps (core of DTS-HR)
ID_AUDIO_ID=1
ID_AID_1_LANG=eng
ID_AID_1_NAME=English DTS-ES 6.1 @ 1.536 kbps (core of DTS-HR)
[lavf] stream 2: audio (dca), -aid 1, -alang eng, English DTS-ES 6.1 @ 1.536 kbps (core of DTS-HR)
ID_AUDIO_ID=2
ID_AID_2_LANG=eng
ID_AID_2_NAME=English Commentary OGG 2.0 @ 96 kbps
[lavf] stream 3: audio (vorbis), -aid 2, -alang eng, English Commentary OGG 2.0 @ 96 kbps
ID_SUBTITLE_ID=0
ID_SID_0_LANG=ger
ID_SID_0_NAME=German
[lavf] stream 4: subtitle (unknown), -sid 0, -slang ger, German
ID_SUBTITLE_ID=1
ID_SID_1_LANG=eng
ID_SID_1_NAME=English
[lavf] stream 5: subtitle (unknown), -sid 1, -slang eng, English
ID_SUBTITLE_ID=2
ID_SID_2_LANG=ger
ID_SID_2_NAME=German for English Commentary
[lavf] stream 6: subtitle (unknown), -sid 2, -slang ger, German for English Commentary
VIDEO:  [H264]  1920x800  0bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)
Clip info:
 title: <Titel steht hier>
ID_CLIP_INFO_NAME0=title
ID_CLIP_INFO_VALUE0=<titel steht hier>
ID_CLIP_INFO_N=1
ID_FILENAME=<Pfad zum mkv file steht hier>
ID_DEMUXER=lavfpref
ID_VIDEO_FORMAT=H264
ID_VIDEO_BITRATE=0
ID_VIDEO_WIDTH=1920
ID_VIDEO_HEIGHT=800
ID_VIDEO_FPS=23.976
ID_VIDEO_ASPECT=2.4000
ID_AUDIO_FORMAT=8193
ID_AUDIO_BITRATE=1536000
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=7
ID_START_TIME=0.00
ID_LENGTH=7535.71
ID_SEEKABLE=1
ID_CHAPTERS=30
Opening video filter: [ass auto=1]
Couldn't open video filter 'ass'.
ASS: cannot add video filter
==========================================================================
Forced video codec: ffh264vdpau
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264vdpau] vfm: ffmpeg (FFmpeg H.264 (VDPAU))
==========================================================================
ID_VIDEO_CODEC=ffh264vdpau
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, s16le, 1536.0 kbit/100.00% (ratio: 192000->192000)
ID_AUDIO_BITRATE=1536000
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=2
Selected audio codec: [ffdca] afm: ffmpeg (FFmpeg DTS)
==========================================================================
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
ID_AUDIO_CODEC=ffdca
[Mixer] No hardware mixing, inserting volume filter.
Starting playback...
[VD_FFMPEG] Trying pixfmt=0.
Movie-Aspect is 2.40:1 - prescaling to correct movie aspect.
ID_VIDEO_ASPECT=2.4000
VO: [vdpau] 1920x800 => 1920x800 H.264 VDPAU acceleration
[VD_FFMPEG] XVMC-accelerated MPEG-2.
[h264_vdpau @ 0xac8380]Cannot parallelize deblocking type 1, decoding such frames in sequential order

Too many buffered pts

Too many buffered pts

Too many buffered pts

Too many buffered pts

Too many buffered pts

Too many buffered pts

Too many buffered pts

Too many buffered pts

Too many buffered pts

Too many buffered pts

Too many buffered pts

Too many buffered pts

Too many buffered pts

Too many buffered pts

Too many buffered pts


           ************************************************
           **** Your system is too SLOW to play this!  ****
           ************************************************


Ich frage mich, was der smplayer anders macht. Das Video ruckelt grausam und kommt machmal völlig zum stehen.

-Erdie
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Sat Jan 29, 2011 10:08 pm    Post subject: Reply with quote

Nimm mal den Cache und die Framedrops raus. Nur so als Vermutung. Ansonsten hab ich den smplayer nie verwendet.
Back to top
View user's profile Send private message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2032
Location: Heidelberg - Germany

PostPosted: Sun Jan 30, 2011 9:41 pm    Post subject: Reply with quote

Hat es leider nicht gebracht, aber ich habe jetzt festgestellt, dass kplayer auch funktioniert. Ich werde einfach auf kplayer wechseln.

Danke und Grüße
Martin
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Mon Jan 31, 2011 8:12 pm    Post subject: Reply with quote

Erdie wrote:
Ich werde einfach auf kplayer wechseln.

Ich weiß, ist Geschmacksache. Ich hab mir einen globalen Alias in der /etc/bash/bashrc eingerichtet:
Code:
alias m="mplayer"

Einen Dateimanager verwende ich fast nie. Ehrlich gesagt hab ich nie das Bedürfnis für eine GUI bei mplayer verspürt. Und mit o.g. Alias reicht ein "m film.mkv". Ich glaub, einfacher geht's nicht wirklich.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Mon Jan 31, 2011 10:29 pm    Post subject: Reply with quote

musv wrote:
Ehrlich gesagt hab ich nie das Bedürfnis für eine GUI bei mplayer verspürt.

Das geht mir ähnlich...
Und wenn man sich erst mal ein wenig mit den Kürzeln auseinandergesetzt hat und sie kennt, dann will man eigentlich nichts anderes mehr... (ausser evtl. noch VLC ;)

Die Default Optionen kann sich auch jeder User in seinem /home/Verzeichnis setzen, für VDPAU oder alternativ xv hab ich hier zb folgendes in der
~/.mplayer/config
Code:
# Write your default config options here!
vo=vdpau,xv,
vc=ffh264vdpau,ffmpeg12vdpau,ffvc1vdpau,ffwmv3vdpau,


Ansonsten könnte man noch mal eine aktuellere Version von smplayer testen (sofern verfügbar)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum